]> git.pld-linux.org Git - packages/PyCXX.git/blob - PyCXX.spec
- Release 2. Added memleak fix by Barry Scott.
[packages/PyCXX.git] / PyCXX.spec
1 # TODO: Find out authors idea behind installing it properly and try implement it
2 # Propably it shoud be library thus not marked as noarch.
3
4 Summary:        Set of classes to help create extensions of Python in the C++ language
5 Summary(pl.UTF-8):      Klasy C++ pomocne przy tworzeniu modułów Pythona
6 Name:           PyCXX
7 Version:        6.2.3
8 Release:        2
9 License:        BSD
10 Group:          Development/Libraries
11 # http://prdownloads.sourceforge.net/cxx/pycxx-6.2.3.tar.gz
12 Source0:        http://downloads.sourceforge.net/cxx/pycxx-%{version}.tar.gz
13 # Source0-md5:  4e545ad225df9c14a3b344b1e6224661
14 Patch0:         %{name}-memleak_fix.patch
15 URL:            http://cxx.sourceforge.net/
16 BuildRequires:  python-modules
17 Requires:       libstdc++-devel
18 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
19
20 %description
21 PyCXX is a set of classes to help create extensions of Python in the
22 C++ language. The first part encapsulates the Python C API taking care
23 of exceptions and ref counting. The second part supports the building
24 of Python extension modules in C++.
25
26 %description -l pl.UTF-8
27 PyCXX jest zbiorem klas pomagających tworzorzyć moduły rozszerzeń
28 Pythona w języku C++. Pierwsza część hermetyzuje interfejs C Pythona
29 dbając o wyjątki i zliczanie refrencji. Druga wspiera budowanie
30 modułów rozszerzeń Pythona.
31
32 %prep
33 %setup -q -n pycxx-%{version}
34 %patch0 -p1
35
36 %build
37
38 %install
39 rm -rf $RPM_BUILD_ROOT
40
41 install -d $RPM_BUILD_ROOT%{_includedir}/
42 cp -r CXX $RPM_BUILD_ROOT%{_includedir}/
43 install -d $RPM_BUILD_ROOT%{_includedir}/CXX/Src
44 install Src/IndirectPythonInterface.cxx  $RPM_BUILD_ROOT%{_includedir}/CXX/Src
45 install Src/Python2/*  $RPM_BUILD_ROOT%{_includedir}/CXX/Src
46
47 %clean
48 rm -rf $RPM_BUILD_ROOT
49
50 %files
51 %defattr(644,root,root,755)
52 %defattr(644,root,root,755)
53 %{_includedir}/CXX
This page took 0.049072 seconds and 3 git commands to generate.