]> git.pld-linux.org Git - packages/PyAuthD.git/blob - PyAuthD.spec
BR: rpmbuild(macros) >= 1.710
[packages/PyAuthD.git] / PyAuthD.spec
1 %define snap    20070218
2 Summary:        PyAuthD - authentication daemon which implements a unified NSS/PAM infractructure
3 Summary(pl.UTF-8):      PyAuthD - demon uwierzytelniania implementujący jednolitą infrastrukturę NSS/PAM
4 Name:           PyAuthD
5 Version:        0.1
6 Release:        0.%{snap}.1
7 License:        GPL
8 Group:          Libraries/Python
9 Source0:        %{name}-%{snap}.tar.gz
10 # Source0-md5:  2b7d72bd6c75f0fa58707c25e398f87e
11 URL:            http://svn.asta.mh-hannover.de/categories/python/pyauthd/
12 BuildRequires:  rpmbuild(macros) >= 1.710
13 BuildRequires:  pam-devel
14 BuildRequires:  python
15 BuildRequires:  rpm-pythonprov
16 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
17
18 %description
19 PyAuthD is an authentication daemon which implements a unified NSS/PAM
20 infrastructure for creating virtual user accounts under Unix. It is
21 similar to the combination of {nss,pam}_ldap to authenticate against a
22 user database in LDAP, but is more extensible.
23
24 %description -l pl.UTF-8
25 PyAuthD to demon uwierzytelniania implementujący jednolitą
26 infrastrukturę NSS/PAM do tworzenia wirtualnych kont użytkowników pod
27 Uniksem. Jest podobny do kombinacji {nss,pam}_ldap przy
28 uwierzytelnianiu względem bazy użytkowników w LDAP, ale jest bardziej
29 rozszerzalny.
30
31 %prep
32 %setup -q -n %{name}
33
34 %build
35 %{__cc} %{rpmcflags} -Wall -fPIC -DPIC -c -I. -Iinclude -o PyAuthD_client.o src/PyAuthD_client.c
36 %{__cc} %{rpmcflags} -Wall -fPIC -DPIC -c -I. -Iinclude -o PyAuthD_PAM.o src/PyAuthD_PAM.c
37 %{__cc} %{rpmldflags} -shared PyAuthD_client.o PyAuthD_PAM.o -o pam_PyAuthD.so -lpam
38
39 %{__cc} %{rpmcflags} -Wall -fPIC -DPIC -c -I. -Iinclude -o PyAuthD_NSS_passwd.o src/PyAuthD_NSS_passwd.c
40 %{__cc} %{rpmcflags} -Wall -fPIC -DPIC -c -I. -Iinclude -o PyAuthD_NSS_shadow.o src/PyAuthD_NSS_shadow.c
41 %{__cc} %{rpmcflags} -Wall -fPIC -DPIC -c -I. -Iinclude -o PyAuthD_NSS_group.o src/PyAuthD_NSS_group.c
42 %{__cc} %{rpmldflags} -shared PyAuthD_NSS_passwd.o PyAuthD_NSS_shadow.o PyAuthD_NSS_group.o -o libnss_PyAuthD.so.2 -Wl,-soname -Wl,libnss_PyAuthD.so.2
43
44 %{__cc} %{rpmcflags} -Wall -fPIC -DPIC -c -I. -Iinclude -o PyAuthD_PPP.o src/PyAuthD_PPP.c
45 %{__cc} %{rpmldflags} -shared PyAuthD_PPP.o PyAuthD_client.o -o ppp_PyAuthD.so
46
47 %install
48 rm -rf $RPM_BUILD_ROOT
49
50 %py_install
51
52 %clean
53 rm -rf $RPM_BUILD_ROOT
54
55 %files
56 %defattr(644,root,root,755)
57 %doc *.html
58 %attr(755,root,root) %{py_sitedir}/*.so
This page took 0.088029 seconds and 3 git commands to generate.