]> git.pld-linux.org Git - packages/PyAuthD.git/blame - PyAuthD.spec
- raw
[packages/PyAuthD.git] / PyAuthD.spec
CommitLineData
adb5e29d
AM
1%define snap 20070218
2Summary: Python module for accessing Extended Attributes of the files
3Summary(pl.UTF-8): Moduł języka Python pozwalający na dostęp do rozszerzonych atrybutów plików
4Name: PyAuthD
5Version: 0.1
6Release: 0.%{snap}.1
7License: GPL
8Group: Libraries/Python
9Source0: %{name}-20070218.tar.gz
10# Source0-md5: 2b7d72bd6c75f0fa58707c25e398f87e
11URL: http://svn.asta.mh-hannover.de/categories/python/pyauthd/
12BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
13
14%description
15PyAuthD is an authentication daemon which implements a unified NSS/PAM
16infrastructure for creating virtual user accounts under Unix. It is
17similar to the combination of {nss,pam}_ldap to authenticate against a
18user database in LDAP, but is more extensible.
19
20%prep
21%setup -q -n %{name}
22
23%build
24%{__cc} %{rpmcflags} -Wall -fPIC -DPIC -c -I. -Iinclude -o PyAuthD_client.o src/PyAuthD_client.c
25%{__cc} %{rpmcflags} -Wall -fPIC -DPIC -c -I. -Iinclude -o PyAuthD_PAM.o src/PyAuthD_PAM.c
26%{__cc} %{rpmldflags} -shared PyAuthD_client.o PyAuthD_PAM.o -o pam_PyAuthD.so -lpam
27
28%{__cc} %{rpmcflags} -Wall -fPIC -DPIC -c -I. -Iinclude -o PyAuthD_NSS_passwd.o src/PyAuthD_NSS_passwd.c
29%{__cc} %{rpmcflags} -Wall -fPIC -DPIC -c -I. -Iinclude -o PyAuthD_NSS_shadow.o src/PyAuthD_NSS_shadow.c
30%{__cc} %{rpmcflags} -Wall -fPIC -DPIC -c -I. -Iinclude -o PyAuthD_NSS_group.o src/PyAuthD_NSS_group.c
31%{__cc} %{rpmldflags} -shared PyAuthD_NSS_passwd.o PyAuthD_NSS_shadow.o PyAuthD_NSS_group.o -o libnss_PyAuthD.so.2 -Wl,-soname -Wl,libnss_PyAuthD.so.2
32
33%{__cc} %{rpmcflags} -Wall -fPIC -DPIC -c -I. -Iinclude -o PyAuthD_PPP.o src/PyAuthD_PPP.c
34%{__cc} %{rpmldflags} -shared PyAuthD_PPP.o PyAuthD_client.o -o ppp_PyAuthD.so
35
36%install
37rm -rf $RPM_BUILD_ROOT
38
39python setup.py install \
40 --root=$RPM_BUILD_ROOT \
41 --optimize=2
42
43%clean
44rm -rf $RPM_BUILD_ROOT
45
46%files
47%defattr(644,root,root,755)
48%doc *.html
49%attr(755,root,root) %{py_sitedir}/*.so
This page took 0.07848 seconds and 4 git commands to generate.