]> git.pld-linux.org Git - packages/Producer.git/blob - Producer.spec
- tabs in preamble
[packages/Producer.git] / Producer.spec
1 %define fversion        %(echo %{version} | tr r - )
2 Summary:        Cross-platform library for OpenGL rendering
3 Summary(pl.UTF-8):      Wieloplatformowa biblioteka do renderingu OpenGL
4 Name:           Producer
5 Version:        0.8.5r3
6 Release:        1
7 License:        LGPL
8 Group:          Libraries
9 Source0:        http://www.andesengineering.com/Producer/Download/%{name}-%{fversion}.tar.gz
10 # Source0-md5:  889c99c47a3af7d8df03fb5584919cbe
11 Source1:        %{name}.pc
12 Patch0:         %{name}-soname.patch
13 Patch1:         %{name}-notix86.patch
14 URL:            http://www.andesengineering.com/Producer/index.html
15 BuildRequires:  OpenGL-devel
16 BuildRequires:  OpenThreads-devel
17 BuildRequires:  XFree86-devel
18 BuildRequires:  libstdc++-devel
19 Provides:       OpenProducer = %{version}
20 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
21
22 %description
23 Open Producer (or simply Producer) is a cross-platform, C++ library
24 for managing OpenGL rendering contexts in a windowing system
25 independent manner. Producer provides a simple, yet powerfully
26 scalable approach for real-time 3D applications wishing to run within
27 a single window to large, multidisplay systems. Producer is highly
28 portable and has been tested on Linux, Windows, Mac OSX, Solaris and
29 IRIX. Producer works on all Unix based OS's (including Mac OSX)
30 through the X11 Windowing system, and through the native win32 on
31 Windows. Producer is written with productivity, performance and
32 scalability in mind by adhering to industry standard and employing
33 advanced software engineering practices. Software developers wishing
34 to produce 3D rendering software that can display on a desktop, and
35 move to a large system or clustered system of displays by simply
36 changing a configuration file, can depend on Open Producer to handle
37 all the complexity for them.
38
39 %description -l pl.UTF-8
40 Open Producer (lub po prostu Producer) jest wieloplatformową
41 biblioteką C++ do zarządzania renderingiem OpenGL. Producer udostępnia
42 prostą, ale skalowalną możliwość dla aplikacji czasu rzeczywistego 3D
43 od chcących uruchamiać się w pojedynczym oknie aż do wielkich,
44 wieloekranowych systemów. Producer jest bardzo przenośny i
45 przetestowany na Linuksie, Windows, MacOS X, Solarisie i IRIXie.
46 Producer działa na wszystkich bazujących na Uniksie systemach
47 (włączając w to MacOS X) poprzez system okien X11 lub przez natywne
48 wywołania win32 na Windows. Producer był pisany z myślą o wydajności i
49 skalowalności uwzględniając systemy produkcyjne. Autorzy
50 oprogramowania chcący tworzyć aplikacje renderujące 3D, które mogą się
51 wyświetlać na ekranie lub przenieść na wielki system lub klaster
52 systemów wyświetlaczy poprzez prostą zmianę plików konfiguracyjnych,
53 mogą polegać na Open Producer, że obsłuży wszystko co jest potrzebne
54 dla nich.
55
56 %package devel
57 Summary:        Development files for Producer
58 Summary(pl.UTF-8):      Pliki programistyczne biblioteki Producer
59 Group:          Development/Libraries
60 Requires:       %{name} = %{version}-%{release}
61 Requires:       OpenThreads-devel
62 Requires:       XFree86-devel
63 Requires:       libstdc++-devel
64
65 %description devel
66 Development files for Producent.
67
68 %description devel -l pl.UTF-8
69 Biblioteki programistyczne biblioteki Producer.
70
71 %prep
72 %setup -q -n %{name}
73 %patch0 -p1
74 %patch1 -p1
75
76 find -type d -name CVS |xargs rm -rf
77
78 %build
79 %{__make} \
80         CXX="%{__cxx} %{rpmcflags} -fPIC -fpermissive"
81
82 %install
83 rm -rf $RPM_BUILD_ROOT
84
85 %{__make} install \
86         INST_LOCATION=$RPM_BUILD_ROOT%{_prefix} \
87         INST_LIBS=$RPM_BUILD_ROOT%{_libdir}
88
89 ln -sf `basename $RPM_BUILD_ROOT%{_libdir}/lib%{name}.so.*` $RPM_BUILD_ROOT%{_libdir}/lib%{name}.so
90
91 install -d $RPM_BUILD_ROOT%{_pkgconfigdir}
92 sed -e 's,^libdir=.*,libdir=%{_libdir},' %{SOURCE1} >$RPM_BUILD_ROOT%{_pkgconfigdir}/producer.pc
93
94 %clean
95 rm -rf $RPM_BUILD_ROOT
96
97 %post   -p /sbin/ldconfig
98 %postun -p /sbin/ldconfig
99
100 %files
101 %defattr(644,root,root,755)
102 %attr(755,root,root) %{_libdir}/lib*.so.*.*
103
104 %files devel
105 %defattr(644,root,root,755)
106 %doc README.txt doc
107 %attr(755,root,root) %{_libdir}/lib*.so
108 %{_includedir}/%{name}
109 %{_pkgconfigdir}/*.pc
This page took 0.0588 seconds and 3 git commands to generate.