]> git.pld-linux.org Git - packages/Pression.git/blob - Pression.spec
- fixed description
[packages/Pression.git] / Pression.spec
1 #
2 # Conditional build:
3 %bcond_without  apidocs         # do not build and package API docs
4
5 Summary:        C++ library for compression and CPU-GPU data transfer plugins
6 Name:           Pression
7 Version:        1.1.1
8 Release:        1
9 License:        LGPL v2.1
10 Group:          Libraries
11 Source0:        https://github.com/Eyescale/Pression/archive/%{version}/%{name}-%{version}.tar.gz
12 # Source0-md5:  0eef1d53cdfbf53feebff1dfe9980161
13 URL:            http://libcollage.net/
14 BuildRequires:  Lunchbox-devel >= 1.13.0
15 BuildRequires:  boost-devel >= 1.41.0
16 BuildRequires:  cmake >= 2.8
17 %{?with_apidocs:BuildRequires:  doxygen}
18 BuildRequires:  pkgconfig
19 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
20
21 %description
22 C++ library for implementing and loading compression and CPU-GPU data
23 transfer plugins.
24
25 %package devel
26 Summary:        Header files for Pression library
27 Summary(pl.UTF-8):      Pliki nagłówkowe biblioteki Pression
28 Group:          Development/Libraries
29 Requires:       %{name} = %{version}-%{release}
30
31 %description devel
32 Header files for Pression library.
33
34 %description devel -l pl.UTF-8
35 Pliki nagłówkowe biblioteki Pression.
36
37 %package apidocs
38 Summary:        Pression API documentation
39 Summary(pl.UTF-8):      Dokumentacja API biblioteki Pression
40 Group:          Documentation
41 %if "%{_rpmversion}" >= "5"
42 BuildArch:      noarch
43 %endif
44
45 %description apidocs
46 API documentation for Pression library.
47
48 %description apidocs -l pl.UTF-8
49 Dokumentacja API biblioteki Pression.
50
51 %prep
52 %setup -q
53
54 ln -s %{_datadir}/Eyescale-CMake CMake/common
55 %{__rm} .gitexternals
56
57 %build
58 install -d build
59 cd build
60 CXXFLAGS="%{rpmcxxflags} -Wno-unused-variable"
61 %cmake .. \
62         -DBUILDYARD_DISABLED=ON
63 %{__make}
64
65 %if %{with apidocs}
66 doxygen doc/Doxyfile
67 %endif
68
69 %install
70 rm -rf $RPM_BUILD_ROOT
71
72 %{__make} -C build install \
73         DESTDIR=$RPM_BUILD_ROOT
74
75 %{__rm} -r $RPM_BUILD_ROOT%{_datadir}/Pression/{doc,tests}
76
77 %clean
78 rm -rf $RPM_BUILD_ROOT
79
80 %post   -p /sbin/ldconfig
81 %postun -p /sbin/ldconfig
82
83 %files
84 %defattr(644,root,root,755)
85 %doc LICENSE.txt README.md doc/Changelog.md
86 %attr(755,root,root) %{_libdir}/libPression.so.*.*.*
87 %attr(755,root,root) %ghost %{_libdir}/libPression.so.2
88
89 %files devel
90 %defattr(644,root,root,755)
91 %attr(755,root,root) %{_libdir}/libPression.so
92 %{_includedir}/pression
93 %dir %{_datadir}/Pression
94 %{_datadir}/Pression/CMake
95
96 %if %{with apidocs}
97 %files apidocs
98 %defattr(644,root,root,755)
99 %doc build/doc/html/*
100 %endif
This page took 0.102596 seconds and 3 git commands to generate.