]> git.pld-linux.org Git - packages/Pression.git/blob - Pression.spec
- unconditional noarch subpackages
[packages/Pression.git] / Pression.spec
1 #
2 # Conditional build:
3 %bcond_without  apidocs # API documentation
4
5 Summary:        C++ library for compression and CPU-GPU data transfer plugins
6 Summary(pl.UTF-8):      Biblioteka C++ do wtyczek kompresji i przesyłu danych CPU-GPU
7 Name:           Pression
8 Version:        2.0.0
9 Release:        4
10 License:        LGPL v2.1
11 Group:          Libraries
12 #Source0Download: https://github.com/Eyescale/Pression/releases
13 Source0:        https://github.com/Eyescale/Pression/archive/%{version}/%{name}-%{version}.tar.gz
14 # Source0-md5:  7b1546fa85838934a302776e5741b7f4
15 Source1:        https://github.com/facebook/zstd/archive/83543a7/zstd-83543a7.tar.gz
16 # Source1-md5:  81cd6ac24a536b544e78683a373bfeec
17 Source2:        https://github.com/google/snappy/archive/32d6d7d/snappy-32d6d7d.tar.gz
18 # Source2-md5:  e3c76d092a1405db503b92db2d65c81f
19 URL:            https://eyescale.github.io/
20 BuildRequires:  Eyescale-CMake >= 2017.05
21 BuildRequires:  Lunchbox-devel >= 1.16.0
22 # just to satisfy cmake projects stupidity (FIXME)
23 BuildRequires:  Servus-qt-devel
24 BuildRequires:  boost-devel >= 1.41.0
25 BuildRequires:  cmake >= 2.8
26 BuildRequires:  gcc-c++ >= 6:4.2
27 BuildRequires:  libgomp-devel
28 BuildRequires:  libstdc++-devel
29 %{?with_apidocs:BuildRequires:  doxygen}
30 BuildRequires:  pkgconfig
31 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
32
33 %description
34 C++ library for implementing and loading compression and CPU-GPU data
35 transfer plugins.
36
37 %description -l pl.UTF-8
38 Biblioteka C++ do implementowania i ładowania wtyczek kompresji oraz
39 przesyłu danych CPU-GPU.
40
41 %package devel
42 Summary:        Header files for Pression library
43 Summary(pl.UTF-8):      Pliki nagłówkowe biblioteki Pression
44 Group:          Development/Libraries
45 Requires:       %{name} = %{version}-%{release}
46 Requires:       Lunchbox-devel >= 1.16.0
47 Requires:       boost-devel >= 1.41.0
48
49 %description devel
50 Header files for Pression library.
51
52 %description devel -l pl.UTF-8
53 Pliki nagłówkowe biblioteki Pression.
54
55 %package apidocs
56 Summary:        Pression API documentation
57 Summary(pl.UTF-8):      Dokumentacja API biblioteki Pression
58 Group:          Documentation
59 BuildArch:      noarch
60
61 %description apidocs
62 API documentation for Pression library.
63
64 %description apidocs -l pl.UTF-8
65 Dokumentacja API biblioteki Pression.
66
67 %prep
68 %setup -q -a1 -a2
69
70 %{__mv} zstd-83543a7*/* pression/data/zstd/
71 %{__mv} snappy-32d6d7d*/* pression/data/snappy/
72
73 rmdir CMake/common
74 ln -s %{_datadir}/Eyescale-CMake CMake/common
75
76 %build
77 install -d build
78 cd build
79 %cmake .. \
80         -DCOMMON_DISABLE_WERROR=ON
81
82 %{__make}
83
84 %if %{with apidocs}
85 doxygen doc/Doxyfile
86 %endif
87
88 %install
89 rm -rf $RPM_BUILD_ROOT
90
91 %{__make} -C build install \
92         DESTDIR=$RPM_BUILD_ROOT
93
94 %{__rm} -r $RPM_BUILD_ROOT%{_datadir}/Pression/{doc,tests}
95
96 %clean
97 rm -rf $RPM_BUILD_ROOT
98
99 %post   -p /sbin/ldconfig
100 %postun -p /sbin/ldconfig
101
102 %files
103 %defattr(644,root,root,755)
104 %doc ACKNOWLEDGEMENTS.txt LICENSE.txt README.md doc/Changelog.md
105 %attr(755,root,root) %{_libdir}/libPression.so.*.*.*
106 %attr(755,root,root) %ghost %{_libdir}/libPression.so.3
107 %attr(755,root,root) %{_libdir}/libPressionData.so.*.*.*
108 %attr(755,root,root) %ghost %{_libdir}/libPressionData.so.3
109 %dir %{_datadir}/Pression
110 %{_datadir}/Pression/benchmarks
111
112 %files devel
113 %defattr(644,root,root,755)
114 %attr(755,root,root) %{_libdir}/libPression.so
115 %attr(755,root,root) %{_libdir}/libPressionData.so
116 %{_includedir}/pression
117 %{_datadir}/Pression/CMake
118
119 %if %{with apidocs}
120 %files apidocs
121 %defattr(644,root,root,755)
122 %doc build/doc/html/*
123 %endif
This page took 0.09186 seconds and 3 git commands to generate.