]> git.pld-linux.org Git - packages/Pression.git/blob - Pression.spec
6aaa5a354d6e4aea213cd0094f655b58419a71d2
[packages/Pression.git] / Pression.spec
1 #
2 # Conditional build:
3 %bcond_without  apidocs         # do not build and package API docs
4
5 Summary:        C++ library for compression and CPU-GPU data transfer plugins
6 Name:           Pression
7 Version:        1.1.1
8 Release:        1
9 License:        LGPL v2.1
10 Group:          Libraries
11 Source0:        https://github.com/Eyescale/Pression/archive/%{version}/%{name}-%{version}.tar.gz
12 # Source0-md5:  0eef1d53cdfbf53feebff1dfe9980161
13 URL:            http://libcollage.net/
14 BuildRequires:  Lunchbox-devel >= 1.13.0
15 BuildRequires:  boost-devel >= 1.41.0
16 BuildRequires:  cmake >= 2.8
17 %{?with_apidocs:BuildRequires:  doxygen}
18 BuildRequires:  pkgconfig
19 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
20
21 %description
22 Collage is a cross-platform C++ library for building heterogenous,
23 distributed applications. Among other things, it is the cluster
24 backend for the Equalizer parallel rendering framework. Collage
25 provides an abstraction of different network connections, peer-to-peer
26 messaging, node discovery, synchronization and high-performance,
27 object-oriented, versioned data distribution. Collage is designed for
28 low-overhead multi-threaded execution which allows applications to
29 easily exploit multi-core architectures.
30
31 %package devel
32 Summary:        Header files for Pression library
33 Summary(pl.UTF-8):      Pliki nagłówkowe biblioteki Pression
34 Group:          Development/Libraries
35 Requires:       %{name} = %{version}-%{release}
36
37 %description devel
38 Header files for Pression library.
39
40 %description devel -l pl.UTF-8
41 Pliki nagłówkowe biblioteki Pression.
42
43 %package apidocs
44 Summary:        Pression API documentation
45 Summary(pl.UTF-8):      Dokumentacja API biblioteki Pression
46 Group:          Documentation
47 %if "%{_rpmversion}" >= "5"
48 BuildArch:      noarch
49 %endif
50
51 %description apidocs
52 API documentation for Pression library.
53
54 %description apidocs -l pl.UTF-8
55 Dokumentacja API biblioteki Pression.
56
57 %prep
58 %setup -q
59
60 ln -s %{_datadir}/Eyescale-CMake CMake/common
61 %{__rm} .gitexternals
62
63 %build
64 install -d build
65 cd build
66 CXXFLAGS="%{rpmcxxflags} -Wno-unused-variable"
67 %cmake .. \
68         -DBUILDYARD_DISABLED=ON
69 %{__make}
70
71 %if %{with apidocs}
72 doxygen doc/Doxyfile
73 %endif
74
75 %install
76 rm -rf $RPM_BUILD_ROOT
77
78 %{__make} -C build install \
79         DESTDIR=$RPM_BUILD_ROOT
80
81 %{__rm} -r $RPM_BUILD_ROOT%{_datadir}/Pression/{doc,tests}
82
83 %clean
84 rm -rf $RPM_BUILD_ROOT
85
86 %post   -p /sbin/ldconfig
87 %postun -p /sbin/ldconfig
88
89 %files
90 %defattr(644,root,root,755)
91 %doc LICENSE.txt README.md doc/Changelog.md
92 %attr(755,root,root) %{_libdir}/libPression.so.*.*.*
93 %attr(755,root,root) %ghost %{_libdir}/libPression.so.2
94
95 %files devel
96 %defattr(644,root,root,755)
97 %attr(755,root,root) %{_libdir}/libPression.so
98 %{_includedir}/pression
99 %dir %{_datadir}/Pression
100 %{_datadir}/Pression/CMake
101
102 %if %{with apidocs}
103 %files apidocs
104 %defattr(644,root,root,755)
105 %doc build/doc/html/*
106 %endif
This page took 0.056581 seconds and 2 git commands to generate.