]> git.pld-linux.org Git - packages/Pression.git/blob - Pression.spec
- up to 1.2.0
[packages/Pression.git] / Pression.spec
1 #
2 # Conditional build:
3 %bcond_without  apidocs         # do not build and package API docs
4
5 Summary:        C++ library for compression and CPU-GPU data transfer plugins
6 Name:           Pression
7 Version:        1.2.0
8 Release:        1
9 License:        LGPL v2.1
10 Group:          Libraries
11 Source0:        https://github.com/Eyescale/Pression/archive/%{version}/%{name}-%{version}.tar.gz
12 # Source0-md5:  47e048b975efc681f00b62fc63951c07
13 Source1:        https://github.com/facebook/zstd/archive/83543a7/zstd-83543a7.tar.gz
14 # Source1-md5:  81cd6ac24a536b544e78683a373bfeec
15 URL:            http://libcollage.net/
16 BuildRequires:  Lunchbox-devel >= 1.13.0
17 BuildRequires:  boost-devel >= 1.41.0
18 BuildRequires:  cmake >= 2.8
19 %{?with_apidocs:BuildRequires:  doxygen}
20 BuildRequires:  pkgconfig
21 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
22
23 %description
24 C++ library for implementing and loading compression and CPU-GPU data
25 transfer plugins.
26
27 %package devel
28 Summary:        Header files for Pression library
29 Summary(pl.UTF-8):      Pliki nagłówkowe biblioteki Pression
30 Group:          Development/Libraries
31 Requires:       %{name} = %{version}-%{release}
32
33 %description devel
34 Header files for Pression library.
35
36 %description devel -l pl.UTF-8
37 Pliki nagłówkowe biblioteki Pression.
38
39 %package apidocs
40 Summary:        Pression API documentation
41 Summary(pl.UTF-8):      Dokumentacja API biblioteki Pression
42 Group:          Documentation
43 %if "%{_rpmversion}" >= "5"
44 BuildArch:      noarch
45 %endif
46
47 %description apidocs
48 API documentation for Pression library.
49
50 %description apidocs -l pl.UTF-8
51 Dokumentacja API biblioteki Pression.
52
53 %prep
54 %setup -q -a1
55
56 %{__mv} zstd-83543a7*/* pression/compressor/zstd/
57
58 ln -s %{_datadir}/Eyescale-CMake CMake/common
59 %{__rm} .gitexternals
60
61 %build
62 install -d build
63 cd build
64 CXXFLAGS="%{rpmcxxflags} -Wno-unused-variable"
65 %cmake .. \
66         -DBUILDYARD_DISABLED=ON
67 %{__make}
68
69 %if %{with apidocs}
70 doxygen doc/Doxyfile
71 %endif
72
73 %install
74 rm -rf $RPM_BUILD_ROOT
75
76 %{__make} -C build install \
77         DESTDIR=$RPM_BUILD_ROOT
78
79 %{__rm} -r $RPM_BUILD_ROOT%{_datadir}/Pression/{doc,tests}
80
81 %clean
82 rm -rf $RPM_BUILD_ROOT
83
84 %post   -p /sbin/ldconfig
85 %postun -p /sbin/ldconfig
86
87 %files
88 %defattr(644,root,root,755)
89 %doc LICENSE.txt README.md doc/Changelog.md
90 %attr(755,root,root) %{_libdir}/libPression.so.*.*.*
91 %attr(755,root,root) %ghost %{_libdir}/libPression.so.2
92
93 %files devel
94 %defattr(644,root,root,755)
95 %attr(755,root,root) %{_libdir}/libPression.so
96 %{_includedir}/pression
97 %dir %{_datadir}/Pression
98 %{_datadir}/Pression/CMake
99
100 %if %{with apidocs}
101 %files apidocs
102 %defattr(644,root,root,755)
103 %doc build/doc/html/*
104 %endif
This page took 0.037054 seconds and 3 git commands to generate.