]> git.pld-linux.org Git - packages/Pression.git/blob - Pression.spec
- rebuild with boost 1.71 and icu 65.1
[packages/Pression.git] / Pression.spec
1 #
2 # Conditional build:
3 %bcond_without  apidocs # API documentation
4
5 Summary:        C++ library for compression and CPU-GPU data transfer plugins
6 Summary(pl.UTF-8):      Biblioteka C++ do wtyczek kompresji i przesyłu danych CPU-GPU
7 Name:           Pression
8 Version:        2.0.0
9 Release:        3
10 License:        LGPL v2.1
11 Group:          Libraries
12 #Source0Download: https://github.com/Eyescale/Pression/releases
13 Source0:        https://github.com/Eyescale/Pression/archive/%{version}/%{name}-%{version}.tar.gz
14 # Source0-md5:  7b1546fa85838934a302776e5741b7f4
15 Source1:        https://github.com/facebook/zstd/archive/83543a7/zstd-83543a7.tar.gz
16 # Source1-md5:  81cd6ac24a536b544e78683a373bfeec
17 Source2:        https://github.com/google/snappy/archive/32d6d7d/snappy-32d6d7d.tar.gz
18 # Source2-md5:  e3c76d092a1405db503b92db2d65c81f
19 URL:            https://eyescale.github.io/
20 BuildRequires:  Eyescale-CMake >= 2017.05
21 BuildRequires:  Lunchbox-devel >= 1.16.0
22 # just to satisfy cmake projects stupidity (FIXME)
23 BuildRequires:  Servus-qt-devel
24 BuildRequires:  boost-devel >= 1.41.0
25 BuildRequires:  cmake >= 2.8
26 BuildRequires:  gcc-c++ >= 6:4.2
27 BuildRequires:  libgomp-devel
28 BuildRequires:  libstdc++-devel
29 %{?with_apidocs:BuildRequires:  doxygen}
30 BuildRequires:  pkgconfig
31 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
32
33 %description
34 C++ library for implementing and loading compression and CPU-GPU data
35 transfer plugins.
36
37 %description -l pl.UTF-8
38 Biblioteka C++ do implementowania i ładowania wtyczek kompresji oraz
39 przesyłu danych CPU-GPU.
40
41 %package devel
42 Summary:        Header files for Pression library
43 Summary(pl.UTF-8):      Pliki nagłówkowe biblioteki Pression
44 Group:          Development/Libraries
45 Requires:       %{name} = %{version}-%{release}
46 Requires:       Lunchbox-devel >= 1.16.0
47 Requires:       boost-devel >= 1.41.0
48
49 %description devel
50 Header files for Pression library.
51
52 %description devel -l pl.UTF-8
53 Pliki nagłówkowe biblioteki Pression.
54
55 %package apidocs
56 Summary:        Pression API documentation
57 Summary(pl.UTF-8):      Dokumentacja API biblioteki Pression
58 Group:          Documentation
59 %if "%{_rpmversion}" >= "5"
60 BuildArch:      noarch
61 %endif
62
63 %description apidocs
64 API documentation for Pression library.
65
66 %description apidocs -l pl.UTF-8
67 Dokumentacja API biblioteki Pression.
68
69 %prep
70 %setup -q -a1 -a2
71
72 %{__mv} zstd-83543a7*/* pression/data/zstd/
73 %{__mv} snappy-32d6d7d*/* pression/data/snappy/
74
75 rmdir CMake/common
76 ln -s %{_datadir}/Eyescale-CMake CMake/common
77
78 %build
79 install -d build
80 cd build
81 %cmake .. \
82         -DCOMMON_DISABLE_WERROR=ON
83
84 %{__make}
85
86 %if %{with apidocs}
87 doxygen doc/Doxyfile
88 %endif
89
90 %install
91 rm -rf $RPM_BUILD_ROOT
92
93 %{__make} -C build install \
94         DESTDIR=$RPM_BUILD_ROOT
95
96 %{__rm} -r $RPM_BUILD_ROOT%{_datadir}/Pression/{doc,tests}
97
98 %clean
99 rm -rf $RPM_BUILD_ROOT
100
101 %post   -p /sbin/ldconfig
102 %postun -p /sbin/ldconfig
103
104 %files
105 %defattr(644,root,root,755)
106 %doc ACKNOWLEDGEMENTS.txt LICENSE.txt README.md doc/Changelog.md
107 %attr(755,root,root) %{_libdir}/libPression.so.*.*.*
108 %attr(755,root,root) %ghost %{_libdir}/libPression.so.3
109 %attr(755,root,root) %{_libdir}/libPressionData.so.*.*.*
110 %attr(755,root,root) %ghost %{_libdir}/libPressionData.so.3
111 %dir %{_datadir}/Pression
112 %{_datadir}/Pression/benchmarks
113
114 %files devel
115 %defattr(644,root,root,755)
116 %attr(755,root,root) %{_libdir}/libPression.so
117 %attr(755,root,root) %{_libdir}/libPressionData.so
118 %{_includedir}/pression
119 %{_datadir}/Pression/CMake
120
121 %if %{with apidocs}
122 %files apidocs
123 %defattr(644,root,root,755)
124 %doc build/doc/html/*
125 %endif
This page took 0.110428 seconds and 3 git commands to generate.