]> git.pld-linux.org Git - packages/PowerChutePlus.git/blob - PowerChutePlus.spec
- reverting last change: removing new macros from %p{re,ost}{,un}
[packages/PowerChutePlus.git] / PowerChutePlus.spec
1 Summary:        UPS management software for APC UPS models
2 Name:           PowerChutePlus
3 Version:        4.5.2.1
4 Release:        2
5 Copyright:      (c) 1999 APC, inc.
6 Group:          Applications/System
7 Group(de):      Applikationen/System
8 Group(pl):      Aplikacje/System
9 Source0:        ftp://ftp.apcc.com/apc/public/software/unix/linux/pcplus/4521/pc4521_glibc.tar
10 Source1:        ftp://ftp.apcc.com/apc/public/software/unix/linux/pcplus/4521/pclinxug.pdf
11 Source2:        upsd.init
12 Source3:        %{name}-xpowerchute.sh
13 Source4:        %{name}-Config.sh
14 Source5:        %{name}-powerchute.ini
15 Source6:        %{name}-powerchute.ini_templ
16 Patch0:         %{name}-fix-sh.patch
17 ExclusiveOS:    linux
18 ExclusiveArch:  %{ix86}
19 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
20
21 %description
22 This program allows users to safely shut down their system in response
23 to power failures and other power events. It also allows users to
24 configure and manage UPS models.
25
26 Please note that /usr/lib/powerchute/Config.sh should be run in order
27 to configure PowerChute plus.
28
29 %prep
30 %setup -q -c
31 for i in BI_LINUX CI_LINUX COMMON FI_LINUX HELP ; do
32         tar xf $i
33 done
34 %patch0 -p1
35
36 %build
37 # No build, binaty package
38
39 %install
40 rm -rf $RPM_BUILD_ROOT
41 install -d $RPM_BUILD_ROOT{%{_sbindir},%{_libdir}/powerchute} \
42         $RPM_BUILD_ROOT/etc/rc.d/init.d \
43 $RPM_BUILD_ROOT%{_prefix}/X11R6/{bin,lib/X11/{app-defaults,uid}}
44
45 install %{SOURCE1} .
46 install %{SOURCE2} $RPM_BUILD_ROOT/etc/rc.d/init.d/upsd
47 install %{SOURCE3} $RPM_BUILD_ROOT%{_prefix}/X11R6/bin/xpowerchute
48 install %{SOURCE4} $RPM_BUILD_ROOT%{_libdir}/powerchute/Config.sh
49 install %{SOURCE6} $RPM_BUILD_ROOT%{_libdir}/powerchute/powerchute.ini_templ
50 install %{SOURCE5} $RPM_BUILD_ROOT%{_sysconfdir}/powerchute.ini
51
52 ln -s %{_sysconfdir}/powerchute.ini $RPM_BUILD_ROOT%{_libdir}/powerchute/
53
54 install _upsd $RPM_BUILD_ROOT%{_sbindir}/upsd
55
56 install _xpwrchute $RPM_BUILD_ROOT%{_libdir}/powerchute
57 install addpage.sh $RPM_BUILD_ROOT%{_libdir}/powerchute
58 install apacheshut $RPM_BUILD_ROOT%{_libdir}/powerchute
59 install bkupsd $RPM_BUILD_ROOT%{_libdir}/powerchute
60 install dialpager.sh $RPM_BUILD_ROOT%{_libdir}/powerchute
61 install killbk.sh $RPM_BUILD_ROOT%{_libdir}/powerchute
62 install killpc.sh $RPM_BUILD_ROOT%{_libdir}/powerchute
63 install machine_id $RPM_BUILD_ROOT%{_libdir}/powerchute
64 install mailer.sh $RPM_BUILD_ROOT%{_libdir}/powerchute
65 install notifier.sh $RPM_BUILD_ROOT%{_libdir}/powerchute
66 install pcshut.sh $RPM_BUILD_ROOT%{_libdir}/powerchute
67 install portcheck $RPM_BUILD_ROOT%{_libdir}/powerchute
68 install ttycheck $RPM_BUILD_ROOT%{_libdir}/powerchute
69 install ups_adjust $RPM_BUILD_ROOT%{_libdir}/powerchute
70 install upsoff $RPM_BUILD_ROOT%{_libdir}/powerchute
71 install upswrite $RPM_BUILD_ROOT%{_libdir}/powerchute
72 install wall.sh $RPM_BUILD_ROOT%{_libdir}/powerchute
73 install what_os.sh $RPM_BUILD_ROOT%{_libdir}/powerchute
74 install pwrchute.uid $RPM_BUILD_ROOT%{_prefix}/X11R6/lib/X11/uid/
75
76 install pwrchute.ad $RPM_BUILD_ROOT%{_prefix}/X11R6/lib/X11/app-defaults/pwrchute
77
78 ln -s /var/run/upsd.pid $RPM_BUILD_ROOT%{_libdir}/powerchute/
79 ln -s /var/run/bkupsd.pid $RPM_BUILD_ROOT%{_libdir}/powerchute/
80
81 gzip -9nf language.txt readme_apache
82
83 %pre
84 if ! id -g pwrchute > /dev/null 2>&1 ; then
85         %{_sbindir}/groupadd -g 68 pwrchute
86 fi
87 if ! id -u pwrchute > /dev/null 2>&1 ; then
88         %{_sbindir}/useradd -u 68 -g 68 -d /dev/null -s /bin/false -c "PowerChute Plus" pwrchute
89 fi
90
91 %post
92 /sbin/chkconfig --add upsd
93 if [ -f /var/lock/subsys/upsd ]; then
94         /etc/rc.d/init.d/upsd restart 1>&2
95 else
96         echo "Type \"/etc/rc.d/init.d/upsd start\" to start UPSd server" 1>&2
97 fi
98 cd %{_libdir}/powerchute
99 ./machine_id
100 echo "You should run %{_libdir}/powerchute/Config.sh to configure PowerChute plus"
101 echo "Remember to set the password for pwrchute account"
102         
103 %preun
104 if [ "$1" = "0" ]; then
105         if [ -f /var/lock/subsys/upsd ]; then
106                 /etc/rc.d/init.d/upsd stop 1>&2
107         fi
108         /sbin/chkconfig --del upsd
109 fi
110
111 %postun
112 if [ "$1" = "0" ]; then
113         %{_sbindir}/userdel pwrchute
114         %{_sbindir}/groupdel pwrchute
115 fi
116
117 %clean
118 rm -rf $RPM_BUILD_ROOT
119
120 %files
121 %defattr(644,root,root,755)
122 %doc help/* apachesh.pdf language.txt.gz readme_apache.gz pclinxug.pdf
123 %attr(754,root,root) /etc/rc.d/init.d/upsd
124 %config(noreplace) %verify(not size mtime md5) %{_sysconfdir}/powerchute.ini
125 %attr(755,root,root) %{_sbindir}/upsd
126 %attr(755,root,root) %{_libdir}/powerchute/Config.sh
127 %attr(755,root,root) %{_libdir}/powerchute/_xpwrchute
128 %attr(755,root,root) %{_libdir}/powerchute/addpage.sh
129 %attr(755,root,root) %{_libdir}/powerchute/apacheshut
130 %attr(755,root,root) %{_libdir}/powerchute/bkupsd
131 %attr(755,root,root) %{_libdir}/powerchute/dialpager.sh
132 %attr(755,root,root) %{_libdir}/powerchute/killbk.sh
133 %attr(755,root,root) %{_libdir}/powerchute/killpc.sh
134 %attr(755,root,root) %{_libdir}/powerchute/machine_id
135 %attr(755,root,root) %{_libdir}/powerchute/mailer.sh
136 %attr(755,root,root) %{_libdir}/powerchute/notifier.sh
137 %attr(755,root,root) %{_libdir}/powerchute/pcshut.sh
138 %attr(755,root,root) %{_libdir}/powerchute/portcheck
139 %attr(755,root,root) %{_libdir}/powerchute/ttycheck
140 %attr(755,root,root) %{_libdir}/powerchute/ups_adjust
141 %attr(755,root,root) %{_libdir}/powerchute/upsoff
142 %attr(755,root,root) %{_libdir}/powerchute/upswrite
143 %attr(755,root,root) %{_libdir}/powerchute/wall.sh
144 %attr(755,root,root) %{_libdir}/powerchute/what_os.sh
145 %{_libdir}/powerchute/powerchute.ini
146 %{_libdir}/powerchute/powerchute.ini_templ
147 %attr(755,root,root) %{_prefix}/X11R6/bin/xpowerchute
148 %{_prefix}/X11R6/lib/X11/app-defaults/*
149 %{_prefix}/X11R6/lib/X11/uid/*
150 %config(noreplace) %verify(not size mtime md5) %{_libdir}/powerchute/upsd.pid
151 %config(noreplace) %verify(not size mtime md5) %{_libdir}/powerchute/bkupsd.pid
This page took 0.075361 seconds and 4 git commands to generate.