]> git.pld-linux.org Git - packages/PowerChutePlus.git/blob - PowerChutePlus.spec
- massive attack: adding Source-md5
[packages/PowerChutePlus.git] / PowerChutePlus.spec
1 Summary:        UPS management software for APC UPS models
2 Summary(pl):    Oprogramowanie do obs³ugi UPS-ów APC
3 Name:           PowerChutePlus
4 Version:        4.5.3
5 Release:        1
6 License:        (c) 1999 APC, inc.
7 Group:          Applications/System
8 Source0:        ftp://ftp.apcc.com/apc/public/software/unix/linux/pcplus/453/pcplus_453_caldera.tar
9 # Source0-md5:  5eb99efd5561694b9f692aa713bd974d
10 Source1:        ftp://ftp.apcc.com/apc/public/software/unix/linux/pcplus/453/pc453ug.pdf
11 # Source1-md5:  0c2a621adcad8fdcb6064ed3cb042711
12 Source2:        upsd.init
13 Source3:        %{name}-xpowerchute.sh
14 Source4:        %{name}-Config.sh
15 Source5:        %{name}-powerchute.ini
16 Source6:        %{name}-powerchute.ini_templ
17 Source7:        ftp://ftp.apcc.com/apc/public/software/unix/linux/pcplus/settings.pdf
18 # Source7-md5:  c69abad141a836fd12ced0cc39049dc6
19 Patch0:         %{name}-fix-sh.patch
20 ExclusiveOS:    linux
21 ExclusiveArch:  %{ix86}
22 Prereq:         chkconfig
23 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
24
25 %description
26 This program allows users to safely shut down their system in response
27 to power failures and other power events. It also allows users to
28 configure and manage UPS models.
29
30 Please note that /usr/lib/powerchute/Config.sh should be run in order
31 to configure PowerChute plus.
32
33 %description -l pl
34 Ten program pozwala u¿ytkownikom bezpiecznie wy³±czyæ system w
35 przypadku awarii zasilania. Pozwala tak¿e na skonfigurowanie UPS.
36
37 Uwaga: aby skonfigurowaæ PowerChute Plus nale¿y uruchomiæ
38 /usr/lib/powerchute/Config.sh .
39
40 %prep
41 %setup -q -c
42 for i in BI_LINUX CI_LINUX COMMON FI_LINUX HELP ; do
43         tar xf $i
44 done
45 %patch0 -p1
46
47 %build
48 # No build, binary package
49
50 %install
51 rm -rf $RPM_BUILD_ROOT
52 install -d $RPM_BUILD_ROOT{%{_sbindir},%{_libdir}/powerchute} \
53         $RPM_BUILD_ROOT/etc/rc.d/init.d \
54         $RPM_BUILD_ROOT%{_prefix}/X11R6/{bin,lib/X11/{app-defaults,uid}}
55
56 install %{SOURCE1} .
57 install %{SOURCE7} .
58 install %{SOURCE2} $RPM_BUILD_ROOT/etc/rc.d/init.d/upsd
59 install %{SOURCE3} $RPM_BUILD_ROOT%{_prefix}/X11R6/bin/xpowerchute
60 install %{SOURCE4} $RPM_BUILD_ROOT%{_libdir}/powerchute/Config.sh
61 install %{SOURCE6} $RPM_BUILD_ROOT%{_libdir}/powerchute/powerchute.ini_templ
62 install %{SOURCE5} $RPM_BUILD_ROOT%{_sysconfdir}/powerchute.ini
63
64 ln -sf %{_sysconfdir}/powerchute.ini $RPM_BUILD_ROOT%{_libdir}/powerchute/
65
66 install _upsd $RPM_BUILD_ROOT%{_sbindir}/upsd
67
68 install _xpwrchute $RPM_BUILD_ROOT%{_libdir}/powerchute
69 install addpage.sh $RPM_BUILD_ROOT%{_libdir}/powerchute
70 install apacheshut $RPM_BUILD_ROOT%{_libdir}/powerchute
71 install bkupsd $RPM_BUILD_ROOT%{_libdir}/powerchute
72 install dialpager.sh $RPM_BUILD_ROOT%{_libdir}/powerchute
73 install killbk.sh $RPM_BUILD_ROOT%{_libdir}/powerchute
74 install killpc.sh $RPM_BUILD_ROOT%{_libdir}/powerchute
75 install machine_id $RPM_BUILD_ROOT%{_libdir}/powerchute
76 install mailer.sh $RPM_BUILD_ROOT%{_libdir}/powerchute
77 install notifier.sh $RPM_BUILD_ROOT%{_libdir}/powerchute
78 install pcshut.sh $RPM_BUILD_ROOT%{_libdir}/powerchute
79 install portcheck $RPM_BUILD_ROOT%{_libdir}/powerchute
80 install ttycheck $RPM_BUILD_ROOT%{_libdir}/powerchute
81 install ups_adjust $RPM_BUILD_ROOT%{_libdir}/powerchute
82 install upsoff $RPM_BUILD_ROOT%{_libdir}/powerchute
83 install upswrite $RPM_BUILD_ROOT%{_libdir}/powerchute
84 install wall.sh $RPM_BUILD_ROOT%{_libdir}/powerchute
85 install what_os.sh $RPM_BUILD_ROOT%{_libdir}/powerchute
86 install pwrchute.uid $RPM_BUILD_ROOT%{_prefix}/X11R6/lib/X11/uid/
87
88 install pwrchute.ad $RPM_BUILD_ROOT%{_prefix}/X11R6/lib/X11/app-defaults/pwrchute
89
90 ln -sf /var/run/upsd.pid $RPM_BUILD_ROOT%{_libdir}/powerchute/
91 ln -sf /var/run/bkupsd.pid $RPM_BUILD_ROOT%{_libdir}/powerchute/
92
93 gzip -9nf language.txt readme_apache
94
95 %clean
96 rm -rf $RPM_BUILD_ROOT
97
98 %pre
99 if ! id -g pwrchute > /dev/null 2>&1 ; then
100         %{_sbindir}/groupadd -g 68 pwrchute
101 fi
102 if ! id -u pwrchute > /dev/null 2>&1 ; then
103         %{_sbindir}/useradd -u 68 -g 68 -d /dev/null -s /bin/false -c "PowerChute Plus" pwrchute
104 fi
105
106 %post
107 /sbin/chkconfig --add upsd
108 if [ -f /var/lock/subsys/upsd ]; then
109         /etc/rc.d/init.d/upsd restart 1>&2
110 else
111         echo "Type \"/etc/rc.d/init.d/upsd start\" to start UPSd server" 1>&2
112 fi
113 cd %{_libdir}/powerchute
114 ./machine_id
115 echo "You should run %{_libdir}/powerchute/Config.sh to configure PowerChute plus"
116 echo "Remember to set the password for pwrchute account"
117         
118 %preun
119 if [ "$1" = "0" ]; then
120         if [ -f /var/lock/subsys/upsd ]; then
121                 /etc/rc.d/init.d/upsd stop 1>&2
122         fi
123         /sbin/chkconfig --del upsd
124 fi
125
126 %postun
127 if [ "$1" = "0" ]; then
128         %{_sbindir}/userdel pwrchute
129         %{_sbindir}/groupdel pwrchute
130 fi
131
132 %files
133 %defattr(644,root,root,755)
134 %doc help/* apachesh.pdf language.txt.gz readme_apache.gz pc453ug.pdf settings.pdf
135 %attr(754,root,root) /etc/rc.d/init.d/upsd
136 %attr(640,root,pwrchute) %config(noreplace) %verify(not size mtime md5) %{_sysconfdir}/powerchute.ini
137 %attr(755,root,root) %{_sbindir}/upsd
138 %attr(755,root,root) %{_libdir}/powerchute/Config.sh
139 %attr(755,root,root) %{_libdir}/powerchute/_xpwrchute
140 %attr(755,root,root) %{_libdir}/powerchute/addpage.sh
141 %attr(755,root,root) %{_libdir}/powerchute/apacheshut
142 %attr(755,root,root) %{_libdir}/powerchute/bkupsd
143 %attr(755,root,root) %{_libdir}/powerchute/dialpager.sh
144 %attr(755,root,root) %{_libdir}/powerchute/killbk.sh
145 %attr(755,root,root) %{_libdir}/powerchute/killpc.sh
146 %attr(755,root,root) %{_libdir}/powerchute/machine_id
147 %attr(755,root,root) %{_libdir}/powerchute/mailer.sh
148 %attr(755,root,root) %{_libdir}/powerchute/notifier.sh
149 %attr(755,root,root) %{_libdir}/powerchute/pcshut.sh
150 %attr(755,root,root) %{_libdir}/powerchute/portcheck
151 %attr(755,root,root) %{_libdir}/powerchute/ttycheck
152 %attr(755,root,root) %{_libdir}/powerchute/ups_adjust
153 %attr(755,root,root) %{_libdir}/powerchute/upsoff
154 %attr(755,root,root) %{_libdir}/powerchute/upswrite
155 %attr(755,root,root) %{_libdir}/powerchute/wall.sh
156 %attr(755,root,root) %{_libdir}/powerchute/what_os.sh
157 %{_libdir}/powerchute/powerchute.ini
158 %{_libdir}/powerchute/powerchute.ini_templ
159 %attr(755,root,root) %{_prefix}/X11R6/bin/xpowerchute
160 %{_prefix}/X11R6/lib/X11/app-defaults/*
161 %{_prefix}/X11R6/lib/X11/uid/*
162 %config(noreplace) %verify(not size mtime md5) %{_libdir}/powerchute/upsd.pid
163 %config(noreplace) %verify(not size mtime md5) %{_libdir}/powerchute/bkupsd.pid
This page took 0.059636 seconds and 4 git commands to generate.