]> git.pld-linux.org Git - packages/PowerChutePlus.git/blob - PowerChutePlus.spec
732c821ddf29bdfa43e3489252e4723747fdf323
[packages/PowerChutePlus.git] / PowerChutePlus.spec
1 Summary:        UPS management software for APC UPS models
2 Summary(pl):    Oprogramowanie do obs³ugi UPS-ów APC
3 Name:           PowerChutePlus
4 Version:        4.5.3
5 Release:        1
6 License:        (c) 1999 APC, inc.
7 Group:          Applications/System
8 Source0:        ftp://ftp.apcc.com/apc/public/software/unix/linux/pcplus/453/pcplus_453_caldera.tar
9 # Source0-md5:  5eb99efd5561694b9f692aa713bd974d
10 Source1:        ftp://ftp.apcc.com/apc/public/software/unix/linux/pcplus/453/pc453ug.pdf
11 # Source1-md5:  0c2a621adcad8fdcb6064ed3cb042711
12 Source2:        upsd.init
13 Source3:        %{name}-xpowerchute.sh
14 Source4:        %{name}-Config.sh
15 Source5:        %{name}-powerchute.ini
16 Source6:        %{name}-powerchute.ini_templ
17 Source7:        ftp://ftp.apcc.com/apc/public/software/unix/linux/pcplus/settings.pdf
18 # Source7-md5:  c69abad141a836fd12ced0cc39049dc6
19 Patch0:         %{name}-fix-sh.patch
20 PreReq:         rc-scripts
21 Requires(pre):  /bin/id
22 Requires(pre):  /usr/bin/getgid
23 Requires(pre):  /usr/sbin/useradd
24 Requires(pre):  /usr/sbin/groupadd
25 Requires(post,preun):   /sbin/chkconfig
26 Requires(postun):       /usr/sbin/groupdel
27 Requires(postun):       /usr/sbin/userdel
28 ExclusiveArch:  %{ix86}
29 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
30
31 %description
32 This program allows users to safely shut down their system in response
33 to power failures and other power events. It also allows users to
34 configure and manage UPS models.
35
36 Please note that /usr/lib/powerchute/Config.sh should be run in order
37 to configure PowerChute plus.
38
39 %description -l pl
40 Ten program pozwala u¿ytkownikom bezpiecznie wy³±czyæ system w
41 przypadku awarii zasilania. Pozwala tak¿e na skonfigurowanie UPS.
42
43 Uwaga: aby skonfigurowaæ PowerChute Plus nale¿y uruchomiæ
44 /usr/lib/powerchute/Config.sh .
45
46 %prep
47 %setup -q -c
48 for i in BI_LINUX CI_LINUX COMMON FI_LINUX HELP ; do
49         tar xf $i
50 done
51 %patch0 -p1
52
53 %build
54 # No build, binary package
55
56 %install
57 rm -rf $RPM_BUILD_ROOT
58 install -d $RPM_BUILD_ROOT{%{_sbindir},%{_libdir}/powerchute} \
59         $RPM_BUILD_ROOT/etc/rc.d/init.d \
60         $RPM_BUILD_ROOT%{_prefix}/X11R6/{bin,lib/X11/{app-defaults,uid}}
61
62 install %{SOURCE1} .
63 install %{SOURCE7} .
64 install %{SOURCE2} $RPM_BUILD_ROOT/etc/rc.d/init.d/upsd
65 install %{SOURCE3} $RPM_BUILD_ROOT%{_prefix}/X11R6/bin/xpowerchute
66 install %{SOURCE4} $RPM_BUILD_ROOT%{_libdir}/powerchute/Config.sh
67 install %{SOURCE6} $RPM_BUILD_ROOT%{_libdir}/powerchute/powerchute.ini_templ
68 install %{SOURCE5} $RPM_BUILD_ROOT%{_sysconfdir}/powerchute.ini
69
70 ln -sf %{_sysconfdir}/powerchute.ini $RPM_BUILD_ROOT%{_libdir}/powerchute
71
72 install _upsd $RPM_BUILD_ROOT%{_sbindir}/upsd
73
74 install _xpwrchute $RPM_BUILD_ROOT%{_libdir}/powerchute
75 install addpage.sh $RPM_BUILD_ROOT%{_libdir}/powerchute
76 install apacheshut $RPM_BUILD_ROOT%{_libdir}/powerchute
77 install bkupsd $RPM_BUILD_ROOT%{_libdir}/powerchute
78 install dialpager.sh $RPM_BUILD_ROOT%{_libdir}/powerchute
79 install killbk.sh $RPM_BUILD_ROOT%{_libdir}/powerchute
80 install killpc.sh $RPM_BUILD_ROOT%{_libdir}/powerchute
81 install machine_id $RPM_BUILD_ROOT%{_libdir}/powerchute
82 install mailer.sh $RPM_BUILD_ROOT%{_libdir}/powerchute
83 install notifier.sh $RPM_BUILD_ROOT%{_libdir}/powerchute
84 install pcshut.sh $RPM_BUILD_ROOT%{_libdir}/powerchute
85 install portcheck $RPM_BUILD_ROOT%{_libdir}/powerchute
86 install ttycheck $RPM_BUILD_ROOT%{_libdir}/powerchute
87 install ups_adjust $RPM_BUILD_ROOT%{_libdir}/powerchute
88 install upsoff $RPM_BUILD_ROOT%{_libdir}/powerchute
89 install upswrite $RPM_BUILD_ROOT%{_libdir}/powerchute
90 install wall.sh $RPM_BUILD_ROOT%{_libdir}/powerchute
91 install what_os.sh $RPM_BUILD_ROOT%{_libdir}/powerchute
92 install pwrchute.uid $RPM_BUILD_ROOT%{_prefix}/X11R6/lib/X11/uid
93
94 install pwrchute.ad $RPM_BUILD_ROOT%{_prefix}/X11R6/lib/X11/app-defaults/pwrchute
95
96 ln -sf /var/run/upsd.pid $RPM_BUILD_ROOT%{_libdir}/powerchute
97 ln -sf /var/run/bkupsd.pid $RPM_BUILD_ROOT%{_libdir}/powerchute
98
99 %clean
100 rm -rf $RPM_BUILD_ROOT
101
102 %pre
103 if [ -n "`getgid pwrchute`" ]; then
104         if [ "`getgid pwrchute`" != "68" ]; then
105                 echo "Error: group pwrchute doesn't have gid=68. Correct this before installing PowerChutePlus." 1>&2
106                 exit 1
107         fi
108 else
109         /usr/sbin/groupadd -g 68 pwrchute
110 fi
111 if [ -n "`id -u pwrchute 2>/dev/null`" ]; then
112         if [ "`id -u pwrchute`" != "68" ]; then
113                 echo "Error: user pwrchute doesn't have uid=68. Correct this before installing PowerChutePlus." 1>&2
114                 exit 1
115         fi
116 else
117         /usr/sbin/useradd -u 68 -g 68 -d /dev/null -s /bin/false -c "PowerChute Plus" pwrchute
118 fi
119
120 %post
121 /sbin/chkconfig --add upsd
122 if [ -f /var/lock/subsys/upsd ]; then
123         /etc/rc.d/init.d/upsd restart 1>&2
124 else
125         echo "Type \"/etc/rc.d/init.d/upsd start\" to start UPSd server" 1>&2
126 fi
127 cd %{_libdir}/powerchute
128 ./machine_id
129 echo "You should run %{_libdir}/powerchute/Config.sh to configure PowerChute plus"
130 echo "Remember to set the password for pwrchute account"
131         
132 %preun
133 if [ "$1" = "0" ]; then
134         if [ -f /var/lock/subsys/upsd ]; then
135                 /etc/rc.d/init.d/upsd stop 1>&2
136         fi
137         /sbin/chkconfig --del upsd
138 fi
139
140 %postun
141 if [ "$1" = "0" ]; then
142         /usr/sbin/userdel pwrchute
143         /usr/sbin/groupdel pwrchute
144 fi
145
146 %files
147 %defattr(644,root,root,755)
148 %doc help/* apachesh.pdf language.txt readme_apache pc453ug.pdf settings.pdf
149 %attr(754,root,root) /etc/rc.d/init.d/upsd
150 %attr(640,root,pwrchute) %config(noreplace) %verify(not size mtime md5) %{_sysconfdir}/powerchute.ini
151 %attr(755,root,root) %{_sbindir}/upsd
152 %attr(755,root,root) %{_libdir}/powerchute/Config.sh
153 %attr(755,root,root) %{_libdir}/powerchute/_xpwrchute
154 %attr(755,root,root) %{_libdir}/powerchute/addpage.sh
155 %attr(755,root,root) %{_libdir}/powerchute/apacheshut
156 %attr(755,root,root) %{_libdir}/powerchute/bkupsd
157 %attr(755,root,root) %{_libdir}/powerchute/dialpager.sh
158 %attr(755,root,root) %{_libdir}/powerchute/killbk.sh
159 %attr(755,root,root) %{_libdir}/powerchute/killpc.sh
160 %attr(755,root,root) %{_libdir}/powerchute/machine_id
161 %attr(755,root,root) %{_libdir}/powerchute/mailer.sh
162 %attr(755,root,root) %{_libdir}/powerchute/notifier.sh
163 %attr(755,root,root) %{_libdir}/powerchute/pcshut.sh
164 %attr(755,root,root) %{_libdir}/powerchute/portcheck
165 %attr(755,root,root) %{_libdir}/powerchute/ttycheck
166 %attr(755,root,root) %{_libdir}/powerchute/ups_adjust
167 %attr(755,root,root) %{_libdir}/powerchute/upsoff
168 %attr(755,root,root) %{_libdir}/powerchute/upswrite
169 %attr(755,root,root) %{_libdir}/powerchute/wall.sh
170 %attr(755,root,root) %{_libdir}/powerchute/what_os.sh
171 %{_libdir}/powerchute/powerchute.ini
172 %{_libdir}/powerchute/powerchute.ini_templ
173 %attr(755,root,root) %{_prefix}/X11R6/bin/xpowerchute
174 %{_prefix}/X11R6/lib/X11/app-defaults/*
175 %{_prefix}/X11R6/lib/X11/uid/*
176 %config(noreplace) %verify(not size mtime md5) %{_libdir}/powerchute/upsd.pid
177 %config(noreplace) %verify(not size mtime md5) %{_libdir}/powerchute/bkupsd.pid
This page took 0.060173 seconds and 2 git commands to generate.