]> git.pld-linux.org Git - packages/PowerChutePlus.git/blob - PowerChutePlus.spec
- new spec syntax is so cool
[packages/PowerChutePlus.git] / PowerChutePlus.spec
1 Summary:        UPS management software for APC UPS models
2 Summary(pl):    Oprogramowanie do obs³ugi UPS-ów APC
3 Name:           PowerChutePlus
4 Version:        4.5.3
5 Release:        1
6 License:        (c) 1999 APC, inc.
7 Group:          Applications/System
8 Source0:        ftp://ftp.apcc.com/apc/public/software/unix/linux/pcplus/453/pcplus_453_caldera.tar
9 # Source0-md5:  5eb99efd5561694b9f692aa713bd974d
10 Source1:        ftp://ftp.apcc.com/apc/public/software/unix/linux/pcplus/453/pc453ug.pdf
11 # Source1-md5:  0c2a621adcad8fdcb6064ed3cb042711
12 Source2:        upsd.init
13 Source3:        %{name}-xpowerchute.sh
14 Source4:        %{name}-Config.sh
15 Source5:        %{name}-powerchute.ini
16 Source6:        %{name}-powerchute.ini_templ
17 Source7:        ftp://ftp.apcc.com/apc/public/software/unix/linux/pcplus/settings.pdf
18 # Source7-md5:  c69abad141a836fd12ced0cc39049dc6
19 Patch0:         %{name}-fix-sh.patch
20 BuildRequires:  rpmbuild(macros) >= 1.202
21 PreReq:         rc-scripts
22 Requires(pre):  /bin/id
23 Requires(pre):  /usr/bin/getgid
24 Requires(pre):  /usr/sbin/useradd
25 Requires(pre):  /usr/sbin/groupadd
26 Requires(post,preun):   /sbin/chkconfig
27 Requires(postun):       /usr/sbin/groupdel
28 Requires(postun):       /usr/sbin/userdel
29 Provides:       group(pwrchute)
30 Provides:       user(pwrchute)
31 ExclusiveArch:  %{ix86}
32 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
33
34 %description
35 This program allows users to safely shut down their system in response
36 to power failures and other power events. It also allows users to
37 configure and manage UPS models.
38
39 Please note that /usr/lib/powerchute/Config.sh should be run in order
40 to configure PowerChute plus.
41
42 %description -l pl
43 Ten program pozwala u¿ytkownikom bezpiecznie wy³±czyæ system w
44 przypadku awarii zasilania. Pozwala tak¿e na skonfigurowanie UPS.
45
46 Uwaga: aby skonfigurowaæ PowerChute Plus nale¿y uruchomiæ
47 /usr/lib/powerchute/Config.sh .
48
49 %prep
50 %setup -q -c
51 for i in BI_LINUX CI_LINUX COMMON FI_LINUX HELP ; do
52         tar xf $i
53 done
54 %patch0 -p1
55
56 %build
57 # No build, binary package
58
59 %install
60 rm -rf $RPM_BUILD_ROOT
61 install -d $RPM_BUILD_ROOT{%{_sbindir},%{_libdir}/powerchute} \
62         $RPM_BUILD_ROOT/etc/rc.d/init.d \
63         $RPM_BUILD_ROOT%{_prefix}/X11R6/{bin,lib/X11/{app-defaults,uid}}
64
65 install %{SOURCE1} .
66 install %{SOURCE7} .
67 install %{SOURCE2} $RPM_BUILD_ROOT/etc/rc.d/init.d/upsd
68 install %{SOURCE3} $RPM_BUILD_ROOT%{_prefix}/X11R6/bin/xpowerchute
69 install %{SOURCE4} $RPM_BUILD_ROOT%{_libdir}/powerchute/Config.sh
70 install %{SOURCE6} $RPM_BUILD_ROOT%{_libdir}/powerchute/powerchute.ini_templ
71 install %{SOURCE5} $RPM_BUILD_ROOT%{_sysconfdir}/powerchute.ini
72
73 ln -sf %{_sysconfdir}/powerchute.ini $RPM_BUILD_ROOT%{_libdir}/powerchute
74
75 install _upsd $RPM_BUILD_ROOT%{_sbindir}/upsd
76
77 install _xpwrchute $RPM_BUILD_ROOT%{_libdir}/powerchute
78 install addpage.sh $RPM_BUILD_ROOT%{_libdir}/powerchute
79 install apacheshut $RPM_BUILD_ROOT%{_libdir}/powerchute
80 install bkupsd $RPM_BUILD_ROOT%{_libdir}/powerchute
81 install dialpager.sh $RPM_BUILD_ROOT%{_libdir}/powerchute
82 install killbk.sh $RPM_BUILD_ROOT%{_libdir}/powerchute
83 install killpc.sh $RPM_BUILD_ROOT%{_libdir}/powerchute
84 install machine_id $RPM_BUILD_ROOT%{_libdir}/powerchute
85 install mailer.sh $RPM_BUILD_ROOT%{_libdir}/powerchute
86 install notifier.sh $RPM_BUILD_ROOT%{_libdir}/powerchute
87 install pcshut.sh $RPM_BUILD_ROOT%{_libdir}/powerchute
88 install portcheck $RPM_BUILD_ROOT%{_libdir}/powerchute
89 install ttycheck $RPM_BUILD_ROOT%{_libdir}/powerchute
90 install ups_adjust $RPM_BUILD_ROOT%{_libdir}/powerchute
91 install upsoff $RPM_BUILD_ROOT%{_libdir}/powerchute
92 install upswrite $RPM_BUILD_ROOT%{_libdir}/powerchute
93 install wall.sh $RPM_BUILD_ROOT%{_libdir}/powerchute
94 install what_os.sh $RPM_BUILD_ROOT%{_libdir}/powerchute
95 install pwrchute.uid $RPM_BUILD_ROOT%{_prefix}/X11R6/lib/X11/uid
96
97 install pwrchute.ad $RPM_BUILD_ROOT%{_prefix}/X11R6/lib/X11/app-defaults/pwrchute
98
99 ln -sf /var/run/upsd.pid $RPM_BUILD_ROOT%{_libdir}/powerchute
100 ln -sf /var/run/bkupsd.pid $RPM_BUILD_ROOT%{_libdir}/powerchute
101
102 %clean
103 rm -rf $RPM_BUILD_ROOT
104
105 %pre
106 %groupadd -g 68 pwrchute
107 %useradd -u 68 -g 68 -d /usr/share/empty -s /bin/false -c "PowerChute Plus" pwrchute
108
109 %post
110 /sbin/chkconfig --add upsd
111 if [ -f /var/lock/subsys/upsd ]; then
112         /etc/rc.d/init.d/upsd restart 1>&2
113 else
114         echo "Type \"/etc/rc.d/init.d/upsd start\" to start UPSd server" 1>&2
115 fi
116 cd %{_libdir}/powerchute
117 ./machine_id
118 echo "You should run %{_libdir}/powerchute/Config.sh to configure PowerChute plus"
119 echo "Remember to set the password for pwrchute account"
120
121 %preun
122 if [ "$1" = "0" ]; then
123         if [ -f /var/lock/subsys/upsd ]; then
124                 /etc/rc.d/init.d/upsd stop 1>&2
125         fi
126         /sbin/chkconfig --del upsd
127 fi
128
129 %postun
130 if [ "$1" = "0" ]; then
131         %userremove pwrchute
132         %groupremove pwrchute
133 fi
134
135 %files
136 %defattr(644,root,root,755)
137 %doc help/* apachesh.pdf language.txt readme_apache pc453ug.pdf settings.pdf
138 %attr(754,root,root) /etc/rc.d/init.d/upsd
139 %attr(640,root,pwrchute) %config(noreplace) %verify(not size mtime md5) %{_sysconfdir}/powerchute.ini
140 %attr(755,root,root) %{_sbindir}/upsd
141 %dir %{_libdir}/powerchute
142 %attr(755,root,root) %{_libdir}/powerchute/Config.sh
143 %attr(755,root,root) %{_libdir}/powerchute/_xpwrchute
144 %attr(755,root,root) %{_libdir}/powerchute/addpage.sh
145 %attr(755,root,root) %{_libdir}/powerchute/apacheshut
146 %attr(755,root,root) %{_libdir}/powerchute/bkupsd
147 %attr(755,root,root) %{_libdir}/powerchute/dialpager.sh
148 %attr(755,root,root) %{_libdir}/powerchute/killbk.sh
149 %attr(755,root,root) %{_libdir}/powerchute/killpc.sh
150 %attr(755,root,root) %{_libdir}/powerchute/machine_id
151 %attr(755,root,root) %{_libdir}/powerchute/mailer.sh
152 %attr(755,root,root) %{_libdir}/powerchute/notifier.sh
153 %attr(755,root,root) %{_libdir}/powerchute/pcshut.sh
154 %attr(755,root,root) %{_libdir}/powerchute/portcheck
155 %attr(755,root,root) %{_libdir}/powerchute/ttycheck
156 %attr(755,root,root) %{_libdir}/powerchute/ups_adjust
157 %attr(755,root,root) %{_libdir}/powerchute/upsoff
158 %attr(755,root,root) %{_libdir}/powerchute/upswrite
159 %attr(755,root,root) %{_libdir}/powerchute/wall.sh
160 %attr(755,root,root) %{_libdir}/powerchute/what_os.sh
161 %{_libdir}/powerchute/powerchute.ini
162 %{_libdir}/powerchute/powerchute.ini_templ
163 %attr(755,root,root) %{_prefix}/X11R6/bin/xpowerchute
164 %{_prefix}/X11R6/lib/X11/app-defaults/*
165 %{_prefix}/X11R6/lib/X11/uid/*
166 %config(noreplace) %verify(not size mtime md5) %{_libdir}/powerchute/upsd.pid
167 %config(noreplace) %verify(not size mtime md5) %{_libdir}/powerchute/bkupsd.pid
This page took 0.071452 seconds and 3 git commands to generate.