]> git.pld-linux.org Git - packages/PolicyKit.git/commitdiff
- fix CVE-2008-1658
authorPatryk Zawadzki <patrys@room-303.com>
Sat, 12 Apr 2008 13:07:47 +0000 (13:07 +0000)
committercvs2git <feedback@pld-linux.org>
Sun, 24 Jun 2012 12:13:13 +0000 (12:13 +0000)
Changed files:
    PolicyKit-CVE.patch -> 1.1

PolicyKit-CVE.patch [new file with mode: 0644]

diff --git a/PolicyKit-CVE.patch b/PolicyKit-CVE.patch
new file mode 100644 (file)
index 0000000..d506453
--- /dev/null
@@ -0,0 +1,49 @@
+From: Kees Cook <kees@outflux.net>
+Date: Fri, 4 Apr 2008 06:26:30 +0000 (-0400)
+Subject: fix for CVE-2008-1658: format string vulnerability in password input
+X-Git-Url: http://gitweb.freedesktop.org/?p=PolicyKit.git;a=commitdiff;h=5bc86a14cc0e356bcf8b5f861674f842869b1be7
+
+fix for CVE-2008-1658: format string vulnerability in password input
+
+http://bugs.freedesktop.org/show_bug.cgi?id=15295
+---
+
+--- a/configure.in
++++ b/configure.in
+@@ -114,6 +114,16 @@ if test "x$GCC" = "xyes"; then
+   *) CFLAGS="$CFLAGS -Wsign-compare" ;;
+   esac
++  case " $CFLAGS " in
++  *[\ \       ]-Wformat[\ \   ]*) ;;
++  *) CFLAGS="$CFLAGS -Wformat" ;;
++  esac
++
++  case " $CFLAGS " in
++  *[\ \       ]-Wformat-security[\ \  ]*) ;;
++  *) CFLAGS="$CFLAGS -Wformat-security" ;;
++  esac
++
+   if test "x$enable_ansi" = "xyes"; then
+     case " $CFLAGS " in
+     *[\ \     ]-ansi[\ \      ]*) ;;
+--- a/src/polkit-grant/polkit-grant-helper.c
++++ b/src/polkit-grant/polkit-grant-helper.c
+@@ -241,7 +241,7 @@ do_auth (const char *user_to_auth, gbool
+                 *empty_conversation = FALSE;
+                 /* send to parent */
+-                fprintf (stdout, buf);
++                fprintf (stdout, "%s", buf);
+                 fflush (stdout);
+                 
+                 /* read from parent */
+@@ -252,7 +252,7 @@ do_auth (const char *user_to_auth, gbool
+                 fprintf (stderr, "received: '%s' from parent; sending to child\n", buf);
+ #endif /* PGH_DEBUG */
+                 /* send to child */
+-                fprintf (child_stdin, buf);
++                fprintf (child_stdin, "%s", buf);
+                 fflush (child_stdin);
+         }
This page took 0.160851 seconds and 4 git commands to generate.