]> git.pld-linux.org Git - packages/PlayOnLinux.git/blob - PlayOnLinux.spec
884764d403f6333948f0e58be61d73897865d003
[packages/PlayOnLinux.git] / PlayOnLinux.spec
1 Summary:        GUI for managing Windows and DOS programs under linux
2 Name:           PlayOnLinux
3 Version:        3.8.8
4 Release:        0.2
5 License:        GPL v3
6 Group:          X11/Applications/Games
7 Source0:        http://www.playonlinux.com/script_files/PlayOnLinux/%{version}/%{name}_%{version}.tar.gz
8 # Source0-md5:  1bc12abd0a3d2426ea35e6887e9d3bd5
9 Source1:        %{name}.desktop
10 URL:            http://www.playonlinux.com/en/
11 Requires:       python-wxPython
12 Requires:       wine
13 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
14
15 %description
16 PlayOnLinux is a piece of sofware which allows you to easily install
17 and use numerous games and apps designed to run with Microsoft®
18 Windows.
19
20 %prep
21 %setup -q -n playonlinux
22
23 %build
24
25 %install
26 rm -rf $RPM_BUILD_ROOT
27 install -d $RPM_BUILD_ROOT{%{_bindir},%{_datadir}/%{name},%{_desktopdir}}
28 cp -r * $RPM_BUILD_ROOT%{_datadir}/%{name}
29 install %SOURCE1 $RPM_BUILD_ROOT%{_desktopdir}
30 rm $RPM_BUILD_ROOT%{_datadir}/%{name}/{CHANGELOG,LICENCE}
31
32 for exec in playonlinux*; do
33 (cat << EOF
34 #!/bin/bash
35 %{_datadir}/%{name}/$exec $@
36
37 EOF
38 ) > $RPM_BUILD_ROOT%{_bindir}/$exec
39 done
40
41 %clean
42 rm -rf $RPM_BUILD_ROOT
43
44 %files
45 %defattr(644,root,root,755)
46 %doc CHANGELOG
47 %dir %{_datadir}/%{name}
48 %attr(755,root,root) %{_bindir}/playonlinux*
49 %attr(755,root,root) %{_datadir}/%{name}/playonlinux*
50 %{_datadir}/%{name}/bash
51 %{_datadir}/%{name}/etc
52 %{_datadir}/%{name}/lang
53 %{_datadir}/%{name}/lib
54 %{_datadir}/%{name}/plugins
55 %{_datadir}/%{name}/python
56 %{_datadir}/%{name}/themes
57 %{_desktopdir}/%{name}.desktop
This page took 0.050291 seconds and 2 git commands to generate.