]> git.pld-linux.org Git - packages/ParaView.git/commitdiff
- fix protobufs for latest libprotobuf
authorJan Rękorajski <baggins@pld-linux.org>
Wed, 29 Oct 2014 20:59:30 +0000 (21:59 +0100)
committerJan Rękorajski <baggins@pld-linux.org>
Wed, 29 Oct 2014 20:59:30 +0000 (21:59 +0100)
- rel 8

ParaView.spec
protobuf.patch [new file with mode: 0644]

index d7395e62108fe1d1bb4912c4d4b8f0de0eade803..49776eded43d956ce8a5a7c4840c7dcb6aa6c4ad 100644 (file)
@@ -1,7 +1,7 @@
 Summary:       Parallel visualization application
 Name:          ParaView
 Version:       4.0.1
-Release:       7
+Release:       8
 License:       BSD
 Group:         Applications/Engineering
 URL:           http://www.paraview.org/
@@ -14,6 +14,7 @@ Patch1:               %{name}-install.patch
 Patch2:                %{name}-system-Protobuf.patch
 Patch3:                %{name}-system-netcdf.patch
 Patch4:                disable-broken-tests.patch
+Patch5:                protobuf.patch
 BuildRequires: Mesa-libOSMesa-devel
 BuildRequires: QtDesigner-devel
 BuildRequires: QtHelp-devel
diff --git a/protobuf.patch b/protobuf.patch
new file mode 100644 (file)
index 0000000..a22d688
--- /dev/null
@@ -0,0 +1,64 @@
+--- ParaView-v4.0.1-source/ParaViewCore/ServerImplementation/Core/vtkPVMessage.proto.orig      2014-10-29 21:55:42.582965302 +0100
++++ ParaView-v4.0.1-source/ParaViewCore/ServerImplementation/Core/vtkPVMessage.proto   2014-10-29 21:58:20.865441145 +0100
+@@ -62,10 +62,10 @@
+ {
+   extend Message {
+     // The classname for the driver process i.e. the client, typically
+-    required string client_class = 10;
++    optional string client_class = 10;
+     // The classname for the process where the processing occurs
+-    required string server_class = 11;
++    optional string server_class = 11;
+   }
+ }
+@@ -98,8 +98,8 @@
+     }
+   extend Message {
+-    required string     xml_group           = 20;
+-    required string     xml_name            = 21;
++    optional string     xml_group           = 20;
++    optional string     xml_name            = 21;
+     optional string     xml_sub_proxy_name  = 22;
+     repeated Property   property            = 23;
+     repeated SubProxy   subproxy            = 24;
+@@ -204,7 +204,7 @@
+   }
+   extend Message {
+-    required uint32 view      = 70;
++    optional uint32 view      = 70;
+     optional double x         = 71 [default = 0];
+     optional double y         = 72 [default = 0];
+     optional bool   forceShow = 73 [default = false];
+@@ -217,7 +217,7 @@
+ message ChartViewBounds {
+   extend Message {
+-    required uint32 view  = 75;
++    optional uint32 view  = 75;
+     repeated double range = 76;
+   }
+ }
+@@ -240,8 +240,8 @@
+ message ChatMessage {
+   extend Message {
+-    required uint32 author = 84;
+-    required string txt    = 85;
++    optional uint32 author = 84;
++    optional string txt    = 85;
+   }
+ }
+@@ -254,7 +254,7 @@
+   }
+   extend Message {
+-    required QtEventType type  = 98;
++    optional QtEventType type  = 98;
+   }
+ }
This page took 0.078778 seconds and 4 git commands to generate.