]> git.pld-linux.org Git - packages/ParaView.git/commitdiff
- new, based on fedora
authorJan Rękorajski <baggins@pld-linux.org>
Fri, 17 Feb 2012 11:11:39 +0000 (11:11 +0000)
committercvs2git <feedback@pld-linux.org>
Sun, 24 Jun 2012 12:13:13 +0000 (12:13 +0000)
Changed files:
    ParaView-3.12.0-boost-1.48.0-bfs.patch -> 1.1
    ParaView-3.2.2-hdf5.patch -> 1.1
    ParaView-3.8.0-include.patch -> 1.1
    ParaView-gcc47.patch -> 1.1
    ParaView.spec -> 1.1
    ParaView.xml -> 1.1

ParaView-3.12.0-boost-1.48.0-bfs.patch [new file with mode: 0644]
ParaView-3.2.2-hdf5.patch [new file with mode: 0644]
ParaView-3.8.0-include.patch [new file with mode: 0644]
ParaView-gcc47.patch [new file with mode: 0644]
ParaView.spec [new file with mode: 0644]
ParaView.xml [new file with mode: 0644]

diff --git a/ParaView-3.12.0-boost-1.48.0-bfs.patch b/ParaView-3.12.0-boost-1.48.0-bfs.patch
new file mode 100644 (file)
index 0000000..5cc2217
--- /dev/null
@@ -0,0 +1,31 @@
+diff -up ParaView-3.12.0/VTK/Infovis/vtkBoostBreadthFirstSearchTree.cxx\~ ParaView-3.12.0/VTK/Infovis/vtkBoostBreadthFirstSearchTree.cxx
+--- ParaView-3.12.0/VTK/Infovis/vtkBoostBreadthFirstSearchTree.cxx~    2011-11-08 21:56:37.000000000 +0100
++++ ParaView-3.12.0/VTK/Infovis/vtkBoostBreadthFirstSearchTree.cxx     2011-12-06 01:11:42.487760688 +0100
+@@ -47,6 +47,15 @@ using namespace boost;
+ vtkStandardNewMacro(vtkBoostBreadthFirstSearchTree);
++namespace {
++  vtkIdType unwrap_edge_id(vtkEdgeType const &e) {
++    return e.Id;
++  }
++  vtkIdType unwrap_edge_id(boost::detail::reverse_graph_edge_descriptor<vtkEdgeType> const &e) {
++    return e.underlying_desc.Id;
++  }
++}
++
+ // Redefine the bfs visitor, the only visitor we
+ // are using is the tree_edge visitor.
+ template <typename IdMap>
+@@ -95,7 +104,8 @@ public:
+     // Copy the vertex and edge data from the graph to the tree.
+     tree->GetVertexData()->CopyData(graph->GetVertexData(), v, tree_v);
+-    tree->GetEdgeData()->CopyData(graph->GetEdgeData(), e.Id, tree_e.Id);
++    tree->GetEdgeData()->CopyData(graph->GetEdgeData(),
++                                unwrap_edge_id(e), tree_e.Id);
+   }
+ private:
+
+Diff finished.  Tue Dec  6 01:13:13 2011
diff --git a/ParaView-3.2.2-hdf5.patch b/ParaView-3.2.2-hdf5.patch
new file mode 100644 (file)
index 0000000..f019fe9
--- /dev/null
@@ -0,0 +1,11 @@
+--- ParaView3.2.1/Utilities/Xdmf2/libsrc/XdmfH5Driver.h.hdf5   2007-11-07 13:51:40.000000000 -0700
++++ ParaView3.2.1/Utilities/Xdmf2/libsrc/XdmfH5Driver.h        2008-06-26 16:31:16.000000000 -0600
+@@ -27,7 +27,7 @@
+ #include "XdmfDsmBuffer.h"
+ #include "H5Ipublic.h"
+-#include "H5pubconf.h"
++#include "H5public.h"
+ #include "XdmfExport.h"
diff --git a/ParaView-3.8.0-include.patch b/ParaView-3.8.0-include.patch
new file mode 100644 (file)
index 0000000..d216cc6
--- /dev/null
@@ -0,0 +1,20 @@
+--- ParaView-3.8.0/Utilities/Xdmf2/libsrc/XdmfDataDesc.h.include       2009-11-27 02:56:17.000000000 -0700
++++ ParaView-3.8.0/Utilities/Xdmf2/libsrc/XdmfDataDesc.h       2010-04-19 13:59:05.609711395 -0600
+@@ -27,6 +27,7 @@
+ #include "XdmfObject.h"
+ #include "XdmfHDFSupport.h"
++#include <cstring>
+ #define XDMF_SELECTALL    0
+ #define XDMF_HYPERSLAB    1
+--- ParaView-3.8.1/VTK/Utilities/vtkmetaio/metaUtils.cxx.orig  2010-09-28 10:08:05.000000000 -0400
++++ ParaView-3.8.1/VTK/Utilities/vtkmetaio/metaUtils.cxx       2011-03-29 20:05:06.658419554 -0400
+@@ -36,6 +36,7 @@
+ #include <stdlib.h>
+ #include <string.h>
++#include <stddef.h>
+ #include <string>
+ #if defined (__BORLANDC__) && (__BORLANDC__ >= 0x0580)
diff --git a/ParaView-gcc47.patch b/ParaView-gcc47.patch
new file mode 100644 (file)
index 0000000..c34e901
--- /dev/null
@@ -0,0 +1,24 @@
+diff -up ParaView-3.12.0/Qt/Core/pqServerManagerSelectionModel.h.gcc47 ParaView-3.12.0/Qt/Core/pqServerManagerSelectionModel.h
+--- ParaView-3.12.0/Qt/Core/pqServerManagerSelectionModel.h.gcc47      2012-01-27 12:12:55.623530977 -0700
++++ ParaView-3.12.0/Qt/Core/pqServerManagerSelectionModel.h    2012-01-30 15:26:33.107335300 -0700
+@@ -72,7 +72,7 @@ public:
+     Clear          = QItemSelectionModel::Clear,
+     Select         = QItemSelectionModel::Select,
+     Deselect       = QItemSelectionModel::Deselect, 
+-    ClearAndSelect = Clear | Select
++    ClearAndSelect = static_cast<int>(Clear) | static_cast<int>(Select)
+   };
+   Q_DECLARE_FLAGS(SelectionFlags, SelectionFlag)
+diff -up ParaView-3.12.0/Utilities/Xdmf2/vtk/Testing/Cxx/XdmfTestVTKIO.cxx.gcc47 ParaView-3.12.0/Utilities/Xdmf2/vtk/Testing/Cxx/XdmfTestVTKIO.cxx
+--- ParaView-3.12.0/Utilities/Xdmf2/vtk/Testing/Cxx/XdmfTestVTKIO.cxx.gcc47    2011-11-08 13:56:29.000000000 -0700
++++ ParaView-3.12.0/Utilities/Xdmf2/vtk/Testing/Cxx/XdmfTestVTKIO.cxx  2012-01-27 09:30:00.088542888 -0700
+@@ -37,6 +37,8 @@
+ #include "vtkTimeSourceExample.h"
+ #include "vtkXdmfReader.h"
++#include <unistd.h>
++
+ #define NUMTESTS 20
+ const char testobject[NUMTESTS][40] = {
diff --git a/ParaView.spec b/ParaView.spec
new file mode 100644 (file)
index 0000000..56f750f
--- /dev/null
@@ -0,0 +1,211 @@
+Summary:       Parallel visualization application
+Name:          ParaView
+Version:       3.12.0
+Release:       0.1
+License:       BSD
+Group:         Applications/Engineering
+URL:           http://www.paraview.org/
+Source0:       http://www.paraview.org/files/v3.12/%{name}-%{version}.tar.gz
+# Source0-md5: 8feabc6261e2060648eaac593d85b1de
+Source1:       %{name}_22x22.png
+Source2:       %{name}.xml
+Patch0:                %{name}-3.8.0-include.patch
+Patch1:                %{name}-3.12.0-boost-1.48.0-bfs.patch
+Patch2:                %{name}-gcc47.patch
+Patch3:                %{name}-3.2.2-hdf5.patch
+BuildRequires: boost-devel
+BuildRequires: cmake
+BuildRequires: desktop-file-utils
+BuildRequires: doxygen
+BuildRequires: expat-devel
+BuildRequires: freetype-devel
+BuildRequires: gnuplot
+BuildRequires: graphviz
+BuildRequires: hdf5-devel
+BuildRequires: libjpeg-devel
+BuildRequires: libpng-devel
+BuildRequires: libtheora-devel
+BuildRequires: libtiff-devel
+BuildRequires: Mesa-libOSMesa-devel
+BuildRequires: openssl-devel
+BuildRequires: python-devel
+BuildRequires: qt4-build
+BuildRequires: QtWebKit-devel
+BuildRequires: QtSql-devel
+BuildRequires: QtSql-sqlite
+BuildRequires: QtUiTools-devel
+BuildRequires: QtHelp-devel
+BuildRequires: QtDesigner-devel
+BuildRequires: readline-devel
+BuildRequires: tk-devel
+BuildRequires: wget
+BuildRequires: zlib-devel
+Requires:      %{name}-data = %{version}-%{release}
+Requires:      %{name}-doc = %{version}-%{release}
+Requires(post):        desktop-file-utils
+Requires(postun):      desktop-file-utils
+BuildRoot:     %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
+
+%description
+ParaView is an application designed with the need to visualize large
+data sets in mind. The goals of the ParaView project include the
+following:
+
+    - Develop an open-source, multi-platform visualization application.
+    - Support distributed computation models to process large data sets.
+    - Create an open, flexible, and intuitive user interface.
+    - Develop an extensible architecture based on open standards.
+
+ParaView runs on distributed and shared memory parallel as well as
+single processor systems and has been successfully tested on Windows,
+Linux and various Unix workstations and clusters. Under the hood,
+ParaView uses the Visualization Toolkit as the data processing and
+rendering engine and has a user interface written using a unique blend
+of Tcl/Tk and C++.
+
+NOTE: The version in this package has NOT been compiled with MPI
+support.
+
+%package        data
+Summary:       Data files for ParaView
+Group:         Applications/Engineering
+Requires:      %{name} = %{version}-%{release}
+BuildArch:     noarch
+
+%description    data
+Data files for ParaView.
+
+%package        devel
+Summary:       Development files for %{name}
+Group:         Development/Libraries
+Requires:      %{name}%{?_isa} = %{version}-%{release}
+
+%description    devel
+The %{name}-devel package contains libraries and header files for
+developing applications that use %{name}.
+
+%package        doc
+Summary:       Documentation files for ParaView
+Group:         Applications/Engineering
+Requires:      %{name} = %{version}-%{release}
+BuildArch:     noarch
+
+%description    doc
+Documentation files for ParaView.
+
+%prep
+%setup -q
+%patch0 -p1
+%patch1 -p1
+%patch2 -p1
+%patch3 -p1
+#Remove included hdf5 just to be sure
+rm -r VTK/Utilities/vtkhdf5
+
+%build
+mkdir build
+cd build
+%cmake .. \
+       -DPV_INSTALL_INCLUDE_DIR:PATH=include/paraview \
+       -DPV_INSTALL_LIB_DIR:PATH=%{_lib}/paraview \
+       -DTCL_LIBRARY:PATH=tcl \
+       -DTK_LIBRARY:PATH=tk \
+       -DPARAVIEW_BUILD_PLUGIN_AdiosReader:BOOL=ON \
+       -DPARAVIEW_BUILD_PLUGIN_CoProcessingScriptGenerator:BOOL=ON \
+       -DPARAVIEW_BUILD_PLUGIN_EyeDomeLighting:BOOL=ON \
+       -DPARAVIEW_BUILD_PLUGIN_ForceTime:BOOL=ON \
+       -DPARAVIEW_ENABLE_PYTHON:BOOL=ON \
+       -DPARAVIEW_INSTALL_THIRD_PARTY_LIBRARIES:BOOL=OFF \
+       -DPARAVIEW_INSTALL_DEVELOPMENT:BOOL=ON \
+       -DVTK_OPENGL_HAS_OSMESA:BOOL=ON \
+       -DVTK_USE_BOOST:BOOL=ON \
+       -DVTK_USE_INFOVIS:BOOL=OFF \
+       -DVTK_USE_N_WAY_ARRAYS:BOOL=ON \
+       -DVTK_USE_OGGTHEORA_ENCODER:BOOL=ON \
+       -DVTK_USE_SYSTEM_EXPAT:BOOL=ON \
+       -DVTK_USE_SYSTEM_FREETYPE:BOOL=ON \
+       -DVTK_USE_SYSTEM_HDF5:BOOL=ON \
+       -DVTK_USE_SYSTEM_JPEG:BOOL=ON \
+       -DVTK_USE_SYSTEM_PNG:BOOL=ON \
+       -DVTK_USE_SYSTEM_TIFF:BOOL=ON \
+       -DVTK_USE_SYSTEM_ZLIB:BOOL=ON \
+       -DXDMF_WRAP_PYTHON:BOOL=ON \
+       -DBUILD_DOCUMENTATION:BOOL=ON \
+       -DBUILD_EXAMPLES:BOOL=ON
+
+%{__make} VERBOSE=1
+
+%install
+rm -rf $RPM_BUILD_ROOT
+install -d $RPM_BUILD_ROOT%{_desktopdir}
+install -d $RPM_BUILD_ROOT%{_pixmapsdir}
+install -d $RPM_BUILD_ROOT%{_datadir}/mime/packages
+
+install %SOURCE1 $RPM_BUILD_ROOT%{_pixmapsdir}
+install %SOURCE2 $RPM_BUILD_ROOT%{_datadir}/mime/packages
+
+cd build
+%{__make} install DESTDIR=$RPM_BUILD_ROOT
+
+#Create desktop file
+cat > $RPM_BUILD_ROOT%{_desktopdir}/paraview.desktop <<EOF
+[Desktop Entry]
+Encoding=UTF-8
+Name=ParaView Viewer
+GenericName=Data Viewer
+Comment=ParaView allows viewing of large data sets
+Type=Application
+Terminal=false
+Icon=paraview_22x22
+MimeType=application/x-paraview;
+Categories=Application;Graphics;
+Exec=paraview
+EOF
+
+#Install vtk*Python.so by hand for now
+cp -p bin/vtk*Python.so $RPM_BUILD_ROOT%{_libdir}/paraview/site-packages/paraview/vtk/
+mv $RPM_BUILD_ROOT%{_libdir}/paraview/site-packages/paraview/vtk/vtkPV*Python.so $RPM_BUILD_ROOT%{_libdir}/paraview/site-packages/paraview/
+
+#Cleanup vtk binaries
+rm $RPM_BUILD_ROOT%{_bindir}/vtk*
+
+%clean
+rm -rf $RPM_BUILD_ROOT
+
+%post
+/sbin/ldconfig
+%update_desktop_database
+
+%postun
+/sbin/ldconfig
+%update_desktop_database
+
+%post data
+%update_mime_database
+
+%postun data
+%update_mime_database
+
+%files
+%defattr(644,root,root,755)
+%doc License_v1.2.txt
+%attr(755,root,root) %{_bindir}/paraview
+%attr(755,root,root) %{_bindir}/pvbatch
+%attr(755,root,root) %{_bindir}/pvblot
+%attr(755,root,root) %{_bindir}/pvdataserver
+%attr(755,root,root) %{_bindir}/pvpython
+%attr(755,root,root) %{_bindir}/pvrenderserver
+%attr(755,root,root) %{_bindir}/pvserver
+%attr(755,root,root) %{_bindir}/smTestDriver
+%{_libdir}/paraview/
+
+%files data
+%defattr(644,root,root,755)
+%{_desktopdir}/fedora-paraview.desktop
+%{_pixmapsdir}/paraview_22x22.png
+%{_datadir}/mime/packages/paraview.xml
+
+%files devel
+%defattr(644,root,root,755)
+%attr(755,root,root) %{_bindir}/kwProcessXML
+%{_includedir}/paraview/
diff --git a/ParaView.xml b/ParaView.xml
new file mode 100644 (file)
index 0000000..53d0006
--- /dev/null
@@ -0,0 +1,13 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<mime-info xmlns="http://www.freedesktop.org/standards/shared-mime-info">
+    <mime-type type="application/x-paraview">
+        <comment>ParaView Document</comment>
+        <comment xml:lang="en_US">ParaView Document</comment>
+        <glob pattern="*.pvd" />
+        <glob pattern="*.pvs" />
+        <glob pattern="*.vti" />
+        <glob pattern="*.vtp" />
+        <glob pattern="*.vts" />
+        <glob pattern="*.vtu" />
+  </mime-type>
+</mime-info>
This page took 0.153062 seconds and 4 git commands to generate.