- updated to 1.0.11 auto/th/PackageKit-1.0.11-1
authorJakub Bogusz <qboosh@pld-linux.org>
Mon, 30 Nov 2015 20:27:31 +0000 (21:27 +0100)
committerJakub Bogusz <qboosh@pld-linux.org>
Mon, 30 Nov 2015 20:27:31 +0000 (21:27 +0100)
- added zypp patch (internal API update)

PackageKit-zypp.patch [new file with mode: 0644]
PackageKit.spec

diff --git a/PackageKit-zypp.patch b/PackageKit-zypp.patch
new file mode 100644 (file)
index 0000000..148e1dc
--- /dev/null
@@ -0,0 +1,59 @@
+--- PackageKit-1.0.11/backends/zypp/pk-backend-zypp.cpp.orig   2015-11-30 17:18:58.487752181 +0100
++++ PackageKit-1.0.11/backends/zypp/pk-backend-zypp.cpp        2015-11-30 17:45:58.811017517 +0100
+@@ -3577,7 +3577,6 @@
+       const gchar *proxy_http;
+       const gchar *proxy_https;
+       const gchar *proxy_ftp;
+-      const gchar *uri;
+       const gchar *proxy_socks;
+       const gchar *no_proxy;
+       const gchar *pac;
+@@ -3590,33 +3589,29 @@
+       /* http_proxy */
+       proxy_http = pk_backend_job_get_proxy_http (job);
+       if (!pk_strzero (proxy_http)) {
+-              uri = pk_backend_convert_uri (proxy_http);
++              _cleanup_free_ gchar *uri = pk_backend_convert_uri (proxy_http);
+               g_setenv ("http_proxy", uri, TRUE);
+-              g_free (uri);
+       }
+       /* https_proxy */
+       proxy_https = pk_backend_job_get_proxy_https (job);
+       if (!pk_strzero (proxy_https)) {
+-              uri = pk_backend_convert_uri (proxy_https);
++              _cleanup_free_ gchar *uri = pk_backend_convert_uri (proxy_https);
+               g_setenv ("https_proxy", uri, TRUE);
+-              g_free (uri);
+       }
+       /* ftp_proxy */
+       proxy_ftp = pk_backend_job_get_proxy_ftp (job);
+       if (!pk_strzero (proxy_ftp)) {
+-              uri = pk_backend_convert_uri (proxy_ftp);
++              _cleanup_free_ gchar *uri = pk_backend_convert_uri (proxy_ftp);
+               g_setenv ("ftp_proxy", uri, TRUE);
+-              g_free (uri);
+       }
+       /* socks_proxy */
+       proxy_socks = pk_backend_job_get_proxy_socks (job);
+       if (!pk_strzero (proxy_socks)) {
+-              uri = pk_backend_convert_uri (proxy_socks);
++              _cleanup_free_ gchar *uri = pk_backend_convert_uri (proxy_socks);
+               g_setenv ("socks_proxy", uri, TRUE);
+-              g_free (uri);
+       }
+       /* no_proxy */
+@@ -3628,9 +3623,8 @@
+       /* pac */
+       pac = pk_backend_job_get_pac (job);
+       if (!pk_strzero (pac)) {
+-              uri = pk_backend_convert_uri (pac);
++              _cleanup_free_ gchar *uri = pk_backend_convert_uri (pac);
+               g_setenv ("pac", uri, TRUE);
+-              g_free (uri);
+       }
+ }
index 424a015..746b5b7 100644 (file)
 Summary:       System daemon that is a D-Bus abstraction layer for package management
 Summary(pl.UTF-8):     Demon systemowy będący warstwą abstrakcji D-Bus do zarządzania pakietami
 Name:          PackageKit
-Version:       1.0.10
+Version:       1.0.11
 Release:       1
 License:       GPL v2+
 Group:         Applications/System
 Source0:       http://www.freedesktop.org/software/PackageKit/releases/%{name}-%{version}.tar.xz
-# Source0-md5: 2f00e3e55656a6e06da55e30ad5ef2f4
+# Source0-md5: f7ab847e87328d4bee155bcada10dcba
 Patch0:                %{name}-poldek.patch
 Patch1:                %{name}-bashcomp.patch
 Patch2:                %{name}-format.patch
 Patch3:                consolekit-fallback.patch
+Patch4:                %{name}-zypp.patch
 URL:           http://www.packagekit.org/
 BuildRequires: NetworkManager-devel >= 0.6.5
 # pkgconfig(libalpm) >= 8.2.0
@@ -64,7 +65,7 @@ BuildRequires:        libarchive-devel
 %{?with_hif:BuildRequires:     libhif-devel >= 0.1.7}
 BuildRequires: libtool
 BuildRequires: libxslt-progs
-%{?with_zypp:BuildRequires:    libzypp-devel >= 6.16.0}
+%{?with_zypp:BuildRequires:    libzypp-devel >= 15}
 BuildRequires: pango-devel
 BuildRequires: pkgconfig
 %{?with_poldek:BuildRequires:  poldek-devel >= 0.30-1.rc6.4}
@@ -335,7 +336,7 @@ Summary:    PackageKit Zypp backend
 Summary(pl.UTF-8):     Backend PackageKit Zypp
 Group:         Libraries
 Requires:      %{name} = %{version}-%{release}
-Requires:      libzypp >= 6.16.0
+Requires:      libzypp >= 15
 Provides:      %{name}-backend = %{version}-%{release}
 
 %description backend-zypp
@@ -437,6 +438,7 @@ Wtyczka PackageKit do przeglądarek WWW.
 %patch1 -p1
 %patch2 -p1
 %patch3 -p1
+%patch4 -p1
 
 %build
 %if %{with doc}
This page took 0.301561 seconds and 4 git commands to generate.