]> git.pld-linux.org Git - packages/PackageKit.git/blobdiff - PackageKit.spec
- package yum backend files
[packages/PackageKit.git] / PackageKit.spec
index 7951495de3622ad84b5330cd88badc98feb1ae2f..bec5f0d61f4396cb1c9bf7c1492cb18e9cfdfec8 100644 (file)
@@ -1,21 +1,39 @@
 # TODO:
 # - BASH command-not-found functionality disabled for now as it needs patched bash
 #   (details in bash from Fedora Rawhide)
-# - package browser plugin
+# - do not package browser plugin (it's flawed by concept)
+# - package: gir stuff (invert bcond if works)
+#   /usr/lib/girepository-1.0/PackageKitGlib-1.0.typelib
+#   /usr/share/gir-1.0/PackageKitGlib-1.0.gir
+# - todo:
+#   configure: WARNING: unrecognized options: --disable-ruck
 #
 # Conditional build:
 %bcond_without qt      # don't build packagekit-qt library
 %bcond_without doc     # build without docs
-#
+%bcond_with            gir     # gobject introspection, time to time broken
+%bcond_without poldek  # build default backend as poldek
+%bcond_with    yum     # build default backend as yum
+
+%if %{with yum}
+%define                backend yum
+%undefine      with_poldek
+%endif
+
+%if %{with poldek}
+%define                backend poldek
+%undefine      with_yum
+%endif
+
 Summary:       System daemon that is a D-Bus abstraction layer for package management
 Summary(pl.UTF-8):     Demon systemowy będący warstwą abstrakcji D-Bus do zarządzania pakietami
 Name:          PackageKit
-Version:       0.6.0
-Release:       1
+Version:       0.6.8
+Release:       2
 License:       GPL v2+
 Group:         Applications/System
 Source0:       http://www.packagekit.org/releases/%{name}-%{version}.tar.bz2
-# Source0-md5: e1d6db7917f2a13bc5175f7cd2791e35
+# Source0-md5: 47987b91826bd522de1202d5a1e2510d
 Patch1:                %{name}-PLD.patch
 Patch2:                bashism.patch
 URL:           http://www.packagekit.org/
@@ -27,7 +45,7 @@ BuildRequires:        QtGui-devel >= 4.4.0
 BuildRequires: QtSql-devel >= 4.4.0
 BuildRequires: QtXml-devel >= 4.4.0
 %endif
-BuildRequires: autoconf >= 2.52
+BuildRequires: autoconf >= 2.65
 BuildRequires: automake
 %{?with_qt:BuildRequires:      cppunit-devel}
 BuildRequires: dbus-devel >= 1.2.0
@@ -44,7 +62,7 @@ BuildRequires:        libarchive-devel
 BuildRequires: libtool
 BuildRequires: pkgconfig
 BuildRequires: pm-utils
-BuildRequires: poldek-devel >= 0.30-0.20080820.23.20
+%{?with_poldek:BuildRequires:  poldek-devel >= 0.30-0.20080820.23.20}
 BuildRequires: polkit-devel >= 0.92
 BuildRequires: python-devel
 %{?with_qt:BuildRequires:      qt4-build >= 4.4.0}
@@ -59,7 +77,7 @@ Requires(post,postun):        shared-mime-info
 Requires:      %{name}-libs = %{version}-%{release}
 Requires:      ConsoleKit
 Requires:      crondaemon
-Requires:      poldek >= 0.30-0.20080820.23.20
+%{?with_poldek:Requires:       poldek >= 0.30-0.20080820.23.20}
 Requires:      polkit >= 0.92
 BuildRoot:     %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
 
@@ -239,14 +257,13 @@ Requires: python-pygobject
 %description -n python-packagekit
 PackageKit Python bindings.
 
-%description -n python-packagekit
+%description -n python-packagekit -l pl.UTF-8
 Wiązania PackageKit dla Pythona.
 
 %prep
 %setup -q
 %patch1 -p1
 %patch2 -p1
-mkdir m4
 
 %build
 %if %{with doc}
@@ -262,11 +279,14 @@ mkdir m4
        --disable-dummy \
        --disable-ruck \
        --disable-command-not-found \
-       --enable-poldek \
+       --disable-browser-plugin \
+       %{!?with_gir:--disable-introspection} \
+       %{?with_poldek:--enable-poldek} \
+       %{?with_yum:--enable-yum} \
        --%{!?with_doc:dis}%{?with_doc:en}able-gtk-doc \
        --%{?with_qt:en}%{!?with_qt:dis}able-qt \
        --with-html-dir=%{_gtkdocdir} \
-       --with-default-backend=poldek
+       --with-default-backend=%{backend}
 %{__make}
 
 %install
@@ -279,7 +299,7 @@ rm -rf $RPM_BUILD_ROOT
 ln -s pk-gstreamer-install $RPM_BUILD_ROOT%{_libdir}/gst-install-plugins-helper
 
 install -d $RPM_BUILD_ROOT%{_libdir}/pm-utils/sleep.d
-cp contrib/pm-utils/95packagekit $RPM_BUILD_ROOT%{_libdir}/pm-utils/sleep.d/
+install -p contrib/pm-utils/95packagekit $RPM_BUILD_ROOT%{_libdir}/pm-utils/sleep.d
 
 rm -f $RPM_BUILD_ROOT%{_libdir}/gtk-2.0/modules/*.{la,a}
 rm -f $RPM_BUILD_ROOT%{_libdir}/mozilla/plugins/*.{la,a}
@@ -320,9 +340,8 @@ rm -rf $RPM_BUILD_ROOT
 %attr(755,root,root) %{_bindir}/pk-debuginfo-install
 %attr(750,root,root) /etc/cron.daily/packagekit-background.cron
 %dir %{_libdir}/packagekit-backend
-%attr(755,root,root) %{_libdir}/packagekit-backend/libpk_backend_poldek.so
 %attr(755,root,root) %{_libdir}/polkit-1/extensions/libpackagekit-action-lookup.so
-%attr(755,root,root) %{_sbindir}/packagekitd
+%attr(755,root,root) %{_libdir}/packagekitd
 %attr(755,root,root) %{_sbindir}/pk-device-rebind
 %dir %{_sysconfdir}/PackageKit
 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/PackageKit/PackageKit.conf
@@ -330,6 +349,7 @@ rm -rf $RPM_BUILD_ROOT
 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/sysconfig/packagekit-background
 /etc/dbus-1/system.d/org.freedesktop.PackageKit.conf
 %dir %{_datadir}/PackageKit
+%dir %{_datadir}/PackageKit/helpers
 %attr(755,root,root) %{_datadir}/PackageKit/pk-upgrade-distro.sh
 %{_datadir}/polkit-1/actions/org.freedesktop.packagekit.policy
 %{_datadir}/dbus-1/system-services/org.freedesktop.PackageKit.service
@@ -346,10 +366,29 @@ rm -rf $RPM_BUILD_ROOT
 %dir /var/lib/PackageKit
 %ghost /var/lib/PackageKit/transactions.db
 
+# backend: poldek
+%if %{with poldek}
+%attr(755,root,root) %{_libdir}/packagekit-backend/libpk_backend_poldek.so
+%endif
+
+# backend: yum
+%if %{with yum}
+%config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/PackageKit/Yum.conf
+%config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/yum/pluginconf.d/refresh-packagekit.conf
+%attr(755,root,root) %{_libdir}/packagekit-backend/libpk_backend_yum.so
+%{_libdir}/yum-plugins/refresh-packagekit.py
+%dir %{_datadir}/PackageKit/helpers/yum
+%{_datadir}/PackageKit/helpers/yum/licenses.txt
+%{_datadir}/PackageKit/helpers/yum/yum-comps-groups.conf
+%{_datadir}/PackageKit/helpers/yum/yumBackend.py
+%{_datadir}/PackageKit/helpers/yum/yumComps.py
+%{_datadir}/PackageKit/helpers/yum/yumFilter.py
+%endif
+
 %files libs
 %defattr(644,root,root,755)
 %attr(755,root,root) %{_libdir}/libpackagekit-glib2.so.*.*.*
-%attr(755,root,root) %ghost %{_libdir}/libpackagekit-glib2.so.13
+%attr(755,root,root) %ghost %{_libdir}/libpackagekit-glib2.so.14
 
 %files devel
 %defattr(644,root,root,755)
@@ -368,7 +407,7 @@ rm -rf $RPM_BUILD_ROOT
 %files qt
 %defattr(644,root,root,755)
 %attr(755,root,root) %{_libdir}/libpackagekit-qt.so.*.*.*
-%attr(755,root,root) %ghost %{_libdir}/libpackagekit-qt.so.13
+%attr(755,root,root) %ghost %{_libdir}/libpackagekit-qt.so.14
 
 %files qt-devel
 %defattr(644,root,root,755)
This page took 0.077768 seconds and 4 git commands to generate.