]> git.pld-linux.org Git - packages/PackageKit.git/blobdiff - PackageKit.spec
Release 2 (by relup.sh)
[packages/PackageKit.git] / PackageKit.spec
index f73798d1c7472515b4bea4595bed87019bcb4c5c..4d281e42c3734faf47ac58a343d22ce47bab7939 100644 (file)
@@ -16,6 +16,7 @@
 %bcond_without dnf             # DNF (Fedora/RHEL/Mageia/OpenMandriva/OpenSUSE/Rosa) backend
 %bcond_with    entropy         # Entropy (Sabayon) backend (Python)
 %bcond_with    nix             # Nix (NixOS) backend [broken as of 1.2.0-1.2.5]
+%bcond_with    pisi            # PiSi (Pardus) backend (Python)
 %bcond_without poldek          # Poldek (PLD) backend
 %bcond_with    portage         # portage (Gentoo) backend (Python)
 %bcond_with    slack           # Slack (Slackware) backend
 
 %if %{without python}
 %undefine      with_entropy
+%undefine      with_pisi
 %undefine      with_portage
 %endif
 
 Summary:       System daemon that is a D-Bus abstraction layer for package management
 Summary(pl.UTF-8):     Demon systemowy będący warstwą abstrakcji D-Bus do zarządzania pakietami
 Name:          PackageKit
-Version:       1.2.7
-Release:       1
+Version:       1.2.8
+Release:       2
 License:       GPL v2+
 Group:         Applications/System
 Source0:       https://www.freedesktop.org/software/PackageKit/releases/%{name}-%{version}.tar.xz
-# Source0-md5: 3bca1b66bff0267515ff0761df2701cf
+# Source0-md5: 78cb918f4128a57bfc8a454b60f5a3c1
 Patch0:                %{name}-poldek.patch
 Patch2:                %{name}-meson.patch
 Patch3:                consolekit-fallback.patch
 URL:           https://www.freedesktop.org/software/PackageKit/
-%{?with_apt:BuildRequires:     AppStream-devel >= 0.12}
+%{?with_dnf:BuildRequires:     AppStream-devel >= 0.14.0}
+%{?with_apt:BuildRequires:     AppStream-devel >= 0.16.0}
 BuildRequires: NetworkManager-devel >= 0.6.5
 # pkgconfig(libalpm) >= 13.0.0
 %{?with_alpm:BuildRequires:    alpm-devel >= 6.0}
-%{?with_dnf:BuildRequires:     appstream-glib-devel}
 %{?with_apt:BuildRequires:     apt-devel >= 1.9.2}
 BuildRequires: bash-completion-devel >= 1:2.0
 BuildRequires: connman-devel
@@ -52,6 +54,7 @@ BuildRequires:        dbus-devel >= 1.2.0
 BuildRequires: dbus-glib-devel >= 0.76
 BuildRequires: docbook-dtd412-xml
 BuildRequires: docbook-dtd42-xml
+BuildRequires: docbook-style-xsl-nons
 BuildRequires: fontconfig-devel
 BuildRequires: gettext-tools
 BuildRequires: glib2-devel >= 1:2.62
@@ -98,7 +101,6 @@ Requires:    %{name}-libs = %{version}-%{release}
 Requires:      crondaemon
 Requires:      polkit >= 0.114
 Suggests:      ConsoleKit-x11
-Obsoletes:     PackageKit-backend-pisi < 1.2
 Obsoletes:     PackageKit-backend-ports < 1.2
 Obsoletes:     PackageKit-backend-smart < 1.0
 Obsoletes:     PackageKit-backend-urpmi < 1.2
@@ -266,6 +268,24 @@ NixOS).
 %description backend-nix -l pl.UTF-8
 Backend PackageKit dodający obsługę pakietów Nix (używanych w NixOS).
 
+%package backend-pisi
+Summary:       PackageKit PiSi backend
+Summary(pl.UTF-8):     Backend PackageKit PiSi
+Group:         Libraries
+Requires:      %{name} = %{version}-%{release}
+Requires:      python3-packagekit = %{version}-%{release}
+#Requires:     python3-piksemel
+#Requires:     python3-pisi
+Provides:      %{name}-backend = %{version}-%{release}
+
+%description backend-pisi
+A backend for PackageKit to enable PiSi packages support. PiSi
+packages are originated in Pardus distribution.
+
+%description backend-pisi -l pl.UTF-8
+Backend PackageKit dodający obsługę pakietów PiSi. Pakiety PiSi
+wywodzą się z dystrybucji Pardus.
+
 %package backend-poldek
 Summary:       PackageKit Poldek backend
 Summary(pl.UTF-8):     Backend PackageKit oparty na Poldku
@@ -390,6 +410,8 @@ Wiązania PackageKit dla Pythona.
 %patch2 -p1
 %patch3 -p1
 
+%{__sed} -i -e '1s,/usr/bin/python$,%{__python3},' backends/pisi/pisiBackend.py
+
 %if %{with static_libs}
 %{__sed} -i -e '/^packagekit_glib2_library =/ s/shared_library/library/' lib/packagekit-glib2/meson.build
 %endif
@@ -400,7 +422,7 @@ Wiązania PackageKit dla Pythona.
        -Dbash_command_not_found=false \
        %{!?with_introspection:-Dgobject_introspection=false} \
        %{?with_apidocs:-Dgtk_doc=true} \
-       -Dpackaging_backend=dummy%{?with_alpm:,alpm}%{?with_apt:,aptcc}%{?with_dnf:,dnf}%{?with_entropy:,entropy}%{?with_poldek:,poldek}%{?with_portage:,portage}%{?with_slack:,slack}%{?with_zypp:,zypp}%{?with_nix:,nix} \
+       -Dpackaging_backend=dummy%{?with_alpm:,alpm}%{?with_apt:,aptcc}%{?with_dnf:,dnf}%{?with_entropy:,entropy}%{?with_pisi:,pisi}%{?with_poldek:,poldek}%{?with_portage:,portage}%{?with_slack:,slack}%{?with_zypp:,zypp}%{?with_nix:,nix} \
        %{!?with_python:-Dpython_backend=false} \
        -Dsystemdsystemunitdir=%{systemdunitdir}
 
@@ -424,7 +446,7 @@ ln -s pk-gstreamer-install $RPM_BUILD_ROOT%{_libexecdir}/gst-install-plugins-hel
 
 install -d $RPM_BUILD_ROOT%{systemdunitdir}/system-update.target.wants
 ln -sf ../packagekit-offline-update.service \
-        $RPM_BUILD_ROOT%{systemdunitdir}/system-update.target.wants/packagekit-offline-update.service
+       $RPM_BUILD_ROOT%{systemdunitdir}/system-update.target.wants/packagekit-offline-update.service
 
 %find_lang %{name}
 
@@ -462,6 +484,7 @@ rm -rf $RPM_BUILD_ROOT
 %{_datadir}/polkit-1/rules.d/org.freedesktop.packagekit.rules
 %{_datadir}/dbus-1/system-services/org.freedesktop.PackageKit.service
 %{_datadir}/dbus-1/system.d/org.freedesktop.PackageKit.conf
+%{_datadir}/metainfo/org.freedesktop.packagekit.metainfo.xml
 %{_mandir}/man1/pkcon.1*
 %{_mandir}/man1/pkmon.1*
 %{systemdunitdir}/packagekit.service
@@ -558,6 +581,14 @@ rm -rf $RPM_BUILD_ROOT
 %attr(755,root,root) %{_libdir}/packagekit-backend/libpk_backend_nix.so
 %endif
 
+%if %{with pisi}
+%files backend-pisi
+%defattr(644,root,root,755)
+%attr(755,root,root) %{_libdir}/packagekit-backend/libpk_backend_pisi.so
+%dir %{_datadir}/PackageKit/helpers/pisi
+%attr(755,root,root) %{_datadir}/PackageKit/helpers/pisi/pisiBackend.py
+%endif
+
 %if %{with poldek}
 %files backend-poldek
 %defattr(644,root,root,755)
This page took 0.448323 seconds and 4 git commands to generate.