]> git.pld-linux.org Git - packages/PackageKit.git/blobdiff - PackageKit.spec
- yum/poldek backend bconds, not tested as current gir changes break build
[packages/PackageKit.git] / PackageKit.spec
index fd29da9210e5ad4871f1a9a8d0fa94ffdd7404ab..1e893e05cdecae70640b203df2b0defea8a397a4 100644 (file)
@@ -1,21 +1,36 @@
 # TODO:
 # - BASH command-not-found functionality disabled for now as it needs patched bash
 #   (details in bash from Fedora Rawhide)
-# - package browser plugin
+# - do not package browser plugin (it's flawed by concept)
+# - package: gir stuff
+#   /usr/lib/girepository-1.0/PackageKitGlib-1.0.typelib
+#   /usr/share/gir-1.0/PackageKitGlib-1.0.gir
 #
 # Conditional build:
 %bcond_without qt      # don't build packagekit-qt library
-%bcond_without docs    # build without docs
-#
+%bcond_without doc     # build without docs
+%bcond_without poldek  # build default backend as poldek
+%bcond_with    yum     # build default backend as yum
+
+%if %{with yum}
+%define                backend yum
+%undefine      with_poldek
+%endif
+
+%if %{with poldek}
+%define                backend poldek
+%undefine      with_yum
+%endif
+
 Summary:       System daemon that is a D-Bus abstraction layer for package management
 Summary(pl.UTF-8):     Demon systemowy będący warstwą abstrakcji D-Bus do zarządzania pakietami
 Name:          PackageKit
-Version:       0.6.0
-Release:       1
+Version:       0.6.8
+Release:       2
 License:       GPL v2+
 Group:         Applications/System
 Source0:       http://www.packagekit.org/releases/%{name}-%{version}.tar.bz2
-# Source0-md5: e1d6db7917f2a13bc5175f7cd2791e35
+# Source0-md5: 47987b91826bd522de1202d5a1e2510d
 Patch1:                %{name}-PLD.patch
 Patch2:                bashism.patch
 URL:           http://www.packagekit.org/
@@ -27,25 +42,24 @@ BuildRequires:      QtGui-devel >= 4.4.0
 BuildRequires: QtSql-devel >= 4.4.0
 BuildRequires: QtXml-devel >= 4.4.0
 %endif
-BuildRequires: autoconf >= 2.52
+BuildRequires: autoconf >= 2.65
 BuildRequires: automake
 %{?with_qt:BuildRequires:      cppunit-devel}
 BuildRequires: dbus-devel >= 1.2.0
 BuildRequires: dbus-glib-devel >= 0.76
 BuildRequires: docbook-dtd412-xml
 BuildRequires: docbook-dtd42-xml
-%{?with_docs:BuildRequires:    docbook-to-man}
 BuildRequires: gettext-devel
 BuildRequires: glib2-devel >= 1:2.22.0
 BuildRequires: gstreamer-plugins-base-devel
 BuildRequires: gtk+2-devel >= 2:2.14.0
-%{?with_docs:BuildRequires:    gtk-doc >= 1.9}
+%{?with_doc:BuildRequires:     gtk-doc >= 1.9}
 BuildRequires: intltool >= 0.35.0
 BuildRequires: libarchive-devel
 BuildRequires: libtool
 BuildRequires: pkgconfig
 BuildRequires: pm-utils
-BuildRequires: poldek-devel >= 0.30-0.20080820.23.20
+%{?with_poldek:BuildRequires:  poldek-devel >= 0.30-0.20080820.23.20}
 BuildRequires: polkit-devel >= 0.92
 BuildRequires: python-devel
 %{?with_qt:BuildRequires:      qt4-build >= 4.4.0}
@@ -60,7 +74,7 @@ Requires(post,postun):        shared-mime-info
 Requires:      %{name}-libs = %{version}-%{release}
 Requires:      ConsoleKit
 Requires:      crondaemon
-Requires:      poldek >= 0.30-0.20080820.23.20
+%{?with_poldek:Requires:       poldek >= 0.30-0.20080820.23.20}
 Requires:      polkit >= 0.92
 BuildRoot:     %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
 
@@ -240,17 +254,16 @@ Requires: python-pygobject
 %description -n python-packagekit
 PackageKit Python bindings.
 
-%description -n python-packagekit
+%description -n python-packagekit -l pl.UTF-8
 Wiązania PackageKit dla Pythona.
 
 %prep
 %setup -q
 %patch1 -p1
 %patch2 -p1
-mkdir m4
 
 %build
-%if %{with docs}
+%if %{with doc}
 %{__gtkdocize}
 %endif
 %{__intltoolize}
@@ -263,11 +276,12 @@ mkdir m4
        --disable-dummy \
        --disable-ruck \
        --disable-command-not-found \
-       --enable-poldek \
-       --%{!?with_docs:dis}%{?with_docs:en}able-gtk-doc \
+       --disable-browser-plugin \
+       %{?with_poldek:--enable-poldek} \
+       --%{!?with_doc:dis}%{?with_doc:en}able-gtk-doc \
        --%{?with_qt:en}%{!?with_qt:dis}able-qt \
        --with-html-dir=%{_gtkdocdir} \
-       --with-default-backend=poldek
+       --with-default-backend=%{backend}
 %{__make}
 
 %install
@@ -280,7 +294,7 @@ rm -rf $RPM_BUILD_ROOT
 ln -s pk-gstreamer-install $RPM_BUILD_ROOT%{_libdir}/gst-install-plugins-helper
 
 install -d $RPM_BUILD_ROOT%{_libdir}/pm-utils/sleep.d
-cp contrib/pm-utils/95packagekit $RPM_BUILD_ROOT%{_libdir}/pm-utils/sleep.d/
+install -p contrib/pm-utils/95packagekit $RPM_BUILD_ROOT%{_libdir}/pm-utils/sleep.d
 
 rm -f $RPM_BUILD_ROOT%{_libdir}/gtk-2.0/modules/*.{la,a}
 rm -f $RPM_BUILD_ROOT%{_libdir}/mozilla/plugins/*.{la,a}
@@ -323,7 +337,7 @@ rm -rf $RPM_BUILD_ROOT
 %dir %{_libdir}/packagekit-backend
 %attr(755,root,root) %{_libdir}/packagekit-backend/libpk_backend_poldek.so
 %attr(755,root,root) %{_libdir}/polkit-1/extensions/libpackagekit-action-lookup.so
-%attr(755,root,root) %{_sbindir}/packagekitd
+%attr(755,root,root) %{_libdir}/packagekitd
 %attr(755,root,root) %{_sbindir}/pk-device-rebind
 %dir %{_sysconfdir}/PackageKit
 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/PackageKit/PackageKit.conf
@@ -350,7 +364,7 @@ rm -rf $RPM_BUILD_ROOT
 %files libs
 %defattr(644,root,root,755)
 %attr(755,root,root) %{_libdir}/libpackagekit-glib2.so.*.*.*
-%attr(755,root,root) %ghost %{_libdir}/libpackagekit-glib2.so.13
+%attr(755,root,root) %ghost %{_libdir}/libpackagekit-glib2.so.14
 
 %files devel
 %defattr(644,root,root,755)
@@ -369,7 +383,7 @@ rm -rf $RPM_BUILD_ROOT
 %files qt
 %defattr(644,root,root,755)
 %attr(755,root,root) %{_libdir}/libpackagekit-qt.so.*.*.*
-%attr(755,root,root) %ghost %{_libdir}/libpackagekit-qt.so.13
+%attr(755,root,root) %ghost %{_libdir}/libpackagekit-qt.so.14
 
 %files qt-devel
 %defattr(644,root,root,755)
This page took 0.076938 seconds and 4 git commands to generate.