]> git.pld-linux.org Git - packages/PackageKit.git/blob - PackageKit.spec
- updated to 1.0.11
[packages/PackageKit.git] / PackageKit.spec
1 # TODO:
2 # - BASH command-not-found functionality disabled for now as it needs patched bash
3 #   (details in bash from Fedora Rawhide)
4 #
5 # Conditional build:
6 %bcond_without  doc             # build without docs
7 %bcond_without  introspection   # gobject introspection, time to time broken
8 %bcond_with     alpm            # ALPM (Arch Linux package manager) backend
9 %bcond_with     apt             # APT (Debian/Ubuntu) backend using C++ API
10 %bcond_with     entropy         # Entropy (Sabayon) backend (Python)
11 %bcond_with     hif             # HIF (Fedora/RHEL) backend
12 %bcond_with     katja           # Katja (Slackware) backend
13 %bcond_with     pisi            # PiSi (Pardus) backend (Python)
14 %bcond_without  poldek          # Poldek (PLD) backend
15 %bcond_with     portage         # portage (Gentoo) backend (Python)
16 %bcond_with     ports           # ports (FreeBSD) backend (Ruby)
17 %bcond_with     urpmi           # urpmi (Mandriva/Mageia) backend (Perl)
18 %bcond_with     zypp            # ZYPP (openSUSE/SLE) backend
19 %bcond_without  python          # Python binding (only for a few backends)
20 %bcond_without  vala            # Vala binding
21 %bcond_with     browser         # browser plugin (patrys says: it's flawed by concept)
22 # python binding is built when building any python binding
23 %if %{without entropy} && %{without pisi} && %{without ports}
24 %undefine       with_python
25 %endif
26 Summary:        System daemon that is a D-Bus abstraction layer for package management
27 Summary(pl.UTF-8):      Demon systemowy będący warstwą abstrakcji D-Bus do zarządzania pakietami
28 Name:           PackageKit
29 Version:        1.0.11
30 Release:        1
31 License:        GPL v2+
32 Group:          Applications/System
33 Source0:        http://www.freedesktop.org/software/PackageKit/releases/%{name}-%{version}.tar.xz
34 # Source0-md5:  f7ab847e87328d4bee155bcada10dcba
35 Patch0:         %{name}-poldek.patch
36 Patch1:         %{name}-bashcomp.patch
37 Patch2:         %{name}-format.patch
38 Patch3:         consolekit-fallback.patch
39 Patch4:         %{name}-zypp.patch
40 URL:            http://www.packagekit.org/
41 BuildRequires:  NetworkManager-devel >= 0.6.5
42 # pkgconfig(libalpm) >= 8.2.0
43 %{?with_alpm:BuildRequires:     alpm-devel >= 4}
44 %{?with_hif:BuildRequires:      appstream-glib-devel}
45 %{?with_apt:BuildRequires:      apt-devel >= 0.7}
46 BuildRequires:  autoconf >= 2.65
47 BuildRequires:  automake >= 1:1.11
48 BuildRequires:  connman-devel
49 %{?with_katja:BuildRequires:    curl-devel}
50 BuildRequires:  dbus-devel >= 1.2.0
51 BuildRequires:  dbus-glib-devel >= 0.76
52 BuildRequires:  docbook-dtd412-xml
53 BuildRequires:  docbook-dtd42-xml
54 BuildRequires:  fontconfig-devel
55 BuildRequires:  gettext-tools
56 BuildRequires:  glib2-devel >= 1:2.32.0
57 %{?with_introspection:BuildRequires:    gobject-introspection-devel >= 0.9.9}
58 BuildRequires:  gstreamer-devel >= 1.0.0
59 BuildRequires:  gstreamer-plugins-base-devel >= 1.0.0
60 BuildRequires:  gtk+2-devel >= 2:2.14.0
61 BuildRequires:  gtk+3-devel >= 3.0.0
62 %{?with_doc:BuildRequires:      gtk-doc >= 1.11}
63 BuildRequires:  intltool >= 0.35.0
64 BuildRequires:  libarchive-devel
65 %{?with_hif:BuildRequires:      libhif-devel >= 0.1.7}
66 BuildRequires:  libtool
67 BuildRequires:  libxslt-progs
68 %{?with_zypp:BuildRequires:     libzypp-devel >= 15}
69 BuildRequires:  pango-devel
70 BuildRequires:  pkgconfig
71 %{?with_poldek:BuildRequires:   poldek-devel >= 0.30-1.rc6.4}
72 BuildRequires:  polkit-devel >= 0.98
73 %{?with_python:BuildRequires:   python-devel >= 1:2.7}
74 BuildRequires:  readline-devel
75 BuildRequires:  rpm-pythonprov
76 BuildRequires:  rpmbuild(macros) >= 1.311
77 BuildRequires:  sqlite3-devel >= 3
78 BuildRequires:  systemd-devel >= 1:209
79 BuildRequires:  tar >= 1:1.22
80 BuildRequires:  udev-glib-devel
81 %{?with_vala:BuildRequires:     vala >= 2:0.16}
82 BuildRequires:  xz
83 %if %{with browser}
84 BuildRequires:  cairo-devel
85 BuildRequires:  nspr-devel >= 4.8
86 BuildRequires:  pango-devel
87 BuildRequires:  xulrunner-devel >= 8.0
88 %endif
89 Requires(post,postun):  shared-mime-info
90 Requires:       %{name}-backend
91 Requires:       %{name}-libs = %{version}-%{release}
92 Requires:       crondaemon
93 Requires:       polkit >= 0.98
94 Suggests:       ConsoleKit-x11
95 Obsoletes:      PackageKit-backend-smart
96 Obsoletes:      PackageKit-backend-yum
97 Obsoletes:      PackageKit-docs < 0.8.4
98 Obsoletes:      pm-utils-packagekit
99 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
100
101 %description
102 PackageKit is a D-Bus abstraction layer that allows the session user
103 to manage packages in a secure way using a cross-distro,
104 cross-architecture API.
105
106 %description -l pl.UTF-8
107 PackageKit to warstwa abstrakcji D-Bus pozwalająca użytkownikowi
108 sesyjnemu w bezpieczny sposob zarządzać pakietami przy użyciu API
109 zgodnego z wieloma dystrybucjami i architekturami.
110
111 %package libs
112 Summary:        packagekit-glib library
113 Summary(pl.UTF-8):      Biblioteka packagekit-glib
114 Group:          Libraries
115 Requires:       glib2 >= 1:2.32.0
116
117 %description libs
118 packagekit-glib library.
119
120 %description libs -l pl.UTF-8
121 Biblioteka packagekit-glib.
122
123 %package devel
124 Summary:        Header files for packagekit-glib library
125 Summary(pl.UTF-8):      Pliki nagłówkowe biblioteki packagekit-glib
126 Group:          Development/Libraries
127 Requires:       %{name}-libs = %{version}-%{release}
128 Requires:       dbus-devel >= 1.2.0
129 Requires:       glib2-devel >= 1:2.32.0
130 Requires:       sqlite3-devel
131
132 %description devel
133 Header files for packagekit-glib library.
134
135 %description devel -l pl.UTF-8
136 Pliki nagłówkowe biblioteki packagekit-glib.
137
138 %package static
139 Summary:        Static packagekit-glib library
140 Summary(pl.UTF-8):      Statyczna biblioteka packagekit-glib
141 Group:          Development/Libraries
142 Requires:       %{name}-devel = %{version}-%{release}
143
144 %description static
145 Static packagekit-glib library.
146
147 %description static -l pl.UTF-8
148 Statyczna biblioteka packagekit-glib.
149
150 %package -n vala-packagekit
151 Summary:        Vala API for PackageKit library
152 Summary(pl.UTF-8):      API języka Vala do biblioteki PackageKitu
153 Group:          Development/Libraries
154 Requires:       %{name}-devel = %{version}-%{release}
155 Requires:       vala >= 2:0.16
156
157 %description -n vala-packagekit
158 Vala API for PackageKit library.
159
160 %description -n vala-packagekit -l pl.UTF-8
161 API języka Vala do biblioteki PackageKitu.
162
163 %package apidocs
164 Summary:        PackageKit library API documentation
165 Summary(pl.UTF-8):      Dokumentacja API biblioteki PackageKit
166 Group:          Documentation
167 Requires:       gtk-doc-common
168 %if "%{_rpmversion}" >= "5"
169 BuildArch:      noarch
170 %endif
171
172 %description apidocs
173 PackageKit library API documentation.
174
175 %description apidocs -l pl.UTF-8
176 Dokumentacja API biblioteki PackageKit.
177
178 %package backend-alpm
179 Summary:        PackageKit ALPM backend
180 Summary(pl.UTF-8):      Backend PackageKit oparty na bibliotece ALPM
181 Group:          Libraries
182 Requires:       %{name} = %{version}-%{release}
183 Provides:       %{name}-backend = %{version}-%{release}
184
185 %description backend-alpm
186 A backend for PackageKit to enable Arch Linux packages via ALPM
187 library.
188
189 %description backend-alpm -l pl.UTF-8
190 Backend PackageKit dodający obsługę pakietów Arch Linuksa poprzez
191 bibliotekę ALPM.
192
193 %package backend-aptcc
194 Summary:        PackageKit APTcc backend
195 Summary(pl.UTF-8):      Backend PackageKit APTcc
196 Group:          Libraries
197 Requires:       %{name} = %{version}-%{release}
198 Provides:       %{name}-backend = %{version}-%{release}
199
200 %description backend-aptcc
201 A backend for PackageKit to enable APT support via C++ API.
202
203 %description backend-aptcc -l pl.UTF-8
204 Backend PackageKit dodający obsługę zarządcy pakietów APT poprzez API
205 C++.
206
207 %package backend-entropy
208 Summary:        PackageKit Entropy backend
209 Summary(pl.UTF-8):      Backend PackageKit Entropy
210 Group:          Libraries
211 Requires:       %{name} = %{version}-%{release}
212 Requires:       python-packagekit = %{version}-%{release}
213 #Requires:      python-entropy
214 Provides:       %{name}-backend = %{version}-%{release}
215
216 %description backend-entropy
217 A backend for PackageKit to enable Sabayon packages support through
218 Entropy package manager.
219
220 %description backend-entropy -l pl.UTF-8
221 Backend PackageKit dodający obsługę pakietów dystrybucji Sabayon przy
222 użyciu zarządcy pakietów Entropy.
223
224 %package backend-hif
225 Summary:        PackageKit hif backend
226 Summary(pl.UTF-8):      Backend PackageKit oparty na bibliotece hif
227 Group:          Libraries
228 Requires:       %{name} = %{version}-%{release}
229 Requires:       libhif >= 0.1.7
230 Provides:       %{name}-backend = %{version}-%{release}
231 Obsoletes:      PackageKit-backend-hawkey
232
233 %description backend-hif
234 A backend for PackageKit to enable RPM packages support via hif
235 library (used in Fedora).
236
237 %description backend-hif -l pl.UTF-8
238 Backend PackageKit dodający obsługę pakietów RPM poprzez bibliotekę
239 hif (używaną w dystrybucji Fedora).
240
241 %package backend-katja
242 Summary:        PackageKit Katja backend
243 Summary(pl.UTF-8):      Backend PackageKit Katja
244 Group:          Libraries
245 Requires:       %{name} = %{version}-%{release}
246 Provides:       %{name}-backend = %{version}-%{release}
247
248 %description backend-katja
249 Katja backend for PackageKit to enable Slackware repositories support.
250
251 %description backend-katja -l pl.UTF-8
252 Backend PackageKit Katja dodający obsługę repozytoriów Slackware.
253
254 %package backend-pisi
255 Summary:        PackageKit PiSi backend
256 Summary(pl.UTF-8):      Backend PackageKit PiSi
257 Group:          Libraries
258 Requires:       %{name} = %{version}-%{release}
259 Requires:       python-packagekit = %{version}-%{release}
260 #Requires:      python-piksemel
261 #Requires:      python-pisi
262 Provides:       %{name}-backend = %{version}-%{release}
263
264 %description backend-pisi
265 A backend for PackageKit to enable PiSi packages support. PiSi
266 packages are originated in Pardus distribution.
267
268 %description backend-pisi -l pl.UTF-8
269 Backend PackageKit dodający obsługę pakietów PiSi. Pakiety PiSi
270 wywodzą się z dystrybucji Pardus.
271
272 %package backend-poldek
273 Summary:        PackageKit Poldek backend
274 Summary(pl.UTF-8):      Backend PackageKit oparty na Poldku
275 Group:          Libraries
276 Requires:       %{name} = %{version}-%{release}
277 Requires:       poldek >= 0.30-1.rc6.4
278 Provides:       %{name}-backend = %{version}-%{release}
279
280 %description backend-poldek
281 A backend for PackageKit to enable RPM packages support through Poldek
282 - native PLD package manager.
283
284 %description backend-poldek -l pl.UTF-8
285 Backend PackageKit dodający obsługę pakietów RPM poprzez Poldka -
286 natywnego zarządcę pakietów dystrybucji PLD.
287
288 %package backend-portage
289 Summary:        PackageKit Portage backend
290 Summary(pl.UTF-8):      Backend PackageKit Portage
291 Group:          Libraries
292 Requires:       %{name} = %{version}-%{release}
293 Requires:       python-packagekit = %{version}-%{release}
294 #Requires:      python-portage
295 Provides:       %{name}-backend = %{version}-%{release}
296
297 %description backend-portage
298 A backend for PackageKit to enable Gentoo Portage support.
299
300 %description backend-portage -l pl.UTF-8
301 Backend PackageKit dodający obsługę systemu Portage dystrybucji
302 Gentoo.
303
304 %package backend-ports
305 Summary:        PackageKit Ports backend
306 Summary(pl.UTF-8):      Backend PackageKit Ports
307 Group:          Libraries
308 Requires:       %{name} = %{version}-%{release}
309 #Requires:      ruby-pkgtools
310 Provides:       %{name}-backend = %{version}-%{release}
311
312 %description backend-ports
313 A backend for PackageKit to enable FreeBSD Ports support.
314
315 %description backend-ports -l pl.UTF-8
316 Backend PackageKit dodający obsługę portów systemu FreeBSD.
317
318 %package backend-urpmi
319 Summary:        PackageKit URPMI backend
320 Summary(pl.UTF-8):      Backend PackageKit URPMI
321 Group:          Libraries
322 Requires:       %{name} = %{version}-%{release}
323 #Requires:      perl-URPM
324 Provides:       %{name}-backend = %{version}-%{release}
325
326 %description backend-urpmi
327 A backend for PackageKit to enable RPM packages support through URPMI
328 package manager (originated in Mandriva).
329
330 %description backend-urpmi -l pl.UTF-8
331 Backend PackageKit dodający obsługę pakietów RPM poprzez zarządcę
332 URPMI (pochodzącego z dystrybucji Mandriva).
333
334 %package backend-zypp
335 Summary:        PackageKit Zypp backend
336 Summary(pl.UTF-8):      Backend PackageKit Zypp
337 Group:          Libraries
338 Requires:       %{name} = %{version}-%{release}
339 Requires:       libzypp >= 15
340 Provides:       %{name}-backend = %{version}-%{release}
341
342 %description backend-zypp
343 A backend for PackageKit to enable RPM packages support through Zypp
344 library (originated in openSUSE/SLE).
345
346 %description backend-zypp -l pl.UTF-8
347 Backend PackageKit dodający obsługę pakietów RPM poprzez bibliotekę
348 Zypp (pochodzącą z dystrybucji openSUSE/SLE).
349
350 %package gstreamer-plugin
351 Summary:        GStreamer codecs installer
352 Summary(pl.UTF-8):      Instalator kodeków GStreamera
353 Group:          Applications
354 Requires:       %{name} = %{version}-%{release}
355 Requires:       %{name}-gtk-module = %{version}-%{release}
356
357 %description gstreamer-plugin
358 The PackageKit GStreamer plugin allows any GStreamer application to
359 install codecs from configured repositories using PackageKit.
360
361 %description gstreamer-plugin -l pl.UTF-8
362 Wtyczka GStreamer pozwala każdej aplikacji używającej GStreamera
363 zainstalować kodeki ze skonfigurowanych źródeł PackageKit.
364
365 %package gtk-module
366 Summary:        GTK+ module to detect and install missing fonts
367 Summary(pl.UTF-8):      Moduł GTK+ do wykrywania i instalowania brakujących czcionek
368 Group:          X11/Libraries
369
370 %description gtk-module
371 The PackageKit GTK+ module allows any pango application to install
372 missing fonts from configured repositories using PackageKit.
373
374 %description gtk-module -l pl.UTF-8
375 Moduł GTK+ pozwala każdej aplikacji używającej pango zainstalować
376 brakującą czcionkę ze skonfigurowanych źródeł PackageKit.
377
378 %package gtk3-module
379 Summary:        GTK+ 3.x module to detect and install missing fonts
380 Summary(pl.UTF-8):      Moduł GTK+ 3.x do wykrywania i instalowania brakujących czcionek
381 Group:          X11/Libraries
382
383 %description gtk3-module
384 The PackageKit GTK+ 3.x module allows any pango application to install
385 missing fonts from configured repositories using PackageKit.
386
387 %description gtk3-module -l pl.UTF-8
388 Moduł GTK+ 3.x pozwala każdej aplikacji używającej pango zainstalować
389 brakującą czcionkę ze skonfigurowanych źródeł PackageKit.
390
391 %package -n bash-completion-packagekit
392 Summary:        Bash completion for PackageKit console commands
393 Summary(pl.UTF-8):      Bashowe uzupełnianie parametrów dla poleceń konsolowych PackageKit
394 Group:          Applications/Shells
395 Requires:       %{name} = %{version}-%{release}
396 Requires:       bash-completion >= 2
397 %if "%{_rpmversion}" >= "5"
398 BuildArch:      noarch
399 %endif
400
401 %description -n bash-completion-packagekit
402 This package provides bash-completion for PackageKit console commands.
403
404 %description -n bash-completion-packagekit -l pl.UTF-8
405 Pakiet ten dostarcza bashowe uzupełnianie parametrów dla poleceń
406 konsolowych PackageKit.
407
408 %package -n python-packagekit
409 Summary:        PackageKit Python bindings
410 Summary(pl.UTF-8):      Wiązania PackageKit dla Pythona
411 Group:          Development/Languages/Python
412 Requires:       python-dbus
413 Requires:       python-pygobject
414
415 %description -n python-packagekit
416 PackageKit Python bindings.
417
418 %description -n python-packagekit -l pl.UTF-8
419 Wiązania PackageKit dla Pythona.
420
421 %package -n browser-plugin-packagekit
422 Summary:        PackageKit's browser plugin
423 Summary(pl.UTF-8):      Wtyczka PackageKit do przeglądarek WWW
424 Group:          X11/Libraries
425 Requires:       %{name} = %{version}-%{release}
426 Requires:       browser-plugins >= 2.0
427 Requires:       browser-plugins(%{_target_base_arch})
428
429 %description -n browser-plugin-packagekit
430 PackageKit's plugin for browsers.
431
432 %description -n browser-plugin-packagekit -l pl.UTF-8
433 Wtyczka PackageKit do przeglądarek WWW.
434
435 %prep
436 %setup -q
437 %patch0 -p1
438 %patch1 -p1
439 %patch2 -p1
440 %patch3 -p1
441 %patch4 -p1
442
443 %build
444 %if %{with doc}
445 %{__gtkdocize}
446 %endif
447 %{__intltoolize}
448 %{__libtoolize}
449 %{__aclocal} -I m4
450 %{__autoconf}
451 %{__autoheader}
452 %{__automake}
453 %{?with_zypp:CPPFLAGS="%{rpmcppflags} -D_RPM_5 -I/usr/include/rpm"}
454 %configure \
455         --disable-command-not-found \
456         --disable-dummy \
457         %{!?with_doc:--disable-gtk-doc} \
458         %{!?with_introspection:--disable-introspection} \
459         --disable-silent-rules \
460         --enable-bash-completion=%{bash_compdir} \
461         %{__enable_disable alpm} \
462         %{__enable_disable apt aptcc} \
463         %{__enable_disable browser browser-plugin} \
464         %{__enable_disable entropy} \
465         %{__enable_disable hif} \
466         %{__enable_disable katja} \
467         %{__enable_disable pisi} \
468         %{__enable_disable poldek} \
469         %{__enable_disable portage} \
470         %{__enable_disable ports} \
471         %{__enable_disable urpmi} \
472         %{__enable_disable zypp} \
473         --with-html-dir=%{_gtkdocdir} \
474         --with-mozilla-plugin-dir=%{_browserpluginsdir} \
475         --with-security-framework=polkit
476 %{__make}
477
478 %install
479 rm -rf $RPM_BUILD_ROOT
480
481 %{__make} install \
482         DESTDIR=$RPM_BUILD_ROOT
483
484 # use pk-gstreamer-install as codec installer
485 ln -s pk-gstreamer-install $RPM_BUILD_ROOT%{_libdir}/gst-install-plugins-helper
486
487 %{__rm} $RPM_BUILD_ROOT%{_libdir}/gtk-{2,3}.0/modules/*.{la,a}
488 %{__rm} $RPM_BUILD_ROOT%{_libdir}/packagekit-backend/*.{la,a}
489 %{__rm} $RPM_BUILD_ROOT%{_libdir}/packagekit-backend/libpk_backend_test_*.so
490 %{__rm} $RPM_BUILD_ROOT%{_libdir}/*.la
491 %{__rm} -r $RPM_BUILD_ROOT%{_datadir}/PackageKit/helpers/test_spawn
492
493 %if %{with browser}
494 %{__rm} $RPM_BUILD_ROOT%{_browserpluginsdir}/*.{la,a}
495 %endif
496
497 # empty version of bg
498 %{__rm} -r $RPM_BUILD_ROOT%{_localedir}/bg_BG
499 # empty version of fa (empty as well BTW)
500 %{__rm} -r $RPM_BUILD_ROOT%{_localedir}/fa_IR
501 # outdated copy of it
502 %{__rm} -r $RPM_BUILD_ROOT%{_localedir}/it_IT
503
504 %py_postclean
505
506 %find_lang %{name}
507
508 %clean
509 rm -rf $RPM_BUILD_ROOT
510
511 %post
512 %update_mime_database
513
514 %postun
515 %update_mime_database
516
517 %post   libs -p /sbin/ldconfig
518 %postun libs -p /sbin/ldconfig
519
520 %post -n browser-plugin-packagekit
521 %update_browser_plugins
522
523 %postun -n browser-plugin-packagekit
524 if [ "$1" = 0 ]; then
525         %update_browser_plugins
526 fi
527
528 %files -f %{name}.lang
529 %defattr(644,root,root,755)
530 %doc AUTHORS HACKING MAINTAINERS NEWS README
531 %attr(755,root,root) %{_bindir}/pkcon
532 %attr(755,root,root) %{_bindir}/pkmon
533 %attr(750,root,root) /etc/cron.daily/packagekit-background.cron
534 %attr(755,root,root) %{_libexecdir}/packagekit-direct
535 %attr(755,root,root) %{_libexecdir}/packagekitd
536 %attr(755,root,root) %{_libexecdir}/pk-offline-update
537 %dir %{_libdir}/packagekit-backend
538 %dir %{_sysconfdir}/PackageKit
539 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/PackageKit/PackageKit.conf
540 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/PackageKit/Vendor.conf
541 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/sysconfig/packagekit-background
542 /etc/dbus-1/system.d/org.freedesktop.PackageKit.conf
543 %dir %{_datadir}/PackageKit
544 %dir %{_datadir}/PackageKit/helpers
545 %attr(755,root,root) %{_datadir}/PackageKit/pk-upgrade-distro.sh
546 %{_datadir}/polkit-1/actions/org.freedesktop.packagekit.policy
547 %{_datadir}/polkit-1/rules.d/org.freedesktop.packagekit.rules
548 %{_datadir}/dbus-1/system-services/org.freedesktop.PackageKit.service
549 %{_mandir}/man1/pkcon.1*
550 %{_mandir}/man1/pkmon.1*
551 %{systemdunitdir}/packagekit.service
552 %{systemdunitdir}/packagekit-offline-update.service
553 %dir %{systemdunitdir}/system-update.target.wants
554 %{systemdunitdir}/system-update.target.wants/packagekit-offline-update.service
555 %dir /var/cache/PackageKit
556 %dir /var/cache/PackageKit/downloads
557 %dir /var/lib/PackageKit
558 %ghost /var/lib/PackageKit/transactions.db
559
560 %files libs
561 %defattr(644,root,root,755)
562 %attr(755,root,root) %{_libdir}/libpackagekit-glib2.so.*.*.*
563 %attr(755,root,root) %ghost %{_libdir}/libpackagekit-glib2.so.18
564 %{_libdir}/girepository-1.0/PackageKitGlib-1.0.typelib
565 # NOTE: dbus interface xmls are commonly used:
566 # - at runtime by packagekitd
567 # - for development of applications using PK dbus interface
568 %{_datadir}/dbus-1/interfaces/org.freedesktop.PackageKit.Transaction.xml
569 %{_datadir}/dbus-1/interfaces/org.freedesktop.PackageKit.xml
570
571 %files devel
572 %defattr(644,root,root,755)
573 %attr(755,root,root) %{_libdir}/libpackagekit-glib2.so
574 %{_pkgconfigdir}/packagekit-glib2.pc
575 %dir %{_includedir}/PackageKit
576 %{_includedir}/PackageKit/packagekit-glib2
577 %{_datadir}/gir-1.0/PackageKitGlib-1.0.gir
578
579 %files static
580 %defattr(644,root,root,755)
581 %{_libdir}/libpackagekit-glib2.a
582
583 %if %{with vala}
584 %files -n vala-packagekit
585 %defattr(644,root,root,755)
586 %{_datadir}/vala/vapi/packagekit-glib2.vapi
587 %endif
588
589 %files apidocs
590 %defattr(644,root,root,755)
591 %{_gtkdocdir}/PackageKit
592
593 %if %{with alpm}
594 %files backend-alpm
595 %defattr(644,root,root,755)
596 %attr(755,root,root) %{_libdir}/packagekit-backend/libpk_backend_alpm.so
597 %dir %{_sysconfdir}/PackageKit/alpm.d
598 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/PackageKit/alpm.d/groups.list
599 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/PackageKit/alpm.d/pacman.conf
600 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/PackageKit/alpm.d/repos.list
601 %endif
602
603 %if %{with apt}
604 %files backend-aptcc
605 %defattr(644,root,root,755)
606 %attr(755,root,root) %{_libdir}/packagekit-backend/libpk_backend_aptcc.so
607 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/apt/apt.conf.d/20packagekit
608 %dir %{_datadir}/PackageKit/helpers/aptcc
609 %attr(755,root,root) %{_datadir}/PackageKit/helpers/aptcc/get-distro-upgrade.py
610 %attr(755,root,root) %{_datadir}/PackageKit/helpers/aptcc/pkconffile
611 %{_datadir}/PackageKit/helpers/aptcc/pkconffile.nodiff
612 %endif
613
614 %if %{with entropy}
615 %files backend-entropy
616 %defattr(644,root,root,755)
617 %attr(755,root,root) %{_libdir}/packagekit-backend/libpk_backend_entropy.so
618 %dir %{_datadir}/PackageKit/helpers/entropy
619 %attr(755,root,root) %{_datadir}/PackageKit/helpers/entropy/entropyBackend.py
620 %endif
621
622 %if %{with hif}
623 %files backend-hif
624 %defattr(644,root,root,755)
625 %attr(755,root,root) %{_libdir}/packagekit-backend/libpk_backend_hif.so
626 %endif
627
628 %if %{with katja}
629 %files backend-katja
630 %defattr(644,root,root,755)
631 %attr(755,root,root) %{_libdir}/packagekit-backend/libpk_backend_katja.so
632 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/PackageKit/Katja.conf
633 %dir /var/cache/PackageKit/metadata
634 %ghost /var/cache/PackageKit/metadata/metadata.db
635 %endif
636
637 %if %{with pisi}
638 %files backend-pisi
639 %defattr(644,root,root,755)
640 %attr(755,root,root) %{_libdir}/packagekit-backend/libpk_backend_pisi.so
641 %dir %{_datadir}/PackageKit/helpers/pisi
642 %attr(755,root,root) %{_datadir}/PackageKit/helpers/pisi/pisiBackend.py
643 %endif
644
645 %if %{with poldek}
646 %files backend-poldek
647 %defattr(644,root,root,755)
648 %attr(755,root,root) %{_libdir}/packagekit-backend/libpk_backend_poldek.so
649 %endif
650
651 %if %{with portage}
652 %files backend-portage
653 %defattr(644,root,root,755)
654 %attr(755,root,root) %{_libdir}/packagekit-backend/libpk_backend_portage.so
655 %dir %{_datadir}/PackageKit/helpers/portage
656 %attr(755,root,root) %{_datadir}/PackageKit/helpers/portage/portageBackend.py
657 %endif
658
659 %if %{with ports}
660 %files backend-ports
661 %defattr(644,root,root,755)
662 %attr(755,root,root) %{_libdir}/packagekit-backend/libpk_backend_ports.so
663 %dir %{_datadir}/PackageKit/helpers/ports
664 %attr(755,root,root) %{_datadir}/PackageKit/helpers/ports/portsBackend.rb
665 %{_datadir}/PackageKit/helpers/ports/ruby_packagekit
666 %endif
667
668 %if %{with urpmi}
669 %files backend-urpmi
670 %defattr(644,root,root,755)
671 %attr(755,root,root) %{_libdir}/packagekit-backend/libpk_backend_urpmi.so
672 %dir %{_datadir}/PackageKit/helpers/urpmi
673 %attr(755,root,root) %{_datadir}/PackageKit/helpers/urpmi/urpmi-dispatched-backend.pl
674 %{_datadir}/PackageKit/helpers/urpmi/perl_packagekit
675 %{_datadir}/PackageKit/helpers/urpmi/urpmi_backend
676 %endif
677
678 %if %{with zypp}
679 %files backend-zypp
680 %defattr(644,root,root,755)
681 %attr(755,root,root) %{_libdir}/packagekit-backend/libpk_backend_zypp.so
682 %endif
683
684 %files gstreamer-plugin
685 %defattr(644,root,root,755)
686 %doc contrib/gstreamer-plugin/README
687 %attr(755,root,root) %{_libexecdir}/gst-install-plugins-helper
688 %attr(755,root,root) %{_libexecdir}/pk-gstreamer-install
689
690 %files gtk-module
691 %defattr(644,root,root,755)
692 %doc contrib/gtk-module/{GLASS.txt,README}
693 %attr(755,root,root) %{_libdir}/gtk-2.0/modules/libpk-gtk-module.so
694
695 %files gtk3-module
696 %defattr(644,root,root,755)
697 %attr(755,root,root) %{_libdir}/gtk-3.0/modules/libpk-gtk-module.so
698 %{_libdir}/gnome-settings-daemon-3.0/gtk-modules/pk-gtk-module.desktop
699
700 %files -n bash-completion-packagekit
701 %defattr(644,root,root,755)
702 %{bash_compdir}/pkcon
703
704 %if %{with python}
705 %files -n python-packagekit
706 %defattr(644,root,root,755)
707 %dir %{py_sitescriptdir}/packagekit
708 %{py_sitescriptdir}/packagekit/*.py[co]
709 %endif
710
711 %if %{with browser}
712 %files -n browser-plugin-packagekit
713 %defattr(644,root,root,755)
714 %attr(755,root,root) %{_browserpluginsdir}/packagekit-plugin.so
715 %endif
This page took 0.109143 seconds and 3 git commands to generate.