- updated to 1.0.5
[packages/PackageKit.git] / PackageKit.spec
1 # TODO:
2 # - BASH command-not-found functionality disabled for now as it needs patched bash
3 #   (details in bash from Fedora Rawhide)
4 #
5 # Conditional build:
6 %bcond_without  doc             # build without docs
7 %bcond_without  introspection   # gobject introspection, time to time broken
8 %bcond_with     alpm            # ALPM (Arch Linux package manager) backend
9 %bcond_with     apt             # APT (Debian/Ubuntu) backend using C++ API
10 %bcond_with     entropy         # Entropy (Sabayon) backend (Python)
11 %bcond_with     hif             # HIF (Fedora/RHEL) backend
12 %bcond_with     katja           # Katja (Slackware) backend
13 %bcond_with     pisi            # PiSi (Pardus) backend (Python)
14 %bcond_without  poldek          # Poldek (PLD) backend
15 %bcond_with     portage         # portage (Gentoo) backend (Python)
16 %bcond_with     ports           # ports (FreeBSD) backend (Ruby)
17 %bcond_with     urpmi           # urpmi (Mandriva/Mageia) backend (Perl)
18 %bcond_with     zypp            # ZYPP (openSUSE/SLE) backend
19 %bcond_without  python          # Python binding (only for a few backends)
20 %bcond_with     browser         # browser plugin (patrys says: it's flawed by concept)
21 # python binding is built when building any python binding
22 %if %{without entropy} && %{without pisi} && %{without ports}
23 %undefine       with_python
24 %endif
25 Summary:        System daemon that is a D-Bus abstraction layer for package management
26 Summary(pl.UTF-8):      Demon systemowy będący warstwą abstrakcji D-Bus do zarządzania pakietami
27 Name:           PackageKit
28 Version:        1.0.5
29 Release:        1
30 License:        GPL v2+
31 Group:          Applications/System
32 Source0:        http://www.freedesktop.org/software/PackageKit/releases/%{name}-%{version}.tar.xz
33 # Source0-md5:  1b7b4f820d522cf5fb1d4449afd89a27
34 Patch0:         %{name}-poldek.patch
35 Patch1:         %{name}-bashcomp.patch
36 Patch2:         %{name}-format.patch
37 URL:            http://www.packagekit.org/
38 BuildRequires:  NetworkManager-devel >= 0.6.5
39 # pkgconfig(libalpm) >= 8.2.0
40 %{?with_alpm:BuildRequires:     alpm-devel >= 4}
41 %{?with_hif:BuildRequires:      appstream-glib-devel}
42 %{?with_apt:BuildRequires:      apt-devel >= 0.7}
43 BuildRequires:  autoconf >= 2.65
44 BuildRequires:  automake >= 1:1.11
45 BuildRequires:  connman-devel
46 %{?with_katja:BuildRequires:    curl-devel}
47 BuildRequires:  dbus-devel >= 1.2.0
48 BuildRequires:  dbus-glib-devel >= 0.76
49 BuildRequires:  docbook-dtd412-xml
50 BuildRequires:  docbook-dtd42-xml
51 BuildRequires:  fontconfig-devel
52 BuildRequires:  gettext-tools
53 BuildRequires:  glib2-devel >= 1:2.32.0
54 %{?with_introspection:BuildRequires:    gobject-introspection-devel >= 0.9.9}
55 BuildRequires:  gstreamer-devel >= 1.0.0
56 BuildRequires:  gstreamer-plugins-base-devel >= 1.0.0
57 BuildRequires:  gtk+2-devel >= 2:2.14.0
58 BuildRequires:  gtk+3-devel >= 3.0.0
59 %{?with_doc:BuildRequires:      gtk-doc >= 1.11}
60 BuildRequires:  intltool >= 0.35.0
61 BuildRequires:  libarchive-devel
62 %{?with_hif:BuildRequires:      libhif-devel >= 0.1.7}
63 BuildRequires:  libtool
64 BuildRequires:  libxslt-progs
65 %{?with_zypp:BuildRequires:     libzypp-devel >= 6.16.0}
66 BuildRequires:  pango-devel
67 BuildRequires:  pkgconfig
68 %{?with_poldek:BuildRequires:   poldek-devel >= 0.30-1.rc6.4}
69 BuildRequires:  polkit-devel >= 0.98
70 %{?with_python:BuildRequires:   python-devel >= 1:2.7}
71 BuildRequires:  readline-devel
72 BuildRequires:  rpm-pythonprov
73 BuildRequires:  rpmbuild(macros) >= 1.311
74 BuildRequires:  sqlite3-devel >= 3
75 BuildRequires:  systemd-devel
76 BuildRequires:  tar >= 1:1.22
77 BuildRequires:  udev-glib-devel
78 BuildRequires:  xz
79 %if %{with browser}
80 BuildRequires:  cairo-devel
81 BuildRequires:  nspr-devel >= 4.8
82 BuildRequires:  pango-devel
83 BuildRequires:  xulrunner-devel >= 8.0
84 %endif
85 Requires(post,postun):  shared-mime-info
86 Requires:       %{name}-backend
87 Requires:       %{name}-libs = %{version}-%{release}
88 Requires:       ConsoleKit-x11
89 Requires:       crondaemon
90 Requires:       polkit >= 0.98
91 Obsoletes:      PackageKit-backend-smart
92 Obsoletes:      PackageKit-backend-yum
93 Obsoletes:      PackageKit-docs < 0.8.4
94 Obsoletes:      pm-utils-packagekit
95 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
96
97 %description
98 PackageKit is a D-Bus abstraction layer that allows the session user
99 to manage packages in a secure way using a cross-distro,
100 cross-architecture API.
101
102 %description -l pl.UTF-8
103 PackageKit to warstwa abstrakcji D-Bus pozwalająca użytkownikowi
104 sesyjnemu w bezpieczny sposob zarządzać pakietami przy użyciu API
105 zgodnego z wieloma dystrybucjami i architekturami.
106
107 %package libs
108 Summary:        packagekit-glib library
109 Summary(pl.UTF-8):      Biblioteka packagekit-glib
110 Group:          Libraries
111 Requires:       glib2 >= 1:2.32.0
112
113 %description libs
114 packagekit-glib library.
115
116 %description libs -l pl.UTF-8
117 Biblioteka packagekit-glib.
118
119 %package devel
120 Summary:        Header files for packagekit-glib library
121 Summary(pl.UTF-8):      Pliki nagłówkowe biblioteki packagekit-glib
122 Group:          Development/Libraries
123 Requires:       %{name}-libs = %{version}-%{release}
124 Requires:       dbus-devel >= 1.2.0
125 Requires:       glib2-devel >= 1:2.32.0
126 Requires:       sqlite3-devel
127
128 %description devel
129 Header files for packagekit-glib library.
130
131 %description devel -l pl.UTF-8
132 Pliki nagłówkowe biblioteki packagekit-glib.
133
134 %package static
135 Summary:        Static packagekit-glib library
136 Summary(pl.UTF-8):      Statyczna biblioteka packagekit-glib
137 Group:          Development/Libraries
138 Requires:       %{name}-devel = %{version}-%{release}
139
140 %description static
141 Static packagekit-glib library.
142
143 %description static -l pl.UTF-8
144 Statyczna biblioteka packagekit-glib.
145
146 %package apidocs
147 Summary:        PackageKit library API documentation
148 Summary(pl.UTF-8):      Dokumentacja API biblioteki PackageKit
149 Group:          Documentation
150 Requires:       gtk-doc-common
151 %if "%{_rpmversion}" >= "5"
152 BuildArch:      noarch
153 %endif
154
155 %description apidocs
156 PackageKit library API documentation.
157
158 %description apidocs -l pl.UTF-8
159 Dokumentacja API biblioteki PackageKit.
160
161 %package backend-alpm
162 Summary:        PackageKit ALPM backend
163 Summary(pl.UTF-8):      Backend PackageKit oparty na bibliotece ALPM
164 Group:          Libraries
165 Requires:       %{name} = %{version}-%{release}
166 Provides:       %{name}-backend = %{version}-%{release}
167
168 %description backend-alpm
169 A backend for PackageKit to enable Arch Linux packages via ALPM
170 library.
171
172 %description backend-alpm -l pl.UTF-8
173 Backend PackageKit dodający obsługę pakietów Arch Linuksa poprzez
174 bibliotekę ALPM.
175
176 %package backend-aptcc
177 Summary:        PackageKit APTcc backend
178 Summary(pl.UTF-8):      Backend PackageKit APTcc
179 Group:          Libraries
180 Requires:       %{name} = %{version}-%{release}
181 Provides:       %{name}-backend = %{version}-%{release}
182
183 %description backend-aptcc
184 A backend for PackageKit to enable APT support via C++ API.
185
186 %description backend-aptcc -l pl.UTF-8
187 Backend PackageKit dodający obsługę zarządcy pakietów APT poprzez API
188 C++.
189
190 %package backend-entropy
191 Summary:        PackageKit Entropy backend
192 Summary(pl.UTF-8):      Backend PackageKit Entropy
193 Group:          Libraries
194 Requires:       %{name} = %{version}-%{release}
195 Requires:       python-packagekit = %{version}-%{release}
196 #Requires:      python-entropy
197 Provides:       %{name}-backend = %{version}-%{release}
198
199 %description backend-entropy
200 A backend for PackageKit to enable Sabayon packages support through
201 Entropy package manager.
202
203 %description backend-entropy -l pl.UTF-8
204 Backend PackageKit dodający obsługę pakietów dystrybucji Sabayon przy
205 użyciu zarządcy pakietów Entropy.
206
207 %package backend-hif
208 Summary:        PackageKit hif backend
209 Summary(pl.UTF-8):      Backend PackageKit oparty na bibliotece hif
210 Group:          Libraries
211 Requires:       %{name} = %{version}-%{release}
212 Requires:       libhif >= 0.1.7
213 Provides:       %{name}-backend = %{version}-%{release}
214 Obsoletes:      PackageKit-backend-hawkey
215
216 %description backend-hif
217 A backend for PackageKit to enable RPM packages support via hif
218 library (used in Fedora).
219
220 %description backend-hif -l pl.UTF-8
221 Backend PackageKit dodający obsługę pakietów RPM poprzez bibliotekę
222 hif (używaną w dystrybucji Fedora).
223
224 %package backend-katja
225 Summary:        PackageKit Katja backend
226 Summary(pl.UTF-8):      Backend PackageKit Katja
227 Group:          Libraries
228 Requires:       %{name} = %{version}-%{release}
229 Provides:       %{name}-backend = %{version}-%{release}
230
231 %description backend-katja
232 Katja backend for PackageKit to enable Slackware repositories
233 support.
234
235 %description backend-katja -l pl.UTF-8
236 Backend PackageKit Katja dodający obsługę repozytoriów Slackware.
237
238 %package backend-pisi
239 Summary:        PackageKit PiSi backend
240 Summary(pl.UTF-8):      Backend PackageKit PiSi
241 Group:          Libraries
242 Requires:       %{name} = %{version}-%{release}
243 Requires:       python-packagekit = %{version}-%{release}
244 #Requires:      python-piksemel
245 #Requires:      python-pisi
246 Provides:       %{name}-backend = %{version}-%{release}
247
248 %description backend-pisi
249 A backend for PackageKit to enable PiSi packages support. PiSi
250 packages are originated in Pardus distribution.
251
252 %description backend-pisi -l pl.UTF-8
253 Backend PackageKit dodający obsługę pakietów PiSi. Pakiety PiSi
254 wywodzą się z dystrybucji Pardus.
255
256 %package backend-poldek
257 Summary:        PackageKit Poldek backend
258 Summary(pl.UTF-8):      Backend PackageKit oparty na Poldku
259 Group:          Libraries
260 Requires:       %{name} = %{version}-%{release}
261 Requires:       poldek >= 0.30-1.rc6.4
262 Provides:       %{name}-backend = %{version}-%{release}
263
264 %description backend-poldek
265 A backend for PackageKit to enable RPM packages support through Poldek
266 - native PLD package manager.
267
268 %description backend-poldek -l pl.UTF-8
269 Backend PackageKit dodający obsługę pakietów RPM poprzez Poldka -
270 natywnego zarządcę pakietów dystrybucji PLD.
271
272 %package backend-portage
273 Summary:        PackageKit Portage backend
274 Summary(pl.UTF-8):      Backend PackageKit Portage
275 Group:          Libraries
276 Requires:       %{name} = %{version}-%{release}
277 Requires:       python-packagekit = %{version}-%{release}
278 #Requires:      python-portage
279 Provides:       %{name}-backend = %{version}-%{release}
280
281 %description backend-portage
282 A backend for PackageKit to enable Gentoo Portage support.
283
284 %description backend-portage -l pl.UTF-8
285 Backend PackageKit dodający obsługę systemu Portage dystrybucji
286 Gentoo.
287
288 %package backend-ports
289 Summary:        PackageKit Ports backend
290 Summary(pl.UTF-8):      Backend PackageKit Ports
291 Group:          Libraries
292 Requires:       %{name} = %{version}-%{release}
293 #Requires:      ruby-pkgtools
294 Provides:       %{name}-backend = %{version}-%{release}
295
296 %description backend-ports
297 A backend for PackageKit to enable FreeBSD Ports support.
298
299 %description backend-ports -l pl.UTF-8
300 Backend PackageKit dodający obsługę portów systemu FreeBSD.
301
302 %package backend-urpmi
303 Summary:        PackageKit URPMI backend
304 Summary(pl.UTF-8):      Backend PackageKit URPMI
305 Group:          Libraries
306 Requires:       %{name} = %{version}-%{release}
307 #Requires:      perl-URPM
308 Provides:       %{name}-backend = %{version}-%{release}
309
310 %description backend-urpmi
311 A backend for PackageKit to enable RPM packages support through URPMI
312 package manager (originated in Mandriva).
313
314 %description backend-urpmi -l pl.UTF-8
315 Backend PackageKit dodający obsługę pakietów RPM poprzez zarządcę
316 URPMI (pochodzącego z dystrybucji Mandriva).
317
318 %package backend-zypp
319 Summary:        PackageKit Zypp backend
320 Summary(pl.UTF-8):      Backend PackageKit Zypp
321 Group:          Libraries
322 Requires:       %{name} = %{version}-%{release}
323 Requires:       libzypp >= 6.16.0
324 Provides:       %{name}-backend = %{version}-%{release}
325
326 %description backend-zypp
327 A backend for PackageKit to enable RPM packages support through Zypp
328 library (originated in openSUSE/SLE).
329
330 %description backend-zypp -l pl.UTF-8
331 Backend PackageKit dodający obsługę pakietów RPM poprzez bibliotekę
332 Zypp (pochodzącą z dystrybucji openSUSE/SLE).
333
334 %package gstreamer-plugin
335 Summary:        GStreamer codecs installer
336 Summary(pl.UTF-8):      Instalator kodeków GStreamera
337 Group:          Applications
338 Requires:       %{name} = %{version}-%{release}
339 Requires:       %{name}-gtk-module = %{version}-%{release}
340
341 %description gstreamer-plugin
342 The PackageKit GStreamer plugin allows any GStreamer application to
343 install codecs from configured repositories using PackageKit.
344
345 %description gstreamer-plugin -l pl.UTF-8
346 Wtyczka GStreamer pozwala każdej aplikacji używającej GStreamera
347 zainstalować kodeki ze skonfigurowanych źródeł PackageKit.
348
349 %package gtk-module
350 Summary:        GTK+ module to detect and install missing fonts
351 Summary(pl.UTF-8):      Moduł GTK+ do wykrywania i instalowania brakujących czcionek
352 Group:          X11/Libraries
353
354 %description gtk-module
355 The PackageKit GTK+ module allows any pango application to install
356 missing fonts from configured repositories using PackageKit.
357
358 %description gtk-module -l pl.UTF-8
359 Moduł GTK+ pozwala każdej aplikacji używającej pango zainstalować
360 brakującą czcionkę ze skonfigurowanych źródeł PackageKit.
361
362 %package gtk3-module
363 Summary:        GTK+ 3.x module to detect and install missing fonts
364 Summary(pl.UTF-8):      Moduł GTK+ 3.x do wykrywania i instalowania brakujących czcionek
365 Group:          X11/Libraries
366
367 %description gtk3-module
368 The PackageKit GTK+ 3.x module allows any pango application to install
369 missing fonts from configured repositories using PackageKit.
370
371 %description gtk3-module -l pl.UTF-8
372 Moduł GTK+ 3.x pozwala każdej aplikacji używającej pango zainstalować
373 brakującą czcionkę ze skonfigurowanych źródeł PackageKit.
374
375 %package -n bash-completion-packagekit
376 Summary:        Bash completion for PackageKit console commands
377 Summary(pl.UTF-8):      Bashowe uzupełnianie parametrów dla poleceń konsolowych PackageKit
378 Group:          Applications/Shells
379 Requires:       %{name} = %{version}-%{release}
380 Requires:       bash-completion >= 2
381 %if "%{_rpmversion}" >= "5"
382 BuildArch:      noarch
383 %endif
384
385 %description -n bash-completion-packagekit
386 This package provides bash-completion for PackageKit console commands.
387
388 %description -n bash-completion-packagekit -l pl.UTF-8
389 Pakiet ten dostarcza bashowe uzupełnianie parametrów dla poleceń
390 konsolowych PackageKit.
391
392 %package -n python-packagekit
393 Summary:        PackageKit Python bindings
394 Summary(pl.UTF-8):      Wiązania PackageKit dla Pythona
395 Group:          Development/Languages/Python
396 Requires:       python-dbus
397 Requires:       python-pygobject
398
399 %description -n python-packagekit
400 PackageKit Python bindings.
401
402 %description -n python-packagekit -l pl.UTF-8
403 Wiązania PackageKit dla Pythona.
404
405 %package -n browser-plugin-packagekit
406 Summary:        PackageKit's browser plugin
407 Summary(pl.UTF-8):      Wtyczka PackageKit do przeglądarek WWW
408 Group:          X11/Libraries
409 Requires:       %{name} = %{version}-%{release}
410 Requires:       browser-plugins >= 2.0
411 Requires:       browser-plugins(%{_target_base_arch})
412
413 %description -n browser-plugin-packagekit
414 PackageKit's plugin for browsers.
415
416 %description -n browser-plugin-packagekit -l pl.UTF-8
417 Wtyczka PackageKit do przeglądarek WWW.
418
419 %prep
420 %setup -q
421 %patch0 -p1
422 %patch1 -p1
423 %patch2 -p1
424
425 %build
426 %if %{with doc}
427 %{__gtkdocize}
428 %endif
429 %{__intltoolize}
430 %{__libtoolize}
431 %{__aclocal} -I m4
432 %{__autoconf}
433 %{__autoheader}
434 %{__automake}
435 %{?with_zypp:CPPFLAGS="%{rpmcppflags} -D_RPM_5 -I/usr/include/rpm"}
436 %configure \
437         --disable-command-not-found \
438         --disable-dummy \
439         %{!?with_doc:--disable-gtk-doc} \
440         %{!?with_introspection:--disable-introspection} \
441         --disable-silent-rules \
442         --enable-bash-completion=%{bash_compdir} \
443         %{__enable_disable alpm} \
444         %{__enable_disable apt aptcc} \
445         %{__enable_disable browser browser-plugin} \
446         %{__enable_disable entropy} \
447         %{__enable_disable hif} \
448         %{__enable_disable katja} \
449         %{__enable_disable pisi} \
450         %{__enable_disable poldek} \
451         %{__enable_disable portage} \
452         %{__enable_disable ports} \
453         %{__enable_disable urpmi} \
454         %{__enable_disable zypp} \
455         --with-html-dir=%{_gtkdocdir} \
456         --with-mozilla-plugin-dir=%{_browserpluginsdir} \
457         --with-security-framework=polkit
458 %{__make}
459
460 %install
461 rm -rf $RPM_BUILD_ROOT
462
463 %{__make} install \
464         DESTDIR=$RPM_BUILD_ROOT
465
466 # use pk-gstreamer-install as codec installer
467 ln -s pk-gstreamer-install $RPM_BUILD_ROOT%{_libdir}/gst-install-plugins-helper
468
469 %{__rm} $RPM_BUILD_ROOT%{_libdir}/gtk-{2,3}.0/modules/*.{la,a}
470 %{__rm} $RPM_BUILD_ROOT%{_libdir}/packagekit-backend/*.{la,a}
471 %{__rm} $RPM_BUILD_ROOT%{_libdir}/packagekit-backend/libpk_backend_test_*.so
472 %{__rm} $RPM_BUILD_ROOT%{_libdir}/*.la
473 %{__rm} -r $RPM_BUILD_ROOT%{_datadir}/PackageKit/helpers/test_spawn
474
475 %if %{with browser}
476 %{__rm} $RPM_BUILD_ROOT%{_browserpluginsdir}/*.{la,a}
477 %endif
478
479 # empty version of bg
480 %{__rm} -r $RPM_BUILD_ROOT%{_localedir}/bg_BG
481 # empty version of fa (empty as well BTW)
482 %{__rm} -r $RPM_BUILD_ROOT%{_localedir}/fa_IR
483 # outdated copy of it
484 %{__rm} -r $RPM_BUILD_ROOT%{_localedir}/it_IT
485
486 %py_postclean
487
488 %find_lang %{name}
489
490 %clean
491 rm -rf $RPM_BUILD_ROOT
492
493 %post
494 %update_mime_database
495
496 %postun
497 %update_mime_database
498
499 %post   libs -p /sbin/ldconfig
500 %postun libs -p /sbin/ldconfig
501
502 %post -n browser-plugin-packagekit
503 %update_browser_plugins
504
505 %postun -n browser-plugin-packagekit
506 if [ "$1" = 0 ]; then
507         %update_browser_plugins
508 fi
509
510 %files -f %{name}.lang
511 %defattr(644,root,root,755)
512 %doc AUTHORS HACKING MAINTAINERS NEWS README
513 %attr(755,root,root) %{_bindir}/pkcon
514 %attr(755,root,root) %{_bindir}/pkmon
515 %attr(750,root,root) /etc/cron.daily/packagekit-background.cron
516 %attr(755,root,root) %{_libexecdir}/packagekit-direct
517 %attr(755,root,root) %{_libexecdir}/packagekitd
518 %attr(755,root,root) %{_libexecdir}/pk-offline-update
519 %dir %{_libdir}/packagekit-backend
520 %dir %{_sysconfdir}/PackageKit
521 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/PackageKit/PackageKit.conf
522 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/PackageKit/Vendor.conf
523 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/sysconfig/packagekit-background
524 /etc/dbus-1/system.d/org.freedesktop.PackageKit.conf
525 %dir %{_datadir}/PackageKit
526 %dir %{_datadir}/PackageKit/helpers
527 %attr(755,root,root) %{_datadir}/PackageKit/pk-upgrade-distro.sh
528 %{_datadir}/polkit-1/actions/org.freedesktop.packagekit.policy
529 %{_datadir}/polkit-1/rules.d/org.freedesktop.packagekit.rules
530 %{_datadir}/dbus-1/system-services/org.freedesktop.PackageKit.service
531 %{_mandir}/man1/pkcon.1*
532 %{_mandir}/man1/pkmon.1*
533 %{systemdunitdir}/packagekit.service
534 %{systemdunitdir}/packagekit-offline-update.service
535 %dir %{systemdunitdir}/system-update.target.wants
536 %{systemdunitdir}/system-update.target.wants/packagekit-offline-update.service
537 %dir /var/cache/PackageKit
538 %dir /var/cache/PackageKit/downloads
539 %dir /var/lib/PackageKit
540 %ghost /var/lib/PackageKit/transactions.db
541
542 %files libs
543 %defattr(644,root,root,755)
544 %attr(755,root,root) %{_libdir}/libpackagekit-glib2.so.*.*.*
545 %attr(755,root,root) %ghost %{_libdir}/libpackagekit-glib2.so.18
546 %{_libdir}/girepository-1.0/PackageKitGlib-1.0.typelib
547 # NOTE: dbus interface xmls are commonly used:
548 # - at runtime by packagekitd
549 # - for development of applications using PK dbus interface
550 %{_datadir}/dbus-1/interfaces/org.freedesktop.PackageKit.Transaction.xml
551 %{_datadir}/dbus-1/interfaces/org.freedesktop.PackageKit.xml
552
553 %files devel
554 %defattr(644,root,root,755)
555 %attr(755,root,root) %{_libdir}/libpackagekit-glib2.so
556 %{_pkgconfigdir}/packagekit-glib2.pc
557 %dir %{_includedir}/PackageKit
558 %{_includedir}/PackageKit/packagekit-glib2
559 %{_datadir}/gir-1.0/PackageKitGlib-1.0.gir
560
561 %files static
562 %defattr(644,root,root,755)
563 %{_libdir}/libpackagekit-glib2.a
564
565 %files apidocs
566 %defattr(644,root,root,755)
567 %{_gtkdocdir}/PackageKit
568
569 %if %{with alpm}
570 %files backend-alpm
571 %defattr(644,root,root,755)
572 %attr(755,root,root) %{_libdir}/packagekit-backend/libpk_backend_alpm.so
573 %dir %{_sysconfdir}/PackageKit/alpm.d
574 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/PackageKit/alpm.d/groups.list
575 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/PackageKit/alpm.d/pacman.conf
576 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/PackageKit/alpm.d/repos.list
577 %endif
578
579 %if %{with apt}
580 %files backend-aptcc
581 %defattr(644,root,root,755)
582 %attr(755,root,root) %{_libdir}/packagekit-backend/libpk_backend_aptcc.so
583 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/apt/apt.conf.d/20packagekit
584 %dir %{_datadir}/PackageKit/helpers/aptcc
585 %attr(755,root,root) %{_datadir}/PackageKit/helpers/aptcc/get-distro-upgrade.py
586 %attr(755,root,root) %{_datadir}/PackageKit/helpers/aptcc/pkconffile
587 %{_datadir}/PackageKit/helpers/aptcc/pkconffile.nodiff
588 %endif
589
590 %if %{with entropy}
591 %files backend-entropy
592 %defattr(644,root,root,755)
593 %attr(755,root,root) %{_libdir}/packagekit-backend/libpk_backend_entropy.so
594 %dir %{_datadir}/PackageKit/helpers/entropy
595 %attr(755,root,root) %{_datadir}/PackageKit/helpers/entropy/entropyBackend.py
596 %endif
597
598 %if %{with hif}
599 %files backend-hif
600 %defattr(644,root,root,755)
601 %attr(755,root,root) %{_libdir}/packagekit-backend/libpk_backend_hif.so
602 %endif
603
604 %if %{with katja}
605 %files backend-katja
606 %defattr(644,root,root,755)
607 %attr(755,root,root) %{_libdir}/packagekit-backend/libpk_backend_katja.so
608 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/PackageKit/Katja.conf
609 %dir /var/cache/PackageKit/metadata
610 %ghost /var/cache/PackageKit/metadata/metadata.db
611 %endif
612
613 %if %{with pisi}
614 %files backend-pisi
615 %defattr(644,root,root,755)
616 %attr(755,root,root) %{_libdir}/packagekit-backend/libpk_backend_pisi.so
617 %dir %{_datadir}/PackageKit/helpers/pisi
618 %attr(755,root,root) %{_datadir}/PackageKit/helpers/pisi/pisiBackend.py
619 %endif
620
621 %if %{with poldek}
622 %files backend-poldek
623 %defattr(644,root,root,755)
624 %attr(755,root,root) %{_libdir}/packagekit-backend/libpk_backend_poldek.so
625 %endif
626
627 %if %{with portage}
628 %files backend-portage
629 %defattr(644,root,root,755)
630 %attr(755,root,root) %{_libdir}/packagekit-backend/libpk_backend_portage.so
631 %dir %{_datadir}/PackageKit/helpers/portage
632 %attr(755,root,root) %{_datadir}/PackageKit/helpers/portage/portageBackend.py
633 %endif
634
635 %if %{with ports}
636 %files backend-ports
637 %defattr(644,root,root,755)
638 %attr(755,root,root) %{_libdir}/packagekit-backend/libpk_backend_ports.so
639 %dir %{_datadir}/PackageKit/helpers/ports
640 %attr(755,root,root) %{_datadir}/PackageKit/helpers/ports/portsBackend.rb
641 %{_datadir}/PackageKit/helpers/ports/ruby_packagekit
642 %endif
643
644 %if %{with urpmi}
645 %files backend-urpmi
646 %defattr(644,root,root,755)
647 %attr(755,root,root) %{_libdir}/packagekit-backend/libpk_backend_urpmi.so
648 %dir %{_datadir}/PackageKit/helpers/urpmi
649 %attr(755,root,root) %{_datadir}/PackageKit/helpers/urpmi/urpmi-dispatched-backend.pl
650 %{_datadir}/PackageKit/helpers/urpmi/perl_packagekit
651 %{_datadir}/PackageKit/helpers/urpmi/urpmi_backend
652 %endif
653
654 %if %{with zypp}
655 %files backend-zypp
656 %defattr(644,root,root,755)
657 %attr(755,root,root) %{_libdir}/packagekit-backend/libpk_backend_zypp.so
658 %endif
659
660 %files gstreamer-plugin
661 %defattr(644,root,root,755)
662 %doc contrib/gstreamer-plugin/README
663 %attr(755,root,root) %{_libexecdir}/gst-install-plugins-helper
664 %attr(755,root,root) %{_libexecdir}/pk-gstreamer-install
665
666 %files gtk-module
667 %defattr(644,root,root,755)
668 %doc contrib/gtk-module/{GLASS.txt,README}
669 %attr(755,root,root) %{_libdir}/gtk-2.0/modules/libpk-gtk-module.so
670
671 %files gtk3-module
672 %defattr(644,root,root,755)
673 %attr(755,root,root) %{_libdir}/gtk-3.0/modules/libpk-gtk-module.so
674 %{_libdir}/gnome-settings-daemon-3.0/gtk-modules/pk-gtk-module.desktop
675
676 %files -n bash-completion-packagekit
677 %defattr(644,root,root,755)
678 %{bash_compdir}/pkcon
679
680 %if %{with python}
681 %files -n python-packagekit
682 %defattr(644,root,root,755)
683 %dir %{py_sitescriptdir}/packagekit
684 %{py_sitescriptdir}/packagekit/*.py[co]
685 %endif
686
687 %if %{with browser}
688 %files -n browser-plugin-packagekit
689 %defattr(644,root,root,755)
690 %attr(755,root,root) %{_browserpluginsdir}/packagekit-plugin.so
691 %endif
This page took 0.172382 seconds and 3 git commands to generate.