]> git.pld-linux.org Git - packages/PackageKit.git/blame - PackageKit.spec
Release 2 (by relup.sh)
[packages/PackageKit.git] / PackageKit.spec
CommitLineData
d05d9108
MB
1# TODO:
2# - BASH command-not-found functionality disabled for now as it needs patched bash
3# (details in bash from Fedora Rawhide)
574f2e60
JB
4# - setup dnf vendor properly? (see meson command)
5# - daemon user (see meson command)
d05d9108
MB
6#
7# Conditional build:
658d6c88 8%bcond_without apidocs # API documentation
53810c7c 9%bcond_without introspection # gobject introspection, time to time broken
aa278a7b
JB
10%bcond_without static_libs # static library
11%bcond_without python # Python binding (used by entropy and portage backends)
12%bcond_without vala # Vala binding
13# backends
d06070b1 14%bcond_with alpm # ALPM (Arch Linux package manager) backend
04e18045 15%bcond_with apt # APT (Debian/Ubuntu) backend using C++ API
574f2e60 16%bcond_without dnf # DNF (Fedora/RHEL/Mageia/OpenMandriva/OpenSUSE/Rosa) backend
04e18045 17%bcond_with entropy # Entropy (Sabayon) backend (Python)
574f2e60 18%bcond_with nix # Nix (NixOS) backend [broken as of 1.2.0-1.2.5]
e12b9e2b 19%bcond_with pisi # PiSi (Pardus) backend (Python)
04e18045
JB
20%bcond_without poldek # Poldek (PLD) backend
21%bcond_with portage # portage (Gentoo) backend (Python)
49ea0764 22%bcond_with slack # Slack (Slackware) backend
574f2e60 23%bcond_with zypp # ZYPP (openSUSE/SLE) backend
0e84469f 24
aa278a7b
JB
25%if %{without python}
26%undefine with_entropy
e12b9e2b 27%undefine with_pisi
aa278a7b 28%undefine with_portage
04e18045 29%endif
0e84469f 30
85d27e4f
JB
31Summary: System daemon that is a D-Bus abstraction layer for package management
32Summary(pl.UTF-8): Demon systemowy będący warstwą abstrakcji D-Bus do zarządzania pakietami
a2d83637 33Name: PackageKit
2b0af1bc 34Version: 1.2.8
2ddcf14d 35Release: 2
a2d83637 36License: GPL v2+
85d27e4f 37Group: Applications/System
90405068 38Source0: https://www.freedesktop.org/software/PackageKit/releases/%{name}-%{version}.tar.xz
2b0af1bc 39# Source0-md5: 78cb918f4128a57bfc8a454b60f5a3c1
02b3d2d3 40Patch0: %{name}-poldek.patch
aa278a7b 41Patch2: %{name}-meson.patch
bcd7526e 42Patch3: consolekit-fallback.patch
90405068 43URL: https://www.freedesktop.org/software/PackageKit/
80f3e6e1
JP
44%{?with_dnf:BuildRequires: AppStream-devel >= 0.14.0}
45%{?with_apt:BuildRequires: AppStream-devel >= 0.16.0}
a2d83637 46BuildRequires: NetworkManager-devel >= 0.6.5
574f2e60
JB
47# pkgconfig(libalpm) >= 13.0.0
48%{?with_alpm:BuildRequires: alpm-devel >= 6.0}
ea58ad5c 49%{?with_apt:BuildRequires: apt-devel >= 1.9.2}
dd5c7282 50BuildRequires: bash-completion-devel >= 1:2.0
577193a4 51BuildRequires: connman-devel
49ea0764 52%{?with_slack:BuildRequires: curl-devel}
6808f644 53BuildRequires: dbus-devel >= 1.2.0
f5f5e3ff 54BuildRequires: dbus-glib-devel >= 0.76
bdd8c0ca 55BuildRequires: docbook-dtd412-xml
56BuildRequires: docbook-dtd42-xml
01260b07 57BuildRequires: docbook-style-xsl-nons
dac2b5e1 58BuildRequires: fontconfig-devel
a0f1aeda 59BuildRequires: gettext-tools
574f2e60 60BuildRequires: glib2-devel >= 1:2.62
53810c7c 61%{?with_introspection:BuildRequires: gobject-introspection-devel >= 0.9.9}
7cd3cbcf
MB
62BuildRequires: gstreamer-devel >= 1.0.0
63BuildRequires: gstreamer-plugins-base-devel >= 1.0.0
dac2b5e1 64BuildRequires: gtk+3-devel >= 3.0.0
658d6c88 65%{?with_apidocs:BuildRequires: gtk-doc >= 1.11}
78293e06 66BuildRequires: libarchive-devel
aa278a7b 67%{?with_dnf:BuildRequires: libdnf-devel >= 0.43.1}
49ea0764
JB
68%if %{with apt} || %{with nix}
69BuildRequires: libstdc++-devel >= 6:4.7
70%endif
71%{?with_slack:BuildRequires: libstdc++-devel >= 6:5}
dac2b5e1 72BuildRequires: libxslt-progs
5ece0444 73%{?with_zypp:BuildRequires: libzypp-devel >= 17.31.0}
e0e35018 74BuildRequires: meson >= 0.50
aa278a7b 75BuildRequires: ninja >= 1.5
49ea0764 76# nix-expr nix-main nix-store
5ece0444 77%{?with_nix:BuildRequires: nix-devel >= 2.9}
dac2b5e1 78BuildRequires: pango-devel
a2d83637 79BuildRequires: pkgconfig
e0e35018 80# just to detect which reboot modes to use (library not linked)
49ea0764 81#BuildRequires: plymouth-devel >= 0.9.5
7cd3cbcf 82%{?with_poldek:BuildRequires: poldek-devel >= 0.30-1.rc6.4}
49ea0764 83BuildRequires: polkit-devel >= 0.114
dd5c7282 84%{?with_python:BuildRequires: python3-devel >= 1:3.2}
827cd5e7 85BuildRequires: readline-devel
e0e35018 86BuildRequires: rpm-build >= 4.6
ea58ad5c 87%{?with_dnf:BuildRequires: rpm-devel >= 1:4.6}
a2d83637 88BuildRequires: rpm-pythonprov
aa278a7b
JB
89BuildRequires: rpmbuild(macros) >= 1.736
90BuildRequires: sed >= 4.0
577193a4 91BuildRequires: sqlite3-devel >= 3
574f2e60 92# or elogind >= 229.4
49ea0764 93BuildRequires: systemd-devel >= 1:213
e216f3d9 94BuildRequires: tar >= 1:1.22
9ed4ca79 95BuildRequires: udev-glib-devel
8ad97aee 96%{?with_vala:BuildRequires: vala >= 2:0.16}
e216f3d9 97BuildRequires: xz
fcd0bc5c 98Requires(post,postun): shared-mime-info
0d5f415c 99Requires: %{name}-backend
a2d83637 100Requires: %{name}-libs = %{version}-%{release}
8d48627e 101Requires: crondaemon
49ea0764 102Requires: polkit >= 0.114
48178e4e 103Suggests: ConsoleKit-x11
e0e35018
JB
104Obsoletes: PackageKit-backend-ports < 1.2
105Obsoletes: PackageKit-backend-smart < 1.0
106Obsoletes: PackageKit-backend-urpmi < 1.2
107Obsoletes: PackageKit-backend-yum < 1.2
7cd3cbcf 108Obsoletes: PackageKit-docs < 0.8.4
e0e35018 109Obsoletes: pm-utils-packagekit < 0.8.15
a2d83637
MB
110BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
111
112%description
113PackageKit is a D-Bus abstraction layer that allows the session user
114to manage packages in a secure way using a cross-distro,
115cross-architecture API.
116
85d27e4f
JB
117%description -l pl.UTF-8
118PackageKit to warstwa abstrakcji D-Bus pozwalająca użytkownikowi
119sesyjnemu w bezpieczny sposob zarządzać pakietami przy użyciu API
120zgodnego z wieloma dystrybucjami i architekturami.
121
a2d83637 122%package libs
d05d9108
MB
123Summary: packagekit-glib library
124Summary(pl.UTF-8): Biblioteka packagekit-glib
a2d83637 125Group: Libraries
574f2e60 126Requires: glib2 >= 1:2.62
49ea0764 127Obsoletes: browser-plugin-packagekit < 1.1.0
a2d83637
MB
128
129%description libs
d05d9108 130packagekit-glib library.
a2d83637
MB
131
132%description libs -l pl.UTF-8
d05d9108 133Biblioteka packagekit-glib.
a2d83637
MB
134
135%package devel
d05d9108
MB
136Summary: Header files for packagekit-glib library
137Summary(pl.UTF-8): Pliki nagłówkowe biblioteki packagekit-glib
a2d83637
MB
138Group: Development/Libraries
139Requires: %{name}-libs = %{version}-%{release}
9ed4ca79 140Requires: dbus-devel >= 1.2.0
574f2e60 141Requires: glib2-devel >= 1:2.62
9ed4ca79 142Requires: sqlite3-devel
a2d83637
MB
143
144%description devel
d05d9108 145Header files for packagekit-glib library.
a2d83637
MB
146
147%description devel -l pl.UTF-8
d05d9108 148Pliki nagłówkowe biblioteki packagekit-glib.
a2d83637
MB
149
150%package static
d05d9108
MB
151Summary: Static packagekit-glib library
152Summary(pl.UTF-8): Statyczna biblioteka packagekit-glib
a2d83637
MB
153Group: Development/Libraries
154Requires: %{name}-devel = %{version}-%{release}
155
156%description static
d05d9108 157Static packagekit-glib library.
a2d83637
MB
158
159%description static -l pl.UTF-8
d05d9108
MB
160Statyczna biblioteka packagekit-glib.
161
8ad97aee
JB
162%package -n vala-packagekit
163Summary: Vala API for PackageKit library
164Summary(pl.UTF-8): API języka Vala do biblioteki PackageKitu
165Group: Development/Libraries
166Requires: %{name}-devel = %{version}-%{release}
167Requires: vala >= 2:0.16
0e84469f 168BuildArch: noarch
8ad97aee
JB
169
170%description -n vala-packagekit
171Vala API for PackageKit library.
172
173%description -n vala-packagekit -l pl.UTF-8
174API języka Vala do biblioteki PackageKitu.
175
16acf8d5
JB
176%package apidocs
177Summary: PackageKit library API documentation
178Summary(pl.UTF-8): Dokumentacja API biblioteki PackageKit
179Group: Documentation
180Requires: gtk-doc-common
2aa4ef3d 181BuildArch: noarch
16acf8d5
JB
182
183%description apidocs
184PackageKit library API documentation.
185
186%description apidocs -l pl.UTF-8
187Dokumentacja API biblioteki PackageKit.
188
d06070b1
JB
189%package backend-alpm
190Summary: PackageKit ALPM backend
191Summary(pl.UTF-8): Backend PackageKit oparty na bibliotece ALPM
192Group: Libraries
193Requires: %{name} = %{version}-%{release}
194Provides: %{name}-backend = %{version}-%{release}
d06070b1
JB
195
196%description backend-alpm
197A backend for PackageKit to enable Arch Linux packages via ALPM
198library.
199
200%description backend-alpm -l pl.UTF-8
201Backend PackageKit dodający obsługę pakietów Arch Linuksa poprzez
202bibliotekę ALPM.
203
04e18045
JB
204%package backend-aptcc
205Summary: PackageKit APTcc backend
206Summary(pl.UTF-8): Backend PackageKit APTcc
207Group: Libraries
208Requires: %{name} = %{version}-%{release}
ea58ad5c
JB
209Requires: AppStream >= 0.12
210Requires: apt >= 1.9.2
04e18045
JB
211Provides: %{name}-backend = %{version}-%{release}
212
213%description backend-aptcc
214A backend for PackageKit to enable APT support via C++ API.
215
216%description backend-aptcc -l pl.UTF-8
217Backend PackageKit dodający obsługę zarządcy pakietów APT poprzez API
218C++.
219
49ea0764
JB
220%package backend-dnf
221Summary: PackageKit dnf backend
222Summary(pl.UTF-8): Backend PackageKit oparty na bibliotece dnfhif
223Group: Libraries
224Requires: %{name} = %{version}-%{release}
ea58ad5c
JB
225Requires: libdnf >= 0.43.1
226Requires: rpm >= 1:4.6
49ea0764 227Provides: %{name}-backend = %{version}-%{release}
e0e35018
JB
228Obsoletes: PackageKit-backend-hawkey < 1.0
229Obsoletes: PackageKit-backend-hif < 1.2
49ea0764
JB
230
231%description backend-dnf
232A backend for PackageKit to enable RPM packages support via dnf
233library (used in Fedora).
234
235%description backend-dnf -l pl.UTF-8
236Backend PackageKit dodający obsługę pakietów RPM poprzez bibliotekę
237dnf (używaną w dystrybucji Fedora).
238
04e18045
JB
239%package backend-entropy
240Summary: PackageKit Entropy backend
241Summary(pl.UTF-8): Backend PackageKit Entropy
242Group: Libraries
243Requires: %{name} = %{version}-%{release}
dd5c7282
JB
244Requires: python3-packagekit = %{version}-%{release}
245#Requires: python3-entropy
04e18045
JB
246Provides: %{name}-backend = %{version}-%{release}
247
248%description backend-entropy
249A backend for PackageKit to enable Sabayon packages support through
250Entropy package manager.
251
252%description backend-entropy -l pl.UTF-8
253Backend PackageKit dodający obsługę pakietów dystrybucji Sabayon przy
254użyciu zarządcy pakietów Entropy.
255
49ea0764
JB
256%package backend-nix
257Summary: PackageKit Nix backend
258Summary(pl.UTF-8): Backend PackageKit oparty na zarządcy pakietów Nix
04e18045
JB
259Group: Libraries
260Requires: %{name} = %{version}-%{release}
5ece0444 261Requires: nix >= 2.9
04e18045
JB
262Provides: %{name}-backend = %{version}-%{release}
263
49ea0764
JB
264%description backend-nix
265A backend for PackageKit to enable Nix packages support (used in
266NixOS).
04e18045 267
49ea0764
JB
268%description backend-nix -l pl.UTF-8
269Backend PackageKit dodający obsługę pakietów Nix (używanych w NixOS).
04e18045 270
e12b9e2b
JB
271%package backend-pisi
272Summary: PackageKit PiSi backend
273Summary(pl.UTF-8): Backend PackageKit PiSi
274Group: Libraries
275Requires: %{name} = %{version}-%{release}
276Requires: python3-packagekit = %{version}-%{release}
277#Requires: python3-piksemel
278#Requires: python3-pisi
279Provides: %{name}-backend = %{version}-%{release}
280
281%description backend-pisi
282A backend for PackageKit to enable PiSi packages support. PiSi
283packages are originated in Pardus distribution.
284
285%description backend-pisi -l pl.UTF-8
286Backend PackageKit dodający obsługę pakietów PiSi. Pakiety PiSi
287wywodzą się z dystrybucji Pardus.
288
0d5f415c
ER
289%package backend-poldek
290Summary: PackageKit Poldek backend
16acf8d5 291Summary(pl.UTF-8): Backend PackageKit oparty na Poldku
0d5f415c
ER
292Group: Libraries
293Requires: %{name} = %{version}-%{release}
7cd3cbcf 294Requires: poldek >= 0.30-1.rc6.4
16acf8d5 295Provides: %{name}-backend = %{version}-%{release}
0d5f415c
ER
296
297%description backend-poldek
04e18045
JB
298A backend for PackageKit to enable RPM packages support through Poldek
299- native PLD package manager.
0d5f415c 300
16acf8d5 301%description backend-poldek -l pl.UTF-8
04e18045
JB
302Backend PackageKit dodający obsługę pakietów RPM poprzez Poldka -
303natywnego zarządcę pakietów dystrybucji PLD.
304
305%package backend-portage
306Summary: PackageKit Portage backend
307Summary(pl.UTF-8): Backend PackageKit Portage
308Group: Libraries
309Requires: %{name} = %{version}-%{release}
dd5c7282
JB
310Requires: python3-packagekit = %{version}-%{release}
311#Requires: python3-portage
04e18045
JB
312Provides: %{name}-backend = %{version}-%{release}
313
314%description backend-portage
315A backend for PackageKit to enable Gentoo Portage support.
316
317%description backend-portage -l pl.UTF-8
318Backend PackageKit dodający obsługę systemu Portage dystrybucji
319Gentoo.
320
49ea0764
JB
321%package backend-slack
322Summary: PackageKit Slack backend
323Summary(pl.UTF-8): Backend PackageKit Slack
324Group: Libraries
325Requires: %{name} = %{version}-%{release}
326Provides: %{name}-backend = %{version}-%{release}
e0e35018 327Obsoletes: PackageKit-backend-katja < 1.2
49ea0764
JB
328
329%description backend-slack
330Slack backend for PackageKit to enable Slackware repositories support.
331
332%description backend-slack -l pl.UTF-8
333Backend PackageKit Slack dodający obsługę repozytoriów Slackware.
334
04e18045
JB
335%package backend-zypp
336Summary: PackageKit Zypp backend
337Summary(pl.UTF-8): Backend PackageKit Zypp
338Group: Libraries
339Requires: %{name} = %{version}-%{release}
5ece0444 340Requires: libzypp >= 17.31.0
04e18045
JB
341Provides: %{name}-backend = %{version}-%{release}
342
343%description backend-zypp
344A backend for PackageKit to enable RPM packages support through Zypp
345library (originated in openSUSE/SLE).
346
347%description backend-zypp -l pl.UTF-8
348Backend PackageKit dodający obsługę pakietów RPM poprzez bibliotekę
349Zypp (pochodzącą z dystrybucji openSUSE/SLE).
16acf8d5 350
d05d9108
MB
351%package gstreamer-plugin
352Summary: GStreamer codecs installer
353Summary(pl.UTF-8): Instalator kodeków GStreamera
354Group: Applications
355Requires: %{name} = %{version}-%{release}
aa278a7b 356Requires: %{name}-gtk3-module = %{version}-%{release}
d05d9108
MB
357
358%description gstreamer-plugin
359The PackageKit GStreamer plugin allows any GStreamer application to
360install codecs from configured repositories using PackageKit.
361
362%description gstreamer-plugin -l pl.UTF-8
363Wtyczka GStreamer pozwala każdej aplikacji używającej GStreamera
364zainstalować kodeki ze skonfigurowanych źródeł PackageKit.
365
dac2b5e1
AF
366%package gtk3-module
367Summary: GTK+ 3.x module to detect and install missing fonts
368Summary(pl.UTF-8): Moduł GTK+ 3.x do wykrywania i instalowania brakujących czcionek
369Group: X11/Libraries
aa278a7b 370Obsoletes: PackageKit-gtk-module < 1.2.0
dac2b5e1
AF
371
372%description gtk3-module
373The PackageKit GTK+ 3.x module allows any pango application to install
374missing fonts from configured repositories using PackageKit.
375
376%description gtk3-module -l pl.UTF-8
377Moduł GTK+ 3.x pozwala każdej aplikacji używającej pango zainstalować
378brakującą czcionkę ze skonfigurowanych źródeł PackageKit.
379
a2d83637 380%package -n bash-completion-packagekit
16acf8d5
JB
381Summary: Bash completion for PackageKit console commands
382Summary(pl.UTF-8): Bashowe uzupełnianie parametrów dla poleceń konsolowych PackageKit
a2d83637 383Group: Applications/Shells
577193a4 384Requires: %{name} = %{version}-%{release}
dd5c7282 385Requires: bash-completion >= 1:2.0
ead2d2f6 386BuildArch: noarch
a2d83637
MB
387
388%description -n bash-completion-packagekit
16acf8d5 389This package provides bash-completion for PackageKit console commands.
a2d83637
MB
390
391%description -n bash-completion-packagekit -l pl.UTF-8
16acf8d5
JB
392Pakiet ten dostarcza bashowe uzupełnianie parametrów dla poleceń
393konsolowych PackageKit.
a2d83637 394
dd5c7282 395%package -n python3-packagekit
a2d83637
MB
396Summary: PackageKit Python bindings
397Summary(pl.UTF-8): Wiązania PackageKit dla Pythona
398Group: Development/Languages/Python
dd5c7282 399Obsoletes: python-packagekit < 1.2.7
a2d83637 400
dd5c7282 401%description -n python3-packagekit
a2d83637
MB
402PackageKit Python bindings.
403
dd5c7282 404%description -n python3-packagekit -l pl.UTF-8
a2d83637
MB
405Wiązania PackageKit dla Pythona.
406
407%prep
408%setup -q
d113818a 409%patch0 -p1
aa278a7b 410%patch2 -p1
bcd7526e 411%patch3 -p1
a2d83637 412
e12b9e2b
JB
413%{__sed} -i -e '1s,/usr/bin/python$,%{__python3},' backends/pisi/pisiBackend.py
414
aa278a7b
JB
415%if %{with static_libs}
416%{__sed} -i -e '/^packagekit_glib2_library =/ s/shared_library/library/' lib/packagekit-glib2/meson.build
d5617342 417%endif
aa278a7b
JB
418
419%build
aa278a7b 420%meson build \
dd5c7282 421 --python.bytecompile=2 \
aa278a7b 422 -Dbash_command_not_found=false \
aa278a7b 423 %{!?with_introspection:-Dgobject_introspection=false} \
658d6c88 424 %{?with_apidocs:-Dgtk_doc=true} \
e12b9e2b 425 -Dpackaging_backend=dummy%{?with_alpm:,alpm}%{?with_apt:,aptcc}%{?with_dnf:,dnf}%{?with_entropy:,entropy}%{?with_pisi:,pisi}%{?with_poldek:,poldek}%{?with_portage:,portage}%{?with_slack:,slack}%{?with_zypp:,zypp}%{?with_nix:,nix} \
aa278a7b 426 %{!?with_python:-Dpython_backend=false} \
aa278a7b
JB
427 -Dsystemdsystemunitdir=%{systemdunitdir}
428
429# TODO:
430# -Ddnf_vendor=
431# -Dpackagekit_user=
432
433%ninja_build -C build
a2d83637
MB
434
435%install
436rm -rf $RPM_BUILD_ROOT
aa278a7b 437install -d $RPM_BUILD_ROOT/var/cache/PackageKit/downloads
a2d83637 438
aa278a7b
JB
439%ninja_install -C build
440
441%{__rm} $RPM_BUILD_ROOT%{_libdir}/packagekit-backend/libpk_backend_test_*.so
e0e35018 442%{__rm} -r $RPM_BUILD_ROOT%{_datadir}/PackageKit/helpers/test_spawn
5059111f 443
d05d9108 444# use pk-gstreamer-install as codec installer
aa278a7b 445ln -s pk-gstreamer-install $RPM_BUILD_ROOT%{_libexecdir}/gst-install-plugins-helper
d05d9108 446
aa278a7b
JB
447install -d $RPM_BUILD_ROOT%{systemdunitdir}/system-update.target.wants
448ln -sf ../packagekit-offline-update.service \
01260b07 449 $RPM_BUILD_ROOT%{systemdunitdir}/system-update.target.wants/packagekit-offline-update.service
aa278a7b 450
6808f644
MB
451%find_lang %{name}
452
a2d83637
MB
453%clean
454rm -rf $RPM_BUILD_ROOT
455
fcd0bc5c
MB
456%post
457%update_mime_database
458
459%postun
460%update_mime_database
461
85d27e4f 462%post libs -p /sbin/ldconfig
a2d83637
MB
463%postun libs -p /sbin/ldconfig
464
6808f644 465%files -f %{name}.lang
a2d83637 466%defattr(644,root,root,755)
02b3d2d3 467%doc AUTHORS HACKING MAINTAINERS NEWS README
a2d83637
MB
468%attr(755,root,root) %{_bindir}/pkcon
469%attr(755,root,root) %{_bindir}/pkmon
50832223 470%attr(750,root,root) /etc/cron.daily/packagekit-background.cron
02b3d2d3
JB
471%attr(755,root,root) %{_libexecdir}/packagekit-direct
472%attr(755,root,root) %{_libexecdir}/packagekitd
473%attr(755,root,root) %{_libexecdir}/pk-offline-update
a2d83637 474%dir %{_libdir}/packagekit-backend
aa278a7b 475%attr(755,root,root) %{_libdir}/packagekit-backend/libpk_backend_dummy.so
a2d83637
MB
476%dir %{_sysconfdir}/PackageKit
477%config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/PackageKit/PackageKit.conf
d05d9108 478%config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/PackageKit/Vendor.conf
5baab3aa 479%attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/sysconfig/packagekit-background
d05d9108 480%dir %{_datadir}/PackageKit
6e66a3a4 481%dir %{_datadir}/PackageKit/helpers
d05d9108 482%attr(755,root,root) %{_datadir}/PackageKit/pk-upgrade-distro.sh
f058dba9 483%{_datadir}/polkit-1/actions/org.freedesktop.packagekit.policy
577193a4 484%{_datadir}/polkit-1/rules.d/org.freedesktop.packagekit.rules
a2d83637 485%{_datadir}/dbus-1/system-services/org.freedesktop.PackageKit.service
dd5c7282 486%{_datadir}/dbus-1/system.d/org.freedesktop.PackageKit.conf
e12b9e2b 487%{_datadir}/metainfo/org.freedesktop.packagekit.metainfo.xml
a2d83637 488%{_mandir}/man1/pkcon.1*
78293e06 489%{_mandir}/man1/pkmon.1*
53810c7c 490%{systemdunitdir}/packagekit.service
7cd3cbcf 491%{systemdunitdir}/packagekit-offline-update.service
02b3d2d3 492%{systemdunitdir}/system-update.target.wants/packagekit-offline-update.service
78293e06
MB
493%dir /var/cache/PackageKit
494%dir /var/cache/PackageKit/downloads
a2d83637 495%dir /var/lib/PackageKit
d05d9108 496%ghost /var/lib/PackageKit/transactions.db
a2d83637
MB
497
498%files libs
499%defattr(644,root,root,755)
74872af2 500%attr(755,root,root) %{_libdir}/libpackagekit-glib2.so.*.*.*
02b3d2d3 501%attr(755,root,root) %ghost %{_libdir}/libpackagekit-glib2.so.18
dac2b5e1 502%{_libdir}/girepository-1.0/PackageKitGlib-1.0.typelib
2ab9cd42
JB
503# NOTE: dbus interface xmls are commonly used:
504# - at runtime by packagekitd
505# - for development of applications using PK dbus interface
506%{_datadir}/dbus-1/interfaces/org.freedesktop.PackageKit.Transaction.xml
507%{_datadir}/dbus-1/interfaces/org.freedesktop.PackageKit.xml
08c67dac 508
a2d83637
MB
509%files devel
510%defattr(644,root,root,755)
74872af2 511%attr(755,root,root) %{_libdir}/libpackagekit-glib2.so
74872af2 512%{_pkgconfigdir}/packagekit-glib2.pc
d05d9108 513%dir %{_includedir}/PackageKit
74872af2 514%{_includedir}/PackageKit/packagekit-glib2
dac2b5e1 515%{_datadir}/gir-1.0/PackageKitGlib-1.0.gir
08c67dac 516
0e57d6d1 517%if %{with static_libs}
a2d83637
MB
518%files static
519%defattr(644,root,root,755)
74872af2 520%{_libdir}/libpackagekit-glib2.a
0e57d6d1 521%endif
d05d9108 522
8ad97aee
JB
523%if %{with vala}
524%files -n vala-packagekit
525%defattr(644,root,root,755)
aa278a7b 526%{_datadir}/vala/vapi/packagekit-glib2.deps
8ad97aee
JB
527%{_datadir}/vala/vapi/packagekit-glib2.vapi
528%endif
529
0e57d6d1 530%if %{with apidocs}
16acf8d5
JB
531%files apidocs
532%defattr(644,root,root,755)
533%{_gtkdocdir}/PackageKit
0e57d6d1 534%endif
16acf8d5 535
d06070b1
JB
536%if %{with alpm}
537%files backend-alpm
0d5f415c 538%defattr(644,root,root,755)
d06070b1
JB
539%attr(755,root,root) %{_libdir}/packagekit-backend/libpk_backend_alpm.so
540%dir %{_sysconfdir}/PackageKit/alpm.d
541%config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/PackageKit/alpm.d/groups.list
542%config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/PackageKit/alpm.d/pacman.conf
543%config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/PackageKit/alpm.d/repos.list
574f2e60
JB
544# FIXME: dirs should be owned by alpm?
545%dir %{_datadir}/libalpm
546%dir %{_datadir}/libalpm/hooks
547%{_datadir}/libalpm/hooks/90-packagekit-refresh.hook
0d5f415c
ER
548%endif
549
04e18045
JB
550%if %{with apt}
551%files backend-aptcc
552%defattr(644,root,root,755)
553%attr(755,root,root) %{_libdir}/packagekit-backend/libpk_backend_aptcc.so
554%config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/apt/apt.conf.d/20packagekit
555%dir %{_datadir}/PackageKit/helpers/aptcc
556%attr(755,root,root) %{_datadir}/PackageKit/helpers/aptcc/get-distro-upgrade.py
557%attr(755,root,root) %{_datadir}/PackageKit/helpers/aptcc/pkconffile
558%{_datadir}/PackageKit/helpers/aptcc/pkconffile.nodiff
559%endif
560
49ea0764
JB
561%if %{with dnf}
562%files backend-dnf
563%defattr(644,root,root,755)
564%attr(755,root,root) %{_libdir}/packagekit-backend/libpk_backend_dnf.so
dd5c7282
JB
565%attr(755,root,root) %{_libexecdir}/packagekit-dnf-refresh-repo
566%{py3_sitescriptdir}/dnf-plugins/notify_packagekit.py
567%{py3_sitescriptdir}/dnf-plugins/__pycache__/notify_packagekit.cpython-*.py[co]
49ea0764
JB
568%endif
569
04e18045
JB
570%if %{with entropy}
571%files backend-entropy
572%defattr(644,root,root,755)
573%attr(755,root,root) %{_libdir}/packagekit-backend/libpk_backend_entropy.so
574%dir %{_datadir}/PackageKit/helpers/entropy
575%attr(755,root,root) %{_datadir}/PackageKit/helpers/entropy/entropyBackend.py
576%endif
577
49ea0764
JB
578%if %{with nix}
579%files backend-nix
ee375c30 580%defattr(644,root,root,755)
49ea0764 581%attr(755,root,root) %{_libdir}/packagekit-backend/libpk_backend_nix.so
04e18045
JB
582%endif
583
e12b9e2b
JB
584%if %{with pisi}
585%files backend-pisi
586%defattr(644,root,root,755)
587%attr(755,root,root) %{_libdir}/packagekit-backend/libpk_backend_pisi.so
588%dir %{_datadir}/PackageKit/helpers/pisi
589%attr(755,root,root) %{_datadir}/PackageKit/helpers/pisi/pisiBackend.py
590%endif
591
d06070b1
JB
592%if %{with poldek}
593%files backend-poldek
594%defattr(644,root,root,755)
595%attr(755,root,root) %{_libdir}/packagekit-backend/libpk_backend_poldek.so
596%endif
597
04e18045
JB
598%if %{with portage}
599%files backend-portage
600%defattr(644,root,root,755)
601%attr(755,root,root) %{_libdir}/packagekit-backend/libpk_backend_portage.so
602%dir %{_datadir}/PackageKit/helpers/portage
603%attr(755,root,root) %{_datadir}/PackageKit/helpers/portage/portageBackend.py
604%endif
605
49ea0764
JB
606%if %{with slack}
607%files backend-slack
608%defattr(644,root,root,755)
609%attr(755,root,root) %{_libdir}/packagekit-backend/libpk_backend_slack.so
610%config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/PackageKit/Slackware.conf
611%dir /var/cache/PackageKit/metadata
612%ghost /var/cache/PackageKit/metadata/metadata.db
613%endif
614
04e18045
JB
615%if %{with zypp}
616%files backend-zypp
617%defattr(644,root,root,755)
618%attr(755,root,root) %{_libdir}/packagekit-backend/libpk_backend_zypp.so
619%endif
620
d05d9108
MB
621%files gstreamer-plugin
622%defattr(644,root,root,755)
623%doc contrib/gstreamer-plugin/README
aa278a7b 624%attr(755,root,root) %{_libexecdir}/gst-install-plugins-helper
02b3d2d3 625%attr(755,root,root) %{_libexecdir}/pk-gstreamer-install
d05d9108 626
dac2b5e1
AF
627%files gtk3-module
628%defattr(644,root,root,755)
aa278a7b 629%doc contrib/gtk-module/{GLASS.txt,README}
dac2b5e1 630%attr(755,root,root) %{_libdir}/gtk-3.0/modules/libpk-gtk-module.so
7cd3cbcf 631%{_libdir}/gnome-settings-daemon-3.0/gtk-modules/pk-gtk-module.desktop
dac2b5e1 632
a2d83637
MB
633%files -n bash-completion-packagekit
634%defattr(644,root,root,755)
577193a4 635%{bash_compdir}/pkcon
a2d83637 636
02b3d2d3 637%if %{with python}
dd5c7282 638%files -n python3-packagekit
a2d83637 639%defattr(644,root,root,755)
dd5c7282 640%{py3_sitescriptdir}/packagekit
02b3d2d3 641%endif
This page took 0.162967 seconds and 4 git commands to generate.