]> git.pld-linux.org Git - packages/PPerl.git/blob - PPerl.spec
- drop obsolete and outdated manual inclusion of rpm macros
[packages/PPerl.git] / PPerl.spec
1 #
2 # Conditional build:
3 %bcond_with     tests   # perform "make test" (one test fails)
4 #
5 %include        /usr/lib/rpm/macros.perl
6 Summary:        A persistent Perl interpreter system, designed to speed up Perl scripts
7 Summary(pl.UTF-8):      Trwały system interpretera Perla służący do przyspieszenia skryptów
8 Name:           PPerl
9 Version:        0.25
10 Release:        1
11 # same as perl
12 License:        GPL v1+ or Artistic
13 Group:          Development/Languages/Perl
14 Source0:        http://search.cpan.org/CPAN/authors/id/M/MS/MSERGEANT/%{name}-%{version}.tar.gz
15 # Source0-md5:  32c94d7154494e292241a3d629eed4ea
16 BuildRequires:  gdbm-devel
17 BuildRequires:  perl-devel >= 1:5.8.0
18 BuildRequires:  rpm-perlprov >= 4.1-13
19 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
20
21 %description
22 PPerl provides a persistent environment for Perl scripts. It makes
23 converting a useful old script into a persistent daemon process a
24 breeze.
25
26 Simply change your shebang line to "#!/usr/bin/pperl", rather than
27 "perl", and you'll find your old slow scripts that take ages to start
28 up, running like they were brand spanking new again. Well, that's the
29 plan at least!
30
31 %description -l pl.UTF-8
32 PPerl dostarcza trwałe środowisko dla skryptów perlowych. Znacznie
33 ułatwia zamianę starego, przydatnego skryptu na stale działającego
34 demona.
35
36 Wystarczy zmienić pierwszą linię na "#!/usr/bin/pperl" zamiast "perl",
37 a stare, wolne skrypty, wcześniej potrzebujące wieków na uruchomienie,
38 zaczną działać jakby znowu były nowe. A przynajmniej taki jest plan.
39
40 %prep
41 %setup -q
42
43 %build
44 %{__perl} Makefile.PL \
45         PERL_PATH=%{__perl} \
46         INSTALLDIRS=vendor
47 %{__make} \
48         OPTIMIZE="%{rpmcflags}"
49
50 %{?with_tests:%{__make} test}
51
52 %install
53 rm -rf $RPM_BUILD_ROOT
54 install -d $RPM_BUILD_ROOT%{_examplesdir}
55
56 %{__make} install \
57         DESTDIR=$RPM_BUILD_ROOT
58
59 cp -r examples $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}
60
61 %clean
62 rm -rf $RPM_BUILD_ROOT
63
64 %files
65 %defattr(644,root,root,755)
66 %doc Changes README TODO examples
67 %attr(755,root,root) %{_bindir}/pperl
68 %{perl_vendorarch}/%{name}.pm
69 %dir %{perl_vendorarch}/auto/%{name}
70 %{perl_vendorarch}/auto/%{name}/%{name}.bs
71 %attr(755,root,root) %{perl_vendorarch}/auto/%{name}/%{name}.so
72 %{_mandir}/man1/*
73 %{_mandir}/man3/*
74 %{_examplesdir}/%{name}-%{version}
This page took 0.063192 seconds and 3 git commands to generate.