]> git.pld-linux.org Git - packages/PPerl.git/blob - PPerl.spec
599849e8dea166aa345fc6a527805be19d00a189
[packages/PPerl.git] / PPerl.spec
1 #
2 # Conditional build:
3 %bcond_with     tests   # perform "make test" (one test fails)
4 #
5 %include        /usr/lib/rpm/macros.perl
6 Summary:        A persistent Perl interpreter system, designed to speed up Perl scripts
7 Summary(pl):    Trwa³y system interpretera Perla s³u¿±cy do przyspieszenia skryptów
8 Name:           PPerl
9 Version:        0.24
10 Release:        0.1
11 License:        unknown
12 Group:          Development/Languages/Perl
13 Source0:        http://search.cpan.org/CPAN/authors/id/M/MS/MSERGEANT/%{name}-%{version}.tar.gz
14 # Source0-md5:  ce1407d265e96e8a1185b699386eb14b
15 BuildRequires:  perl-devel >= 1:5.8.0
16 BuildRequires:  rpm-perlprov >= 4.1-13
17 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
18
19 %description
20 PPerl provides a persistent environment for Perl scripts. It makes
21 converting a useful old script into a persistent daemon process a
22 breeze.
23
24 Simply change your shebang line to "#!/usr/bin/pperl", rather than
25 "perl", and you'll find your old slow scripts that take ages to start
26 up, running like they were brand spanking new again. Well, that's the
27 plan at least!
28
29 %description -l pl
30 PPerl dostarcza trwa³e ¶rodowisko dla skryptów perlowych. Znacznie
31 u³atwia zamianê starego, przydatnego skryptu na stale dzia³aj±cego
32 demona.
33
34 Wystarczy zmieniæ pierwsz± liniê na "#!/usr/bin/pperl" zamiast "perl",
35 a stare, wolne skrypty, wcze¶niej potrzebuj±ce wieków na uruchomienie,
36 zaczn± dzia³aæ jakby znowu by³y nowe. A przynajmniej taki jest plan.
37
38 %prep
39 %setup -q
40
41 %build
42 %{__perl} Makefile.PL \
43         INSTALLDIRS=vendor
44 %{__make} \
45         OPTIMIZE="%{rpmcflags}"
46
47 %{?with_tests:%{__make} test}
48
49 %install
50 rm -rf $RPM_BUILD_ROOT
51
52 %{__make} install \
53         DESTDIR=$RPM_BUILD_ROOT
54
55 %clean
56 rm -rf $RPM_BUILD_ROOT
57
58 %files
59 %defattr(644,root,root,755)
60 %doc Changes README TODO examples
61 %attr(755,root,root) %{_bindir}/pperl
62 %{perl_vendorarch}/%{name}.pm
63 %dir %{perl_vendorarch}/auto/%{name}
64 %{perl_vendorarch}/auto/%{name}/%{name}.bs
65 %attr(755,root,root) %{perl_vendorarch}/auto/%{name}/%{name}.so
66 %{_mandir}/man1/*
67 %{_mandir}/man3/*
This page took 0.05532 seconds and 2 git commands to generate.