]> git.pld-linux.org Git - packages/OpenSceneGraph.git/blob - OpenSceneGraph.spec
- added cmake to BR's
[packages/OpenSceneGraph.git] / OpenSceneGraph.spec
1 Summary:        Open Scene Graph - real-time visualization library
2 Summary(pl.UTF-8):      Open Scene Graph - biblioteka do wizualizacji
3 Name:           OpenSceneGraph
4 Version:        2.0
5 Release:        0.1
6 License:        OpenSceneGraph Public Licence (based on LGPL with exceptions)
7 Group:          X11/Libraries
8 Source0:        http://www.openscenegraph.com/downloads/snapshots/%{name}-%{version}.zip
9 # Source0-md5:  9e8d8311868f2acce377a6d7d69c26c2
10 #Source1:       osg-doxygen-0.9.1.tar.gz
11 ## Source1-md5: 7e6d785d1b763aaeae03c2dc4c148805
12 URL:            http://openscenegraph.org/
13 BuildRequires:  cmake
14 BuildRequires:  freetype-devel
15 BuildRequires:  giflib-devel
16 BuildRequires:  libjpeg-devel
17 BuildRequires:  libpng-devel
18 BuildRequires:  libtiff-devel
19 BuildRequires:  zlib-devel
20 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
21
22 %description
23 The Open Scene Graph is a cross-platform C++/OpenGL library for
24 the real-time visualization.
25
26 %description -l pl.UTF-8
27 Open Scene Graph to wieloplatformowa oparta o C++ i OpenGL biblioteka
28 do wizualizacji w czasie rzeczywistym.
29
30 %package devel
31 Summary:        Header files for Open Scene Graph
32 Summary(pl.UTF-8):      Pliki nagłówkowe dla Open Scene Graph
33 Group:          Development/Libraries
34 Requires:       %{name} = %{version}-%{release}
35
36 %description devel
37 Headers file for OSD library.
38
39 %description devel -l pl.UTF-8
40 Pliki nagłówkowe dla biblioteki Open Scene Graph.
41
42 %package examples
43 Summary:        Examples for Open Scene Graph
44 Summary(pl.UTF-8):      Przykłady dla Open Scene Graph
45 Group:          Development/Libraries
46 Requires:       %{name} = %{version}-%{release}
47
48 %description examples
49 Examples for Open Scene Graph Library.
50
51 %description examples -l pl.UTF-8
52 Przykłady dla biblioteki Open Scene Graph.
53
54 %package plugins
55 Summary:        Plugins for Open Scene Graph
56 Summary(pl):    Wtyczki dla biblioteki Open Scene Graph
57 Group:          Libraries
58 Requires:       %{name} = %{version}-%{release}
59
60 %description plugins
61 Plugins for Open Scene Graph library.
62
63 %description plugins -l pl
64 Wtyczki dla biblioteki Open Scene Graph.
65
66 %prep
67 %setup -q -n OpenSceneGraph
68
69 %build
70 mkdir build
71 cd build
72 cmake .. -DCMAKE_BUILD_TYPE=Release -DCMAKE_INSTALL_PREFIX=/usr
73 %{__make}
74
75 %install
76 rm -rf $RPM_BUILD_ROOT
77 install -d $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}
78
79 cp -r examples/osg* $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}
80 cd build
81 %{__make} install \
82     DESTDIR=$RPM_BUILD_ROOT
83
84 %clean
85 rm -rf $RPM_BUILD_ROOT
86
87 %post   -p /sbin/ldconfig
88 %postun -p /sbin/ldconfig
89
90 %files
91 %defattr(644,root,root,755)
92 %attr(755,root,root) %{_libdir}/*.so
93 %attr(755,root,root) %{_libdir}/*.so.*.*.*
94 %{_libdir}/*.so.11
95 %{_libdir}/*.so.7
96
97 %files plugins
98 %defattr(644,root,root,755)
99 %dir %{_libdir}/osgPlugins-2.0.0
100 %attr(755,root,root) %{_libdir}/osgPlugins-2.0.0/*.so
101
102 %files devel
103 %defattr(644,root,root,755)
104 %{_includedir}/osg*
105 %{_includedir}/Open*
106
107 %files examples
108 %defattr(644,root,root,755)
109 %attr(755,root,root) %{_bindir}/*
110 %{_examplesdir}/%{name}-%{version}
This page took 0.075577 seconds and 4 git commands to generate.