]> git.pld-linux.org Git - packages/OpenImageIO.git/commitdiff
It's gcc atomics that causes problems on i486, not tbb. auto/th/OpenImageIO-1.0.7-3
authorJan Rękorajski <baggins@pld-linux.org>
Wed, 11 Jul 2012 22:38:48 +0000 (00:38 +0200)
committerJan Rękorajski <baggins@pld-linux.org>
Wed, 11 Jul 2012 22:38:48 +0000 (00:38 +0200)
Release 3

OpenImageIO.spec
no-gcc-atomics.patch [new file with mode: 0644]

index 492d66189dbe6038b9617b8272604fb30e8aab2d..5445582b1ac4b29817c622c158268935f52283c9 100644 (file)
@@ -2,16 +2,11 @@
 %bcond_without static_libs     # don't build static libraries
 %bcond_without tbb             # Threading Building Blocks
 #
-
-%ifarch i486
-%undefine      with_tbb
-%endif
-
 Summary:       Library for reading and writing images
 Summary(pl.UTF-8):     Biblioteka do odczytu i zapisu obrazów
 Name:          OpenImageIO
 Version:       1.0.7
-Release:       2
+Release:       3
 License:       BSD
 Group:         Libraries
 Source0:       https://github.com/OpenImageIO/oiio/tarball/Release-%{version}#/%{name}-%{version}.tar.gz
@@ -22,6 +17,7 @@ Patch3:               %{name}-system-squish.patch
 Patch4:                %{name}-system-ptex.patch
 Patch5:                %{name}-system-dpx.patch
 Patch6:                %{name}-system-libcineon.patch
+Patch7:                no-gcc-atomics.patch
 URL:           https://sites.google.com/site/openimageio/home
 BuildRequires: Field3D-devel
 BuildRequires: OpenEXR-devel >= 1.6.1
@@ -294,6 +290,9 @@ Wiązanie Pythona do biblioteki OpenImageIO.
 %patch4 -p1
 %patch5 -p1
 %patch6 -p1
+%ifarch i486
+%patch7 -p1
+%endif
 
 %{__rm} -r src/dds.imageio/squish src/ptex.imageio/ptex
 
diff --git a/no-gcc-atomics.patch b/no-gcc-atomics.patch
new file mode 100644 (file)
index 0000000..6f056cb
--- /dev/null
@@ -0,0 +1,15 @@
+--- OpenImageIO-oiio-e9fa4c7/src/include/thread.h~     2012-07-09 08:28:46.000000000 +0200
++++ OpenImageIO-oiio-e9fa4c7/src/include/thread.h      2012-07-12 00:36:54.502654305 +0200
+@@ -102,11 +102,7 @@
+ #  include <libkern/OSAtomic.h>
+ #endif
+-#if defined(__GNUC__) && (defined(_GLIBCXX_ATOMIC_BUILTINS) || (__GNUC__ * 100 + __GNUC_MINOR__ >= 401))
+-#if !defined(__FreeBSD__) || defined(__x86_64__)
+-#define USE_GCC_ATOMICS
+-#endif
+-#endif
++#undef USE_GCC_ATOMICS
+ OIIO_NAMESPACE_ENTER
+ {
This page took 0.253451 seconds and 4 git commands to generate.