]> git.pld-linux.org Git - packages/OpenColorIO.git/blob - OpenColorIO.spec
- updated to 2.3.2 (new soname)
[packages/OpenColorIO.git] / OpenColorIO.spec
1 # TODO (proprietary?):
2 # - truelight http://www.filmlight.ltd.uk/products/truelight/overview_tl.php
3 # - nuke: http://docs.thefoundry.co.uk/products/nuke/
4 #
5 # Conditional build:
6 %bcond_without  oiio    # OpenImageIO-dependent apps (ocioconvert,ociodisplay)
7 %bcond_without  opengl  # OpenGL-dependent app (ociodisplay)
8 %bcond_without  java    # JNI glue
9 %bcond_without  docs    # documentation
10 %bcond_with     sse2    # use SSE2 instructions
11 #
12 %ifarch %{x8664} pentrium4
13 %define with_sse2       1
14 %endif
15 Summary:        Complete color management solution
16 Summary(pl.UTF-8):      Kompletny pakiet do zarządzania kolorami
17 Name:           OpenColorIO
18 Version:        1.1.0
19 Release:        1
20 License:        BSD
21 Group:          Libraries
22 Source0:        https://github.com/imageworks/OpenColorIO/archive/v%{version}/%{name}-%{version}.tar.gz
23 # Source0-md5:  802d8f5b1d1fe316ec5f76511aa611b8
24 Patch0:         %{name}-system-libs.patch
25 Patch1:         %{name}-java.patch
26 Patch2:         %{name}-libsuffix.patch
27 Patch3:         %{name}-missing.patch
28 Patch4:         %{name}-yaml-cpp.patch
29 Patch5:         %{name}-no-Werror.patch
30 Patch6:         %{name}-oiio.patch
31 Patch7:         %{name}-cmake-dir.patch
32 URL:            http://opencolorio.org/
33 BuildRequires:  cmake >= 2.8
34 %{?with_java:BuildRequires:     jdk}
35 BuildRequires:  libstdc++-devel >= 6:4.7
36 BuildRequires:  pkgconfig
37 BuildRequires:  python-devel
38 %if %{with docs}
39 BuildRequires:  sphinx-pdg >= 1.1
40 BuildRequires:  texlive-latex-ams
41 BuildRequires:  texlive-xetex
42 %endif
43 BuildRequires:  tinyxml-devel >= 2.6.1
44 BuildRequires:  yaml-cpp-devel >= 0.3.0
45 %if %{with opengl}
46 BuildRequires:  OpenGL-devel
47 BuildRequires:  OpenGL-glut-devel
48 BuildRequires:  glew-devel >= 1.5.1
49 %endif
50 %if %{with oiio}
51 BuildRequires:  OpenImageIO-devel
52 BuildRequires:  lcms2-devel >= 2.1
53 %endif
54 Requires:       tinyxml >= 2.6.1
55 Requires:       yaml-cpp >= 0.3.0
56 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
57
58 %description
59 OpenColorIO (OCIO) is a complete color management solution geared
60 towards motion picture production with an emphasis on visual effects
61 and computer animation. OCIO provides a straightforward and consistent
62 user experience across all supporting applications while allowing for
63 sophisticated back-end configuration options suitable for high-end
64 production usage. OCIO is compatible with the Academy Color Encoding
65 Specification (ACES) and is LUT-format agnostic, supporting many
66 popular formats.
67
68 %description -l pl.UTF-8
69 OpenColorIO (OCIO) to kompletne rozwiązanie zarządzania kolorami
70 przeznaczone do tworzenia obrazów ruchomych, w szczególności efektów
71 wizualnych i animacji komputerowej. OCIO zapewnia proste i spójne
72 elementy we wszystkich współpracujących aplikacjach, pozwalając na
73 wyszukane opcje konfiguracyjne backendu, nadające się do zastosowań
74 produkcyjnych wysokiej jakości. OCIO jest zgodne ze specyfikacją ACES
75 (Academy Color Encoding Specification) i jest niezależne od formatu
76 LUT dzięki obsłudze wielu popularnych formatów.
77
78 %package convert
79 Summary:        OpenColorIO convert tool
80 Summary(pl.UTF-8):      Narzędzie OpenColorIO do konwersji
81 Group:          Applications/Graphics
82 Requires:       %{name} = %{version}-%{release}
83 Requires:       lcms2 >= 2.1
84
85 %description convert
86 OpenColorIO convert tool.
87
88 %description convert -l pl.UTF-8
89 Narzędzie OpenColorIO do konwersji.
90
91 %package display
92 Summary:        OpenColorIO viewer based on OpenGL
93 Summary(pl.UTF-8):      Przeglądarka OpenColorIO oparta na OpenGL-u
94 Group:          X11/Applications/Graphics
95 Requires:       %{name} = %{version}-%{release}
96
97 %description display
98 OpenColorIO viewer based on OpenGL.
99
100 %description display -l pl.UTF-8
101 Przeglądarka OpenColorIO oparta na OpenGL-u.
102
103 %package devel
104 Summary:        Header files for OpenColorIO library
105 Summary(pl.UTF-8):      Pliki nagłówkowe biblioteki OpenColorIO
106 Group:          Development/Libraries
107 Requires:       %{name} = %{version}-%{release}
108 Requires:       libstdc++-devel
109
110 %description devel
111 Header files for OpenColorIO library.
112
113 %description devel -l pl.UTF-8
114 Pliki nagłówkowe biblioteki OpenColorIO.
115
116 %package static
117 Summary:        Static OpenColorIO library
118 Summary(pl.UTF-8):      Statyczna biblioteka OpenColorIO
119 Group:          Development/Libraries
120 Requires:       %{name}-devel = %{version}-%{release}
121
122 %description static
123 Static OpenColorIO library.
124
125 %description static -l pl.UTF-8
126 Statyczna biblioteka OpenColorIO.
127
128 %package -n java-OpenColorIO
129 Summary:        Java binding for OpenColorIO library
130 Summary(pl.UTF-8):      Wiązanie Javy do biblioteki OpenColorIO
131 Group:          Libraries/Java
132 Requires:       %{name} = %{version}-%{release}
133
134 %description -n java-OpenColorIO
135 Java binding for OpenColorIO library.
136
137 %description -n java-OpenColorIO -l pl.UTF-8
138 Wiązanie Javy do biblioteki OpenColorIO.
139
140 %package -n python-OpenColorIO
141 Summary:        Python binding for OpenColorIO library
142 Summary(pl.UTF-8):      Wiązanie Pythona do biblioteki OpenColorIO
143 Group:          Libraries/Python
144 Requires:       %{name} = %{version}-%{release}
145
146 %description -n python-OpenColorIO
147 Python binding for OpenColorIO library.
148
149 %description -n python-OpenColorIO -l pl.UTF-8
150 Wiązanie Pythona do biblioteki OpenColorIO.
151
152 %package -n python-OpenColorIO-devel
153 Summary:        Header file for PyOpenColorIO API
154 Summary(pl.UTF-8):      Plik nagłówkowy API PyOpenColorIO
155 Group:          Development/Libraries
156 Requires:       %{name}-devel = %{version}-%{release}
157 Requires:       python-OpenColorIO = %{version}-%{release}
158
159 %description -n python-OpenColorIO-devel
160 Header file for PyOpenColorIO API.
161
162 %description -n python-OpenColorIO-devel -l pl.UTF-8
163 Plik nagłówkowy API PyOpenColorIO.
164
165 %prep
166 %setup -q
167 %patch0 -p1
168 %patch1 -p1
169 %patch2 -p1
170 %patch3 -p1
171 %patch4 -p1
172 %patch5 -p1
173 %patch6 -p1
174 %patch7 -p1
175
176 %build
177 # required for cmake to find JNI headers/libs when lib64 is in use
178 %{?with_java:export JAVA_HOME=%{_jvmlibdir}/java}
179
180 install -d build
181 cd build
182 # yaml-cpp 0.6.x requires C++11
183 CXXFLAGS="%{rpmcxxflags} -std=c++11"
184 %cmake .. \
185         %{!?with_oiio:-DDISABLE_OIIO=ON} \
186         -DOCIO_BUILD_DOCS=ON \
187 %if %{with java}
188         -DOCIO_BUILD_JNIGLUE=ON \
189         -DOCIO_STATIC_JNIGLUE=OFF \
190 %endif
191         %{!?with_sse2:-DOCIO_USE_SSE=OFF} \
192         -DUSE_EXTERNAL_LCMS=ON \
193         -DUSE_EXTERNAL_TINYXML=ON \
194         -DUSE_EXTERNAL_YAML=ON
195
196 %{__make}
197
198 %install
199 rm -rf $RPM_BUILD_ROOT
200
201 %{__make} -C build install \
202         DESTDIR=$RPM_BUILD_ROOT
203
204 # not needed when installing to /usr
205 %{__rm} $RPM_BUILD_ROOT%{_datadir}/ocio/setup_ocio.sh
206 # packaged as %doc
207 %{__rm} -r $RPM_BUILD_ROOT%{_docdir}/OpenColorIO
208
209 %clean
210 rm -rf $RPM_BUILD_ROOT
211
212 %post   -p /sbin/ldconfig
213 %postun -p /sbin/ldconfig
214
215 %post   -n java-OpenColorIO -p /sbin/ldconfig
216 %postun -n java-OpenColorIO -p /sbin/ldconfig
217
218 %post   -n python-OpenColorIO -p /sbin/ldconfig
219 %postun -n python-OpenColorIO -p /sbin/ldconfig
220
221 %files
222 %defattr(644,root,root,755)
223 %doc ChangeLog LICENSE README.md
224 %attr(755,root,root) %{_bindir}/ociobakelut
225 %attr(755,root,root) %{_bindir}/ociocheck
226 %attr(755,root,root) %{_libdir}/libOpenColorIO.so.*.*.*
227 %attr(755,root,root) %ghost %{_libdir}/libOpenColorIO.so.1
228
229 %if %{with oiio}
230 %files convert
231 %defattr(644,root,root,755)
232 %attr(755,root,root) %{_bindir}/ocioconvert
233 %attr(755,root,root) %{_bindir}/ociolutimage
234 %endif
235
236 %if %{with oiio} && %{with opengl}
237 %files display
238 %defattr(644,root,root,755)
239 %attr(755,root,root) %{_bindir}/ociodisplay
240 %endif
241
242 %files devel
243 %defattr(644,root,root,755)
244 %doc build/docs/build-html/*
245 %attr(755,root,root) %{_libdir}/libOpenColorIO.so
246 %{_includedir}/OpenColorIO
247 %{_pkgconfigdir}/OpenColorIO.pc
248 %{_libdir}/cmake/OpenColorIO
249
250 %files static
251 %defattr(644,root,root,755)
252 %{_libdir}/libOpenColorIO.a
253
254 %if %{with java}
255 %files -n java-OpenColorIO
256 %defattr(644,root,root,755)
257 %attr(755,root,root) %{_libdir}/libOpenColorIO-JNI.so.*.*.*
258 %attr(755,root,root) %ghost %{_libdir}/libOpenColorIO-JNI.so.1
259 %attr(755,root,root) %{_libdir}/libOpenColorIO-JNI.so
260 %dir %{_datadir}/ocio
261 %{_datadir}/ocio/OpenColorIO-%{version}.jar
262 %endif
263
264 %files -n python-OpenColorIO
265 %defattr(644,root,root,755)
266 %attr(755,root,root) %{py_sitedir}/PyOpenColorIO.so
267
268 %files -n python-OpenColorIO-devel
269 %defattr(644,root,root,755)
270 %{_includedir}/PyOpenColorIO
This page took 0.099826 seconds and 3 git commands to generate.