]> git.pld-linux.org Git - packages/OpenCASCADE.git/commitdiff
- rel 43; fix tcl/tk 8.6 build auto/th/OpenCASCADE-6.3.0-43
authorArkadiusz Miśkiewicz <arekm@maven.pl>
Tue, 3 Jun 2014 13:57:54 +0000 (15:57 +0200)
committerArkadiusz Miśkiewicz <arekm@maven.pl>
Tue, 3 Jun 2014 13:57:54 +0000 (15:57 +0200)
OpenCASCADE-build.patch [new file with mode: 0644]
OpenCASCADE.spec

diff --git a/OpenCASCADE-build.patch b/OpenCASCADE-build.patch
new file mode 100644 (file)
index 0000000..e4310b9
--- /dev/null
@@ -0,0 +1,65 @@
+--- OpenCASCADE6.3.0/ros/configure.in~ 2014-06-03 13:19:52.000000000 +0200
++++ OpenCASCADE6.3.0/ros/configure.in  2014-06-03 13:23:59.627135512 +0200
+@@ -24,7 +24,6 @@
+ AM_PROG_LIBTOOL
+ AC_PROG_CXX
+ AC_PROG_CC_C_O
+-AM_C_PROTOTYPES
+ AC_PROG_AWK
+ AC_PROG_INSTALL
+--- OpenCASCADE6.3.0/ros/src/OpenGl/OpenGl_degmodel.c~ 2001-09-21 09:57:40.000000000 +0200
++++ OpenCASCADE6.3.0/ros/src/OpenGl/OpenGl_degmodel.c  2014-06-03 14:17:23.552574867 +0200
+@@ -101,7 +101,7 @@
+  }  /* end switch */
+- fprintf ( stdout, ptr );
++ fprintf ( stdout, "%s", ptr );
+  return TSuccess;
+--- OpenCASCADE6.3.0/ros/src/IFSelect/IFSelect_SessionPilot.cxx~       2007-09-14 15:28:20.000000000 +0200
++++ OpenCASCADE6.3.0/ros/src/IFSelect/IFSelect_SessionPilot.cxx        2014-06-03 14:27:40.856874774 +0200
+@@ -222,7 +222,7 @@
+   for (;;) {
+     char ligne[100];
+-    if (!lefic) printf (theprompt.ToCString());
++    if (!lefic) printf ("%s", theprompt.ToCString());
+     ligne[0] = '\0';
+     fgets(ligne,100,fic);
+     if (feof(fic)) break;
+--- OpenCASCADE6.3.0/ros/src/BOPTest/BOPTest_LowCommands.cxx~  2008-08-15 15:57:31.000000000 +0200
++++ OpenCASCADE6.3.0/ros/src/BOPTest/BOPTest_LowCommands.cxx   2014-06-03 14:43:20.658784793 +0200
+@@ -716,24 +716,24 @@
+   //
+   switch (aState) {
+   case TopAbs_IN:             
+-    sprintf(sbf, sIN.ToCString());
++    sprintf(sbf, "%s", sIN.ToCString());
+     break;
+   case TopAbs_OUT:            
+-    sprintf(sbf, sOUT.ToCString());
++    sprintf(sbf, "%s", sOUT.ToCString());
+     break;
+   case TopAbs_ON:             
+-    sprintf(sbf, sON.ToCString());
++    sprintf(sbf, "%s", sON.ToCString());
+     break;
+   case TopAbs_UNKNOWN:                
+-    sprintf(sbf, sUNKNOWN.ToCString());
++    sprintf(sbf, "%s", sUNKNOWN.ToCString());
+     break;
+   default:
+-    sprintf(sbf, sUNKNOWN.ToCString()); 
++    sprintf(sbf, "%s", sUNKNOWN.ToCString()); 
+     break;
+   }
+   aDI<<sbf; 
+       //
+-  sprintf(sbf, " shape\n");
++  sprintf(sbf, "%s", " shape\n");
+   aDI<<sbf;
+   
+ }
index d2c0414d4804ff29d48cfb7d852ee4e36d951c6b..29dea8610fc80434d09519944ebb5347d0186602 100644 (file)
@@ -26,7 +26,7 @@ Summary:      OpenCASCADE CAE platform
 Name:          OpenCASCADE
 # The 6.3.1 is a maintenance release, only available for OCC customers
 Version:       6.3.0
-Release:       42
+Release:       43
 License:       LGPL-like, see http://www.opencascade.org/occ/license/
 Group:         Applications/Engineering
 Source0:       http://files.opencascade.com/OCC_6.3_release/%{name}_src.tgz
@@ -49,13 +49,14 @@ Patch14:    %{name}6.3.0-wok-install.patch
 Patch15:       %{name}6.3.0-udlist.patch
 Patch16:       %{name}6.3.0-WOKUnix_FDescr.patch
 Patch17:       fix-tklcaf.patch
+Patch18:       %{name}-build.patch
 URL:           http://www.opencascade.org/
 BuildRequires: autoconf
 BuildRequires: automake
 BuildRequires: bison
 BuildRequires: flex
 %ifnarch i486
-BuildRequires: java-sun-jdk-base
+BuildRequires: jdk
 %endif
 BuildRequires: libstdc++-devel
 BuildRequires: libtool
@@ -121,6 +122,7 @@ OpenCASCADE samples.
 %patch15 -p1
 %patch16 -p1
 %patch17 -p1
+%patch18 -p1
 cd ros/src/ExprIntrp
 bison -d -p ExprIntrp -o ExprIntrp.tab.c ExprIntrp.yacc
 flex -L -8 -Cf -Cr -P ExprIntrp -o lex.ExprIntrp.c ExprIntrp.lex
@@ -136,11 +138,11 @@ cd ros
 %{__automake}
 
 %ifarch x86_64 ppc64
-export CFLAGS="%{rpmcflags} -D_OCC64 -fno-strict-aliasing"
-export CXXFLAGS="%{rpmcflags} -D_OCC64 -fno-strict-aliasing"
+export CFLAGS="%{rpmcflags} -D_OCC64 -fno-strict-aliasing -DUSE_INTERP_RESULT"
+export CXXFLAGS="%{rpmcflags} -D_OCC64 -fno-strict-aliasing -DUSE_INTERP_RESULT"
 %else
-export CFLAGS="%{rpmcflags} -fno-strict-aliasing"
-export CXXFLAGS="%{rpmcflags} -fno-strict-aliasing"
+export CFLAGS="%{rpmcflags} -fno-strict-aliasing -DUSE_INTERP_RESULT"
+export CXXFLAGS="%{rpmcflags} -fno-strict-aliasing -DUSE_INTERP_RESULT"
 %endif
 LDFLAGS=-lpthread %configure \
        %{?debug:--disable-production  --enable-debug} \
This page took 0.138563 seconds and 4 git commands to generate.