]> git.pld-linux.org Git - packages/OpenAL.git/commitdiff
- outdated
authorkosmo <kosmo@pld-linux.org>
Fri, 16 Apr 2004 18:44:53 +0000 (18:44 +0000)
committercvs2git <feedback@pld-linux.org>
Sun, 24 Jun 2012 12:13:13 +0000 (12:13 +0000)
Changed files:
    OpenAL-acfix.patch -> 1.3
    OpenAL-alsa_1_0.patch -> 1.2

OpenAL-acfix.patch [deleted file]
OpenAL-alsa_1_0.patch [deleted file]

diff --git a/OpenAL-acfix.patch b/OpenAL-acfix.patch
deleted file mode 100644 (file)
index 780e752..0000000
+++ /dev/null
@@ -1,62 +0,0 @@
---- openal/linux/configure.in.orig     Mon Jan 13 23:28:25 2003
-+++ openal/linux/configure.in  Tue Feb 18 21:24:56 2003
-@@ -85,23 +85,7 @@
- enable_paranoid_locks=no
- enable_empty_locks=no
--CFLAGS="-O6 -fexpensive-optimizations -funroll-all-loops -funroll-loops -fomit-frame-pointer -finline-functions -ffast-math $CFLAGS"
--
--dnl add -march
--case "$target" in 
--    *i386*)
--    CFLAGS="$CFLAGS -march=i386" ;;
--    *i486*)
--    CFLAGS="$CFLAGS -march=i486" ;;
--    *i586*)
--    CFLAGS="$CFLAGS -march=i586" ;;
--    *i686*)
--    CFLAGS="$CFLAGS -march=i686" ;;
--    mips*)
--    CFLAGS="$CFLAGS -march=mips" ;;
--    *)
--    echo "Unknown target $target" ;;
--esac
-+CFLAGS="-fexpensive-optimizations -funroll-all-loops -funroll-loops -fomit-frame-pointer -finline-functions -ffast-math $CFLAGS"
- fi
-@@ -270,7 +254,7 @@
- [  --enable-dmalloc          enable DMALLOC support       [default=no]],
-               , enable_dmalloc=no)
- if test x$enable_dmalloc = xyes; then
--    AC_CHECK_HEADER(dmalloc.h, 
-+    AC_CHECK_HEADER(dmalloc.h,[
-       dnl header found
-       AC_DEFINE(DMALLOC, 1, [undocumented])
-       AC_DEFINE(DMALLOC_FUNC_CHECK, 1, [undocumented])
-@@ -280,14 +264,14 @@
-       REDUNDANT_DECLS_WARN=no,
-       dnl header not found, check local/include
-       dnl invalid cache
--      [AC_CHECK_HEADER(/usr/local/include/dmalloc.h,
-+      AC_CHECK_HEADER(/usr/local/include/dmalloc.h,[
-               dnl header found in local/include
-               AC_DEFINE(DMALLOC, 1, [undocumented])
-               AC_DEFINE(DMALLOC_FUNC_CHECK, 1, [undocumented])
-               INCLUDES="$CFLAGS -include \"/usr/local/include/dmalloc.h\""
-               LIBS="$LIBS -ldmallocth"
-               SHOULD_USE_WERROR=no
--              REDUNDANT_DECLS_WARN=no)])
-+              REDUNDANT_DECLS_WARN=no])])
- fi
- dnl efence stuff
-@@ -685,7 +669,7 @@
- if test x$enable_vorbis = xyes; then
-       AC_CHECK_LIB(vorbisfile, ov_info,
--              AC_DEFINE( VORBIS_SUPPORT, 1, [undocumented] )
-+              AC_DEFINE([VORBIS_SUPPORT], 1, [undocumented] )
-               LIBS="$LIBS -lvorbis -lvorbisfile",, -lvorbis )
- fi #   enable_vorbis = no
diff --git a/OpenAL-alsa_1_0.patch b/OpenAL-alsa_1_0.patch
deleted file mode 100644 (file)
index 5199c11..0000000
+++ /dev/null
@@ -1,48 +0,0 @@
-diff -durN -x '*~' openal.orig/linux/src/arch/alsa/alsa.c openal/linux/src/arch/alsa/alsa.c
---- openal.orig/linux/src/arch/alsa/alsa.c     2003-06-20 19:23:06.000000000 +0000
-+++ openal/linux/src/arch/alsa/alsa.c  2004-12-29 10:56:25.000000000 +0000
-@@ -157,6 +157,7 @@
-       struct alsa_info *ai = handle;
-       snd_pcm_hw_params_t *setup;
-       snd_pcm_t *phandle = 0;
-+      snd_pcm_uframes_t ufr;
-       int err, dir;
-       if( (ai == NULL) || (ai->handle == NULL) )
-@@ -215,8 +216,9 @@
-       err = snd_pcm_hw_params_set_channels(phandle, setup, ai->channels);
-       if(err < 0)
-       {
--              err = snd_pcm_hw_params_get_channels(setup);
--              if(err!= (int) (ai->channels)) {
-+              unsigned int val;
-+              err = snd_pcm_hw_params_get_channels(setup,&val);
-+              if(err || val != (int) (ai->channels)) {
-                       _alDebug(ALD_MAXIMUS, __FILE__, __LINE__,
-                                "set_write_alsa: could not set channels: %s",snd_strerror(err));
-@@ -226,7 +228,7 @@
-       /* sampling rate */
--      err = snd_pcm_hw_params_set_rate_near(phandle, setup, ai->speed, NULL);
-+      err = snd_pcm_hw_params_set_rate_near(phandle, setup, &ai->speed, NULL);
-       if(err < 0)
-       {
-               _alDebug(ALD_MAXIMUS, __FILE__, __LINE__,
-@@ -253,11 +255,13 @@
-               return AL_FALSE;
-         }
-+      err=snd_pcm_hw_params_get_buffer_size(setup,&ufr);
-         _alDebug(ALD_MAXIMUS, __FILE__, __LINE__,
--         "set_write_alsa (info): Buffersize = %i (%i)",snd_pcm_hw_params_get_buffer_size(setup), *bufsiz);
-+         "set_write_alsa (info): Buffersize = %i (%i)",ufr, *bufsiz);
-+      err=snd_pcm_hw_params_get_period_size(setup,&ufr,&dir);
-         _alDebug(ALD_MAXIMUS, __FILE__, __LINE__,
--         "set_write_alsa (info): Periodsize = %i",snd_pcm_hw_params_get_period_size(setup, &dir));
-+         "set_write_alsa (info): Periodsize = %i",ufr);
-       err = snd_pcm_hw_params(phandle, setup);
-       if(err < 0)
This page took 0.180918 seconds and 4 git commands to generate.