]> git.pld-linux.org Git - packages/OpenAL.git/blobdiff - OpenAL.spec
- cleanups, rel 1
[packages/OpenAL.git] / OpenAL.spec
index dab6838954295db240e1de671b7465dc364f078d..5b05f2378902cbb270e52ed4bd7aabc0fcac0bc7 100644 (file)
@@ -1,30 +1,40 @@
-Summary:       OpenAL - Open Audio Library
-Summary(pl):   OpenAL - Otwarta Biblioteka D¼wiêku
+#
+# TODO:
+# - Build stops at:
+# arch/i386/x86_floatmul.c:86:74: warning: use of C99 long long integer constant
+# arch/i386/x86_floatmul.c:89:74: warning: use of C99 long long integer constant
+# arch/i386/x86_floatmul.c: In function `_alFloatMul':
+#arch/i386/x86_floatmul.c:86: internal compiler error: in ix86_expand_binop_builtin, at config/i386/i386.c:13246
+# Please submit a full bug report,
+#
+# - autoconf provides undefined macro....
+
+# Conditional build:
+#
+%bcond_without alsa    # without ALSA support
+%bcond_with    arts    # with aRts support
+%bcond_without esd     # without esd support
+%bcond_with    mmx     # use MMX (makes sense on i[56]86 with MMX; won't run on non-MMX CPU)
+
+Summary:       Open Audio Library
+Summary(pl):   Otwarta Biblioteka D¼wiêku
 Name:          OpenAL
-Version:       0.0.6
-Release:       2
+Version:       0.0.8
+Release:       1
 License:       LGPL
-Group:         X11/Libraries
-Group(de):     X11/Libraries
-Group(es):     X11/Bibliotecas
-Group(fr):     X11/Librairies
-Group(pl):     X11/Biblioteki
-Group(pt_BR):  X11/Bibliotecas
-Group(ru):     X11/âÉÂÌÉÏÔÅËÉ
-Group(uk):     X11/â¦Â̦ÏÔÅËÉ
-Vendor:                Loki Entertainment Software - http://www.lokigames.com/
-Source0:       ftp://ftp.openal.com/nie-wiem-co-tu-daæ.tar.bz2/%{name}-20011116.tar.bz2
-Source1:       ftp://ftp.openal.com/nie-wiem-co-tu-daæ.tar.bz2/%{name}-headers-20011116.tar.bz2
-Patch0:                %{name}-stdio.patch
-Patch1:                %{name}-include_unconsequency.patch
-Patch2:                %{name}-symlinks.patch
-URL:           http://www.openal.com/
+Group:         Libraries
+Source0:       http://www.openal.org/openal_webstf/downloads/openal-%{version}.tar.gz
+# Source0-md5: 641cf53761f35ee979f3e888614797a0
+URL:           http://www.openal.org/
+BuildRequires: SDL-devel
+%{?with_alsa:BuildRequires:    alsa-lib-devel}
+%{?with_arts:BuildRequires:    artsc-devel}
+%{?with_esd:BuildRequires:     esound-devel}
+BuildRequires: libvorbis-devel
+%{?with_mmx:BuildRequires:     nasm}
+BuildRequires: smpeg-devel
 BuildRoot:     %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
 
-%define        _noautoreqdep   libGL.so.1 libGLU.so.1
-%define                _prefix         /usr/X11R6
-%define                _mandir         %{_prefix}/man
-
 %description
 OpenAL, the Open Audio Library, is a joint effort to create an open,
 vendor-neutral, cross-platform API for interactive, primarily
@@ -34,79 +44,63 @@ OpenGL, for games and other multimedia applications. OpenAL is already
 supported by a number of hardware vendors and developers.
 
 %description -l pl
-OpenAL, otwarta bibliotela d¼wiêku, to po³±czony wysi³ek w celu
-stworzenia otwartego, niezale¿nego od producentów, miedzyplatformowego
+OpenAL, otwarta biblioteka d¼wiêku, to po³±czony wysi³ek w celu
+stworzenia otwartego, niezale¿nego od producentów, miêdzyplatformowego
 interfejsu projektowania aplikacji w czê¶ci obs³ugi d¼wiêku.
-Biblioteka adersowana jest do twórców aplikacji i urzytkowników,
+Biblioteka adresowana jest do twórców aplikacji i u¿ytkowników,
 którzy wybieraj± przeno¶ne standardy, jak OpenGL, w grach i
 aplikacjach multimedialnych. OpenAL posiada ju¿ wsparcie wielu
 dostarczycieli sprzêtu i programistów.
 
-
 %package devel
-Summary:       OpenAL development files
-Summary(pl):   Pakiet dla Programistów OpenAL
-Group:         Development/Building
-Group(de):     Entwicklung/Bauen
-Group(pl):     Programowanie/Budowanie
-Requires:      %{name} = %{version}
+Summary:       Headers for OpenAL
+Summary(pl):   Pliki nag³ówkowe do OpenAL
+Group:         Development/Libraries
+Requires:      %{name} = %{version}-%{release}
 
 %description devel
-OpenAL header files.
+Header files for OpenAL-based programs.
 
 %description devel -l pl
-Pliki nag³ówkowe biblioteki OpenAL.
-
+Pliki nag³ówkowe potrzebne przy budowaniu programów opartych na
+OpenAL.
 
 %package static
 Summary:       OpenAL static library
 Summary(pl):   Statyczna biblioteka OpenAL
-Group:         Development/Building
-Group(de):     Entwicklung/Bauen
-Group(pl):     Programowanie/Budowanie
-Requires:      %{name} = %{version}
+Group:         Development/Libraries
+Requires:      %{name}-devel = %{version}-%{release}
 
 %description static
 OpenAL static library.
 
 %description static -l pl
-Biblioteka OpenAL do statycznego linkowania.
-
+Biblioteka OpenAL do konsolidacji statycznej.
 
 %prep
-%setup -q -n %{name} -a 1
-cp -f AL/*.h include/AL/
-%patch0 -p1
-%patch1 -p1
-%patch2 -p1
+%setup -q -n openal-%{version}
 
 %build
-CFLAGS="%{rpmcflags} -I%{_includedir} \
-       -fexpensive-optimizations       -funroll-all-loops \
-       -funroll-loops                  -fomit-frame-pointer \
-       -finline-functions              -ffast-math "
-export CFLAGS
-
-LDFLAGS="-L%{_libdir}" ; export LDFLAGS
-
-sh ./autogen.sh
-
-./configure --enable-prefix=%{_prefix} \
-           --enable-optimization       --enable-alsa           --enable-sdl \
-           --enable-vorbis             --enable-smpeg          --enable-capture \
-           --with-gcc=%{__cc}
+%configure \
+       %{?with_alsa:--enable-alsa --enable-alsa-dlopen} \
+       %{?with_arts:--enable-arts --enable-arts-dlopen} \
+       %{?with_esd:--enable-esd --enable-esd-dlopen} \
+       --enable-sdl --enable-sdl-dlopen \
+       --enable-capture \
+       --enable-linux \
+       --enable-null \
+       --enable-waveout \
+       --enable-vorbis --enable-vorbis-dlopen \
+       --enable-mp3 --enable-mp3-dlopen \
+       --with-gcc=%{__cc}
 
 %{__make}
 
 %install
 rm -rf $RPM_BUILD_ROOT
-%{__make} -e DESTDIR=$RPM_BUILD_ROOT/%{_prefix}/  install
-
-gzip -9nf TODO NOTES ChangeLog CREDITS COPYING
 
-cd $RPM_BUILD_ROOT/%{_libdir}
-ln -sf libopenal.so.0.0.6 libopenal.so.0
-ln -sf libopenal.so.0.0.6 libopenal.so
+%{__make} install \
+       DESTDIR=$RPM_BUILD_ROOT
 
 %clean
 rm -rf $RPM_BUILD_ROOT
@@ -115,14 +109,18 @@ rm -rf $RPM_BUILD_ROOT
 %postun        -p /sbin/ldconfig
 
 %files
-%defattr(-,root,root,755)
-%doc TODO.gz ChangeLog.gz NOTES.gz CREDITS.gz COPYING.gz
-%{_libdir}/*so*
+%defattr(644,root,root,755)
+%doc ChangeLog NOTES TODO
+%attr(755,root,root) %{_libdir}/lib*.so.*.*.*
 
 %files devel
 %defattr(644,root,root,755)
-%{_includedir}/AL/*
+%attr(755,root,root) %{_bindir}/*-config
+%attr(755,root,root) %{_libdir}/lib*.so
+%{_libdir}/*.la
+%{_pkgconfigdir}/*
+%{_includedir}/AL
 
 %files static
-%defattr(-,root,root,755)
+%defattr(644,root,root,755)
 %{_libdir}/*.a
This page took 0.047222 seconds and 4 git commands to generate.