]> git.pld-linux.org Git - packages/OpenAL.git/blobdiff - OpenAL.spec
- kill needless BR zip
[packages/OpenAL.git] / OpenAL.spec
index 4f145590df241784ce829769404abe655e8fe5b3..4870a894d50f2f5d1e693b0c116a1e60e043b9ed 100644 (file)
@@ -1,38 +1,38 @@
 #
 # Conditional build:
-# _without_alsa                - without ALSA support
-# _without_doc         - don't build HTML documentation (from SGML source)
-# _with_mmx            - use MMX (won't run on non-MMX CPU)
-#
-%ifarch athlon
-%define                _with_mmx       1
-%endif
-%ifnarch i586 i686 athlon
-%define                _with_mmx       0
-%endif
+%bcond_without alsa    # without ALSA support
+%bcond_with    arts    # with aRts support
+%bcond_without doc     # don't build HTML documentation (from SGML source)
+%bcond_without esd     # without esd support
+%bcond_with    mmx     # use MMX (makes sense on i[56]86 with MMX; won't run on non-MMX CPU)
+
+%define        _branch Linux_Spec1-0
+
 Summary:       Open Audio Library
 Summary(pl):   Otwarta Biblioteka D¼wiêku
 Name:          OpenAL
-Version:       0.0.6
-%define        snap    20030218
-Release:       1.%{snap}.1
+Version:       0.0.8
+%define        snap    20051015
+Release:       0.%{snap}.1
 License:       LGPL
 Group:         Libraries
 # from CVS :pserver:guest@opensource.creative.com:/usr/local/cvs-repository /openal
 # (without all Win and Mac stuff and demos)
-Source0:       %{name}-linuxonly-%{snap}.tar.bz2
+Source0:       %{name}-%{_branch}-%{snap}.tar.bz2
+# Source0-md5: 013a571cf588bec1d3a5628b5ed527ea
 Patch0:                %{name}-prefix.patch
-Patch1:                %{name}-acfix.patch
-Patch2:                %{name}-info.patch
-URL:           http://www.openal.com/
+Patch1:                %{name}-info.patch
+URL:           http://www.openal.org/
 BuildRequires: SDL-devel
-%{!?_without_alsa:BuildRequires:       alsa-lib-devel}
+%{?with_alsa:BuildRequires:    alsa-lib-devel}
+%{?with_arts:BuildRequires:    artsc-devel}
 BuildRequires: autoconf
 BuildRequires: automake
-%{!?_without_doc:BuildRequires:        docbook-utils}
-%{!?_without_doc:BuildRequires:        gnome-doc-tools}
+%{?with_doc:BuildRequires:     docbook-utils}
+%{?with_esd:BuildRequires:     esound-devel}
+%{?with_doc:BuildRequires:     gnome-doc-tools}
 BuildRequires: libvorbis-devel
-%{?_with_mmx:BuildRequires:    nasm}
+%{?with_mmx:BuildRequires:     nasm}
 BuildRequires: smpeg-devel
 BuildRequires: texinfo
 BuildRoot:     %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
@@ -47,7 +47,7 @@ supported by a number of hardware vendors and developers.
 
 %description -l pl
 OpenAL, otwarta biblioteka d¼wiêku, to po³±czony wysi³ek w celu
-stworzenia otwartego, niezale¿nego od producentów, miedzyplatformowego
+stworzenia otwartego, niezale¿nego od producentów, miêdzyplatformowego
 interfejsu projektowania aplikacji w czê¶ci obs³ugi d¼wiêku.
 Biblioteka adresowana jest do twórców aplikacji i u¿ytkowników,
 którzy wybieraj± przeno¶ne standardy, jak OpenGL, w grach i
@@ -58,7 +58,7 @@ dostarczycieli sprz
 Summary:       Headers for OpenAL
 Summary(pl):   Pliki nag³ówkowe do OpenAL
 Group:         Development/Libraries
-Requires:      %{name} = %{version}
+Requires:      %{name} = %{version}-%{release}
 
 %description devel
 Header files for OpenAL-based programs.
@@ -71,51 +71,51 @@ OpenAL.
 Summary:       OpenAL static library
 Summary(pl):   Statyczna biblioteka OpenAL
 Group:         Development/Libraries
-Requires:      %{name}-devel = %{version}
+Requires:      %{name}-devel = %{version}-%{release}
 
 %description static
 OpenAL static library.
 
 %description static -l pl
-Biblioteka OpenAL do statycznego linkowania.
+Biblioteka OpenAL do konsolidacji statycznej.
 
 %prep
-%setup -q -n openal
+%setup -q -n %{name}-%{_branch}-%{snap}
 %patch0 -p1
 %patch1 -p1
-%patch2 -p1
 
-echo 'AC_DEFUN([AC_HAS_MMX],[$%{?_with_mmx:1}%{!?_with_mmx:2}])' >> linux/acinclude.m4
+cp CREDITS docs
 
 %build
 cd linux
+cp -f /usr/share/automake/config.sub .
 %{__aclocal}
 %{__autoconf}
 %{__autoheader}
 %configure \
-       %{!?debug:--enable-optimization} \
-       %{?_with_mmx:--enable-arch-asm} \
-       %{!?_without_alsa:--enable-alsa} \
+       %{?with_alsa:--enable-alsa --enable-alsa-dlopen} \
+       %{?with_arts:--enable-arts --enable-arts-dlopen} \
+       %{?with_esd:--enable-esd --enable-esd-dlopen} \
        --enable-sdl \
        --enable-vorbis \
        --enable-smpeg \
        --enable-capture \
-       --with-gcc=%{__cc}                          
+       --with-gcc=%{__cc}
 
 %{__make}
 
-cd ../docs
-%{!?_without_doc:%{__make} full-html}
+cd ../docs/spec1-0
+%{?with_doc:%{__make} full-html}
 
 %install
 rm -rf $RPM_BUILD_ROOT
 install -d $RPM_BUILD_ROOT%{_infodir}
 
-cd linux
-%{__make} install \
+%{__make} -C linux install \
+       DESTLIB='$(DESTDIR)%{_libdir}' \
        DESTDIR=$RPM_BUILD_ROOT
 
-install doc/openal.info $RPM_BUILD_ROOT%{_infodir}
+install linux/doc/openal.info $RPM_BUILD_ROOT%{_infodir}
 
 %clean
 rm -rf $RPM_BUILD_ROOT
@@ -136,11 +136,13 @@ rm -rf $RPM_BUILD_ROOT
 
 %files devel
 %defattr(644,root,root,755)
-%doc linux/doc/LOKI* %{!?_without_doc:docs/oalspecs-full}
+%doc linux/doc/LOKI* %{?with_doc:docs/spec1-0/oalspecs-full docs/spec1-1/OpenAL1-1Spec.pdf}
 %attr(755,root,root) %{_libdir}/lib*.so
+%attr(755,root,root) %{_bindir}/*-config
+%{_pkgconfigdir}/*
 %{_includedir}/AL
 %{_infodir}/openal.info*
 
 %files static
 %defattr(644,root,root,755)
-%attr(755,root,root)%{_libdir}/*.a
+%{_libdir}/*.a
This page took 0.063008 seconds and 4 git commands to generate.