]> git.pld-linux.org Git - packages/OpenAL.git/blobdiff - OpenAL.spec
up to 1.23.1
[packages/OpenAL.git] / OpenAL.spec
index 1995de08d05ed54541f530177dbd851d8e45fd9b..81c3ae55d3ac07786f599b8b199672f3c89d426a 100644 (file)
@@ -1,35 +1,48 @@
 #
 # Conditional build:
 %bcond_without alsa            # ALSA backend
-%bcond_without fluidsynth      # FluidSynth MIDI support
 %bcond_without jack            # JACK backend
+%bcond_without pipewire        # PipeWire backend
 %bcond_without portaudio       # PortAudio backend
 %bcond_without pulseaudio      # PulseAudio backend
+%bcond_without rtkit           # RTKit support
+%bcond_with    sdl             # SDL2 backend
+%bcond_with    sse2            # force use of SSE2 instructions (x86)
 %bcond_without gui             # alsoft-config GUI
-#
+
+%ifarch pentium4 x32 %{x8664}
+%define        with_sse2       1
+%endif
 Summary:       Open Audio Library
 Summary(pl.UTF-8):     Otwarta Biblioteka Dźwięku
 Name:          OpenAL
-Version:       1.17.1
+Version:       1.23.1
 Release:       1
 License:       LGPL v2+
 Group:         Libraries
-Source0:       http://kcat.strangesoft.net/openal-releases/openal-soft-%{version}.tar.bz2
-# Source0-md5: 4e1cff46cdb3ac147745dea33ad92687
-#URL:          http://kcat.strangesoft.net/openal.html
+Source0:       https://openal-soft.org/openal-releases/openal-soft-%{version}.tar.bz2
+# Source0-md5: 58a73698288d2787451b61f8f4431513
+Patch0:                %{name}-nosse.patch
 URL:           http://www.openal.org/
+%{?with_sdl:BuildRequires:     SDL2-devel >= 2}
 %{?with_alsa:BuildRequires:    alsa-lib-devel}
-BuildRequires: cmake >= 2.6
-%{?with_fluidsynth:BuildRequires:      fluidsynth-devel}
+BuildRequires: cmake >= 3.0.2
+%{?with_rtkit:BuildRequires:   dbus-devel}
 %{?with_jack:BuildRequires:    jack-audio-connection-kit-devel}
+BuildRequires: libmysofa-devel
+BuildRequires: libstdc++-devel >= 6:5
+%{?with_pipewire:BuildRequires:        pipewire-devel >= 0.3.23}
 BuildRequires: pkgconfig
 %{?with_portaudio:BuildRequires:       portaudio-devel}
 %{?with_pulseaudio:BuildRequires:      pulseaudio-devel}
+BuildRequires: rpmbuild(macros) >= 1.742
 %if %{with gui}
-BuildRequires: QtCore-devel >= 4.8.0
-BuildRequires: QtGui-devel >= 4.8.0
-BuildRequires: qt4-build >= 4.8.0
+BuildRequires: Qt5Core-devel >= 5
+BuildRequires: Qt5Gui-devel >= 5
+BuildRequires: Qt5Widgets-devel >= 5
+BuildRequires: qt5-build >= 5
 %endif
+%{?with_sse2:Requires: cpuinfo(sse2)}
 BuildRoot:     %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
 
 %description
@@ -67,8 +80,9 @@ Summary:      OpenAL configuration GUI
 Summary(pl.UTF-8):     Graficzny interfejs do konfiguracji biblioteki OpenAL
 Group:         X11/Applications/Sound
 Requires:      %{name} = %{version}-%{release}
-Requires:      QtCore >= 4.8.0
-Requires:      QtGui >= 4.8.0
+Requires:      Qt5Core >= 5
+Requires:      Qt5Gui >= 5
+Requires:      Qt5Widgets >= 5
 
 %description gui
 OpenAL configuration GUI.
@@ -78,19 +92,21 @@ Graficzny interfejs do konfiguracji biblioteki OpenAL.
 
 %prep
 %setup -q -n openal-soft-%{version}
+%patch0 -p1
 
 %build
-%cmake . \
-       %{!?with_fluidsynth:-DALSOFT_MIDI_FLUIDSYNTH=ON} \
-       %{!?with_gui:-DALSOFT_NO_CONFIG_UTIL=ON} \
-       -DCMAKE_INSTALL_PREFIX=%{_prefix} \
-       -DCMAKE_VERBOSE_MAKEFILE=1 \
-       -DEXAMPLES=OFF \
-       -DLIB_INSTALL_DIR=%{_lib} \
+cd build
+%cmake .. \
        %{!?with_alsa:-DALSOFT_BACKEND_ALSA=OFF} \
        %{!?with_jack:-DALSOFT_BACKEND_JACK=OFF} \
+       %{cmake_on_off pipewire ALSOFT_BACKEND_PIPEWIRE} \
        %{!?with_portaudio:-DALSOFT_BACKEND_PORTAUDIO=OFF} \
-       %{!?with_pulseaudio:-DALSOFT_BACKEND_PULSEAUDIO=OFF}
+       %{!?with_pulseaudio:-DALSOFT_BACKEND_PULSEAUDIO=OFF} \
+       %{cmake_on_off rtkit ALSOFT_RTKIT} \
+       %{?with_sdl:-DALSOFT_BACKEND_SDL2=ON} \
+       %{!?with_sse2:-DALSOFT_ENABLE_SSE2_CODEGEN=OFF} \
+       -DALSOFT_EXAMPLES=OFF \
+       %{!?with_gui:-DALSOFT_NO_CONFIG_UTIL=ON} \
 
 %{__make}
 
@@ -98,14 +114,11 @@ Graficzny interfejs do konfiguracji biblioteki OpenAL.
 rm -rf $RPM_BUILD_ROOT
 install -d $RPM_BUILD_ROOT%{_sysconfdir}/openal
 
-%{__make} install \
+%{__make} -C build install \
        DESTDIR=$RPM_BUILD_ROOT
 
 install -p alsoftrc.sample $RPM_BUILD_ROOT%{_sysconfdir}/openal/alsoft.conf
 
-# these look not really useful
-%{__rm} $RPM_BUILD_ROOT%{_bindir}/{altonegen,bsincgen}
-
 %clean
 rm -rf $RPM_BUILD_ROOT
 
@@ -115,7 +128,7 @@ rm -rf $RPM_BUILD_ROOT
 %files
 %defattr(644,root,root,755)
 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/openal
-%attr(755,root,root) %{_bindir}/makehrtf
+%attr(755,root,root) %{_bindir}/makemhr
 %attr(755,root,root) %{_bindir}/openal-info
 %attr(755,root,root) %{_libdir}/libopenal.so.*.*.*
 %attr(755,root,root) %ghost %{_libdir}/libopenal.so.1
@@ -126,6 +139,7 @@ rm -rf $RPM_BUILD_ROOT
 %attr(755,root,root) %{_libdir}/libopenal.so
 %{_includedir}/AL
 %{_pkgconfigdir}/openal.pc
+%{_libdir}/cmake/OpenAL
 
 %if %{with gui}
 %files gui
This page took 0.027688 seconds and 4 git commands to generate.