]> git.pld-linux.org Git - packages/OpenAL.git/blobdiff - OpenAL.spec
- NOTE: there was no soname change, but ABI HAS CHANGED (undefined symbol: alutInit)
[packages/OpenAL.git] / OpenAL.spec
index bba95fd7c28af9db4a6ec351ac3e6c214c53da28..3c023e8495167a2ba54b9330a56bb5c099875508 100644 (file)
@@ -1,49 +1,45 @@
 #
 # Conditional build:
-# _without_alsa                - without ALSA support
-# _without_doc         - don't build HTML documentation (from SGML source)
-# _without_esd         - without esd support
-# _with_mmx            - use MMX (won't run on non-MMX CPU)
-#
 # TODO:
-# - remove zip bcond?
-# - check %{name}-acfix.patch if it's still nedded, sorry
-#   for the inconvenience, I'll do it if I can...
+# - Build stops at:
+# arch/i386/x86_floatmul.c:86:74: warning: use of C99 long long integer constant
+# arch/i386/x86_floatmul.c:89:74: warning: use of C99 long long integer constant
+# arch/i386/x86_floatmul.c: In function `_alFloatMul':
+#arch/i386/x86_floatmul.c:86: internal compiler error: in ix86_expand_binop_builtin, at config/i386/i386.c:13246
+# Please submit a full bug report,
 #
-%ifarch athlon
-%define                _with_mmx       1
-%endif
-%ifnarch i586 i686 athlon
-%define                _with_mmx       0
-%endif
+# - autoconf provides undefined macro....
+
+%bcond_without alsa    # without ALSA support
+%bcond_with    arts    # with aRts support
+%bcond_without doc     # don't build HTML documentation (from SGML source)
+%bcond_without esd     # without esd support
+%bcond_with    mmx     # use MMX (makes sense on i[56]86 with MMX; won't run on non-MMX CPU)
+
 Summary:       Open Audio Library
 Summary(pl):   Otwarta Biblioteka D¼wiêku
 Name:          OpenAL
-Version:       0.0.6
-%define        snap    20030806
-Release:       1.%{snap}.0.10
+Version:       0.0.8
+Release:       0.1
 License:       LGPL
 Group:         Libraries
-# from CVS :pserver:guest@opensource.creative.com:/usr/local/cvs-repository /openal
-# (without all Win and Mac stuff and demos)
-Source0:       http://pb152.srem.sdi.tpnet.pl/pld/%{name}-linuxonly-%{snap}.tar.bz2
-# Source0-md5: 4a5202f6cba291ae0a9af59410bdda88
-Patch0:                %{name}-prefix.patch
-Patch1:                %{name}-acfix.patch
-Patch2:                %{name}-info.patch
-URL:           http://opensource.creative.com/
+Source0:       http://www.openal.org/openal_webstf/downloads/openal-%{version}.tar.gz
+# Source0-md5: 641cf53761f35ee979f3e888614797a0
+#Patch0:               %{name}-prefix.patch
+#Patch1:               %{name}-info.patch
+URL:           http://www.openal.org/
 BuildRequires: SDL-devel
-%{!?_without_alsa:BuildRequires:       alsa-lib-devel}
+%{?with_alsa:BuildRequires:    alsa-lib-devel}
+%{?with_arts:BuildRequires:    artsc-devel}
 BuildRequires: autoconf
 BuildRequires: automake
-%{!?_without_doc:BuildRequires:        docbook-utils}
-%{!?_without_esd:BuildRequires:        esound-devel}
-%{!?_without_doc:BuildRequires:        gnome-doc-tools}
+%{?with_doc:BuildRequires:     docbook-utils}
+%{?with_esd:BuildRequires:     esound-devel}
+%{?with_doc:BuildRequires:     gnome-doc-tools}
 BuildRequires: libvorbis-devel
-%{?_with_mmx:BuildRequires:    nasm}
+%{?with_mmx:BuildRequires:     nasm}
 BuildRequires: smpeg-devel
 BuildRequires: texinfo
-BuildRequires: zip
 BuildRoot:     %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
 
 %description
@@ -67,7 +63,7 @@ dostarczycieli sprz
 Summary:       Headers for OpenAL
 Summary(pl):   Pliki nag³ówkowe do OpenAL
 Group:         Development/Libraries
-Requires:      %{name} = %{version}
+Requires:      %{name} = %{version}-%{release}
 
 %description devel
 Header files for OpenAL-based programs.
@@ -80,53 +76,43 @@ OpenAL.
 Summary:       OpenAL static library
 Summary(pl):   Statyczna biblioteka OpenAL
 Group:         Development/Libraries
-Requires:      %{name}-devel = %{version}
+Requires:      %{name}-devel = %{version}-%{release}
 
 %description static
 OpenAL static library.
 
 %description static -l pl
-Biblioteka OpenAL do statycznego linkowania.
+Biblioteka OpenAL do konsolidacji statycznej.
 
 %prep
-%setup -q -n openal
-%patch0 -p1
-#%%patch1 -p1
-%patch2 -p1
-
-echo 'AC_DEFUN([AC_HAS_MMX],[$%{?_with_mmx:1}%{!?_with_mmx:2}])' >> linux/acinclude.m4
+%setup -q -n openal-%{version}
+#%patch0 -p1
+#%patch1 -p1
 
 %build
-cd linux
-%{__aclocal}
-%{__autoconf}
-%{__autoheader}
+cp -f /usr/share/automake/config.sub .
+#%{__aclocal}
+#%{__autoconf}
+#%{__autoheader}
 %configure \
-       %{!?debug:--enable-optimization} \
-       %{?_with_mmx:--enable-arch-asm} \
-       %{!?_without_alsa:--enable-alsa} \
-       %{!?_without_esd:--enable-esd} \
+       %{?with_alsa:--enable-alsa --enable-alsa-dlopen} \
+       %{?with_arts:--enable-arts --enable-arts-dlopen} \
+       %{?with_esd:--enable-esd --enable-esd-dlopen} \
        --enable-sdl \
        --enable-vorbis \
        --enable-smpeg \
        --enable-capture \
-       --with-gcc=%{__cc}                          
+       --with-gcc=%{__cc}
 
 %{__make}
 
-cd ../docs
-%{!?_without_doc:%{__make} full-html}
-
 %install
 rm -rf $RPM_BUILD_ROOT
 install -d $RPM_BUILD_ROOT%{_infodir}
 
-cd linux
 %{__make} install \
        DESTDIR=$RPM_BUILD_ROOT
 
-install doc/openal.info $RPM_BUILD_ROOT%{_infodir}
-
 %clean
 rm -rf $RPM_BUILD_ROOT
 
@@ -141,16 +127,17 @@ rm -rf $RPM_BUILD_ROOT
 
 %files
 %defattr(644,root,root,755)
-%doc linux/{CREDITS,ChangeLog,NOTES,TODO}
-%attr(755,root,root) %{_libdir}/lib*.so.*.*
+%doc ChangeLog NOTES TODO
+%attr(755,root,root) %{_libdir}/lib*.so.*.*.*
 
 %files devel
 %defattr(644,root,root,755)
-%doc linux/doc/LOKI* %{!?_without_doc:docs/oalspecs-full}
+%attr(755,root,root) %{_bindir}/*-config
 %attr(755,root,root) %{_libdir}/lib*.so
+%{_libdir}/*.la
+%{_pkgconfigdir}/*
 %{_includedir}/AL
-%{_infodir}/openal.info*
 
 %files static
 %defattr(644,root,root,755)
-%attr(755,root,root)%{_libdir}/*.a
+%{_libdir}/*.a
This page took 0.09336 seconds and 4 git commands to generate.