]> git.pld-linux.org Git - packages/OpenAL.git/blobdiff - OpenAL.spec
- NOTE: there was no soname change, but ABI HAS CHANGED (undefined symbol: alutInit)
[packages/OpenAL.git] / OpenAL.spec
index 1fb29b2b348865d8144b17b49b5e757fafd0086d..3c023e8495167a2ba54b9330a56bb5c099875508 100644 (file)
@@ -1,34 +1,32 @@
 #
 # Conditional build:
+# TODO:
+# - Build stops at:
+# arch/i386/x86_floatmul.c:86:74: warning: use of C99 long long integer constant
+# arch/i386/x86_floatmul.c:89:74: warning: use of C99 long long integer constant
+# arch/i386/x86_floatmul.c: In function `_alFloatMul':
+#arch/i386/x86_floatmul.c:86: internal compiler error: in ix86_expand_binop_builtin, at config/i386/i386.c:13246
+# Please submit a full bug report,
+#
+# - autoconf provides undefined macro....
+
 %bcond_without alsa    # without ALSA support
 %bcond_with    arts    # with aRts support
 %bcond_without doc     # don't build HTML documentation (from SGML source)
 %bcond_without esd     # without esd support
 %bcond_with    mmx     # use MMX (makes sense on i[56]86 with MMX; won't run on non-MMX CPU)
-                       # Currently broken.
-#
-# TODO:
-# - remove zip BR?
-#
-
-#%%ifarch athlon pentium3 pentium4 %{x8664}
-#%%define              with_mmx        1
-#%%endif
 
 Summary:       Open Audio Library
 Summary(pl):   Otwarta Biblioteka D¼wiêku
 Name:          OpenAL
 Version:       0.0.8
-%define        snap    20050714
-Release:       0.%{snap}.1
+Release:       0.1
 License:       LGPL
 Group:         Libraries
-# from CVS :pserver:guest@opensource.creative.com:/usr/local/cvs-repository /openal
-# (without all Win and Mac stuff and demos)
-Source0:       %{name}-linuxonly-%{snap}.tar.bz2
-# Source0-md5: 9f4a98faa2c11bf6d49c8efe60fc8305
-Patch0:                %{name}-prefix.patch
-Patch1:                %{name}-info.patch
+Source0:       http://www.openal.org/openal_webstf/downloads/openal-%{version}.tar.gz
+# Source0-md5: 641cf53761f35ee979f3e888614797a0
+#Patch0:               %{name}-prefix.patch
+#Patch1:               %{name}-info.patch
 URL:           http://www.openal.org/
 BuildRequires: SDL-devel
 %{?with_alsa:BuildRequires:    alsa-lib-devel}
@@ -42,7 +40,6 @@ BuildRequires:        libvorbis-devel
 %{?with_mmx:BuildRequires:     nasm}
 BuildRequires: smpeg-devel
 BuildRequires: texinfo
-BuildRequires: zip
 BuildRoot:     %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
 
 %description
@@ -88,24 +85,19 @@ OpenAL static library.
 Biblioteka OpenAL do konsolidacji statycznej.
 
 %prep
-%setup -q -n openal
-%patch0 -p1
-%patch1 -p1
-
-cp CREDITS docs
-echo 'AC_DEFUN([AC_HAS_MMX],[$%{?with_mmx:1}%{!?with_mmx:2}])' >> linux/acinclude.m4
+%setup -q -n openal-%{version}
+#%patch0 -p1
+#%patch1 -p1
 
 %build
-cd linux
 cp -f /usr/share/automake/config.sub .
-%{__aclocal}
-%{__autoconf}
-%{__autoheader}
+#%{__aclocal}
+#%{__autoconf}
+#%{__autoheader}
 %configure \
-       %{?with_mmx:--enable-arch-asm} \
        %{?with_alsa:--enable-alsa --enable-alsa-dlopen} \
-       %{?with_arts:--enable-arts} \
-       %{?with_esd:--enable-esd} \
+       %{?with_arts:--enable-arts --enable-arts-dlopen} \
+       %{?with_esd:--enable-esd --enable-esd-dlopen} \
        --enable-sdl \
        --enable-vorbis \
        --enable-smpeg \
@@ -114,18 +106,13 @@ cp -f /usr/share/automake/config.sub .
 
 %{__make}
 
-cd ../docs/spec1-0
-%{?with_doc:%{__make} full-html}
-
 %install
 rm -rf $RPM_BUILD_ROOT
 install -d $RPM_BUILD_ROOT%{_infodir}
 
-%{__make} -C linux install \
+%{__make} install \
        DESTDIR=$RPM_BUILD_ROOT
 
-install linux/doc/openal.info $RPM_BUILD_ROOT%{_infodir}
-
 %clean
 rm -rf $RPM_BUILD_ROOT
 
@@ -140,17 +127,16 @@ rm -rf $RPM_BUILD_ROOT
 
 %files
 %defattr(644,root,root,755)
-%doc linux/{CREDITS,ChangeLog,NOTES,TODO}
-%attr(755,root,root) %{_libdir}/lib*.so.*.*
+%doc ChangeLog NOTES TODO
+%attr(755,root,root) %{_libdir}/lib*.so.*.*.*
 
 %files devel
 %defattr(644,root,root,755)
-%doc linux/doc/LOKI* %{?with_doc:docs/spec1-0/oalspecs-full docs/spec1-1/OpenAL1-1Spec.pdf}
-%attr(755,root,root) %{_libdir}/lib*.so
 %attr(755,root,root) %{_bindir}/*-config
+%attr(755,root,root) %{_libdir}/lib*.so
+%{_libdir}/*.la
 %{_pkgconfigdir}/*
 %{_includedir}/AL
-%{_infodir}/openal.info*
 
 %files static
 %defattr(644,root,root,755)
This page took 0.06704 seconds and 4 git commands to generate.