]> git.pld-linux.org Git - packages/OpenAL.git/blobdiff - OpenAL.spec
- autoize
[packages/OpenAL.git] / OpenAL.spec
index 0e25e9ce7625c33abbc7f4abef5f7679c2c9c41c..13ef5cdaabccf121a0a4ca0df826931812bbf85d 100644 (file)
@@ -1,48 +1,49 @@
 #
 # Conditional build:
+#
 %bcond_without alsa    # without ALSA support
 %bcond_with    arts    # with aRts support
-%bcond_without doc     # don't build HTML documentation (from SGML source)
 %bcond_without esd     # without esd support
-%bcond_with    mmx     # use MMX (makes sense on i[56]86 with MMX; won't run on non-MMX CPU)
-#
-# TODO:
-# - remove zip BR?
+%bcond_without mmx     # don't use MMX
 #
-%ifarch athlon pentium3 pentium4 amd64
-%define                with_mmx        1
+%ifnarch %{ix86} %{x8664}
+%undefine      with_mmx
+%endif
+%ifarch i386 i486
+%undefine      with_mmx
 %endif
-
 Summary:       Open Audio Library
 Summary(pl):   Otwarta Biblioteka D¼wiêku
 Name:          OpenAL
-Version:       0.0.7
-%define        snap    20040416
-Release:       0.%{snap}.1
+Version:       0.0.8
+Release:       1
 License:       LGPL
 Group:         Libraries
-# from CVS :pserver:guest@opensource.creative.com:/usr/local/cvs-repository /openal
-# (without all Win and Mac stuff and demos)
-Source0:       %{name}-linuxonly-%{snap}.tar.bz2
-# Source0-md5: 4f42f20484858452bfc30caa8976415d
-Patch0:                %{name}-prefix.patch
-Patch1:                %{name}-info.patch
+Source0:       http://www.openal.org/openal_webstf/downloads/openal-%{version}.tar.gz
+# Source0-md5: 641cf53761f35ee979f3e888614797a0
 URL:           http://www.openal.org/
 BuildRequires: SDL-devel
 %{?with_alsa:BuildRequires:    alsa-lib-devel}
 %{?with_arts:BuildRequires:    artsc-devel}
-BuildRequires: autoconf
-BuildRequires: automake
-%{?with_doc:BuildRequires:     docbook-utils}
 %{?with_esd:BuildRequires:     esound-devel}
-%{?with_doc:BuildRequires:     gnome-doc-tools}
+%if %{with mmx}
+# MMX code triggers ICE in gcc 3.3.x
+BuildRequires: gcc >= 5:3.4.0
+%endif
 BuildRequires: libvorbis-devel
+%ifarch %{ix86}
 %{?with_mmx:BuildRequires:     nasm}
+%endif
+BuildRequires: pkgconfig
 BuildRequires: smpeg-devel
-BuildRequires: texinfo
-BuildRequires: zip
 BuildRoot:     %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
 
+%if %{with mmx}
+%define                specflags_ia32  -mmmx
+%else
+%define                specflags_ia32  -U__MMX__
+%endif
+
 %description
 OpenAL, the Open Audio Library, is a joint effort to create an open,
 vendor-neutral, cross-platform API for interactive, primarily
@@ -86,68 +87,58 @@ OpenAL static library.
 Biblioteka OpenAL do konsolidacji statycznej.
 
 %prep
-%setup -q -n openal
-%patch0 -p1
-%patch1 -p1
-
-echo 'AC_DEFUN([AC_HAS_MMX],[$%{?with_mmx:1}%{!?with_mmx:2}])' >> linux/acinclude.m4
+%setup -q -n openal-%{version}
 
 %build
-cd linux
 cp -f /usr/share/automake/config.sub .
-%{__aclocal}
+%{__libtoolize}
+%{__aclocal} -I admin/autotools/m4
 %{__autoconf}
 %{__autoheader}
 %configure \
-       %{!?debug:--enable-optimization} \
-       %{?with_mmx:--enable-arch-asm} \
-       %{?with_alsa:--enable-alsa --enable-alsa-dlopen} \
-       %{?with_arts:--enable-arts} \
-       %{?with_esd:--enable-esd} \
-       --enable-sdl \
-       --enable-vorbis \
-       --enable-smpeg \
+       --%{?with_alsa:en}%{!?with_alsa:dis}able-alsa{,-dlopen} \
+       --%{?with_arts:en}%{!?with_arts:dis}able-arts{,-dlopen} \
+       --%{?with_esd:en}%{!?with_esd:dis}able-esd{,-dlopen} \
+       --enable-sdl --enable-sdl-dlopen \
        --enable-capture \
-       --with-gcc=%{__cc}
+       --enable-linux \
+       --enable-null \
+%ifarch amd64 x86_64 athlon i686 i586
+       --enable-optim-generic \
+%endif
+       --enable-waveout \
+       --enable-vorbis --enable-vorbis-dlopen \
+       --enable-mp3 --enable-mp3-dlopen \
+       --with-gcc="%{__cc}"
 
 %{__make}
 
-cd ../docs
-%{?with_doc:%{__make} full-html}
-
 %install
 rm -rf $RPM_BUILD_ROOT
-install -d $RPM_BUILD_ROOT%{_infodir}
 
-%{__make} -C linux install \
+%{__make} install \
        DESTDIR=$RPM_BUILD_ROOT
 
-install linux/doc/openal.info $RPM_BUILD_ROOT%{_infodir}
-
 %clean
 rm -rf $RPM_BUILD_ROOT
 
 %post  -p /sbin/ldconfig
 %postun        -p /sbin/ldconfig
 
-%post devel
-[ ! -x /usr/sbin/fix-info-dir ] || /usr/sbin/fix-info-dir -c %{_infodir} >/dev/null 2>&1
-
-%postun        devel
-[ ! -x /usr/sbin/fix-info-dir ] || /usr/sbin/fix-info-dir -c %{_infodir} >/dev/null 2>&1
-
 %files
 %defattr(644,root,root,755)
-%doc linux/{CREDITS,ChangeLog,NOTES,TODO}
-%attr(755,root,root) %{_libdir}/lib*.so.*.*
+%doc ChangeLog NOTES TODO
+%attr(755,root,root) %{_libdir}/libopenal.so.*.*.*
 
 %files devel
 %defattr(644,root,root,755)
-%doc linux/doc/LOKI* %{?with_doc:docs/oalspecs-full}
-%attr(755,root,root) %{_libdir}/lib*.so
+%doc common/specification/OpenAL1-1Spec.pdf
+%attr(755,root,root) %{_bindir}/openal-config
+%attr(755,root,root) %{_libdir}/libopenal.so
+%{_libdir}/libopenal.la
 %{_includedir}/AL
-%{_infodir}/openal.info*
+%{_pkgconfigdir}/openal.pc
 
 %files static
 %defattr(644,root,root,755)
-%{_libdir}/*.a
+%{_libdir}/libopenal.a
This page took 0.030853 seconds and 4 git commands to generate.