]> git.pld-linux.org Git - packages/OpenAL.git/blame - OpenAL.spec
- updated to 1.17.1
[packages/OpenAL.git] / OpenAL.spec
CommitLineData
68071dbf 1#
a35955a2 2# Conditional build:
f2c99d8a
JB
3%bcond_without alsa # ALSA backend
4%bcond_without fluidsynth # FluidSynth MIDI support
b5f2479e 5%bcond_without jack # JACK backend
f2c99d8a
JB
6%bcond_without portaudio # PortAudio backend
7%bcond_without pulseaudio # PulseAudio backend
8%bcond_without gui # alsoft-config GUI
a26f1dac 9#
d451b59a 10Summary: Open Audio Library
8be14136 11Summary(pl.UTF-8): Otwarta Biblioteka Dźwięku
6a3db3d8 12Name: OpenAL
4fafbfa4 13Version: 1.17.1
f2c99d8a 14Release: 1
65437b48 15License: LGPL v2+
68071dbf 16Group: Libraries
7e80d8dd 17Source0: http://kcat.strangesoft.net/openal-releases/openal-soft-%{version}.tar.bz2
4fafbfa4 18# Source0-md5: 4e1cff46cdb3ac147745dea33ad92687
7e80d8dd 19#URL: http://kcat.strangesoft.net/openal.html
827050d4 20URL: http://www.openal.org/
e62907a5 21%{?with_alsa:BuildRequires: alsa-lib-devel}
f2c99d8a
JB
22BuildRequires: cmake >= 2.6
23%{?with_fluidsynth:BuildRequires: fluidsynth-devel}
b5f2479e 24%{?with_jack:BuildRequires: jack-audio-connection-kit-devel}
89d1fa49 25BuildRequires: pkgconfig
7e80d8dd 26%{?with_portaudio:BuildRequires: portaudio-devel}
f953b352 27%{?with_pulseaudio:BuildRequires: pulseaudio-devel}
f2c99d8a
JB
28%if %{with gui}
29BuildRequires: QtCore-devel >= 4.8.0
30BuildRequires: QtGui-devel >= 4.8.0
31BuildRequires: qt4-build >= 4.8.0
32%endif
6a3db3d8 33BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
34
6a3db3d8 35%description
36OpenAL, the Open Audio Library, is a joint effort to create an open,
37vendor-neutral, cross-platform API for interactive, primarily
38spatialized audio. OpenAL's primary audience are application
39developers and desktop users that rely on portable standards like
40OpenGL, for games and other multimedia applications. OpenAL is already
41supported by a number of hardware vendors and developers.
42
a4959810
JR
43%description -l pl.UTF-8
44OpenAL, otwarta biblioteka dźwięku, to połączony wysiłek w celu
45stworzenia otwartego, niezależnego od producentów, międzyplatformowego
46interfejsu projektowania aplikacji w części obsługi dźwięku.
47Biblioteka adresowana jest do twórców aplikacji i użytkowników,
48którzy wybierają przenośne standardy, jak OpenGL, w grach i
49aplikacjach multimedialnych. OpenAL posiada już wsparcie wielu
50dostarczycieli sprzętu i programistów.
d451b59a 51
6a3db3d8 52%package devel
d451b59a 53Summary: Headers for OpenAL
8be14136 54Summary(pl.UTF-8): Pliki nagłówkowe do OpenAL
68071dbf 55Group: Development/Libraries
e62907a5 56Requires: %{name} = %{version}-%{release}
6a3db3d8 57
58%description devel
d451b59a 59Header files for OpenAL-based programs.
6a3db3d8 60
a4959810
JR
61%description devel -l pl.UTF-8
62Pliki nagłówkowe potrzebne przy budowaniu programów opartych na
d451b59a 63OpenAL.
64
f2c99d8a
JB
65%package gui
66Summary: OpenAL configuration GUI
67Summary(pl.UTF-8): Graficzny interfejs do konfiguracji biblioteki OpenAL
68Group: X11/Applications/Sound
69Requires: %{name} = %{version}-%{release}
70Requires: QtCore >= 4.8.0
71Requires: QtGui >= 4.8.0
72
73%description gui
74OpenAL configuration GUI.
75
76%description gui -l pl.UTF-8
77Graficzny interfejs do konfiguracji biblioteki OpenAL.
78
6a3db3d8 79%prep
7e80d8dd 80%setup -q -n openal-soft-%{version}
68071dbf 81
6a3db3d8 82%build
65437b48 83%cmake . \
f2c99d8a
JB
84 %{!?with_fluidsynth:-DALSOFT_MIDI_FLUIDSYNTH=ON} \
85 %{!?with_gui:-DALSOFT_NO_CONFIG_UTIL=ON} \
7e80d8dd 86 -DCMAKE_INSTALL_PREFIX=%{_prefix} \
65437b48 87 -DCMAKE_VERBOSE_MAKEFILE=1 \
ce19b7ae 88 -DEXAMPLES=OFF \
f953b352 89 -DLIB_INSTALL_DIR=%{_lib} \
b5f2479e
JB
90 %{!?with_alsa:-DALSOFT_BACKEND_ALSA=OFF} \
91 %{!?with_jack:-DALSOFT_BACKEND_JACK=OFF} \
92 %{!?with_portaudio:-DALSOFT_BACKEND_PORTAUDIO=OFF} \
93 %{!?with_pulseaudio:-DALSOFT_BACKEND_PULSEAUDIO=OFF}
65437b48 94
7e80d8dd 95%{__make}
6a3db3d8 96
97%install
98rm -rf $RPM_BUILD_ROOT
6ce9e958 99install -d $RPM_BUILD_ROOT%{_sysconfdir}/openal
d451b59a 100
f2c02821 101%{__make} install \
68071dbf 102 DESTDIR=$RPM_BUILD_ROOT
d451b59a 103
c06f4ed0 104install -p alsoftrc.sample $RPM_BUILD_ROOT%{_sysconfdir}/openal/alsoft.conf
6ce9e958 105
b5f2479e
JB
106# these look not really useful
107%{__rm} $RPM_BUILD_ROOT%{_bindir}/{altonegen,bsincgen}
108
6a3db3d8 109%clean
110rm -rf $RPM_BUILD_ROOT
111
404a1bc6
JB
112%post -p /sbin/ldconfig
113%postun -p /sbin/ldconfig
114
6a3db3d8 115%files
3f81b215 116%defattr(644,root,root,755)
6ce9e958 117%config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/openal
ce19b7ae 118%attr(755,root,root) %{_bindir}/makehrtf
65437b48 119%attr(755,root,root) %{_bindir}/openal-info
a26f1dac 120%attr(755,root,root) %{_libdir}/libopenal.so.*.*.*
65437b48 121%attr(755,root,root) %ghost %{_libdir}/libopenal.so.1
f2c99d8a 122%{_datadir}/openal
6a3db3d8 123
124%files devel
125%defattr(644,root,root,755)
a26f1dac 126%attr(755,root,root) %{_libdir}/libopenal.so
68071dbf 127%{_includedir}/AL
a26f1dac 128%{_pkgconfigdir}/openal.pc
f2c99d8a
JB
129
130%if %{with gui}
131%files gui
132%defattr(644,root,root,755)
133%attr(755,root,root) %{_bindir}/alsoft-config
134%endif
This page took 0.063679 seconds and 4 git commands to generate.