]> git.pld-linux.org Git - packages/OpenAL.git/blame - OpenAL.spec
use different cmake flags to toggle sse
[packages/OpenAL.git] / OpenAL.spec
CommitLineData
68071dbf 1#
a35955a2 2# Conditional build:
f2c99d8a 3%bcond_without alsa # ALSA backend
b5f2479e 4%bcond_without jack # JACK backend
f2c99d8a
JB
5%bcond_without portaudio # PortAudio backend
6%bcond_without pulseaudio # PulseAudio backend
bd9b58be
JB
7%bcond_with sdl # SDL2 backend
8%bcond_with sse # force use of SSE instructions (x86)
9%bcond_with sse2 # force use of SSE2 instructions (x86)
f2c99d8a 10%bcond_without gui # alsoft-config GUI
99cf5ae3 11%bcond_with qt4 # Qt 4 instead of Qt 5 for GUI
a26f1dac 12#
bd9b58be
JB
13%ifarch pentium3 pentium4
14%define with_sse 1
15%endif
16%ifarch pentium4
17%define with_sse2 1
18%endif
d451b59a 19Summary: Open Audio Library
8be14136 20Summary(pl.UTF-8): Otwarta Biblioteka Dźwięku
6a3db3d8 21Name: OpenAL
996f154d
JP
22Version: 1.20.0
23Release: 1
65437b48 24License: LGPL v2+
68071dbf 25Group: Libraries
bd9b58be 26Source0: http://openal-soft.org/openal-releases/openal-soft-%{version}.tar.bz2
996f154d 27# Source0-md5: f6349071db03e48994ea09daa031ef6e
60781cc7 28Patch0: %{name}-pc.patch
827050d4 29URL: http://www.openal.org/
bd9b58be 30%{?with_sdl:BuildRequires: SDL2-devel >= 2}
e62907a5 31%{?with_alsa:BuildRequires: alsa-lib-devel}
99cf5ae3 32BuildRequires: cmake >= 3.0.2
b5f2479e 33%{?with_jack:BuildRequires: jack-audio-connection-kit-devel}
996f154d 34BuildRequires: libstdc++-devel >= 6:4.8.1
89d1fa49 35BuildRequires: pkgconfig
7e80d8dd 36%{?with_portaudio:BuildRequires: portaudio-devel}
f953b352 37%{?with_pulseaudio:BuildRequires: pulseaudio-devel}
60652dc3 38BuildRequires: rpmbuild(macros) >= 1.605
f2c99d8a 39%if %{with gui}
99cf5ae3 40%if %{with qt4}
f2c99d8a
JB
41BuildRequires: QtCore-devel >= 4.8.0
42BuildRequires: QtGui-devel >= 4.8.0
43BuildRequires: qt4-build >= 4.8.0
99cf5ae3
JB
44%else
45BuildRequires: Qt5Core-devel >= 5
46BuildRequires: Qt5Gui-devel >= 5
47BuildRequires: Qt5Widgets-devel >= 5
48BuildRequires: qt5-build >= 5
49%endif
f2c99d8a 50%endif
6a3db3d8 51BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
52
6a3db3d8 53%description
54OpenAL, the Open Audio Library, is a joint effort to create an open,
55vendor-neutral, cross-platform API for interactive, primarily
56spatialized audio. OpenAL's primary audience are application
57developers and desktop users that rely on portable standards like
58OpenGL, for games and other multimedia applications. OpenAL is already
59supported by a number of hardware vendors and developers.
60
a4959810
JR
61%description -l pl.UTF-8
62OpenAL, otwarta biblioteka dźwięku, to połączony wysiłek w celu
63stworzenia otwartego, niezależnego od producentów, międzyplatformowego
64interfejsu projektowania aplikacji w części obsługi dźwięku.
65Biblioteka adresowana jest do twórców aplikacji i użytkowników,
66którzy wybierają przenośne standardy, jak OpenGL, w grach i
67aplikacjach multimedialnych. OpenAL posiada już wsparcie wielu
68dostarczycieli sprzętu i programistów.
d451b59a 69
6a3db3d8 70%package devel
d451b59a 71Summary: Headers for OpenAL
8be14136 72Summary(pl.UTF-8): Pliki nagłówkowe do OpenAL
68071dbf 73Group: Development/Libraries
e62907a5 74Requires: %{name} = %{version}-%{release}
6a3db3d8 75
76%description devel
d451b59a 77Header files for OpenAL-based programs.
6a3db3d8 78
a4959810
JR
79%description devel -l pl.UTF-8
80Pliki nagłówkowe potrzebne przy budowaniu programów opartych na
d451b59a 81OpenAL.
82
f2c99d8a
JB
83%package gui
84Summary: OpenAL configuration GUI
85Summary(pl.UTF-8): Graficzny interfejs do konfiguracji biblioteki OpenAL
86Group: X11/Applications/Sound
87Requires: %{name} = %{version}-%{release}
88Requires: QtCore >= 4.8.0
89Requires: QtGui >= 4.8.0
90
91%description gui
92OpenAL configuration GUI.
93
94%description gui -l pl.UTF-8
95Graficzny interfejs do konfiguracji biblioteki OpenAL.
96
6a3db3d8 97%prep
7e80d8dd 98%setup -q -n openal-soft-%{version}
60781cc7 99%patch0 -p1
68071dbf 100
6a3db3d8 101%build
99cf5ae3
JB
102cd build
103%cmake .. \
b5f2479e
JB
104 %{!?with_alsa:-DALSOFT_BACKEND_ALSA=OFF} \
105 %{!?with_jack:-DALSOFT_BACKEND_JACK=OFF} \
106 %{!?with_portaudio:-DALSOFT_BACKEND_PORTAUDIO=OFF} \
99cf5ae3 107 %{!?with_pulseaudio:-DALSOFT_BACKEND_PULSEAUDIO=OFF} \
bd9b58be 108 %{?with_sdl:-DALSOFT_BACKEND_SDL2=ON} \
4d244e7b
JP
109 %{!?with_sse:-DALSOFT_CPUEXT_SSE=OFF} \
110 %{!?with_sse2:-DALSOFT_CPUEXT_SSE2=OFF} \
99cf5ae3
JB
111 -DALSOFT_EXAMPLES=OFF \
112 %{!?with_gui:-DALSOFT_NO_CONFIG_UTIL=ON} \
113 %{?with_qt4:-DALSOFT_NO_QT5=ON} \
65437b48 114
7e80d8dd 115%{__make}
6a3db3d8 116
117%install
118rm -rf $RPM_BUILD_ROOT
6ce9e958 119install -d $RPM_BUILD_ROOT%{_sysconfdir}/openal
d451b59a 120
99cf5ae3 121%{__make} -C build install \
68071dbf 122 DESTDIR=$RPM_BUILD_ROOT
d451b59a 123
c06f4ed0 124install -p alsoftrc.sample $RPM_BUILD_ROOT%{_sysconfdir}/openal/alsoft.conf
6ce9e958 125
b5f2479e 126# these look not really useful
96987817 127%{__rm} $RPM_BUILD_ROOT%{_bindir}/altonegen
b5f2479e 128
6a3db3d8 129%clean
130rm -rf $RPM_BUILD_ROOT
131
404a1bc6
JB
132%post -p /sbin/ldconfig
133%postun -p /sbin/ldconfig
134
6a3db3d8 135%files
3f81b215 136%defattr(644,root,root,755)
6ce9e958 137%config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/openal
996f154d 138%attr(755,root,root) %{_bindir}/makemhr
65437b48 139%attr(755,root,root) %{_bindir}/openal-info
a26f1dac 140%attr(755,root,root) %{_libdir}/libopenal.so.*.*.*
65437b48 141%attr(755,root,root) %ghost %{_libdir}/libopenal.so.1
f2c99d8a 142%{_datadir}/openal
6a3db3d8 143
144%files devel
145%defattr(644,root,root,755)
a26f1dac 146%attr(755,root,root) %{_libdir}/libopenal.so
68071dbf 147%{_includedir}/AL
a26f1dac 148%{_pkgconfigdir}/openal.pc
99cf5ae3 149%{_libdir}/cmake/OpenAL
f2c99d8a
JB
150
151%if %{with gui}
152%files gui
153%defattr(644,root,root,755)
154%attr(755,root,root) %{_bindir}/alsoft-config
155%endif
This page took 0.071948 seconds and 4 git commands to generate.