]> git.pld-linux.org Git - packages/OpenAL.git/blame - OpenAL.spec
- patch for broken pkgconfig file
[packages/OpenAL.git] / OpenAL.spec
CommitLineData
68071dbf 1#
a35955a2 2# Conditional build:
3#
e62907a5
JB
4%bcond_without alsa # without ALSA support
5%bcond_with arts # with aRts support
e62907a5 6%bcond_without esd # without esd support
a26f1dac
JB
7%bcond_without mmx # don't use MMX
8#
9%ifnarch %{ix86} %{x8664}
10%undefine with_mmx
11%endif
12%ifarch i386 i486
13%undefine with_mmx
14%endif
d451b59a 15Summary: Open Audio Library
8be14136 16Summary(pl.UTF-8): Otwarta Biblioteka Dźwięku
6a3db3d8 17Name: OpenAL
f2b62104 18Version: 0.0.8
5b14bc3e 19Release: 4
6a3db3d8 20License: LGPL
68071dbf 21Group: Libraries
43b5504a 22Source0: http://www.openal.org/openal_webstf/downloads/openal-%{version}.tar.gz
23# Source0-md5: 641cf53761f35ee979f3e888614797a0
827050d4 24URL: http://www.openal.org/
a7443cb5 25Patch0: %{name}-alc.h.patch
5b14bc3e 26Patch1: %{name}-pkgconfig.patch
b0b40567 27BuildRequires: SDL-devel
e62907a5
JB
28%{?with_alsa:BuildRequires: alsa-lib-devel}
29%{?with_arts:BuildRequires: artsc-devel}
d3133096
JB
30BuildRequires: autoconf >= 2.56
31BuildRequires: automake
e62907a5 32%{?with_esd:BuildRequires: esound-devel}
a26f1dac
JB
33%if %{with mmx}
34# MMX code triggers ICE in gcc 3.3.x
35BuildRequires: gcc >= 5:3.4.0
36%endif
d3133096 37BuildRequires: libtool
b0b40567 38BuildRequires: libvorbis-devel
a26f1dac 39%ifarch %{ix86}
e62907a5 40%{?with_mmx:BuildRequires: nasm}
a26f1dac
JB
41%endif
42BuildRequires: pkgconfig
b0b40567 43BuildRequires: smpeg-devel
6a3db3d8 44BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
45
a26f1dac
JB
46%if %{with mmx}
47%define specflags_ia32 -mmmx
48%else
49%define specflags_ia32 -U__MMX__
50%endif
51
6a3db3d8 52%description
53OpenAL, the Open Audio Library, is a joint effort to create an open,
54vendor-neutral, cross-platform API for interactive, primarily
55spatialized audio. OpenAL's primary audience are application
56developers and desktop users that rely on portable standards like
57OpenGL, for games and other multimedia applications. OpenAL is already
58supported by a number of hardware vendors and developers.
59
a4959810
JR
60%description -l pl.UTF-8
61OpenAL, otwarta biblioteka dźwięku, to połączony wysiłek w celu
62stworzenia otwartego, niezależnego od producentów, międzyplatformowego
63interfejsu projektowania aplikacji w części obsługi dźwięku.
64Biblioteka adresowana jest do twórców aplikacji i użytkowników,
65którzy wybierają przenośne standardy, jak OpenGL, w grach i
66aplikacjach multimedialnych. OpenAL posiada już wsparcie wielu
67dostarczycieli sprzętu i programistów.
d451b59a 68
6a3db3d8 69%package devel
d451b59a 70Summary: Headers for OpenAL
8be14136 71Summary(pl.UTF-8): Pliki nagłówkowe do OpenAL
68071dbf 72Group: Development/Libraries
e62907a5 73Requires: %{name} = %{version}-%{release}
6a3db3d8 74
75%description devel
d451b59a 76Header files for OpenAL-based programs.
6a3db3d8 77
a4959810
JR
78%description devel -l pl.UTF-8
79Pliki nagłówkowe potrzebne przy budowaniu programów opartych na
d451b59a 80OpenAL.
81
6a3db3d8 82%package static
83Summary: OpenAL static library
8be14136 84Summary(pl.UTF-8): Statyczna biblioteka OpenAL
68071dbf 85Group: Development/Libraries
e62907a5 86Requires: %{name}-devel = %{version}-%{release}
6a3db3d8 87
88%description static
89OpenAL static library.
90
a4959810 91%description static -l pl.UTF-8
a9a6d37c 92Biblioteka OpenAL do konsolidacji statycznej.
6a3db3d8 93
6a3db3d8 94%prep
43b5504a 95%setup -q -n openal-%{version}
a7443cb5 96%patch0 -p1
5b14bc3e 97%patch1 -p1
68071dbf 98
6a3db3d8 99%build
7e6377c0 100%{__libtoolize}
101%{__aclocal} -I admin/autotools/m4
102%{__autoconf}
103%{__autoheader}
d3133096 104%{__automake}
68071dbf 105%configure \
7e6377c0 106 --%{?with_alsa:en}%{!?with_alsa:dis}able-alsa{,-dlopen} \
107 --%{?with_arts:en}%{!?with_arts:dis}able-arts{,-dlopen} \
108 --%{?with_esd:en}%{!?with_esd:dis}able-esd{,-dlopen} \
a35955a2 109 --enable-sdl --enable-sdl-dlopen \
68071dbf 110 --enable-capture \
a35955a2 111 --enable-linux \
112 --enable-null \
7e6377c0 113%ifarch amd64 x86_64 athlon i686 i586
a26f1dac
JB
114 --enable-optim-generic \
115%endif
a35955a2 116 --enable-waveout \
117 --enable-vorbis --enable-vorbis-dlopen \
118 --enable-mp3 --enable-mp3-dlopen \
a26f1dac 119 --with-gcc="%{__cc}"
68071dbf 120
00bac3c4 121%{__make} -j1
6a3db3d8 122
123%install
124rm -rf $RPM_BUILD_ROOT
d451b59a 125
f2c02821 126%{__make} install \
68071dbf 127 DESTDIR=$RPM_BUILD_ROOT
d451b59a 128
6a3db3d8 129%clean
130rm -rf $RPM_BUILD_ROOT
131
404a1bc6
JB
132%post -p /sbin/ldconfig
133%postun -p /sbin/ldconfig
134
6a3db3d8 135%files
3f81b215 136%defattr(644,root,root,755)
f2c02821 137%doc ChangeLog NOTES TODO
a26f1dac 138%attr(755,root,root) %{_libdir}/libopenal.so.*.*.*
5b14bc3e 139%attr(755,root,root) %ghost %{_libdir}/libopenal.so.?
6a3db3d8 140
141%files devel
142%defattr(644,root,root,755)
a26f1dac
JB
143%doc common/specification/OpenAL1-1Spec.pdf
144%attr(755,root,root) %{_bindir}/openal-config
145%attr(755,root,root) %{_libdir}/libopenal.so
146%{_libdir}/libopenal.la
68071dbf 147%{_includedir}/AL
a26f1dac 148%{_pkgconfigdir}/openal.pc
d451b59a 149
6a3db3d8 150%files static
3f81b215 151%defattr(644,root,root,755)
a26f1dac 152%{_libdir}/libopenal.a
This page took 0.058026 seconds and 4 git commands to generate.