]> git.pld-linux.org Git - packages/OpenAL++.git/blob - OpenAL++.spec
- tabs in preamble
[packages/OpenAL++.git] / OpenAL++.spec
1 %define _snap 050303
2 Summary:        An object oriented wrapper for OpenAL
3 Summary(pl.UTF-8):      Obiektowy wrapper dla OpenAL
4 Name:           OpenAL++
5 Version:        0.2
6 Release:        0.20%{_snap}.1
7 License:        LGPL
8 Group:          Libraries
9 Source0:        http://dl.sourceforge.net/alpp/openalpp-%{_snap}.tgz
10 # Source0-md5:  f93325e71675e7e4744cbdb4ca3b9603
11 Patch0:         openalpp-link.patch
12 URL:            http://alpp.sourceforge.net/
13 BuildRequires:  OpenAL-devel
14 BuildRequires:  OpenThreads-devel
15 BuildRequires:  autoconf
16 BuildRequires:  automake
17 BuildRequires:  libogg-devel
18 BuildRequires:  libstdc++-devel
19 BuildRequires:  libtool >= 2:1.5
20 # disabled - unfinished (apps would require -DWITH_PORTAUDIO)
21 #BuildRequires: portaudio-devel
22 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
23
24 %description
25 OpenAL++ is an object oriented wrapper for OpenAL. It makes using
26 spatial sound extremely easy. It has built in functionality for
27 streaming sound over sockets or from an input device.
28
29 %description -l pl.UTF-8
30 OpenAL++ to zorientowany obiektowo wrapper na OpenAL. Znacznie ułatwia
31 używanie dźwięku przestrzennego. Posiada wbudowaną funkcjonalność
32 strumieniowania dźwięku po gniazdach lub z urządzenia wejściowego.
33
34 %package devel
35 Summary:        Header files for OpenAL++ library
36 Summary(pl.UTF-8):      Pliki nagłówkowe biblioteki OpenAL++
37 Group:          Development/Libraries
38 Requires:       %{name} = %{version}-%{release}
39 Requires:       OpenAL-devel
40 Requires:       OpenThreads-devel
41 Requires:       libogg-devel
42 Requires:       libstdc++-devel
43 #Requires:      portaudio-devel
44
45 %description devel
46 Header files for OpenAL++ library.
47
48 %description devel -l pl.UTF-8
49 Pliki nagłówkowe biblioteki OpenAL++.
50
51 %package static
52 Summary:        Static OpenAL++ library
53 Summary(pl.UTF-8):      Statyczna biblioteka OpenAL++
54 Group:          Development/Libraries
55 Requires:       %{name}-devel = %{version}-%{release}
56
57 %description static
58 Static OpenAL++ library.
59
60 %description static -l pl.UTF-8
61 Statyczna biblioteka OpenAL++.
62
63 %prep
64 %setup -q -n openalpp
65 %patch0 -p1
66
67 %build
68 %{__libtoolize}
69 %{__aclocal}
70 %{__autoconf}
71 %{__automake}
72 %configure \
73         --enable-static
74 %{__make}
75
76 %install
77 rm -rf $RPM_BUILD_ROOT
78
79 %{__make} install \
80         DESTDIR=$RPM_BUILD_ROOT
81
82 %clean
83 rm -rf $RPM_BUILD_ROOT
84
85 %post   -p /sbin/ldconfig
86 %postun -p /sbin/ldconfig
87
88 %files
89 %defattr(644,root,root,755)
90 %doc README
91 %attr(755,root,root) %{_libdir}/lib*.so.*.*.*
92
93 %files devel
94 %defattr(644,root,root,755)
95 %attr(755,root,root) %{_libdir}/lib*.so
96 %{_libdir}/lib*.la
97 %{_includedir}/openalpp
98 %{_pkgconfigdir}/*.pc
99
100 %files static
101 %defattr(644,root,root,755)
102 %{_libdir}/lib*.a
This page took 0.204292 seconds and 3 git commands to generate.