]> git.pld-linux.org Git - packages/ORBit2.git/commitdiff
rebuild with separate debuginfo build-ids master auto/th/ORBit2-2.14.19-11
authorJan Rękorajski <baggins@pld-linux.org>
Sat, 20 Nov 2021 21:32:38 +0000 (22:32 +0100)
committerJan Rękorajski <baggins@pld-linux.org>
Sat, 20 Nov 2021 21:32:38 +0000 (22:32 +0100)
Release 11 (by relup.sh)

ORBit2-idl-gtk-doc.patch [new file with mode: 0644]
ORBit2-pthread.patch [deleted file]
ORBit2.spec

diff --git a/ORBit2-idl-gtk-doc.patch b/ORBit2-idl-gtk-doc.patch
new file mode 100644 (file)
index 0000000..ed859a1
--- /dev/null
@@ -0,0 +1,23 @@
+--- ORBit2-2.14.19/src/idl-compiler/orbit-idl-c-headers.c.orig 2010-02-09 13:05:35.000000000 +0100
++++ ORBit2-2.14.19/src/idl-compiler/orbit-idl-c-headers.c      2021-03-12 20:48:55.042479965 +0100
+@@ -634,7 +634,7 @@
+   ctmp = orbit_cbe_get_typespec_str(tree);
+   fprintf(ci->fh,
+-        "typedef struct { CORBA_unsigned_short _digits; CORBA_short _scale; CORBA_char _value[%d]; } %s;\n",
++        "typedef struct {\n  CORBA_unsigned_short _digits;\n  CORBA_short _scale;\n  CORBA_char _value[%d];\n} %s;\n",
+         (int) (IDL_INTEGER(IDL_TYPE_FIXED(tree).positive_int_const).value + 2)/2,
+         ctmp);
+   g_free(ctmp);
+@@ -714,9 +714,9 @@
+       fprintf(ci->fh, "#if !defined(_%s_defined)\n#define _%s_defined 1\n",
+             fullname, fullname);
+-      fprintf(ci->fh, "typedef struct { CORBA_unsigned_long _maximum, _length; ");
++      fprintf(ci->fh, "typedef struct {\n  CORBA_unsigned_long _maximum, _length;\n  ");
+       orbit_cbe_write_typespec(ci->fh, IDL_TYPE_SEQUENCE(tree).simple_type_spec);
+-      fprintf(ci->fh, "* _buffer; CORBA_boolean _release; } ");
++      fprintf(ci->fh, "* _buffer;\n  CORBA_boolean _release;\n} ");
+       orbit_cbe_write_typespec(ci->fh, tree);
+       fprintf(ci->fh, ";\n#endif\n");
+       ch_type_alloc_and_tc(tree, rinfo, ci, TRUE);
diff --git a/ORBit2-pthread.patch b/ORBit2-pthread.patch
deleted file mode 100644 (file)
index 1798634..0000000
+++ /dev/null
@@ -1,48 +0,0 @@
-diff -urN ORBit2-2.5.0.orig/test/Makefile.am ORBit2-2.5.0/test/Makefile.am
---- ORBit2-2.5.0.orig/test/Makefile.am Sat Oct 19 10:25:57 2002
-+++ ORBit2-2.5.0/test/Makefile.am      Sat Oct 19 10:29:03 2002
-@@ -18,7 +18,7 @@
- TESTS = test-dynany test-mem test-performance test-giop
--LDADD = $(top_builddir)/src/orb/libORBit-2.la $(ORBIT_LIBS)
-+LDADD = $(top_builddir)/src/orb/libORBit-2.la $(ORBIT_LIBS) -lpthread
- test_mem_SOURCES=test-mem.c
-diff -urN ORBit2-2.5.0.orig/test/everything/Makefile.am ORBit2-2.5.0/test/everything/Makefile.am
---- ORBit2-2.5.0.orig/test/everything/Makefile.am      Sat Oct 19 10:25:57 2002
-+++ ORBit2-2.5.0/test/everything/Makefile.am   Sat Oct 19 10:29:57 2002
-@@ -28,7 +28,7 @@
- LDADD = $(top_builddir)/src/orb/libORBit-2.la                         \
-       $(top_builddir)/src/services/imodule/libORBit-imodule-2.la      \
-       $(ORBIT_IDL_LIBS)                                               \
--      $(ORBIT_LIBS)
-+      $(ORBIT_LIBS) -lpthread
- #  -lefence
-diff -urN ORBit2-2.5.0.orig/test/inhibit/Makefile.am ORBit2-2.5.0/test/inhibit/Makefile.am
---- ORBit2-2.5.0.orig/test/inhibit/Makefile.am Sat Oct 19 10:25:57 2002
-+++ ORBit2-2.5.0/test/inhibit/Makefile.am      Sat Oct 19 10:30:15 2002
-@@ -7,7 +7,7 @@
-       $(WARN_CFLAGS)               \
-       $(ORBIT_CFLAGS)
--LDADD = $(top_builddir)/src/orb/libORBit-2.la $(ORBIT_LIBS)
-+LDADD = $(top_builddir)/src/orb/libORBit-2.la $(ORBIT_LIBS) -lpthread
- FOO_IDLOUT=foo.h foo-stubs.c foo-skels.c foo-common.c
- BAA_IDLOUT=baa.h baa-stubs.c baa-skels.c baa-common.c
-diff -urN ORBit2-2.5.0.orig/test/poa/Makefile.am ORBit2-2.5.0/test/poa/Makefile.am
---- ORBit2-2.5.0.orig/test/poa/Makefile.am     Sat Oct 19 10:25:57 2002
-+++ ORBit2-2.5.0/test/poa/Makefile.am  Sat Oct 19 10:30:40 2002
-@@ -30,7 +30,7 @@
- check_PROGRAMS = $(TESTS)
--LDADD = $(top_builddir)/src/orb/libORBit-2.la $(ORBIT_LIBS)
-+LDADD = $(top_builddir)/src/orb/libORBit-2.la $(ORBIT_LIBS) -lpthread
- POATEST_IDLOUT = poatest.h poatest-common.c poatest-skels.c poatest-stubs.c
index e6fb189699d96e0e70a08223806dcb3eec11a64b..3ca2dea2da991f11092ae196461e8615b3ad5e0b 100644 (file)
@@ -1,22 +1,22 @@
 #
 # Conditional build:
-%bcond_without apidocs         # disable gtk-doc
-%bcond_without static_libs     # don't build static library
+%bcond_without apidocs         # gtk-doc based API documentation
+%bcond_without static_libs     # static libraries
 
 Summary:       High-performance CORBA Object Request Broker
 Summary(fr.UTF-8):     Requète d'Objects CORBA
 Summary(pl.UTF-8):     Wysoko wydajny CORBA Object Request Broker
 Name:          ORBit2
 Version:       2.14.19
-Release:       7
+Release:       11
 Epoch:         1
 License:       GPL v2+/LGPL v2+
 Group:         Libraries
-Source0:       http://ftp.gnome.org/pub/GNOME/sources/ORBit2/2.14/%{name}-%{version}.tar.bz2
+Source0:       https://download.gnome.org/sources/ORBit2/2.14/%{name}-%{version}.tar.bz2
 # Source0-md5: 7082d317a9573ab338302243082d10d1
-Patch0:                %{name}-pthread.patch
 Patch1:                %{name}-build-fix.patch
-URL:           http://projects.gnome.org/ORBit2/
+Patch2:                %{name}-idl-gtk-doc.patch
+URL:           https://developer.gnome.org/ORBit2/
 BuildRequires: autoconf >= 2.54
 BuildRequires: automake >= 1:1.9
 BuildRequires: docbook-dtd412-xml
@@ -27,11 +27,12 @@ BuildRequires:      indent
 BuildRequires: libIDL-devel >= 0.8.10
 BuildRequires: libtool
 BuildRequires: pkgconfig >= 1:0.18
+BuildRequires: rpm-build >= 4.6
 BuildRequires: rpmbuild(macros) >= 1.197
 Requires:      glib2 >= 1:2.14.1
 Requires:      libIDL >= 0.8.10
 Provides:      linc = 1.1.1
-Obsoletes:     ORBit2-automake
+Obsoletes:     ORBit2-automake < 1:2.12.5
 Obsoletes:     libORBit2_0
 Obsoletes:     linc
 Conflicts:     libbonobo < 2.3.2
@@ -61,9 +62,7 @@ Summary:      ORBit API documentation
 Summary(pl.UTF-8):     Dokumentacja API ORBit
 Group:         Documentation
 Requires:      gtk-doc-common
-%if "%{_rpmversion}" >= "5"
 BuildArch:     noarch
-%endif
 
 %description apidocs
 ORBit API documentation.
@@ -130,10 +129,10 @@ skonsolidowanych statycznie używających technologii CORBA.
 
 %prep
 %setup -q
-%patch0 -p1
 %patch1 -p1
+%patch2 -p1
 
-%if !%{with apidocs}
+%if %{without apidocs}
 echo 'EXTRA_DIST=' > gtk-doc.make
 echo 'AC_DEFUN([GTK_DOC_CHECK],[])' >> acinclude.m4
 %endif
@@ -157,8 +156,13 @@ rm -rf $RPM_BUILD_ROOT
 %{__make} -j1 install \
        DESTDIR=$RPM_BUILD_ROOT
 
+# obsoleted by pkg-config
+%{__rm} $RPM_BUILD_ROOT%{_libdir}/lib*.la
 # no static module - shut up check-files
-rm -f $RPM_BUILD_ROOT%{_libdir}/orbit-2.0/Everything_module.{la,a}
+%{__rm} $RPM_BUILD_ROOT%{_libdir}/orbit-2.0/Everything_module.la
+%if %{with static_libs}
+%{__rm} $RPM_BUILD_ROOT%{_libdir}/orbit-2.0/Everything_module.a
+%endif
 
 %clean
 rm -rf $RPM_BUILD_ROOT
@@ -196,9 +200,7 @@ rm -rf $RPM_BUILD_ROOT
 %attr(755,root,root) %{_libdir}/libORBit-2.so
 %attr(755,root,root) %{_libdir}/libORBit-imodule-2.so
 %attr(755,root,root) %{_libdir}/libORBitCosNaming-2.so
-%{_libdir}/libORBit-2.la
-%{_libdir}/libORBit-imodule-2.la
-%{_libdir}/libORBitCosNaming-2.la
+# static-only library
 %{_libdir}/libname-server-2.a
 %{_includedir}/orbit-2.0
 %{_pkgconfigdir}/ORBit-2.0.pc
This page took 0.085462 seconds and 4 git commands to generate.