]> git.pld-linux.org Git - packages/NuSMV.git/blame - NuSMV.spec
- fix c++ parsing issue
[packages/NuSMV.git] / NuSMV.spec
CommitLineData
5082b6a1 1#
6641397e
JR
2# Conditional build:
3%bcond_with zchaff # enable zChaff SAT Solver (zChaff is for non-commercial purposes only)
4#
5%define zchaff_ver 2008.10.12
6%define minisat_ver 070721
5082b6a1
JR
7#
8Summary: New Symbolic Model Verifier
d6427d08 9Summary(pl.UTF-8): Nowy weryfikator modeli symbolicznych
5082b6a1 10Name: NuSMV
cefc5ce4 11Version: 2.5.4
8c1f86cf 12Release: 12
5082b6a1
JR
13License: LGPL
14Group: Applications
e2c66126 15Source0: http://nusmv.fbk.eu/distrib/%{name}-%{version}.tar.gz
cefc5ce4 16# Source0-md5: 4d8ae6136fbd916d875cd48f82d5f327
6641397e
JR
17Source1: http://minisat.se/downloads/minisat2-%{minisat_ver}.zip
18# Source1-md5: fb12db9a13f86a2133758abfba239546
19Source2: http://www.princeton.edu/~chaff/zchaff/zchaff.%{zchaff_ver}.zip
20# Source2-md5: 7398b3e984a5046755cb3ef6b0e44d2e
5082b6a1 21Patch0: %{name}-build.patch
6641397e 22Patch1: %{name}-solvers.patch
cf278024 23Patch2: format-security.patch
09aa6f55 24Patch3: fork.patch
8c1f86cf 25Patch4: cxx.patch
e2c66126 26URL: http://nusmv.fbk.eu/
5082b6a1
JR
27BuildRequires: autoconf
28BuildRequires: automake
29BuildRequires: expat-devel
30BuildRequires: ghostscript
31BuildRequires: lynx
32# alternative for lynx
33#BuildRequires: links
34BuildRequires: perl-base
35BuildRequires: readline-devel
6641397e
JR
36BuildRequires: texlive-dvips
37BuildRequires: texlive-latex
38BuildRequires: texlive-latex-bibtex
39BuildRequires: texlive-latex-carlisle
40BuildRequires: texlive-latex-extend
41BuildRequires: texlive-latex-psnfss
42BuildRequires: texlive-makeindex
69f6bee2 43BuildRequires: unzip
5082b6a1
JR
44BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
45
1cbb4be0
JR
46# a lot of inter-library deps confusing install_post_check_so
47%define no_install_post_check_so 1
48
5082b6a1
JR
49%description
50NuSMV is a reimplementation and extension of SMV, the first model
51checker based on BDDs. NuSMV has been designed to be an open
52architecture for model checking, which can be reliably used for the
53verification of industrial designs, as a core for custom verification
54tools, as a testbed for formal verification techniques, and applied
55to other research areas.
56
57NuSMV2, combines BDD-based model checking component that exploits the
58CUDD library developed by Fabio Somenzi at Colorado University and
59SAT-based model checking component that includes an RBC-based Bounded
60Model Checker, connected to the SIM SAT library developed by the
61University of Genova.
62
20305e49 63%description -l pl.UTF-8
6206e484 64NuSVM to reimplementacja i rozszerzenie SMV - pierwszego weryfikatora
20305e49
JR
65modeli opartego na BDD. NuSMV został zaprojektowany w otwartej
66architekturze sprawdzania modeli, przez co może być niezawodnie
67używany do weryfikacji projektów przemysłowych, jako podstawa własnych
68narzędzi weryfikujących, jako poligon dla technik weryfikacji
69formalnej oraz stosowany w innych obszarach badań.
6206e484 70
20305e49
JR
71NuSMV2 łączy komponent sprawdzający modele oparty na BDD,
72wykorzystujący bibliotekę CUDD stworzoną przez Fabio Somenziniego w
73Colorado University i komponent sprawdzający modele oparty na SAT
74zawierający weryfikator modeli ograniczonych oparty na RBC, połączony
75z biblioteką SIM SAT stworzoną przez University of Genova.
6206e484 76
5082b6a1
JR
77%package devel
78Summary: Header files for NuSMV
d6427d08 79Summary(pl.UTF-8): Pliki nagłówkowe NuSMV
5082b6a1 80Group: Development/Libraries
6206e484 81Requires: %{name} = %{version}-%{release}
5082b6a1
JR
82
83%description devel
84This is the package containing the header files for NuSMV.
85
20305e49
JR
86%description devel -l pl.UTF-8
87Ten pakiet zawiera pliki nagłówkowe NuSMV.
5082b6a1
JR
88
89%package static
90Summary: Static NuSMV library
d6427d08 91Summary(pl.UTF-8): Statyczna biblioteka NuSMV
5082b6a1
JR
92Group: Development/Libraries
93Requires: %{name}-devel = %{version}-%{release}
94
95%description static
96Static NuSMV library.
97
20305e49 98%description static -l pl.UTF-8
5082b6a1
JR
99Statyczna biblioteka NuSMV.
100
101%prep
102%setup -q
6641397e 103install %{SOURCE1} MiniSat/
17427a19
AM
104cd MiniSat
105unzip -q *.zip
106cd ..
6641397e
JR
107install %{SOURCE2} zchaff/
108
17427a19 109%patch0 -p1
6641397e 110%patch1 -p1
cf278024 111%patch2 -p1
09aa6f55 112%patch3 -p1
8c1f86cf 113%patch4 -p1
6641397e 114
5082b6a1 115%build
1cbb4be0 116ICFLAGS="%{rpmcflags} -fPIC"
d8d91413 117export ICFLAGS
5082b6a1 118
6641397e 119cd MiniSat/
1cbb4be0 120OPTFLAGS="%{rpmcxxflags} -fPIC" COPTIMIZE="%{rpmcxxflags} -fPIC" ./build.sh
6641397e
JR
121%if %{with zchaff}
122cd ../zchaff
1cbb4be0 123OPTFLAGS="%{rpmcxxflags} -fPIC" ./build.sh
6641397e
JR
124%endif
125cd ../cudd-*
25a3234b 126%ifarch %{x8664}
74c2172a
JR
127cp -f Makefile Makefile_32bit
128cp -f Makefile_64bit Makefile
25a3234b 129%endif
6641397e
JR
130%{__make}
131cd ..
25a3234b 132
74c2172a
JR
133cd nusmv
134
1cbb4be0
JR
135%{__libtoolize}
136%{__aclocal} -I m4
137%{__autoconf}
138%{__automake}
139%configure \
5082b6a1 140 --enable-shared \
6641397e
JR
141 %{?with_zchaff:--enable-zchaff} \
142 --enable-minisat
143
5082b6a1 144%{__make}
1cbb4be0 145
34c4f2ed 146%{__make} -j1 docs
5082b6a1
JR
147
148%install
149rm -rf $RPM_BUILD_ROOT
150install -d $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}
151
306c78b8 152%{__make} -j1 -C nusmv install \
1cbb4be0
JR
153 INSTALL_DATA="cp -a" \
154 INSTALL_HEADER="install -p" \
5082b6a1
JR
155 DESTDIR=$RPM_BUILD_ROOT
156
157cp -a nusmv/examples/* $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}
158
1cbb4be0
JR
159%{__rm} -r $RPM_BUILD_ROOT%{_datadir}/nusmv/{doc,examples,LGPL*,NEWS,README*}
160%{__rm} -r $RPM_BUILD_ROOT%{_libdir}/*.la
6641397e 161
5082b6a1
JR
162%clean
163rm -rf $RPM_BUILD_ROOT
164
165%post -p /sbin/ldconfig
166%postun -p /sbin/ldconfig
167
168%files
169%defattr(644,root,root,755)
170%doc nusmv/{AUTHORS,ChangeLog,NEWS,README*}
171%doc nusmv/doc/tutorial/tutorial.p*
172%doc nusmv/doc/user-man/nusmv.p*
173%doc nusmv/doc/html
174%attr(755,root,root) %{_bindir}/*
65c2d833 175%attr(755,root,root) %{_libdir}/lib*smv*.so.*.*.*
2ef2bad5
JR
176%attr(755,root,root) %ghost %{_libdir}/lib*smv*.so.0
177%attr(755,root,root) %{_libdir}/librbcdag.so.*.*.*
178%attr(755,root,root) %ghost %{_libdir}/librbcdag.so.0
5082b6a1
JR
179%dir %{_datadir}/nusmv
180%{_datadir}/nusmv/contrib
181%{_datadir}/nusmv/help
182%{_datadir}/nusmv/master.nusmvrc
183%{_examplesdir}/%{name}-%{version}
184
185%files devel
186%defattr(644,root,root,755)
65c2d833 187%attr(755,root,root) %{_libdir}/lib*smv*.so
2ef2bad5 188%attr(755,root,root) %{_libdir}/librbcdag.so
5082b6a1
JR
189%{_includedir}/cudd*
190%{_includedir}/nusmv
6206e484 191%{_pkgconfigdir}/*
5082b6a1
JR
192
193%files static
194%defattr(644,root,root,755)
65c2d833 195%attr(755,root,root) %{_libdir}/lib*smv*.a
2ef2bad5 196%attr(755,root,root) %{_libdir}/librbcdag.a
This page took 0.095335 seconds and 4 git commands to generate.