]> git.pld-linux.org Git - packages/NetworkManager.git/commitdiff
- added patch from debian for "nmcli con" problem
authorSzymon Siwek <sls@pld-linux.org>
Thu, 14 Jun 2012 08:56:54 +0000 (08:56 +0000)
committercvs2git <feedback@pld-linux.org>
Sun, 24 Jun 2012 12:13:13 +0000 (12:13 +0000)
Changed files:
    11-initialize-nm-remote-settings.patch -> 1.1
    NetworkManager.spec -> 1.112

11-initialize-nm-remote-settings.patch [new file with mode: 0644]
NetworkManager.spec

diff --git a/11-initialize-nm-remote-settings.patch b/11-initialize-nm-remote-settings.patch
new file mode 100644 (file)
index 0000000..fff4194
--- /dev/null
@@ -0,0 +1,27 @@
+commit dd0460697c4e281fe277b53916d5251332e1aafc
+Author: Jiří Klimeš <jklimes@redhat.com>
+Date:   Tue Mar 27 22:36:55 2012 +0200
+
+    libnm-glib: initialize NMRemoteSettings in nm_remote_settings_new() (rh #806664)
+    
+    The object was not initialized after creation in nm_remote_settings_new(). This
+    was a regression caused by 762df85234e7a042a2a5d31053e6cc273ae3e2ec.
+
+diff --git a/libnm-glib/nm-remote-settings.c b/libnm-glib/nm-remote-settings.c
+index 8f213f9..b6b6c18 100644
+--- a/libnm-glib/nm-remote-settings.c
++++ b/libnm-glib/nm-remote-settings.c
+@@ -728,7 +728,12 @@ properties_changed_cb (DBusGProxy *proxy,
+ NMRemoteSettings *
+ nm_remote_settings_new (DBusGConnection *bus)
+ {
+-      return g_object_new (NM_TYPE_REMOTE_SETTINGS, NM_REMOTE_SETTINGS_BUS, bus, NULL);
++      NMRemoteSettings *settings;
++
++      settings = g_object_new (NM_TYPE_REMOTE_SETTINGS, NM_REMOTE_SETTINGS_BUS, bus, NULL);
++
++      _nm_remote_settings_ensure_inited (settings);
++      return settings;
+ }
+ static void
index 6138466c9763c7830aae5998c612047c07dd2766..7f0c268008016790209d3f2612b0c3de0a3ee8e7 100644 (file)
@@ -20,6 +20,7 @@ Patch0:               %{name}-pld.patch
 Patch1:                ifcfg-path.patch
 Patch2:                systemd-fallback.patch
 Patch3:                llh340.patch
+Patch4:                11-initialize-nm-remote-settings.patch
 URL:           http://projects.gnome.org/NetworkManager/
 BuildRequires: autoconf >= 2.63
 BuildRequires: automake >= 1:1.10
@@ -139,6 +140,7 @@ Statyczne biblioteki Network Managera.
 %patch1 -p1
 %{?with_systemd:%patch2 -p1}
 %patch3 -p1
+%patch4 -p1
 
 %build
 %{__gtkdocize}
This page took 0.199255 seconds and 4 git commands to generate.