]> git.pld-linux.org Git - packages/Mesa.git/commitdiff
i965 fix for galaxy view in Stellaris auto/th/Mesa-17.1.2-2
authorJacek Konieczny <jajcus@jajcus.net>
Sat, 17 Jun 2017 13:57:47 +0000 (15:57 +0200)
committerJacek Konieczny <jajcus@jajcus.net>
Sat, 17 Jun 2017 14:01:51 +0000 (16:01 +0200)
Patch from:
https://patchwork.freedesktop.org/patch/162171/

Release: 2

Mesa.spec
i965_ignore_anisotropic_filtering_in_nearest_mode.patch [new file with mode: 0644]

index 8306cfbadf2d8a0c4d19471b460f9d099ee618b1..316810dd5f4937281f4ce153e6e04102c20ded0f 100644 (file)
--- a/Mesa.spec
+++ b/Mesa.spec
@@ -64,12 +64,13 @@ Summary:    Free OpenGL implementation
 Summary(pl.UTF-8):     WolnodostÄ™pna implementacja standardu OpenGL
 Name:          Mesa
 Version:       17.1.2
-Release:       1
+Release:       2
 License:       MIT (core) and others - see license.html file
 Group:         X11/Libraries
 Source0:       ftp://ftp.freedesktop.org/pub/mesa/mesa-%{version}.tar.xz
 # Source0-md5: 4d2eaf5955740b044afd95ed167c906c
 Patch0:                %{name}-link.patch
+Patch1:                i965_ignore_anisotropic_filtering_in_nearest_mode.patch
 URL:           http://www.mesa3d.org/
 BuildRequires: autoconf >= 2.60
 BuildRequires: automake
@@ -1267,6 +1268,7 @@ radv - eksperymentalny sterownik Vulkan dla GPU firmy AMD.
 %prep
 %setup -q -n mesa-%{version}
 %patch0 -p1
+%patch1 -p1
 
 %build
 %{__libtoolize}
diff --git a/i965_ignore_anisotropic_filtering_in_nearest_mode.patch b/i965_ignore_anisotropic_filtering_in_nearest_mode.patch
new file mode 100644 (file)
index 0000000..2a9482b
--- /dev/null
@@ -0,0 +1,16 @@
+diff -dur -x '*~' -x '*.orig' -x '*.rej' mesa-17.1.2.orig/src/mesa/drivers/dri/i965/brw_sampler_state.c mesa-17.1.2/src/mesa/drivers/dri/i965/brw_sampler_state.c
+--- mesa-17.1.2.orig/src/mesa/drivers/dri/i965/brw_sampler_state.c     2017-06-05 23:09:09.000000000 +0200
++++ mesa-17.1.2/src/mesa/drivers/dri/i965/brw_sampler_state.c  2017-06-17 16:01:16.890619847 +0200
+@@ -450,8 +450,10 @@
+    /* Enable anisotropic filtering if desired. */
+    unsigned max_anisotropy = BRW_ANISORATIO_2;
+    if (sampler->MaxAnisotropy > 1.0f) {
+-      min_filter = BRW_MAPFILTER_ANISOTROPIC;
+-      mag_filter = BRW_MAPFILTER_ANISOTROPIC;
++      if (min_filter == BRW_MAPFILTER_LINEAR)
++         min_filter = BRW_MAPFILTER_ANISOTROPIC;
++      if (mag_filter == BRW_MAPFILTER_LINEAR)
++         mag_filter = BRW_MAPFILTER_ANISOTROPIC;
+       if (sampler->MaxAnisotropy > 2.0f) {
+        max_anisotropy =
This page took 0.037565 seconds and 4 git commands to generate.