]> git.pld-linux.org Git - packages/Mesa.git/blobdiff - Mesa.spec
- up to 11.0.4
[packages/Mesa.git] / Mesa.spec
index dd54d0db0d53d72d35d5722b3c0223fd294039aa..e157d4e8d0812576984b339f26e055e272839d03 100644 (file)
--- a/Mesa.spec
+++ b/Mesa.spec
@@ -2,6 +2,7 @@
 # TODO:
 # - check if gallium_intel note is still valid, switch the bcond if not
 # - consider:
+# - ARM drivers (ilo,freedreno,vc4)?
 # - subpackage with non-dri libGL for use with X-servers with missing GLX extension?
 # - resurrect static if it's useful (using plain xorg target? DRI doesn't support static)
 #
 %bcond_without gallium         # gallium drivers
 %bcond_with    gallium_intel   # gallium i915 driver (instead of plain dri; doesn't work with AIGLX)
 %bcond_without gallium_nouveau # gallium nouveau driver
+%bcond_without gallium_radeon  # gallium radeon drivers
 %bcond_without egl             # EGL libraries
+%bcond_with    openvg          # OpenVG library [not builind since 10.4, dropped in 10.6]
 %bcond_without gbm             # Graphics Buffer Manager
-%bcond_without opencl          # OpenCL library
+%bcond_without nine            # Nine Direct3D 9+ state tracker (for Wine)
+%bcond_without opencl          # OpenCL support
+%bcond_without ocl_icd         # OpenCL as ICD (installable client driver)
+%bcond_without omx             # OpenMAX (Bellagio OMXIL) support
+%bcond_without va              # VA library
 %bcond_without wayland         # Wayland EGL
 %bcond_without xa              # XA state tracker (for vmwgfx xorg driver)
+%bcond_with    texture_float   # floating-point textures and renderbuffers (SGI patent in US)
 %bcond_with    static_libs     # static libraries [not supported for DRI, thus broken currently]
 %bcond_with    tests           # tests
 #
 # minimal supported xserver version
 %define                xserver_ver             1.5.0
 # other packages
-%define                libdrm_ver              2.4.52
+%define                libdrm_ver              2.4.60
 %define                dri2proto_ver           2.6
 %define                dri3proto_ver           1.0
 %define                glproto_ver             1.4.14
 %define                presentproto_ver        1.0
 
+%if %{without gallium}
+%undefine      with_gallium_intel
+%undefine      with_gallium_nouveau
+%undefine      with_gallium_radeon
+%undefine      with_nine
+%undefine      with_ocl_icd
+%undefine      with_omx
+%undefine      with_opencl
+%undefine      with_xa
+%endif
+
+%if %{without egl}
+%undefine      with_gbm
+%undefine      with_wayland
+%endif
+
 Summary:       Free OpenGL implementation
 Summary(pl.UTF-8):     Wolnodostępna implementacja standardu OpenGL
 Name:          Mesa
-Version:       10.1.0
+Version:       11.0.4
 Release:       1
 License:       MIT (core) and others - see license.html file
 Group:         X11/Libraries
-Source0:       ftp://ftp.freedesktop.org/pub/mesa/10.1/%{name}Lib-%{version}.tar.bz2
-# Source0-md5: 3ec43f79dbcd9aa2a4a27bf1f51655b6
-Patch0:                %{name}-link.patch
+Source0:       ftp://ftp.freedesktop.org/pub/mesa/%{version}/mesa-%{version}.tar.xz
+# Source0-md5: c92c37200009eceaab4898119f82e358
+Patch0:                missing-type.patch
+Patch1:                x32.patch
 URL:           http://www.mesa3d.org/
 BuildRequires: autoconf >= 2.60
 BuildRequires: automake
 %{?with_opencl:BuildRequires:  clang-devel >= 3.1}
+BuildRequires: elfutils-devel
 BuildRequires: expat-devel
-BuildRequires: gcc >= 5:3.3
+BuildRequires: gcc >= 6:4.2.0
 %{?with_opencl:BuildRequires:  gcc-c++ >= 6:4.7}
 BuildRequires: libdrm-devel >= %{libdrm_ver}
 BuildRequires: libselinux-devel
-BuildRequires: libstdc++-devel >= 5:3.3.0
+BuildRequires: libstdc++-devel >= 6:4.2.0
 BuildRequires: libtalloc-devel >= 2:2.0.1
 BuildRequires: libtool >= 2:2.2
+%{?with_va:BuildRequires:      libva-devel >= 1.3.0}
+%{?with_va:BuildRequires:      pkgconfig(libva) >= 0.35.0}
 BuildRequires: libvdpau-devel >= 0.4.1
 BuildRequires: libxcb-devel >= 1.10
-BuildRequires: llvm-devel >= 3.3
+%{?with_gallium_radeon:BuildRequires:  llvm-devel >= 3.4.2}
 %{?with_opencl:BuildRequires:  llvm-libclc}
+# for SHA1 (could use also libmd/libsha1/libgcrypt/openssl instead)
+BuildRequires: nettle-devel
+%{?with_ocl_icd:BuildRequires: ocl-icd-devel}
+%{?with_omx:BuildRequires:     libomxil-bellagio-devel}
 BuildRequires: perl-base
 BuildRequires: pixman-devel
 BuildRequires: pkgconfig
@@ -63,7 +95,7 @@ BuildRequires:        pkgconfig(talloc) >= 2.0.1
 BuildRequires: pkgconfig(xcb-dri3)
 BuildRequires: pkgconfig(xcb-present)
 BuildRequires: python >= 2
-BuildRequires: python-libxml2
+BuildRequires: python-Mako >= 0.3.4
 BuildRequires: python-modules >= 2
 BuildRequires: rpmbuild(macros) >= 1.470
 BuildRequires: sed >= 4.0
@@ -76,31 +108,18 @@ BuildRequires:     xorg-lib-libXfixes-devel
 BuildRequires: xorg-lib-libXt-devel
 BuildRequires: xorg-lib-libXvMC-devel >= 1.0.6
 BuildRequires: xorg-lib-libXxf86vm-devel
-BuildRequires: xorg-lib-libxshmfence-devel
+BuildRequires: xorg-lib-libxshmfence-devel >= 1.1
 BuildRequires: xorg-proto-dri2proto-devel >= %{dri2proto_ver}
 BuildRequires: xorg-proto-dri3proto-devel >= %{dri3proto_ver}
 BuildRequires: xorg-proto-glproto-devel >= %{glproto_ver}
 BuildRequires: xorg-proto-presentproto-devel >= %{presentproto_ver}
 BuildRequires: xorg-util-makedepend
-BuildRequires: xorg-xserver-server-devel >= %{xserver_ver}
 %if %{with gallium}
 BuildRequires: xorg-proto-xextproto-devel >= 7.0.99.1
-BuildRequires: xorg-xserver-server-devel >= 1.6.0
+BuildRequires: xorg-xserver-server-devel >= %{xserver_ver}
 %endif
 BuildRoot:     %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
 
-%if %{without gallium}
-%undefine      with_gallium_intel
-%undefine      with_gallium_nouveau
-%undefine      with_opencl
-%undefine      with_xa
-%endif
-
-%if %{without egl}
-%undefine      with_gbm
-%undefine      with_wayland
-%endif
-
 # libGLESv1_CM, libGLESv2, libGL, libOSMesa:
 #  _glapi_tls_Dispatch is defined in libglapi, but it's some kind of symbol ldd -r doesn't notice(?)
 # libgbm: circular dependency with libEGL (wayland_buffer_is_drm symbol)
@@ -136,8 +155,6 @@ Requires:   libdrm >= %{libdrm_ver}
 Requires:      libxcb >= 1.9
 %{?with_wayland:Requires:      wayland >= 1.2.0}
 %if %{with gallium}
-# for egl_gallium.so
-Requires:      %{name}-libOpenVG = %{version}-%{release}
 Requires:      udev-libs >= 1:151
 %endif
 %if %{with gbm}
@@ -166,7 +183,7 @@ Requires:   %{name}-libEGL = %{version}-%{release}
 Requires:      libdrm-devel >= %{libdrm_ver}
 Requires:      xorg-lib-libX11-devel
 Requires:      xorg-lib-libXdamage-devel
-Requires:      xorg-lib-libXext-devel
+Requires:      xorg-lib-libXext-devel >= 1.0.5
 Requires:      xorg-lib-libXfixes-devel
 Requires:      xorg-lib-libXxf86vm-devel
 Requires:      xorg-proto-dri2proto-devel >= %{dri2proto_ver}
@@ -239,7 +256,7 @@ Requires:   OpenGL >= 1.5
 Requires:      libdrm-devel >= %{libdrm_ver}
 Requires:      xorg-lib-libX11-devel
 Requires:      xorg-lib-libXdamage-devel
-Requires:      xorg-lib-libXext-devel
+Requires:      xorg-lib-libXext-devel >= 1.0.5
 Requires:      xorg-lib-libXxf86vm-devel
 Requires:      xorg-proto-dri2proto-devel >= %{dri2proto_ver}
 Requires:      xorg-proto-glproto-devel >= %{glproto_ver}
@@ -361,6 +378,39 @@ Static OSMesa (off-screen renderer) library.
 %description libOSMesa-static -l pl.UTF-8
 Biblioteka statyczna OSMesa (renderująca bitmapy w pamięci).
 
+%package OpenCL-icd
+Summary:       Mesa implementation of OpenCL (Compuing Language) API ICD
+Summary(pl.UTF-8):     Implementacja Mesa API OpenCL (języka obliczeń) ICD
+License:       MIT
+Group:         Libraries
+Requires:      filesystem >= 4.0-29
+Requires:      libdrm >= %{libdrm_ver}
+Requires:      llvm-libclc
+Requires:      udev-libs >= 1:151
+Provides:      OpenCL = 1.1
+Provides:      ocl-icd-driver
+
+%description OpenCL-icd
+This package contains Mesa implementation of OpenCL - standard for
+cross-platform, parallel programming of modern processors found in
+personal computers, servers and handheld/embedded devices. OpenCL
+specification can be found on Khronos Group site:
+<http://www.khronos.org/opencl/>. Mesa implements OpenCL 1.1.
+
+The implementation is provided as an installable client driver (ICD)
+for use with the ocl-icd loader.
+
+%description OpenCL-icd -l pl.UTF-8
+Ten pakiet zawiera implementację Mesa standardu OpenCL - standardu
+wieloplatformowego, równoległego programowania nowoczesnych
+procesorów, jakie znajdują się w komputerach osobistych, serwerach
+oraz urządzeniach przenośnych/wbudowanych. Specyfikację OpenCL można
+znaleźć na stronie Khronos Group: <http://www.khronos.org/opencl/>.
+Mesa zawiera implementację OpenCL w wersji 1.1.
+
+Implementacja dostarczona jest w postaci instalowalnego sterownika klienta
+(ICD), który może być użyty z loaderem ocl-icd.
+
 %package libOpenCL
 Summary:       Mesa implementation of OpenCL (Compuing Language) API
 Summary(pl.UTF-8):     Implementacja Mesa API OpenCL (języka obliczeń)
@@ -469,6 +519,18 @@ R600/R700 chips.
 Implementacja Mesa API XvMC dla kart ATI Radeon opartych na układach
 R600/R700.
 
+%package -n libva-driver-gallium
+Summary:       VA driver for Gallium State Tracker
+Summary(pl.UTF-8):     Sterownik VA do Gallium
+Group:         Libraries
+Requires:      libva >= 1.3.0
+
+%description -n libva-driver-gallium
+VA driver for Gallium State Tracker.
+
+%description -n libva-driver-gallium -l pl.UTF-8
+Sterownik VA do Gallium.
+
 %package libgbm
 Summary:       Mesa Graphics Buffer Manager library
 Summary(pl.UTF-8):     Biblioteka Mesa Graphics Buffer Manager
@@ -845,6 +907,30 @@ X.org DRI driver for VMWare.
 %description dri-driver-vmwgfx -l pl.UTF-8
 Sterownik X.org DRI dla VMware.
 
+%package d3d
+Summary:       Nine Direct3D9 driver (for Wine)
+Summary(pl.UTF-8):     Sterownik Direct3D9 Nine (dla Wine)
+Group:         Libraries
+Requires:      libdrm >= %{libdrm_ver}
+
+%description d3d
+Nine Direct3D9 driver (for Wine).
+
+%description d3d -l pl.UTF-8
+Sterownik Direct3D9 Nine (dla Wine).
+
+%package d3d-devel
+Summary:       Nine Direct3D9 driver API
+Summary(pl.UTF-8):     API sterownika Direct3D9 Nine
+Group:         Development/Libraries
+Requires:      libdrm-devel >= %{libdrm_ver}
+
+%description d3d-devel
+Nine Direct3D9 driver API.
+
+%description d3d-devel -l pl.UTF-8
+API sterownika Direct3D9 Nine.
+
 %package -n libvdpau-driver-mesa-nouveau
 Summary:       Mesa nouveau driver for the vdpau API
 Summary(pl.UTF-8):     Sterownik Mesa nouveau dla API vdpau
@@ -862,6 +948,23 @@ Mesa nouveau driver for the vdpau API. It supports NVidia adapters
 Sterownik Mesa nouveau dla API vdpau. Obsługuje karty NVidia
 (NV40-NV96, NVa0).
 
+%package -n libvdpau-driver-mesa-r300
+Summary:       Mesa r300 driver for the vdpau API
+Summary(pl.UTF-8):     Sterownik Mesa r300 dla API vdpau
+License:       MIT
+Group:         X11/Libraries
+Requires:      libdrm >= %{libdrm_ver}
+Requires:      libvdpau >= 0.4.1
+Conflicts:     libvdpau-driver-mesa
+
+%description -n libvdpau-driver-mesa-r300
+Mesa r300 driver for the vdpau API. It supports ATI Radeon adapters
+based on R300 chips.
+
+%description -n libvdpau-driver-mesa-r300 -l pl.UTF-8
+Sterownik Mesa r300 dla API vdpau. Obsługuje karty ATI Radeon oparte
+na układach R300.
+
 %package -n libvdpau-driver-mesa-r600
 Summary:       Mesa r600 driver for the vdpau API
 Summary(pl.UTF-8):     Sterownik Mesa r600 dla API vdpau
@@ -897,9 +1000,79 @@ adapters based on Southern Islands chips.
 Sterownik Mesa radeonsi dla API vdpau. Obsługuje karty ATI Radeon
 oparte na układach Southern Islands.
 
+%package -n omxil-mesa
+Summary:       Mesa driver for Bellagio OpenMAX IL API
+Summary(pl.UTF-8):     Sterownik Mesa nouveau dla API Bellagio OpenMAX IL
+License:       MIT
+Group:         X11/Libraries
+Requires:      libdrm >= %{libdrm_ver}
+Requires:      libxcb >= 1.8
+Requires:      libomxil-bellagio
+Obsoletes:     omxil-mesa-nouveau
+Obsoletes:     omxil-mesa-r600
+Obsoletes:     omxil-mesa-radeonsi
+
+%description -n omxil-mesa
+Mesa driver for Bellagio OpenMAX IL API.
+
+%description -n omxil-mesa -l pl.UTF-8
+Sterownik Mesa dla API Bellagio OpenMAX IL.
+
+%package -n omxil-mesa-nouveau
+Summary:       Mesa nouveau driver for Bellagio OpenMAX IL API
+Summary(pl.UTF-8):     Sterownik Mesa nouveau dla API Bellagio OpenMAX IL
+License:       MIT
+Group:         X11/Libraries
+Requires:      libdrm >= %{libdrm_ver}
+Requires:      libxcb >= 1.8
+Requires:      libomxil-bellagio
+
+%description -n omxil-mesa-nouveau
+Mesa nouveau driver for Bellagio OpenMAX IL API. It supports NVidia
+adapters (NV40-NV96, NVa0).
+
+%description -n omxil-mesa-nouveau -l pl.UTF-8
+Sterownik Mesa nouveau dla API Bellagio OpenMAX IL. Obsługuje karty
+NVidia (NV40-NV96, NVa0).
+
+%package -n omxil-mesa-r600
+Summary:       Mesa r600 driver for Bellagio OpenMAX IL API
+Summary(pl.UTF-8):     Sterownik Mesa r600 dla API Bellagio OpenMAX IL
+License:       MIT
+Group:         X11/Libraries
+Requires:      libdrm >= %{libdrm_ver}
+Requires:      libxcb >= 1.8
+Requires:      libomxil-bellagio
+
+%description -n omxil-mesa-r600
+Mesa r600 driver for Bellagio OpenMAX IL API. It supports ATI Radeon
+adapters based on R600/R700 chips.
+
+%description -n omxil-mesa-r600 -l pl.UTF-8
+Sterownik Mesa r600 dla API Bellagio OpenMAX IL. Obsługuje karty ATI
+Radeon oparte na układach R600/R700.
+
+%package -n omxil-mesa-radeonsi
+Summary:       Mesa radeonsi driver for Bellagio OpenMAX IL API
+Summary(pl.UTF-8):     Sterownik Mesa radeonsi dla API Bellagio OpenMAX IL
+License:       MIT
+Group:         X11/Libraries
+Requires:      libdrm >= %{libdrm_ver}
+Requires:      libxcb >= 1.8
+Requires:      libomxil-bellagio
+
+%description -n omxil-mesa-radeonsi
+Mesa radeonsi driver for Bellagio OpenMAX IL API. It supports ATI
+Radeon adapters based on Southern Islands chips.
+
+%description -n omxil-mesa-radeonsi -l pl.UTF-8
+Sterownik Mesa radeonsi dla API Bellagio OpenMAX IL. Obsługuje karty
+ATI Radeon oparte na układach Southern Islands.
+
 %prep
-%setup -q
+%setup -q -n mesa-%{version}
 %patch0 -p1
+%patch1 -p1
 
 %build
 %{__libtoolize}
@@ -924,9 +1097,11 @@ gallium_drivers="svga swrast \
 %if %{with gallium_intel}
 i915 \
 %endif
+%if %{with gallium_radeon}
 r300 \
 r600 \
 radeonsi \
+%endif
 %if %{with gallium_nouveau}
 nouveau
 %endif
@@ -936,13 +1111,14 @@ gallium_drivers=$(echo $gallium_drivers | xargs | tr ' ' ',')
 
 %configure \
        --disable-silent-rules \
-       --enable-shared \
-       --enable-glx-tls \
-       --enable-selinux \
-       %{?with_static_libs:--enable-static} \
        %{__enable gbm} \
+       --enable-glx-tls \
        --enable-osmesa \
+       --enable-selinux \
+       --enable-shared \
        --enable-shared-glapi \
+       %{?with_static_libs:--enable-static} \
+       %{?with_texture_float:--enable-texture-float} \
 %if %{with egl}
        --enable-egl \
        --enable-gles1 \
@@ -951,12 +1127,14 @@ gallium_drivers=$(echo $gallium_drivers | xargs | tr ' ' ',')
 %endif
 %if %{with gallium}
        --enable-gallium-llvm \
-       --with-llvm-shared-libs \
+       --enable-llvm-shared-libs \
        %{__enable egl gallium-egl} \
        %{__enable gbm gallium-gbm} \
-       %{?with_opencl:--enable-opencl} \
-       %{?with_egl:--enable-openvg} \
+       %{__enable ocl_icd opencl-icd} \
+       %{?with_nine:--enable-nine} \
+       %{__enable opencl} \
        --enable-vdpau \
+       %{?with_omx:--enable-omx} \
        %{?with_xa:--enable-xa} \
        --enable-xvmc \
        --with-gallium-drivers=${gallium_drivers} \
@@ -964,7 +1142,9 @@ gallium_drivers=$(echo $gallium_drivers | xargs | tr ' ' ',')
        --without-gallium-drivers \
 %endif
        --with-dri-drivers=${dri_drivers} \
-       --with-dri-driverdir=%{_libdir}/xorg/modules/dri
+       --with-dri-driverdir=%{_libdir}/xorg/modules/dri \
+       --with-sha1=libnettle \
+       --with-va-libdir=%{_libdir}/libva/dri
 
 %{__make}
 
@@ -977,19 +1157,21 @@ rm -rf $RPM_BUILD_ROOT
        DESTDIR=$RPM_BUILD_ROOT
 
 # strip out undesirable headers
-%{__rm} $RPM_BUILD_ROOT%{_includedir}/GL/{wglext,wmesa}.h
+%{__rm} $RPM_BUILD_ROOT%{_includedir}/GL/wglext.h
 # dlopened by soname
-%{__rm} $RPM_BUILD_ROOT%{_libdir}/libXvMC*.so
+%{?with_gallium:%{__rm} $RPM_BUILD_ROOT%{_libdir}/libXvMC*.so}
+%{?with_gallium:%{__rm} $RPM_BUILD_ROOT%{_libdir}/libXvMC*.so.1.0}
+# dlopened by soname or .so link
+%{?with_gallium:%{__rm} $RPM_BUILD_ROOT%{_libdir}/vdpau/libvdpau_*.so.1.0}
 # not used externally
 %{__rm} $RPM_BUILD_ROOT%{_libdir}/libglapi.so
 # dlopened
-%{__rm} $RPM_BUILD_ROOT%{_libdir}/egl/egl_*.la
-%{__rm} $RPM_BUILD_ROOT%{_libdir}/gallium-pipe/pipe_*.la
-%{__rm} $RPM_BUILD_ROOT%{_libdir}/gbm/gbm_*.la
-%{__rm} $RPM_BUILD_ROOT%{_libdir}/vdpau/libvdpau_*.la
-%{__rm} $RPM_BUILD_ROOT%{_libdir}/xorg/modules/dri/*.la
+%{?with_omx:%{__rm} $RPM_BUILD_ROOT%{_libdir}/bellagio/libomx_*.la}
+%{?with_nine:%{__rm} $RPM_BUILD_ROOT%{_libdir}/d3d/d3dadapter9.la}
+%{?with_gallium:%{__rm} $RPM_BUILD_ROOT%{_libdir}/gallium-pipe/pipe_*.la}
 # not defined by standards; and not needed, there is pkg-config support
 %{__rm} $RPM_BUILD_ROOT%{_libdir}/lib*.la
+%{?with_gallium:%{__rm} $RPM_BUILD_ROOT%{_libdir}/libva/dri/gallium_drv_video.la}
 
 # remove "OS ABI: Linux 2.4.20" tag, so private copies (nvidia or fglrx),
 # set up via /etc/ld.so.conf.d/*.conf will be preferred over this
@@ -1038,10 +1220,6 @@ rm -rf $RPM_BUILD_ROOT
 %defattr(644,root,root,755)
 %attr(755,root,root) %{_libdir}/libEGL.so.*.*
 %attr(755,root,root) %ghost %{_libdir}/libEGL.so.1
-%if %{with gallium}
-%dir %{_libdir}/egl
-%attr(755,root,root) %{_libdir}/egl/egl_gallium.so
-%endif
 
 %files libEGL-devel
 %defattr(644,root,root,755)
@@ -1049,6 +1227,7 @@ rm -rf $RPM_BUILD_ROOT
 %dir %{_includedir}/EGL
 %{_includedir}/EGL/egl.h
 %{_includedir}/EGL/eglext.h
+%{_includedir}/EGL/eglextchromium.h
 %{_includedir}/EGL/eglmesaext.h
 %{_includedir}/EGL/eglplatform.h
 %{_pkgconfigdir}/egl.pc
@@ -1062,7 +1241,7 @@ rm -rf $RPM_BUILD_ROOT
 
 %files libGL
 %defattr(644,root,root,755)
-%doc docs/{*.html,README.UVD,relnotes/*.html}
+%doc docs/{*.html,README.UVD,patents.txt,relnotes/*.html}
 %attr(755,root,root) %{_libdir}/libGL.so.*.*
 %attr(755,root,root) %ghost %{_libdir}/libGL.so.1
 # symlink for binary apps which fail to conform Linux OpenGL ABI
@@ -1075,6 +1254,7 @@ rm -rf $RPM_BUILD_ROOT
 %doc docs/specs/*
 %dir %{_includedir}/GL
 %{_includedir}/GL/gl.h
+%{_includedir}/GL/glcorearb.h
 %{_includedir}/GL/glext.h
 %{_includedir}/GL/gl_mangle.h
 %{_includedir}/GL/glx.h
@@ -1126,6 +1306,14 @@ rm -rf $RPM_BUILD_ROOT
 %endif
 
 %if %{with opencl}
+%if %{with ocl_icd}
+%files OpenCL-icd
+%defattr(644,root,root,755)
+/etc/OpenCL/vendors/mesa.icd
+%attr(755,root,root) %{_libdir}/libMesaOpenCL.so
+%attr(755,root,root) %{_libdir}/libMesaOpenCL.so.*.*.*
+%attr(755,root,root) %ghost %{_libdir}/libMesaOpenCL.so.1
+%else
 %files libOpenCL
 %defattr(644,root,root,755)
 %attr(755,root,root) %{_libdir}/libOpenCL.so.*.*.*
@@ -1136,8 +1324,9 @@ rm -rf $RPM_BUILD_ROOT
 %attr(755,root,root) %{_libdir}/libOpenCL.so
 %{_includedir}/CL
 %endif
+%endif
 
-%if %{with egl} && %{with gallium}
+%if %{with egl} && %{with openvg} && %{with gallium}
 %files libOpenVG
 %defattr(644,root,root,755)
 %attr(755,root,root) %{_libdir}/libOpenVG.so.*.*.*
@@ -1158,21 +1347,27 @@ rm -rf $RPM_BUILD_ROOT
 %attr(755,root,root) %ghost %{_libdir}/libXvMCnouveau.so.1
 %endif
 
+%if %{with gallium_radeon}
 %files libXvMC-r600
 %defattr(644,root,root,755)
 %attr(755,root,root) %{_libdir}/libXvMCr600.so.1.0.0
 %attr(755,root,root) %ghost %{_libdir}/libXvMCr600.so.1
 %endif
 
+%if %{with va}
+%files -n libva-driver-gallium
+%defattr(644,root,root,755)
+%attr(755,root,root) %{_libdir}/libva/dri/gallium_drv_video.so
+%endif
+%endif
+
 %if %{with gbm}
 %files libgbm
 %defattr(644,root,root,755)
 %attr(755,root,root) %{_libdir}/libgbm.so.*.*
 %attr(755,root,root) %ghost %{_libdir}/libgbm.so.1
 %if %{with gallium}
-%dir %{_libdir}/gbm
 %dir %{_libdir}/gallium-pipe
-%attr(755,root,root) %{_libdir}/gbm/gbm_gallium_drm.so
 %endif
 
 %files libgbm-devel
@@ -1195,6 +1390,7 @@ rm -rf $RPM_BUILD_ROOT
 %attr(755,root,root) %{_libdir}/gallium-pipe/pipe_nouveau.so
 %endif
 
+%if %{with gallium_radeon}
 %files gbm-driver-r300
 %defattr(644,root,root,755)
 %attr(755,root,root) %{_libdir}/gallium-pipe/pipe_r300.so
@@ -1206,6 +1402,7 @@ rm -rf $RPM_BUILD_ROOT
 %files gbm-driver-radeonsi
 %defattr(644,root,root,755)
 %attr(755,root,root) %{_libdir}/gallium-pipe/pipe_radeonsi.so
+%endif
 
 %files gbm-driver-swrast
 %defattr(644,root,root,755)
@@ -1266,6 +1463,7 @@ rm -rf $RPM_BUILD_ROOT
 %attr(755,root,root) %{_libdir}/xorg/modules/dri/r200_dri.so
 
 %if %{with gallium}
+%if %{with gallium_radeon}
 %files dri-driver-ati-radeon-R300
 %defattr(644,root,root,755)
 %attr(755,root,root) %{_libdir}/xorg/modules/dri/r300_dri.so
@@ -1273,11 +1471,12 @@ rm -rf $RPM_BUILD_ROOT
 %files dri-driver-ati-radeon-R600
 %defattr(644,root,root,755)
 %attr(755,root,root) %{_libdir}/xorg/modules/dri/r600_dri.so
-%endif
 
 %files dri-driver-ati-radeon-SI
 %defattr(644,root,root,755)
 %attr(755,root,root) %{_libdir}/xorg/modules/dri/radeonsi_dri.so
+%endif
+%endif
 
 %files dri-driver-intel-i915
 %defattr(644,root,root,755)
@@ -1296,6 +1495,9 @@ rm -rf $RPM_BUILD_ROOT
 
 %files dri-driver-swrast
 %defattr(644,root,root,755)
+%if %{with gallium}
+%attr(755,root,root) %{_libdir}/xorg/modules/dri/kms_swrast_dri.so
+%endif
 %attr(755,root,root) %{_libdir}/xorg/modules/dri/swrast_dri.so
 
 %if %{with gallium}
@@ -1304,6 +1506,18 @@ rm -rf $RPM_BUILD_ROOT
 %attr(755,root,root) %{_libdir}/xorg/modules/dri/vmwgfx_dri.so
 %endif
 
+%if %{with nine}
+%files d3d
+%defattr(644,root,root,755)
+%dir %{_libdir}/d3d
+%attr(755,root,root) %{_libdir}/d3d/d3dadapter9.so*
+
+%files d3d-devel
+%defattr(644,root,root,755)
+%{_includedir}/d3dadapter
+%{_pkgconfigdir}/d3d.pc
+%endif
+
 %if %{with gallium}
 # ldconfig is not used in vdpau tree, so package all symlinks
 %if %{with gallium_nouveau}
@@ -1314,6 +1528,13 @@ rm -rf $RPM_BUILD_ROOT
 %attr(755,root,root) %{_libdir}/vdpau/libvdpau_nouveau.so
 %endif
 
+%if %{with gallium_radeon}
+%files -n libvdpau-driver-mesa-r300
+%defattr(644,root,root,755)
+%attr(755,root,root) %{_libdir}/vdpau/libvdpau_r300.so.1.0.0
+%attr(755,root,root) %{_libdir}/vdpau/libvdpau_r300.so.1
+%attr(755,root,root) %{_libdir}/vdpau/libvdpau_r300.so
+
 %files -n libvdpau-driver-mesa-r600
 %defattr(644,root,root,755)
 %attr(755,root,root) %{_libdir}/vdpau/libvdpau_r600.so.1.0.0
@@ -1326,3 +1547,10 @@ rm -rf $RPM_BUILD_ROOT
 %attr(755,root,root) %{_libdir}/vdpau/libvdpau_radeonsi.so.1
 %attr(755,root,root) %{_libdir}/vdpau/libvdpau_radeonsi.so
 %endif
+%endif
+
+%if %{with gallium} && %{with omx}
+%files -n omxil-mesa
+%defattr(644,root,root,755)
+%attr(755,root,root) %{_libdir}/bellagio/libomx_mesa.so
+%endif
This page took 0.485928 seconds and 4 git commands to generate.