]> git.pld-linux.org Git - packages/Mesa.git/blobdiff - Mesa.spec
- up to 10.5.0
[packages/Mesa.git] / Mesa.spec
index 24e2766d8ed092f6f6fef790526bc7348331e130..97f165178287f65597d7c2b51bb7be34b4e87657 100644 (file)
--- a/Mesa.spec
+++ b/Mesa.spec
 # OpenVG hasn't been integrated into standard libEGL yet"
 %bcond_with    openvg          # OpenVG
 %bcond_without gbm             # Graphics Buffer Manager
+%bcond_without nine            # Nine Direct3D 9+ state tracker (for Wine)
 %bcond_without opencl          # OpenCL support
 %bcond_without ocl_icd         # OpenCL as ICD (installable client driver)
 %bcond_without omx             # OpenMAX (Bellagio OMXIL) support
+%bcond_without va              # VA library
 %bcond_without wayland         # Wayland EGL
 %bcond_without xa              # XA state tracker (for vmwgfx xorg driver)
+%bcond_with    texture_float   # floating-point textures and renderbuffers (SGI patent in US)
 %bcond_with    static_libs     # static libraries [not supported for DRI, thus broken currently]
 %bcond_with    tests           # tests
 #
 %define                glproto_ver             1.4.14
 %define                presentproto_ver        1.0
 
+# no clang/llvm on x32 yet
+%ifarch x32
+%undefine      with_gallium
+%endif
+
+%if %{without gallium}
+%undefine      with_gallium_intel
+%undefine      with_gallium_nouveau
+%undefine      with_gallium_radeon
+%undefine      with_nine
+%undefine      with_ocl_icd
+%undefine      with_omx
+%undefine      with_opencl
+%undefine      with_xa
+%endif
+
+%if %{without egl}
+%undefine      with_gbm
+%undefine      with_wayland
+%endif
+
 Summary:       Free OpenGL implementation
 Summary(pl.UTF-8):     Wolnodostępna implementacja standardu OpenGL
 Name:          Mesa
-Version:       10.4.1
+Version:       10.5.0
 Release:       1
 License:       MIT (core) and others - see license.html file
 Group:         X11/Libraries
-Source0:       ftp://ftp.freedesktop.org/pub/mesa/%{version}/%{name}Lib-%{version}.tar.bz2
-# Source0-md5: 461ab299aa38937a679c57b401788a42
+Source0:       ftp://ftp.freedesktop.org/pub/mesa/%{version}/mesa-%{version}.tar.xz
+# Source0-md5: 133c5264a0c81d23168a65435ad23ede
 Patch0:                missing-type.patch
 URL:           http://www.mesa3d.org/
 BuildRequires: autoconf >= 2.60
@@ -52,16 +76,17 @@ BuildRequires:      automake
 %{?with_opencl:BuildRequires:  clang-devel >= 3.1}
 BuildRequires: elfutils-devel
 BuildRequires: expat-devel
-BuildRequires: gcc >= 5:3.3
+BuildRequires: gcc >= 5:4.1
 %{?with_opencl:BuildRequires:  gcc-c++ >= 6:4.7}
 BuildRequires: libdrm-devel >= %{libdrm_ver}
 BuildRequires: libselinux-devel
 BuildRequires: libstdc++-devel >= 5:3.3.0
 BuildRequires: libtalloc-devel >= 2:2.0.1
 BuildRequires: libtool >= 2:2.2
+%{?with_va:BuildRequires:      libva-devel >= 1.3.0}
+%{?with_va:BuildRequires:      pkgconfig(libva) >= 0.35.0}
 BuildRequires: libvdpau-devel >= 0.4.1
 BuildRequires: libxcb-devel >= 1.10
-BuildRequires: llvm-devel >= 3.3
 %{?with_gallium_radeon:BuildRequires:  llvm-devel >= 3.4.2}
 %{?with_opencl:BuildRequires:  llvm-libclc}
 %{?with_ocl_icd:BuildRequires: ocl-icd-devel}
@@ -91,26 +116,12 @@ BuildRequires:     xorg-proto-dri3proto-devel >= %{dri3proto_ver}
 BuildRequires: xorg-proto-glproto-devel >= %{glproto_ver}
 BuildRequires: xorg-proto-presentproto-devel >= %{presentproto_ver}
 BuildRequires: xorg-util-makedepend
-BuildRequires: xorg-xserver-server-devel >= %{xserver_ver}
 %if %{with gallium}
 BuildRequires: xorg-proto-xextproto-devel >= 7.0.99.1
-BuildRequires: xorg-xserver-server-devel >= 1.6.0
+BuildRequires: xorg-xserver-server-devel >= %{xserver_ver}
 %endif
 BuildRoot:     %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
 
-%if %{without gallium}
-%undefine      with_gallium_intel
-%undefine      with_gallium_nouveau
-%undefine      with_ocl_icd
-%undefine      with_opencl
-%undefine      with_xa
-%endif
-
-%if %{without egl}
-%undefine      with_gbm
-%undefine      with_wayland
-%endif
-
 # libGLESv1_CM, libGLESv2, libGL, libOSMesa:
 #  _glapi_tls_Dispatch is defined in libglapi, but it's some kind of symbol ldd -r doesn't notice(?)
 # libgbm: circular dependency with libEGL (wayland_buffer_is_drm symbol)
@@ -383,6 +394,7 @@ Requires:   libdrm >= %{libdrm_ver}
 Requires:      llvm-libclc
 Requires:      udev-libs >= 1:151
 Provides:      OpenCL = 1.1
+Provides:      ocl-icd-driver
 
 %description OpenCL-icd
 This package contains Mesa implementation of OpenCL - standard for
@@ -517,6 +529,7 @@ R600/R700.
 Summary:       VA driver for Gallium State Tracker
 Summary(pl.UTF-8):     Sterownik VA do Gallium
 Group:         Libraries
+Requires:      libva >= 1.3.0
 
 %description -n libva-driver-gallium
 VA driver for Gallium State Tracker.
@@ -900,6 +913,30 @@ X.org DRI driver for VMWare.
 %description dri-driver-vmwgfx -l pl.UTF-8
 Sterownik X.org DRI dla VMware.
 
+%package d3d
+Summary:       Nine Direct3D9 driver (for Wine)
+Summary(pl.UTF-8):     Sterownik Direct3D9 Nine (dla Wine)
+Group:         Libraries
+Requires:      libdrm >= %{libdrm_ver}
+
+%description d3d
+Nine Direct3D9 driver (for Wine).
+
+%description d3d -l pl.UTF-8
+Sterownik Direct3D9 Nine (dla Wine).
+
+%package d3d-devel
+Summary:       Nine Direct3D9 driver API
+Summary(pl.UTF-8):     API sterownika Direct3D9 Nine
+Group:         Development/Libraries
+Requires:      libdrm-devel >= %{libdrm_ver}
+
+%description d3d-devel
+Nine Direct3D9 driver API.
+
+%description d3d-devel -l pl.UTF-8
+API sterownika Direct3D9 Nine.
+
 %package -n libvdpau-driver-mesa-nouveau
 Summary:       Mesa nouveau driver for the vdpau API
 Summary(pl.UTF-8):     Sterownik Mesa nouveau dla API vdpau
@@ -1039,7 +1076,7 @@ Sterownik Mesa radeonsi dla API Bellagio OpenMAX IL. Obsługuje karty
 ATI Radeon oparte na układach Southern Islands.
 
 %prep
-%setup -q
+%setup -q -n mesa-%{version}
 %patch0 -p1
 
 %build
@@ -1079,13 +1116,14 @@ gallium_drivers=$(echo $gallium_drivers | xargs | tr ' ' ',')
 
 %configure \
        --disable-silent-rules \
-       --enable-shared \
-       --enable-glx-tls \
-       --enable-selinux \
-       %{?with_static_libs:--enable-static} \
        %{__enable gbm} \
+       --enable-glx-tls \
        --enable-osmesa \
+       --enable-selinux \
+       --enable-shared \
        --enable-shared-glapi \
+       %{?with_static_libs:--enable-static} \
+       %{?with_texture_float:--enable-texture-float} \
 %if %{with egl}
        --enable-egl \
        --enable-gles1 \
@@ -1098,7 +1136,8 @@ gallium_drivers=$(echo $gallium_drivers | xargs | tr ' ' ',')
        %{__enable egl gallium-egl} \
        %{__enable gbm gallium-gbm} \
        %{__enable ocl_icd opencl-icd} \
-       %{__enable opencl opencl} \
+       %{?with_nine:--enable-nine} \
+       %{__enable opencl} \
        %{?with_egl:%{?with_openvg:--enable-openvg}} \
        --enable-vdpau \
        %{?with_omx:--enable-omx} \
@@ -1125,15 +1164,16 @@ rm -rf $RPM_BUILD_ROOT
 # strip out undesirable headers
 %{__rm} $RPM_BUILD_ROOT%{_includedir}/GL/{wglext,wmesa}.h
 # dlopened by soname
-%{__rm} $RPM_BUILD_ROOT%{_libdir}/libXvMC*.so
-%{__rm} $RPM_BUILD_ROOT%{_libdir}/libXvMC*.so.1.0
+%{?with_gallium:%{__rm} $RPM_BUILD_ROOT%{_libdir}/libXvMC*.so}
+%{?with_gallium:%{__rm} $RPM_BUILD_ROOT%{_libdir}/libXvMC*.so.1.0}
 # dlopened by soname or .so link
-%{__rm} $RPM_BUILD_ROOT%{_libdir}/vdpau/libvdpau_*.so.1.0
+%{?with_gallium:%{__rm} $RPM_BUILD_ROOT%{_libdir}/vdpau/libvdpau_*.so.1.0}
 # not used externally
 %{__rm} $RPM_BUILD_ROOT%{_libdir}/libglapi.so
 # dlopened
 %{?with_omx:%{__rm} $RPM_BUILD_ROOT%{_libdir}/bellagio/libomx_*.la}
-%{__rm} $RPM_BUILD_ROOT%{_libdir}/gallium-pipe/pipe_*.la
+%{?with_nine:%{__rm} $RPM_BUILD_ROOT%{_libdir}/d3d/d3dadapter9.la}
+%{?with_gallium:%{__rm} $RPM_BUILD_ROOT%{_libdir}/gallium-pipe/pipe_*.la}
 # not defined by standards; and not needed, there is pkg-config support
 %{__rm} $RPM_BUILD_ROOT%{_libdir}/lib*.la
 %{?with_gallium:%{__rm} $RPM_BUILD_ROOT%{_libdir}/libva/dri/gallium_drv_video.la}
@@ -1206,7 +1246,7 @@ rm -rf $RPM_BUILD_ROOT
 
 %files libGL
 %defattr(644,root,root,755)
-%doc docs/{*.html,README.UVD,relnotes/*.html}
+%doc docs/{*.html,README.UVD,patents.txt,relnotes/*.html}
 %attr(755,root,root) %{_libdir}/libGL.so.*.*
 %attr(755,root,root) %ghost %{_libdir}/libGL.so.1
 # symlink for binary apps which fail to conform Linux OpenGL ABI
@@ -1319,9 +1359,12 @@ rm -rf $RPM_BUILD_ROOT
 %attr(755,root,root) %ghost %{_libdir}/libXvMCr600.so.1
 %endif
 
+%if %{with va}
 %files -n libva-driver-gallium
+%defattr(644,root,root,755)
 %attr(755,root,root) %{_libdir}/libva/dri/gallium_drv_video.so
 %endif
+%endif
 
 %if %{with gbm}
 %files libgbm
@@ -1461,7 +1504,9 @@ rm -rf $RPM_BUILD_ROOT
 
 %files dri-driver-swrast
 %defattr(644,root,root,755)
+%if %{with gallium}
 %attr(755,root,root) %{_libdir}/xorg/modules/dri/kms_swrast_dri.so
+%endif
 %attr(755,root,root) %{_libdir}/xorg/modules/dri/swrast_dri.so
 
 %if %{with gallium}
@@ -1470,6 +1515,18 @@ rm -rf $RPM_BUILD_ROOT
 %attr(755,root,root) %{_libdir}/xorg/modules/dri/vmwgfx_dri.so
 %endif
 
+%if %{with nine}
+%files d3d
+%defattr(644,root,root,755)
+%dir %{_libdir}/d3d
+%attr(755,root,root) %{_libdir}/d3d/d3dadapter9.so*
+
+%files d3d-devel
+%defattr(644,root,root,755)
+%{_includedir}/d3dadapter
+%{_pkgconfigdir}/d3d.pc
+%endif
+
 %if %{with gallium}
 # ldconfig is not used in vdpau tree, so package all symlinks
 %if %{with gallium_nouveau}
This page took 0.326606 seconds and 4 git commands to generate.