]> git.pld-linux.org Git - packages/Mesa.git/blobdiff - Mesa.spec
- updated libdrm version
[packages/Mesa.git] / Mesa.spec
index 648cb9801cb836ebc43fdaff3ecaa9492d869cd5..5f5e154f0c07c9047f7891344285280c109a5395 100644 (file)
--- a/Mesa.spec
+++ b/Mesa.spec
@@ -2,6 +2,7 @@
 # TODO:
 # - check if gallium_intel note is still valid, switch the bcond if not
 # - consider:
+# - ARM drivers (ilo,freedreno,vc4)?
 # - subpackage with non-dri libGL for use with X-servers with missing GLX extension?
 # - resurrect static if it's useful (using plain xorg target? DRI doesn't support static)
 #
@@ -11,9 +12,7 @@
 %bcond_without gallium_nouveau # gallium nouveau driver
 %bcond_without gallium_radeon  # gallium radeon drivers
 %bcond_without egl             # EGL libraries
-# "Cannot enable OpenVG, because egl_gallium has been removed and
-# OpenVG hasn't been integrated into standard libEGL yet"
-%bcond_with    openvg          # OpenVG
+%bcond_with    openvg          # OpenVG library [not builind since 10.4, dropped in 10.6]
 %bcond_without gbm             # Graphics Buffer Manager
 %bcond_without nine            # Nine Direct3D 9+ state tracker (for Wine)
 %bcond_without opencl          # OpenCL support
@@ -33,7 +32,7 @@
 # minimal supported xserver version
 %define                xserver_ver             1.5.0
 # other packages
-%define                libdrm_ver              2.4.56
+%define                libdrm_ver              2.4.60
 %define                dri2proto_ver           2.6
 %define                dri3proto_ver           1.0
 %define                glproto_ver             1.4.14
 Summary:       Free OpenGL implementation
 Summary(pl.UTF-8):     Wolnodostępna implementacja standardu OpenGL
 Name:          Mesa
-Version:       10.4.3
+Version:       10.6.0
 Release:       1
 License:       MIT (core) and others - see license.html file
 Group:         X11/Libraries
-Source0:       ftp://ftp.freedesktop.org/pub/mesa/%{version}/%{name}Lib-%{version}.tar.bz2
-# Source0-md5: be86c4ee226f8ca28b7d4c728c350b01
+Source0:       ftp://ftp.freedesktop.org/pub/mesa/%{version}/mesa-%{version}.tar.xz
+# Source0-md5: 1a7e2e9f17eff9307fd14fb6cc70783b
 Patch0:                missing-type.patch
 URL:           http://www.mesa3d.org/
 BuildRequires: autoconf >= 2.60
@@ -76,11 +75,11 @@ BuildRequires:      automake
 %{?with_opencl:BuildRequires:  clang-devel >= 3.1}
 BuildRequires: elfutils-devel
 BuildRequires: expat-devel
-BuildRequires: gcc >= 5:3.3
+BuildRequires: gcc >= 6:4.2.0
 %{?with_opencl:BuildRequires:  gcc-c++ >= 6:4.7}
 BuildRequires: libdrm-devel >= %{libdrm_ver}
 BuildRequires: libselinux-devel
-BuildRequires: libstdc++-devel >= 5:3.3.0
+BuildRequires: libstdc++-devel >= 6:4.2.0
 BuildRequires: libtalloc-devel >= 2:2.0.1
 BuildRequires: libtool >= 2:2.2
 %{?with_va:BuildRequires:      libva-devel >= 1.3.0}
@@ -89,6 +88,8 @@ BuildRequires:        libvdpau-devel >= 0.4.1
 BuildRequires: libxcb-devel >= 1.10
 %{?with_gallium_radeon:BuildRequires:  llvm-devel >= 3.4.2}
 %{?with_opencl:BuildRequires:  llvm-libclc}
+# for SHA1 (could use also libmd/libsha1/libgcrypt/openssl instead)
+BuildRequires: nettle-devel
 %{?with_ocl_icd:BuildRequires: ocl-icd-devel}
 %{?with_omx:BuildRequires:     libomxil-bellagio-devel}
 BuildRequires: perl-base
@@ -98,6 +99,7 @@ BuildRequires:        pkgconfig(talloc) >= 2.0.1
 BuildRequires: pkgconfig(xcb-dri3)
 BuildRequires: pkgconfig(xcb-present)
 BuildRequires: python >= 2
+BuildRequires: python-Mako >= 0.3.4
 BuildRequires: python-modules >= 2
 BuildRequires: rpmbuild(macros) >= 1.470
 BuildRequires: sed >= 4.0
@@ -157,10 +159,6 @@ Requires:  libdrm >= %{libdrm_ver}
 Requires:      libxcb >= 1.9
 %{?with_wayland:Requires:      wayland >= 1.2.0}
 %if %{with gallium}
-%if %{with openvg}
-# for egl_gallium.so
-Requires:      %{name}-libOpenVG = %{version}-%{release}
-%endif
 Requires:      udev-libs >= 1:151
 %endif
 %if %{with gbm}
@@ -394,6 +392,7 @@ Requires:   libdrm >= %{libdrm_ver}
 Requires:      llvm-libclc
 Requires:      udev-libs >= 1:151
 Provides:      OpenCL = 1.1
+Provides:      ocl-icd-driver
 
 %description OpenCL-icd
 This package contains Mesa implementation of OpenCL - standard for
@@ -1075,7 +1074,7 @@ Sterownik Mesa radeonsi dla API Bellagio OpenMAX IL. Obsługuje karty
 ATI Radeon oparte na układach Southern Islands.
 
 %prep
-%setup -q
+%setup -q -n mesa-%{version}
 %patch0 -p1
 
 %build
@@ -1137,18 +1136,18 @@ gallium_drivers=$(echo $gallium_drivers | xargs | tr ' ' ',')
        %{__enable ocl_icd opencl-icd} \
        %{?with_nine:--enable-nine} \
        %{__enable opencl} \
-       %{?with_egl:%{?with_openvg:--enable-openvg}} \
        --enable-vdpau \
        %{?with_omx:--enable-omx} \
        %{?with_xa:--enable-xa} \
        --enable-xvmc \
+       --with-dri-drivers=${dri_drivers} \
+       --with-dri-driverdir=%{_libdir}/xorg/modules/dri \
        --with-gallium-drivers=${gallium_drivers} \
 %else
        --without-gallium-drivers \
 %endif
-       --with-va-libdir=%{_libdir}/libva/dri \
-       --with-dri-drivers=${dri_drivers} \
-       --with-dri-driverdir=%{_libdir}/xorg/modules/dri
+       --with-sha1=libnettle \
+       --with-va-libdir=%{_libdir}/libva/dri
 
 %{__make}
 
@@ -1161,7 +1160,7 @@ rm -rf $RPM_BUILD_ROOT
        DESTDIR=$RPM_BUILD_ROOT
 
 # strip out undesirable headers
-%{__rm} $RPM_BUILD_ROOT%{_includedir}/GL/{wglext,wmesa}.h
+%{__rm} $RPM_BUILD_ROOT%{_includedir}/GL/wglext.h
 # dlopened by soname
 %{?with_gallium:%{__rm} $RPM_BUILD_ROOT%{_libdir}/libXvMC*.so}
 %{?with_gallium:%{__rm} $RPM_BUILD_ROOT%{_libdir}/libXvMC*.so.1.0}
@@ -1372,10 +1371,6 @@ rm -rf $RPM_BUILD_ROOT
 %attr(755,root,root) %ghost %{_libdir}/libgbm.so.1
 %if %{with gallium}
 %dir %{_libdir}/gallium-pipe
-%if %{with openvg}
-%dir %{_libdir}/gbm
-%attr(755,root,root) %{_libdir}/gbm/gbm_gallium_drm.so
-%endif
 %endif
 
 %files libgbm-devel
This page took 0.172087 seconds and 4 git commands to generate.