]> git.pld-linux.org Git - packages/Mesa.git/blobdiff - Mesa.spec
Version: 18.2.8
[packages/Mesa.git] / Mesa.spec
index 3f060424a71ddb36b66a31394aea8b2618c65a28..41c64bf258ee4fbcb670a354a66ac28d2d9d0a03 100644 (file)
--- a/Mesa.spec
+++ b/Mesa.spec
 # minimal supported xserver version
 %define                xserver_ver             1.5.0
 # other packages
-%ifarch %{arm}
-%define                libdrm_ver              2.4.80
-%else
-%define                libdrm_ver              2.4.79
-%endif
+%define                libdrm_ver              2.4.92
 %define                dri2proto_ver           2.8
 %define                dri3proto_ver           1.0
 %define                glproto_ver             1.4.14
 %define                presentproto_ver        1.0
 %define                zlib_ver                1.2.8
+%define                wayland_ver             1.11
 
 %if %{without gallium}
 %undefine      with_gallium_i915
 Summary:       Free OpenGL implementation
 Summary(pl.UTF-8):     Wolnodostępna implementacja standardu OpenGL
 Name:          Mesa
-Version:       17.1.5
+#              NOTE: 18.3 is being prepared on the 'Mesa-18.3' branch
+Version:       18.2.8
 Release:       1
 License:       MIT (core) and others - see license.html file
 Group:         X11/Libraries
-Source0:       ftp://ftp.freedesktop.org/pub/mesa/mesa-%{version}.tar.xz
-# Source0-md5: 6cf936fbcaadd98924298a7009e8265d
+#Source0:      ftp://ftp.freedesktop.org/pub/mesa/mesa-%{version}.tar.xz
+## Source0-md5:        7c61a801311fb8d2f7b3cceb7b5cf308
+Source0:       https://gitlab.freedesktop.org/mesa/mesa/-/archive/mesa-%{version}/mesa-mesa-%{version}.tar.bz2
+# Source0-md5: bba8fcfa55424b379363344aba50eebd
 Patch0:                %{name}-link.patch
 URL:           http://www.mesa3d.org/
 BuildRequires: autoconf >= 2.60
@@ -86,13 +86,12 @@ BuildRequires:      libstdc++-devel >= 6:4.2.0
 BuildRequires: libtalloc-devel >= 2:2.0.1
 BuildRequires: libtool >= 2:2.2
 %{?with_va:BuildRequires:      libva-devel >= 1.6.0}
-%{?with_va:BuildRequires:      pkgconfig(libva) >= 0.38.0}
+%{?with_va:BuildRequires:      pkgconfig(libva) >= 0.39.0}
 BuildRequires: libvdpau-devel >= 1.1
-BuildRequires: libxcb-devel >= 1.10
-%{?with_gallium_radeon:BuildRequires:  llvm-devel >= 3.8}
-# for swr driver
-%{?with_gallium:BuildRequires: llvm-devel >= 3.9}
-%{?with_radv:BuildRequires:    llvm-devel >= 3.9}
+BuildRequires: libxcb-devel >= 1.13
+# gallium core requires 3.3.0, OpenCL/r600 require 3.9.0, swr/radeonsi/radv 4.0.0
+%{?with_gallium:BuildRequires: llvm-devel >= 5.0}
+%{?with_radv:BuildRequires:    llvm-devel >= 5.0}
 %{?with_opencl:BuildRequires:  llvm-libclc}
 # for SHA1 (could use also libmd/libsha1/libgcrypt/openssl instead)
 BuildRequires: nettle-devel
@@ -102,15 +101,19 @@ BuildRequires:    perl-base
 BuildRequires: pixman-devel
 BuildRequires: pkgconfig
 BuildRequires: pkgconfig(talloc) >= 2.0.1
-BuildRequires: pkgconfig(xcb-dri3)
-BuildRequires: pkgconfig(xcb-present)
+BuildRequires: pkgconfig(xcb-dri2) >= 1.8
+BuildRequires: pkgconfig(xcb-dri3) >= 1.13
+BuildRequires: pkgconfig(xcb-glx) >= 1.8.1
+BuildRequires: pkgconfig(xcb-present) >= 1.13
 BuildRequires: python >= 2
 BuildRequires: python-Mako >= 0.8.0
 BuildRequires: python-modules >= 2
 BuildRequires: rpmbuild(macros) >= 1.470
 BuildRequires: sed >= 4.0
 # wayland-{client,server}
-%{?with_wayland:BuildRequires: wayland-devel >= 1.11.0}
+%{?with_wayland:BuildRequires: wayland-devel >= %{wayland_ver}}
+%{?with_wayland:BuildRequires: wayland-protocols >= 1.8}
+%{?with_wayland:BuildRequires: wayland-egl-devel >= %{wayland_ver}}
 BuildRequires: xorg-lib-libXdamage-devel >= 1.1
 BuildRequires: xorg-lib-libXext-devel >= 1.0.5
 BuildRequires: xorg-lib-libXfixes-devel
@@ -124,7 +127,7 @@ BuildRequires:      xorg-proto-glproto-devel >= %{glproto_ver}
 BuildRequires: xorg-proto-presentproto-devel >= %{presentproto_ver}
 BuildRequires: xorg-util-makedepend
 %if %{with gallium}
-%{?with_lm_sensors:BuildRequires:      lm_sensors-devel >= 3.4}
+%{?with_lm_sensors:BuildRequires:      lm_sensors-devel >= 4.0}
 BuildRequires: xorg-proto-xextproto-devel >= 7.0.99.1
 BuildRequires: xorg-xserver-server-devel >= %{xserver_ver}
 %endif
@@ -134,7 +137,7 @@ BuildRoot:  %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
 # libGLESv1_CM, libGLESv2, libGL, libOSMesa:
 #  _glapi_tls_Dispatch is defined in libglapi, but it's some kind of symbol ldd -r doesn't notice(?)
 # libgbm: circular dependency with libEGL (wayland_buffer_is_drm symbol)
-%define                skip_post_check_so      libGLESv1_CM.so.1.* libGLESv2.so.2.* libGL.so.1.* libOSMesa.so.* libgbm.*.so.*
+%define                skip_post_check_so      libGLESv1_CM.so.1.* libGLESv2.so.2.* libGL.so.1.* libOSMesa.so.* libgbm.*.so.* libGLX_mesa.so.0.*
 
 # llvm build broken
 %define                filterout_ld    -Wl,--as-needed
@@ -163,7 +166,7 @@ Requires:   %{name}-libglapi = %{version}-%{release}
 # glx driver in libEGL dlopens libGL.so
 Requires:      OpenGL >= 1.2
 Requires:      libdrm >= %{libdrm_ver}
-Requires:      libxcb >= 1.9
+Requires:      libxcb >= 1.13
 %{?with_wayland:Requires:      wayland >= 1.11.0}
 %if %{with gbm}
 Requires:      %{name}-libgbm = %{version}-%{release}
@@ -225,6 +228,7 @@ License:    MIT
 Group:         X11/Libraries
 Requires:      %{name}-libglapi = %{version}-%{release}
 Requires:      libdrm >= %{libdrm_ver}
+Requires:      libxcb >= 1.13
 Requires:      xorg-lib-libXdamage >= 1.1
 Provides:      OpenGL = 4.5
 Provides:      OpenGL-GLX = 1.4
@@ -629,31 +633,6 @@ Mesa GL API shared library, common for various APIs (EGL, GL, GLES).
 Biblioteka współdzielona Mesa GL API, wspólna dla różnych API (EGL,
 GL, GLES).
 
-%package libwayland-egl
-Summary:       Wayland EGL library
-Summary(pl.UTF-8):     Biblioteka Wayland EGL
-Group:         Libraries
-Requires:      libdrm >= %{libdrm_ver}
-
-%description libwayland-egl
-Wayland EGL platform library.
-
-%description libwayland-egl -l pl.UTF-8
-Biblioteka platformy EGL Wayland.
-
-%package libwayland-egl-devel
-Summary:       Development files for Wayland EGL library
-Summary(pl.UTF-8):     Pliki programistyczne biblioteki Wayland EGL
-Group:         Development/Libraries
-Requires:      %{name}-libwayland-egl = %{version}-%{release}
-Requires:      libdrm-devel >= %{libdrm_ver}
-
-%description libwayland-egl-devel
-Development files for Wayland EGL platform library.
-
-%description libwayland-egl-devel -l pl.UTF-8
-Pliki programistyczne biblioteki platformy EGL Wayland.
-
 %package libxatracker
 Summary:       Xorg Gallium3D accelleration library
 Summary(pl.UTF-8):     Biblioteka akceleracji Gallium3D dla Xorg
@@ -1207,7 +1186,7 @@ Summary(pl.UTF-8):        Sterownik Mesa nouveau dla API Bellagio OpenMAX IL
 License:       MIT
 Group:         X11/Libraries
 Requires:      libdrm >= %{libdrm_ver}
-Requires:      libxcb >= 1.8
+Requires:      libxcb >= 1.13
 Requires:      libomxil-bellagio
 Requires:      zlib >= %{zlib_ver}
 Obsoletes:     omxil-mesa-nouveau
@@ -1226,6 +1205,10 @@ Summary(pl.UTF-8):       Sterownik Vulkan dla GPU firmy Intel
 License:       MIT
 Group:         Libraries
 Requires:      libdrm >= %{libdrm_ver}
+Requires:      libxcb >= 1.13
+Requires:      xorg-lib-libxshmfence >= 1.1
+# wayland-client
+Requires:      wayland >= %{wayland_ver}
 Requires:      zlib >= %{zlib_ver}
 Suggests:      vulkan(loader)
 Provides:      vulkan(icd) = 1.0.3
@@ -1254,6 +1237,11 @@ Summary: radv - experimental Mesa Vulkan driver for AMD Radeon GPUs
 Summary(pl.UTF-8):     radv - eksperymentalny sterownik Vulkan dla GPU firmy AMD
 License:       MIT
 Group:         Libraries
+Requires:      libdrm >= %{libdrm_ver}
+Requires:      libxcb >= 1.13
+Requires:      xorg-lib-libxshmfence >= 1.1
+# wayland-client
+Requires:      wayland >= %{wayland_ver}
 Requires:      zlib >= %{zlib_ver}
 Suggests:      vulkan(loader)
 Provides:      vulkan(icd) = 1.0.3
@@ -1265,7 +1253,7 @@ radv - experimental Mesa Vulkan driver for AMD Radeon GPUs.
 radv - eksperymentalny sterownik Vulkan dla GPU firmy AMD.
 
 %prep
-%setup -q -n mesa-%{version}
+%setup -q -n mesa-mesa-%{version}
 %patch0 -p1
 
 %build
@@ -1283,8 +1271,11 @@ i965 %{!?with_gallium_i915:i915} \
 dri_drivers=$(echo $dri_drivers | xargs | tr ' ' ',')
 
 gallium_drivers="svga swrast virgl \
+%ifarch %{x8664}
+swr
+%endif
 %ifarch %{ix86} %{x8664} x32
-swr %{?with_gallium_i915:i915} \
+%{?with_gallium_i915:i915} \
 %endif
 %if %{with gallium_radeon}
 r300 r600 radeonsi \
@@ -1337,7 +1328,7 @@ vulkan_drivers=$(echo $vulkan_drivers | xargs | tr ' ' ',')
        %{__enable opencl} \
        %{__enable va} \
        --enable-vdpau \
-       %{?with_omx:--enable-omx} \
+       %{?with_omx:--enable-omx-bellagio} \
        %{?with_xa:--enable-xa} \
        --enable-xvmc \
        --with-gallium-drivers=${gallium_drivers} \
@@ -1413,21 +1404,28 @@ rm -rf $RPM_BUILD_ROOT
 %post  libglapi -p /sbin/ldconfig
 %postun        libglapi -p /sbin/ldconfig
 
-%post  libwayland-egl -p /sbin/ldconfig
-%postun        libwayland-egl -p /sbin/ldconfig
-
 %post  libxatracker -p /sbin/ldconfig
 %postun        libxatracker -p /sbin/ldconfig
 
 %if %{with egl}
 %files libEGL
 %defattr(644,root,root,755)
+%if %{with glvnd}
+%attr(755,root,root) %{_libdir}/libEGL_mesa.so.*.*
+%attr(755,root,root) %ghost %{_libdir}/libEGL_mesa.so.0
+%{_datadir}/glvnd/egl_vendor.d/50_mesa.json
+%else
 %attr(755,root,root) %{_libdir}/libEGL.so.*.*
 %attr(755,root,root) %ghost %{_libdir}/libEGL.so.1
+%endif
 
 %files libEGL-devel
 %defattr(644,root,root,755)
+%if %{with glvnd}
+%attr(755,root,root) %{_libdir}/libEGL_mesa.so
+%else
 %attr(755,root,root) %{_libdir}/libEGL.so
+%endif
 %dir %{_includedir}/EGL
 %{_includedir}/EGL/egl.h
 %{_includedir}/EGL/eglext.h
@@ -1445,7 +1443,7 @@ rm -rf $RPM_BUILD_ROOT
 
 %files libGL
 %defattr(644,root,root,755)
-%doc docs/{*.html,README.UVD,patents.txt,relnotes/*.html}
+%doc docs/{*.html,README.UVD,features.txt,relnotes/*.html}
 %if %{with glvnd}
 %attr(755,root,root) %{_libdir}/libGLX_mesa.so.*.*
 %attr(755,root,root) %ghost %{_libdir}/libGLX_mesa.so.0
@@ -1610,18 +1608,6 @@ rm -rf $RPM_BUILD_ROOT
 # libglapi-devel? nothing seems to need it atm.
 #%attr(755,root,root) %{_libdir}/libglapi.so
 
-%if %{with wayland}
-%files libwayland-egl
-%defattr(644,root,root,755)
-%attr(755,root,root) %{_libdir}/libwayland-egl.so.*.*
-%attr(755,root,root) %ghost %{_libdir}/libwayland-egl.so.1
-
-%files libwayland-egl-devel
-%defattr(644,root,root,755)
-%attr(755,root,root) %{_libdir}/libwayland-egl.so
-%{_pkgconfigdir}/wayland-egl.pc
-%endif
-
 %if %{with xa}
 %files libxatracker
 %defattr(644,root,root,755)
@@ -1757,7 +1743,7 @@ rm -rf $RPM_BUILD_ROOT
 %defattr(644,root,root,755)
 %attr(755,root,root) %{_libdir}/gallium-pipe/pipe_vmwgfx.so
 
-%ifarch %{ix86} %{x8664} x32
+%ifarch %{x8664}
 %files swr
 %defattr(644,root,root,755)
 %attr(755,root,root) %{_libdir}/libswrAVX.so
This page took 0.061285 seconds and 4 git commands to generate.