]> git.pld-linux.org Git - packages/Mesa-libGLU.git/blob - Mesa-libGLU.spec
- separated from Mesa.spec (for use with Mesa 9)
[packages/Mesa-libGLU.git] / Mesa-libGLU.spec
1 #
2 # Conditional build:
3 %bcond_without  static_libs     # static library
4 #
5 Summary:        SGI implementation of libGLU OpenGL library
6 Summary(pl.UTF-8):      Implementacja SGI biblioteki libGLU ze standardu OpenGL
7 Name:           Mesa-libGLU
8 Version:        9.0.0
9 Release:        1
10 License:        SGI Free Software License B v2.0 (MIT-like)
11 Group:          Libraries
12 Source0:        ftp://ftp.freedesktop.org/pub/mesa/glu/glu-%{version}.tar.bz2
13 # Source0-md5:  be9249132ff49275461cf92039083030
14 URL:            http://www.mesa3d.org/
15 BuildRequires:  OpenGL-devel >= 1.2
16 BuildRequires:  autoconf >= 2.60
17 BuildRequires:  automake
18 BuildRequires:  libstdc++-devel
19 BuildRequires:  libtool >= 2:2.2
20 BuildRequires:  pkgconfig
21 Requires:       OpenGL >= 1.2
22 Provides:       OpenGL-GLU = 1.3
23 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
24
25 %description
26 SGI implementation of libGLU OpenGL library. It implements OpenGL GLU
27 1.3 specifications.
28
29 %description -l pl.UTF-8
30 Implementacja SGI biblioteki libGLU ze standardu OpenGL. Implementuje
31 specyfikację OpenGL GLU 1.3.
32
33 %package devel
34 Summary:        Header files for SGI libGLU library
35 Summary(pl.UTF-8):      Pliki nagłówkowe biblioteki SGI libGLU
36 Group:          Development/Libraries
37 Requires:       %{name} = %{version}-%{release}
38 Requires:       OpenGL-devel >= 1.2
39
40 %description devel
41 Header files for SGI libGLU library.
42
43 %description devel -l pl.UTF-8
44 Pliki nagłówkowe biblioteki SGI libGLU.
45
46 %package static
47 Summary:        Static SGI libGLU library
48 Summary(pl.UTF-8):      Statyczna biblioteka SGI libGLU
49 Group:          Development/Libraries
50 Requires:       %{name}-devel = %{version}-%{release}
51 Provides:       OpenGL-GLU-static = 1.3
52
53 %description static
54 Static SGI libGLU library.
55
56 %description static -l pl.UTF-8
57 Statyczna biblioteka SGI libGLU.
58
59 %prep
60 %setup -q -n glu-%{version}
61
62 %build
63 %{__libtoolize}
64 %{__aclocal}
65 %{__autoconf}
66 %{__automake}
67 %configure \
68         --disable-silent-rules \
69         %{!?with_static_libs:--disable-static}
70
71 %{__make}
72
73 %install
74 rm -rf $RPM_BUILD_ROOT
75
76 %{__make} install \
77         DESTDIR=$RPM_BUILD_ROOT
78
79 # there is pkg-config support; also, traditionally libGLU didn't have .la
80 %{__rm} $RPM_BUILD_ROOT%{_libdir}/libGLU.la
81
82 %clean
83 rm -rf $RPM_BUILD_ROOT
84
85 %post   -p /sbin/ldconfig
86 %postun -p /sbin/ldconfig
87
88 %files
89 %defattr(644,root,root,755)
90 %attr(755,root,root) %{_libdir}/libGLU.so.*.*.*
91 %attr(755,root,root) %ghost %{_libdir}/libGLU.so.1
92
93 %files devel
94 %defattr(644,root,root,755)
95 %attr(755,root,root) %{_libdir}/libGLU.so
96 %{_includedir}/GL/glu.h
97 %{_includedir}/GL/glu_mangle.h
98 %{_pkgconfigdir}/glu.pc
99
100 %if %{with static_libs}
101 %files static
102 %defattr(644,root,root,755)
103 %{_libdir}/libGLU.a
104 %endif
This page took 0.060586 seconds and 3 git commands to generate.